Jump to content
Sign in to follow this  
bink

Links Manager?

Recommended Posts

Is there a contribution that simplifies the addition of links (reciprocal) in osC? Something where others can go in and add their link manually would be good, just wondering otherwise ill write my own!

 

Thanks,

Kevin

Share this post


Link to post
Share on other sites

The is a very simple one in the contributions section. I have added it to my site. It does not categorize the links but, you do have an admin to approve or disapprove.


Kim

~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites

I was going to ask where you got that :-) I need categories, but on your site it is perfect.

 

Debbie


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Thanks Kim. You're always on the ball and so helpful.

 

(Off topic) I wish there was a way to more easily search contributions. Or a consistent naming convention to allow for easier scanning.

 

Mark

Share this post


Link to post
Share on other sites
(Off topic) I wish there was a way to more easily search contributions. Or a consistent naming convention to allow for easier scanning.

 

Mark,

 

I think that is on everyone's wishlist. It will come eventually.


Kim

~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites
Thanks Kim. You're always on the ball and so helpful.

 

(Off topic) I wish there was a way to more easily search contributions. Or a consistent naming convention to allow for easier scanning.

 

There is now a Search feature on the Contributions ... :D

Share this post


Link to post
Share on other sites

Oh man! I need more coffee........I just looked through all 800+ to find that one.........What a way to start my day....... :?


Kim

~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites
Oh man! I need more coffee........I just looked through all 800+ to find that one.........What a way to start my day....... :?

 

LOL ... yeah that silly little search box next to the section name will get you every time ... :wink:

Share this post


Link to post
Share on other sites

first link worked - others look like they work but they aren't posting to the shop - I can see them in the admin - I can add a link from the store and it posts successfully to the admin -but only the first link shows on the site.....

 

 

ideas

Share this post


Link to post
Share on other sites

forgot to mention that the links are in the database - they just aren't being recognized on the site -

 

so to recap:

 

links post successfully from the store into the admin links manager

links post successfully to the database

 

links do NOT show on the site....

Share this post


Link to post
Share on other sites

It's been a long time since I installed it.....Do you have it set to automatically post the links or do you need to activate them from the admin?


Kim

~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites

activate from the admin - but whether I enter it from the admin manually or approve it because it was submitted from the store - it won't show - and actually what I just noticed is that it only seems to be posting 1 link - I deleted the first link that I had and then the #2 link was bumped up and when I refreshed the screen it only showed that 1 link - not the other 4 listed.

 

Is there a min or max that I have to set somewhere?

 

Also, the admin approval is by default - how do I shut it off if I want to?

 

thanks for your quick response!

Share this post


Link to post
Share on other sites
There is now a Search feature on the Contributions ... :D

 

There is but it doesn't seem to work too well. :roll: I just typed in - osc links - the title of the contrib I was looking for, and it brought up 40 contribs to choose from - none of which were the proper one. When I added quotes, it only brought up one - the wrong one. Oh well.

 

This is less of a complaint, and more of an observation.

 

However, I am so appreciative of all the people who are so quick to help out on this forum. Thanks. :bigups:

Share this post


Link to post
Share on other sites

Since everything is osc ... you might try just:

 

links

 

Came up fine ... :D

Share this post


Link to post
Share on other sites
links post successfully from the store into the admin links manager

links post successfully to the database

links do NOT show on the site....

 

Solution

======

File: /CATALOG/LINKS.PHP

 

Replace:

'description' => substr($link['link_html_text'], 0, 250),

 

With:

'description' => substr($link['link_html_text'], 0, 250) . 'Web: <i>http://' . $link['link_url'],

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×