Jump to content
dreamscape

[Contribution] Cross Sell (X-Sell) Admin

Recommended Posts

'text' => tep_image(DIR_WS_IMAGES . $xsell['products_image'], $xsell['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a><br><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $xsell['products_id']) . '">' . $xsell['products_name'] .'</a><br>' . $xsell_price. '<br><a href="' . tep_href_link(FILENAME_DEFAULT, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $xsell['products_id'], 'NONSSL') . '">' . tep_image_button('button_buy_now.gif', TEXT_BUY . $xsell['products_name'] . TEXT_NOW) .'</a>');

 

instead of the buy now botton i would like to add the IN CART (add to cart) functionality from product info beside the x sell products any ideas on how to do this?

Share this post


Link to post
Share on other sites

HI,

 

i have been able to install the contribution, in admin it's looks fine and works... In that catalog i am able to see the related products, but when i click the buy now button, i get to my shopping cart with no products in it... it does not add the product in my shopping cart...

 

assistance much appreciated..

Share this post


Link to post
Share on other sites

Would anyone know the answer to this.

 

I have the buy option but when i click buy no i get to the shopping cart with the cart being empty and the product not add.

 

Please help,.

Share this post


Link to post
Share on other sites

Great contribution, but I am noticing that it doesn't work out as well as it is intended too. When you go to the main product that has "recommended products" you can either buy the main product which takes you to a different page and you no longer see the "recommended products". Or if you click on any one of the "recommended products" you are taken to their product info page, but youy have not added the main product to your basket yet. So waht is happening is you are really not upselling or cross selling, it is just showing other products.

 

I would think that the "recommended products" should show up in the shopping_cart.php page instead of the product_info.php page. Say you add a product to your cart, then go to the cart and it would show the "recommended products" there. Then you already have the main product ready for purchase, and now moving to the "recommended products" product info page would allow you to add them as well. Just seems more logical and would flow better.

 

If anyone has some thoughts on how to implement this into the shopping_cart.php page, please do so. Thanks.


>Insert witty comment here<

Share this post


Link to post
Share on other sites

Hi,

 

Recently I have also installed X-selling and it seems to be a great module and exactly what I need. But my only problem is that I renamed my database tables and somehow the contribution doesn't look at the database table names from databasetables.php. Instead of the stander products table names I uses a prefix in front of it like test_products . Does anyone have a clue how I can change the X-selling contribution to accept my table names wit prefixes?

 

Thanks a lot in advance.

 

Jeroen

Share this post


Link to post
Share on other sites

I get the following error in admin when clicking cross sell products:Access Denied

 

No Right Permission Access

Please contact your Web Administrator to request

more access or if you found any problem.

 

 

Has anyone else received this error. Why would i receive it? ocscommerce catalog works without this error but can't install this cross sell module.Any help Apreciated.

Share this post


Link to post
Share on other sites

Hi

i am still having the buy now problem

 

I have installed it and all went well, but when i go the my product on my site i can see the product and also all the related products with a buy button but when choose to buy the relatated product i go to my shopping cart but it is empty..

If you could assist me i would appreciate it very much.

Share this post


Link to post
Share on other sites

I have the Strangest Problem now.

 

While i was testing on my local machine i was able to go the admin section and see my products listed for Xsell. but once i uploaded the xseel_products.php page in admin. on my live site when i click on the left menu to select this contribution, i can see the title Cross-Sell (X-Sell) Admin at the top but i cannot see any of my products listed and i cannot relate any products..

 

could someone please assist me with this, i have waited for almost 20 mins with nothing else showing up...

 

thanks

Share this post


Link to post
Share on other sites

would anyone know how to show all the products in the Admin section as i am only able to see th title Cross-Sell (X-Sell) Admin, and nothing else.. I have assigned my database.php the match my database with use name and all password and still not progress..

 

any help is much appreciated

Share this post


Link to post
Share on other sites

I did some modifications to this mod that seems better :

Admin

-------

- it makes NO sense to display all the products in Admin esp. when you have multi-languages. In my case, each product is shown 3x times. So I just added the language_id in all sql where-clauses.

- I also changed the "order by" in the sql queries as it is better to display all products by ID and NOT by products_name. Suppose you have 500 articles and you add a new one. You will not find it at the end of the table but somewhere in between. User friendliness = 0.

Catalog

---------

- I added a blank line between the X-sell box and the "also purchased" box else both boxes touches each other. Not nice.

 

Else no proplem with this mod. Works fine !

 

Didier.

Share this post


Link to post
Share on other sites

I isnstalled the mod -- but there is no indication that it exists in the admin. I installed this on an MS1 cart I built last summer and it works great. It's my favorite contrib. I installled the latest version for MS2 to a new cart but the admin doesn't see it -- everything seems to work and I am not getting any errors. I have installed the STS (Simple Template Module) but don't think it should effect the way X-Sell works as X-sell modifies the products pages which work fine under sts. Any ideas what might be wrong would be greatly appreciated.

Share this post


Link to post
Share on other sites

hmm. I guess you have checked 10.000 your php code..the table is in the database ? you have an entry in the Catalog box ? If you follow *exactly* the installation file it should work...it's very easy to install...

Share this post


Link to post
Share on other sites

I am still in search for away to show my product list in admin..

Any assistance is appreciated.. quite deperate

Share this post


Link to post
Share on other sites
hmm. I guess you have checked 10.000 your php code..the table is in the database ? you have an entry in the Catalog box ? If you follow *exactly* the installation file it should work...it's very easy to install...

You were right. i added the database table, I modified the catalog files but then discovered that I didn't go through the admin steps completely. I went back over the steps and modified the 3 admin files which needed code added to them and the modification is working perfectly. Thanks for the push to check my work. That's what happens when you are working late in the night.

Share this post


Link to post
Share on other sites

I am having a problem getting the products in the admin section to add a cross sell itew. Running X-Sell-v2-MS2, and yes, I have version MS2

 

Problem:

 

In admin, all the products are listed. I select "Add"....a screen shows up with all my products and check boxes. I select the check box of the item I want to cross sell, and then click on submit.

 

I then recieve a confirmation message that says "click here to add a new cross sell". I click on the link, it processes for a few seconds and takes me to the original cross sell screen.

 

Problem is the "cross-associated products field remains empty, and no products are added on the catalog side in "We reccommend" box. BTW I do see the header and title bar for the "we reccomend" box in each item. I have read this entire post and have applied the fixes, such as the $POST fix, and the new .sql files. I have removed the table at least 10 times, both using the .sql statement and manually.

 

It appears that it is not updating the datsabase, as there are no records in that table. My store is currently live and this is a much needed feature.

 

I appreciate any guidance on this problem.


There is no spoon.

Share this post


Link to post
Share on other sites
I am having a problem getting the products in the admin section to add a cross sell itew. Running X-Sell-v2-MS2, and yes, I have version MS2

 

Problem:

 

In admin, all the products are listed. I select "Add"....a screen shows up with all my products and check boxes. I select the check box of the item I want to cross sell, and then click on submit.

 

I then recieve a confirmation message that says "click here to add a new cross sell". I click on the link, it processes for a few seconds and takes me to the original cross sell screen.

 

Problem is the "cross-associated products field remains empty, and no products are added on the catalog side in "We reccommend" box. BTW I do see the header and title bar for the "we reccomend" box in each item. I have read this entire post and have applied the fixes, such as the $POST fix, and the new .sql files. I have removed the table at least 10 times, both using the .sql statement and manually.

 

It appears that it is not updating the datsabase, as there are no records in that table. My store is currently live and this is a much needed feature.

 

I appreciate any guidance on this problem.

Does anyone have any ideas on this? I am getting desperate.


There is no spoon.

Share this post


Link to post
Share on other sites

Did you check the contents of the table where the X-Sell records are stored (products_xsell ?). If empty, is the php code behind the "submit" button correct ?

 

There is few to do except checking the code, the tables names, etc. If you do not succeed, the last option is to debug the php code. There are some contributions that allow to display the contents of a php variable.

 

Didier.

Share this post


Link to post
Share on other sites

I've got this contribution working, thanks!... however

 

If a product has not linked cross sell items, the product_info page still displays the title:

 

"We Also Recommend:"

 

with no other recomendations.

 

How can I make it not display the X-Sell recommend box if there are no items cross linked?

 

Thanks!

 

(PS I'm using the one dated 11/14/2003)

Share this post


Link to post
Share on other sites

Has been answered before in this forum

 

Look in file catalog/modules/xsell_products.php line 18 : you should have a test to only display the XSell box if the number of xsell products is equal or greater than the MIN_DISPLAY_ALSO_PURCHASED. This is how my code looks :

...

$num_products_xsell = tep_db_num_rows($xsell_query);

if ($num_products_xsell >= MIN_DISPLAY_ALSO_PURCHASED)

?>

<!-- xsell_products //-->

<?php

...

 

Didier.

Share this post


Link to post
Share on other sites

I have just installed the X-Sell products contribution (MS2) but in my admin section all i see it the title and not products list:

cross_sell.gif

 

Please Help Me!

Share this post


Link to post
Share on other sites

Ok this is really confusing.

 

I downloaded the Nov 17th release of x-sell, I installed it into the admin section of my site, when I click the link under the catalog box, the page loads the header and column left, but runs into an error, as no more of the page is shown not even the footer. I installed the sql that creates the tables also.

 

if I comment out the following:

 

/* Multiple Language fix --- mail@michaelding.net <mailto:mail@michaelding.net>

$query = "SELECT

b.language_id,a.products_id, b.products_name, b.products_description,a.products_quantity, a.products_model, a.products_image,b.products_url, a.products_price

FROM

products a,products_description b WHERE b.products_id = a.products_id AND b.language_id = 1

ORDER BY a.products_id;"; */

 

the page loads but ofcourse it doesnt connect to the databse. Giving me no information.

 

But my point is it leads me to believe that there is an error either in the sql or the function general_db_conct($query_1) itself, is anyone else expeirencing(sp?) this problem and can anyone help me? There are no errors reported on the page or my error logs.

 

 

Thank you all for your time and these great contributions!

 

Judy

Share this post


Link to post
Share on other sites

i am having similiar problem to aleg, it installs ok but does not diplay any products. but the strange thing is when i set it up on my local server i can see the products.. any help

Share this post


Link to post
Share on other sites

OK - I built the Nov 17 release so I guess I have some responsibility to help out :rolleyes:

 

If the problem is with that language fix (I don't know what that does by the way, someone else added it), then here's the code from the previous version of x-sell. Try replacing it and see if it fixes you:

 

        $query = "select a.products_id, b.products_name, b.products_description, " .
                "a.products_quantity, a.products_model, a.products_image, " .
                "b.products_url, a.products_price from products a, products_description b where b.products_id = a.products_id order by b.products_name";

 

I think that's the bit you're talking about? You might want to change 'order by b.products_name' to 'order by a.products_id'.

 

Let me know if that fixes you? If so, I'll try to find out why.

 

But my point is it leads me to believe that there is an error either in the sql or the function general_db_conct($query_1) itself, is anyone else expeirencing(sp?) this problem and can anyone help me? There are no errors reported on the page or my error logs.

 

The 'general__db_conct' way of doing things this script uses is badly written and doesn't use OSC-standard functions as it should. The whole way the script deals with the database is plain strange. No offence to whoever wrote it btw cuz i'm very grateful to them and it does work! It'd make my life easier if it worked how the rest of OSC does tho!

 

Until then, we'll have to keep it - and afaik it does the job OK.

Edited by Pharkie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×