Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

coolnj

Parse error: parse error, expecting `T_OLD_FUNCTION' or `T_FUNCTION' or `T_VAR'

Recommended Posts

Hi

 

I am new to osCommerce. WHile trying to install the application for the first time, I was getting the following error on the first page :

"Parse error: parse error, expecting `T_OLD_FUNCTION' or `T_FUNCTION' or `T_VAR' or `'}'' in c:\apache\htdocs\oscommerce\admin\includes\classes\language.php on line 20

 

Fatal error: Class osc_languageinstall: Cannot inherit from undefined class osc_language in c:\apache\htdocs\oscommerce\install\includes\classes\language.php on line 18 "

Am i missing out on something that needs to be done during installation. Please help.

Thanks

Share this post


Link to post
Share on other sites

Hi

 

I am new to osCommerce. WHile trying to install the application for the first time, I was getting the following error on the first page :

"Parse error: parse error, expecting `T_OLD_FUNCTION' or `T_FUNCTION' or `T_VAR' or `'}'' in c:\apache\htdocs\oscommerce\admin\includes\classes\language.php on line 20

 

Fatal error: Class osc_languageinstall: Cannot inherit from undefined class osc_language in c:\apache\htdocs\oscommerce\install\includes\classes\language.php on line 18 "

Am i missing out on something that needs to be done during installation. Please help.

Thanks

 

I was having the same problem. The original "Parse error: parse error, expecting `T_OLD_FUNCTION' or `T_FUNCTION' or `T_VAR' or `'}'' in .\admin\includes\classes\language.php on line 20" went away when I added "AddType x-mapp-php5 .php" and "AddHandler x-mapp-php5 .php" to the main .htaccess file and the admin .htaccess file, but I then recieved a "Fatal error: Call to undefined function osc_setcookie() in ./includes/classes/language.php on line 106" error.

 

Hopefully, someone will know what the solution is for both problems.

Share this post


Link to post
Share on other sites

What is your PHP version? Server OS? Apache Flavor?

 

Hi..

I was able to get this working . Instead of the installer package I used the zip package for installing PHP 5.2 and used it along with Apache 2.0(there were some issues with Apache 2.2)

Share this post


Link to post
Share on other sites

×