Jump to content
Sign in to follow this  
gregwee

Weird Paypal Error

Recommended Posts

I'm setting up a Paypal Website Payments Standard module in my OsCommerce. I signed up for the Paypal Sandbox and setup both, a merchant account and a Personal account for paying.

 

The Paypal module is setup as follows:

 

Enable PayPal Website Payments Standard
True

E-Mail Address
test@testemail.com

Payment Zone
--none--

Set Preparing Order Status
Preparing [PayPal Standard]

Set PayPal Acknowledged Order Status
Processing

Gateway Server
Sandbox

Transaction Method
Sale

Page Style
Paypal

Debug E-Mail Address
my@email.com

Sort order of display.
0

Enable Encrypted Web Payments
False

Your Private Key


Your Public Certificate


PayPals Public Certificate


Your PayPal Public Certificate ID


Working Directory


OpenSSL Location
/usr/bin/openssl

 

For the Merchant Account under /Profile/Instant Payment Notification (IPN)

I've set IPN to enabled, and pointed the URL to http://mywebshop/checkout_process.php

 

For the Merchant Account under /Profile/Website Payment Preferences

I've turned "On" Auto Return, and pointed the URL to http://mywebshop/ipn.php (this file doesn't actually exist)

 

The error I'm getting after clicking on the "Pay" button is:

paypal_error.jpg

 

Any idea what's happening?

Share this post


Link to post
Share on other sites

OK... I think it's because the Merchant I setup wasn't confirmed yet... It works now that I've confirmed the Account.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×