Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Archived

This topic is now archived and is closed to further replies.

Mort-lemur

URGENT Help Please with Paypal

Recommended Posts

Hi,

 

A problem has suddenly appeared with my store as follows:

 

When a customer goes to checkout everything is fine, he sees the price of the item, the selected carriage charge, and the Tax. - The invoice sent by email shows exactly the same.

 

HOWEVER, when he is tranferred to the paypal page the shipping charge is not correct, ie if he selects a shipment method costing £6.50 then paypal (standard) only charges him £0.68 for shipment !!

 

I have tried reloading the paypal standard file to my includes/modules/payment directory but no change.

 

I am using the "fancier invoice and packing slip " contribution, but this was all working fine after install, and only seems to have appeared recently.

 

Help Please !!

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hi,

 

Everything apart from the paypal payment screen is correct, all the emails are correct, the invoices are correct and all the OSC screens are correct

 

it looks like an error somewhere transmitting the data to paypal ??

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

No it sounds like there is an error in the module to me, just have a look at your shipping set up to ensure that it is correct, including admin / configuration / shipping, and the shipping order totals.

If these are correct then try paypal IPN contribution its dead easy to install and set up.

Nic


Sometimes you're the dog and sometimes the lamp post

[/url]

My Contributions

Share this post


Link to post
Share on other sites

Ok - I checked the shipping data - Im using MZMT shipping contribution and everything is ok - which Paypal IPN contribution ? I have just done a search and there seems to be a few ???

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Thanks Nic,

 

Installed paypal IPN, didn't solve the problem :-(

 

So I read the Paypal IPN Trouble-shooting guide, there was a short paragraph about turning off shipping calcs in Paypal - guess what ? mine were on - so paypal was carrying out its own calcs ! and ignoring my shipping costs.

 

Now set all these to zero and checked the box to allow transactions to overide paypal calcs - and it works like a dream.

 

Plus I like the IPN mod.

 

Thanks soooooooooo much :D


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites
No it sounds like there is an error in the module to me, just have a look at your shipping set up to ensure that it is correct, including admin / configuration / shipping, and the shipping order totals. If these are correct then try paypal IPN contribution its dead easy to install and set up.

 

i am experiencing almost exactly the same problem with my osc site (shipping charges not getting transferred to paypal), my shipping is correctly set up on my end, and paypal assures me that nothing is wrong on their end, but i still get orders without shipping from paypal.

 

and as far as i've been able to tell, the paypal IPN contribution's installation instructions are in german, which doesn't do me any good at all... can someone translate for me?


⇑ Hybrid Elephant ⇒ http://www.hybridelephant.com/ ⇐ The World's Finest Exotic Incense ⇓

Share this post


Link to post
Share on other sites

i am experiencing almost exactly the same problem with my osc site (shipping charges not getting transferred to paypal), my shipping is correctly set up on my end, and paypal assures me that nothing is wrong on their end, but i still get orders without shipping from paypal.

 

and as far as i've been able to tell, the paypal IPN contribution's installation instructions are in german, which doesn't do me any good at all... can someone translate for me?

 

Hi,

 

I Installed the 2.3.4.7 version of the Paypal IPN module. Paypal was working fine for me as well - but you need to check that paypal is not trying to do the shipping calcs for you. Go to your paypal profile and check the shipping calcs section - mine were turned on. I simply set them all to zero and set the over ride and everything now works fine.

 

Hope this helps.


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites
I Installed the 2.3.4.7 version of the Paypal IPN module.

 

i didn't install any version of the paypal IPN addon because the installation instructions were in german, i don't speak german, and machine translation only gave me a marginally understandable (i.e. mostly gibberish) translation.

 

Paypal was working fine for me as well - but you need to check that paypal is not trying to do the shipping calcs for you. Go to your paypal profile and check the shipping calcs section - mine were turned on. I simply set them all to zero and set the over ride and everything now works fine.

 

paypal has been working okay, although they are a bit irritating, they're a hell of a lot less irritating than the other merchant service providers i've been investigating, and this is the only real difficulty i've had from a purly reporting standpoint. however i saw your previous post about turning the shipping calculations off in paypal (definitely counter-intuitive on paypal's part), and tried it. it works.

 

rejoice! now my web site works exactly the way i want it to.

 

thanks! :)


⇑ Hybrid Elephant ⇒ http://www.hybridelephant.com/ ⇐ The World's Finest Exotic Incense ⇓

Share this post


Link to post
Share on other sites

I am experiencing this same problem but it happens randomly and only on the lowest shipping amount (using zone-based shipping). I have not been able to duplicate it myself so I do not know what is displayed for the shipping amount when the buyer goes through the checkout procedure but in the admin side and the emails, the shipping is displayed incorrectly (correct for what is being charged but incorrect for what should be charged).

Share this post


Link to post
Share on other sites
I am experiencing this same problem but it happens randomly and only on the lowest shipping amount (using zone-based shipping). I have not been able to duplicate it myself so I do not know what is displayed for the shipping amount when the buyer goes through the checkout procedure but in the admin side and the emails, the shipping is displayed incorrectly (correct for what is being charged but incorrect for what should be charged).

 

try going in to your paypal account settings and turning off the shipping calculations there. it worked for me... B)


⇑ Hybrid Elephant ⇒ http://www.hybridelephant.com/ ⇐ The World's Finest Exotic Incense ⇓

Share this post


Link to post
Share on other sites

try going in to your paypal account settings and turning off the shipping calculations there. it worked for me... B)

 

Look at the previous versions of Paypal IPN, I dont speak german either but the instructions on the one I downloaded were in english.

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

×