Jump to content
kymation

[Contribution] Products Specifications

Recommended Posts

I don't know exactly what the problem is. I suspect that your URL rewriter is incompatible with the jQuery tabs that PS uses, but I could be wrong there. In any case it looks like you have a solution to that part.

 

To return to the correct tab, add ?tab=9 to the URL. Or whatever tab number you want.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello.

 

I'm trying to install this add-on on my live 2.3.3.4 store. I uploaded all new files, except for the catalog/includes/modules/products_tabs.php. I already have this file, and it belongs to Product Tabs add-on. Since that add-on is working properly on my live store, I don't want to mess things up. Are these two add-ons compatible and what is the easiest way to combine them together?

 

Thanks.

Share this post


Link to post
Share on other sites

No, they are not compatible. You could probably make the PS code work with your tabs addon, but it would take some coding. I haven't looked at the Product Tabs addon for a while, so I'm not sure how much work that would take.

 

I don't recommend trying to add something this big to a live store. Set up a copy of your store in another folder and do your development there. Copy the files to the live site when you are certain everything works.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

I just need your opinion on this do you see any reason why product specifications would not be compatible with option types v2

 

I had a look at the files and as far as I see they could be merged.

 

The only problem I see could be in the includes/modules/product_attributes.php

 

Any thoughts or experience with this?

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

I've done this before, so my opinion is that it can be done. B) It shouldn't be that difficult. Post again if you have a problem with it and I'll dig out the code for that part.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Ok Jim thanks a lot !

 

just see the html as fiddely at the minute and of course my danger antenna (w00t) telling me that that part of the code may need changed I will get back to you when I get stuck :wacko:

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

I wonder if there is a way to display another name for a product filter than that one which is used in the get request. For example, I have a specification group to search for products by men or by women. So the filter is using the database field "sex", but in the database, values for this column are only 1 or 2. Now, what the filter should do is to display men or women as possible values to select but sending 1 or 2 as the value to look for in the database. Is there a way to do this or do I have to write my own code?

Share this post


Link to post
Share on other sites

No, the value must match the specification. Why are you using 1 and 2 in the database instead of the real values?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Well, consider the following example. You have a multi language shop website and you want to have a filter for sex. So in any english shop the filter should display men and women, in german it is Mann and Frau and so on. Now you see that I can't send this value to the database because it is different for every website depending on the language. That's why in the database there are only the values 1 or 2.

Do you know a good place in your code where I can do this the best way?

Share this post


Link to post
Share on other sites

The Specifications database is already set up to handle multiple languages. Apparently the Filters admin page is missing the pulldown to select the language. If you want to go hacking the code, you can fix that. Or you can just enter the data into the specification_filters_description table in your database. I'll fix the code in the addon as soon as I have the time.

 

Thanks for reporting this bug.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

hi all

 

 i have nearly read the whole 52 pages and the pdf manual but cant figure this out.

 

i can get the filter box to show the filters on the left column.

 

i  want the filters to be displayed in the middle column (product listing). i cant figure out how to do this. All the required setting are true. i have double checked the code changes.i even used the supplied index.php  file.

 

i have noticed that the supplied product listing file is unchanged from original.. is this correct. ?

 

Show Filters Module   is set to true

Filter Subcategories   is set to true

 

 

any help would be appreciated.

 

regards

 

nafri

Share this post


Link to post
Share on other sites

The center-column filters box is in /includes/modules/products_filter.php. It's included in /index.php by this code:

 

<?php
// Start Products Specifications
    if (SPECIFICATIONS_FILTERS_MODULE == 'True') {
?>
      <tr>
        <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
      </tr>
      <tr>
        <td>
<?php
      require (DIR_WS_MODULES . 'products_filter.php');
?>
        </td>
      </tr>
<?php
    }
// End Products Specifications
?>

 

Edit: The forum editor is really messing up the code. I can't do anything about that.

 

Check that you have that code in the proper location and that Show Filters Module is set to True in the configuration admin.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The center-column filters box is in /includes/modules/products_filter.php. It's included in /index.php by this code:

 

<?php
// Start Products Specifications
    if (SPECIFICATIONS_FILTERS_MODULE == 'True') {
?>
      <tr>
        <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
      </tr>
      <tr>
        <td>
<?php
      require (DIR_WS_MODULES . 'products_filter.php');
?>
        </td>
      </tr>
<?php
    }
// End Products Specifications
?>

 

Edit: The forum editor is really messing up the code. I can't do anything about that.

 

Check that you have that code in the proper location and that Show Filters Module is set to True in the configuration admin.

 

Regards

Jim

 

 

 

 

 

 

hi jim

 

Many thanks for replying.

 

I spent the whole day yesterday and i still cant get it to work.

 

I am using index.php file supplied in your addon.

 

I can get the filer on the side column to work.Which tells me the  filter is working and set-up right. but cant get it to show up in the middle column. i even did the whole thing from scratch.

 

New database and redid file edits.

 

 

Show Filters Module is set to True . THE  file DIR_WS_MODULES . 'products_filter.php  is present.

 

 

I am trying to show the filter on a sub category.Main category is 

 

 

Monitors, Tvs & Plasma =>Televisions   --Filter to show when clicked on Televisions .

 

Spec data has been added to products.

 

i am using latest 2.3.3.4 oscommerce.

 

regards

 

nafri

Share this post


Link to post
Share on other sites

That really should work. Try replacing this code:

 

    if (SPECIFICATIONS_FILTERS_MODULE == 'True') {

 

with this:

 

    if (SPECIFICATIONS_FILTERS_MODULE == 'True') {
      print 'This module should show!';

 

Then see if the text shows up on the page. If it does, move that print line inside the module and try again.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That really should work. Try replacing this code:

 

    if (SPECIFICATIONS_FILTERS_MODULE == 'True') {

 

with this:

 

    if (SPECIFICATIONS_FILTERS_MODULE == 'True') {
      print 'This module should show!';

 

Then see if the text shows up on the page. If it does, move that print line inside the module and try again.

 

Regards

Jim

 

 

hi

 

strange i get no text.. but i can see the entry in database

Share this post


Link to post
Share on other sites

Check that the database entry is True and not true or some other variation. Also check that SPECIFICATIONS_FILTERS_MODULE is not misspelled.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Check that the database entry is True and not true or some other variation. Also check that SPECIFICATIONS_FILTERS_MODULE is not misspelled.

 

Regards

Jim

 

 

 

Both are Spelled right..

Edited by nafri

Share this post


Link to post
Share on other sites

Then this should be working. The only other possibility I can see is that that block of code is in some part of the page that is not being executed. Sorry, but I'm limited in what I can do here. You'll just have to continue debugging this yourself.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

hi jim

 

thanks for your help.. i  finally got it working. i changed the database entry from True to true .. and the text showed up.I  then changed it back and  it still works.

 

I also had to add an  extra entry on the index.php file so  the filter can show up after 2nd level category.

 

My website shows prices with tax but the filter gets price directly from product price column which is without tax.any way to change this ?

 

i cant figure out how to get instock filter to work.I want customer to be able to choose between instock and out of stock.

 

 

regards

 

nafri

Share this post


Link to post
Share on other sites

The Products Specifications code checks the value of DISPLAY_PRICE_WITH_TAX and adds the tax if set. See the code for the function tep_get_filter_sql in includes/functions/products_specifications.php. That may be another of your weird database settings. I don't understand how your previous solution worked, so I can't predict what might happen with this one.
 
The values in the products_status field are 0 and 1. You would need some code to make that make sense to the customer.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

hi jim

 

 

thanks for replying.   .

 

i will have a look..

 

i think it works not because of the database as i thought initially but because of moving the code in the right place in  index file.

 

regards

Share this post


Link to post
Share on other sites

hi

 

at the moment i got 6 filters in one row. i want to show three filter per row.

 

With 6 filters it is pushing the filter box to right and messing up the display of the page

 

 

regards

 

nafri

Share this post


Link to post
Share on other sites

You might be able to do that with a bit of CSS, or you can modify the code to change the layout to suit your needs.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

version 1.1.11

 

catalog/includes/boxes/products_filter.php

 

looks like it is missing from the package. where can i find a copy?

Share this post


Link to post
Share on other sites

@@RMD27  That's a typo -- it's catalog/includes/modules/boxes/products_filter.php

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×