Jump to content
kymation

[Contribution] Products Specifications

Recommended Posts

Thanks for wonderful contribution, Kymation. My question regarding old version of product specifications. Do the old version (2.2) product specifications still have any update? My current oscommerce already updated using manually update to newest oscommerce version (for bug, core function, error etc, exclude oscommerce template). I didn't use current oscommerce template system. I still love some contribution for old oscommerce template such as STS etc.

 

I see in your product specification addons for oscommerce 2.3 have version 1.1.11 and the oscommerce 2.2 only until version 1.0.2. Do it's have any manual update so the old version also can get updated? Thanks.

Share this post


Link to post
Share on other sites

No, but the old version is still pretty solid. The only problem with using it is that it will probably not run on newer versions of PHP and MySQL. If your host upgrades, you'll be forced to go to a newer version to keep running.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I put include_once("includes/functions/products_specifications.php"); line in application_top.php

 

That fixed 'Call to undefined function' error, but now filters don't apply. Still the same range of products, no matter what filter I choose.

Share this post


Link to post
Share on other sites

Which module are you using to display the products? The Product Rows module works, but probably not any of the others.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I'm pretty sure it's standard osCommerce product listing module. Where can I find The Product Rows module?

Share this post


Link to post
Share on other sites

If you are using the files from this post, you need to install the Product Rows module under Modules >> Categories in your store's admin. The standard listing module has not been well tested and may not work properly.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thank you Jim.

But I don't have that module. I don't even have 'Categories' submenu in Modules section. I'm using files you mentioned but the package contains only 'bm_products_filter.php module'. Looks like something is missing.

Share this post


Link to post
Share on other sites

No, but the old version is still pretty solid. The only problem with using it is that it will probably not run on newer versions of PHP and MySQL. If your host upgrades, you'll be forced to go to a newer version to keep running.

 

Regards

Jim

 

 

Thanks for quick reply. Do it's have any manual update for updating the core function following newer version php and mysql? I'm happy with my current oscommerce, my oscommerce code already uppdating following newer version php and mysql. I only didn't use the template systems using 960 grid.

Share this post


Link to post
Share on other sites

@@slavko You need this package as well as the modified filters box. Or you could modify the existing SQL in index.php to use the filters. It's possible but not that easy.

 

@@centrman No, and I really don't have time to do that for an old version that very few people still use. However, it should not be all that hard to do. I haven't checked, but I don't believe there is much in that old version that would need to be fixed.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

No, this is all pre-release stuff. It was all ripped from a live store, though, so it should work. The install is pretty much self-explanatory. Go install the modules and see what they look like. If you have specific questions on a module, just ask.

 

Regrds

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The problem is that it looks like it needs some modifications in MySQL database. When I installed 'Product Listing' module (which I believe is the one needed to run filter box) i got an error:

 

1146 - Table '********.TABLE_DISCOUNTS' doesn't exist

 

select discount, sort_order from TABLE_DISCOUNTS where categories_id = '2' order by sort_order

Share this post


Link to post
Share on other sites

Yes, this code has not been scrubbed of all extra addons. You'll need to find those and fix them. The Discounts code can just be commented out, for example.

 

The Product Listing module is probably the worst of the bunch, since it was not used at all in the final project. You might want to start with a different module.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@slavko You need this package as well as the modified filters box. Or you could modify the existing SQL in index.php to use the filters. It's possible but not that easy.

 

@@centrman No, and I really don't have time to do that for an old version that very few people still use. However, it should not be all that hard to do. I haven't checked, but I don't believe there is much in that old version that would need to be fixed.

 

Regards

Jim

 

Thanks Jim for quick reply. I will check by myself with compare the new version with old version. Anyway thanks alot for your addons.

Share this post


Link to post
Share on other sites

Hello,

 

I am fighting with this addon for a few hours and because of lack of screenshot and videos I am not sure that i correctly install it (2.3.3.4 osc).

First of all i had a problem with showing tabs correctly in product page, so i get ride of 'base' statment. Is that wrong to delete it ? Last thing in here. Sending reviews or inform about this product someone and send questions about products doesn't work, when i click on button it's just reload page or (with review) adds product to basket.

 

Second i just can't figure out how to configure it :blush: I need simplest basics tutorials how to create:

- colours

- price range

If someone will tell me or even better show me, i will know how to create others specification.

 

Right now, i've created group 'Misc' inserted there: Color and Price.

In color i've set those data:

  • Filter Class: none
  • Display the Filter as: checkbox
  • Filter Show All: True
  • Enter Specification Values as: checkbox

then Specification Values Section i've add some colors and in some products i've set them too. Now on primary page 'index' i have the filter but it's just in color section has only 'show them all' no checkboxes with colors.

 

With Price i tried thats way:

  • Column Name: products_price
  • Filter Class: range
  • Display the Filter as: radio
  • Filter Show All: False
  • Enter Specification Values as: radio

and in filter it shows only '0,00 - 0,00'... ?

Share this post


Link to post
Share on other sites

you have to define filter values too, it is the little icon to the left of where you have added the actual values that you can enter/select from in the admin


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

One icon is 'blue' throught this i can add spec values and throught 'yellow' i can add filters. In those options what i choose in colors i don't have yellow icon, in price i have and i add there 'new filter', but there is no option, only names and order and it's doing nothing or i can't see any effect.

Share this post


Link to post
Share on other sites

for the colors you have to set the filter type to for instance exact

 

for the prices, you define brackets eg 5, 10, 20

the range is shown automatically

products price is a database field,

 

These are my settings Column Name: final_price Filter Class: range Display the Filter as: links Filter Show All: True Enter Specification Values as: text


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

I have strange 'bug'.

 

I've created prices like you said.

http://i40.tinypic.com/2lms2zn.jpg

http://i40.tinypic.com/98fqqx.jpg

http://i44.tinypic.com/2q40ev8.jpg

Filters with prices added. But it's a little bit destroy site look. When i switch off 'Price' (Cena) it's works correctly with Colours(Kolor) but not with Price. Like on a screenshot all of headtags are shown above all filters and Price(Cena) is doubled.

 

I didn't made changes in bm_products_filter.php. - only in products_specifications.php with display buttons on a nicer ones from jQuery UI.

$box_text .= tep_draw_button(IMAGE_BUTTON_SUBMIT, 'circle-arrow-e', null, 'primary');

Edited by slupostrupek

Share this post


Link to post
Share on other sites

The filters box in the distribution download has some bugs. You can fix it with some CSS, or you can use the experimental box linked above. The experimental box also requires changes to the product listing (categories) page that are provided in a separate download.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I wish to try it but, i can't work till i found the way to show PHP Errors instead of Blank Page.

 

I've tried set php_flags in php.ini, checked application_top.php (error_reporting(E_ALL & ~E_NOTICE);)

and everything looks ok. Some advice how to turn them on ?

Share this post


Link to post
Share on other sites

The code in application_top.php needs to be

 

 error_reporting(E_ALL);

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Then your host is blocking that somewhere. Ask them for a way to fix that, or have them enable error messages for your site.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×