Jump to content
spooks

Simple Multi Image Add-on (Un-Limited) with FancyBox Popups

Recommended Posts

Hi, I really like this contribution.

 

I have installed Simple Multi Image Add-on (Un-Limited) with FancyBox Popups and oscThumb. Watermarks work just fine for me but there is a slight little thing that I would like to change:

 

With the oscThumb settings in admin Graphic Watermark in Pop-up Images 'Yes' and Graphic Watermark in Product Information Thumbnails 'No' there is still an watermark in the Product Information Thumbnail in product_info.php.

 

I just want the watermark in the Pop-up Images not in the Thumbnails.

 

How can I change that? Thanks heaps in advance!

Share this post


Link to post
Share on other sites

Hi, I really like this contribution.

 

I have installed Simple Multi Image Add-on (Un-Limited) with FancyBox Popups and oscThumb. Watermarks work just fine for me but there is a slight little thing that I would like to change:

 

With the oscThumb settings in admin Graphic Watermark in Pop-up Images 'Yes' and Graphic Watermark in Product Information Thumbnails 'No' there is still an watermark in the Product Information Thumbnail in product_info.php.

 

I just want the watermark in the Pop-up Images not in the Thumbnails.

 

How can I change that? Thanks heaps in advance!

 

 

Thats nothing to do with this, you should be posting in the osC Thumbs thread. ohmy.gif

 

But the issue is a bug in osCThumb, once you turn on watermark in the Product Information Thumbnail in product_info.php you cannot turn it off, I don't know if there is a fix. wacko.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Thats nothing to do with this, you should be posting in the osC Thumbs thread. ohmy.gif

 

But the issue is a bug in osCThumb, once you turn on watermark in the Product Information Thumbnail in product_info.php you cannot turn it off, I don't know if there is a fix. wacko.gif

 

Hi,

 

try this:

 

In product_info.php:

---------------------------------------------------------

Find:

echo '<a rel="image_group" title="'.$title.'" href="' . ($m_source ? $m_source : DIR_WS_IMAGES . $product_info['products_image']) . '" alt="' . $product_info['products_name'] . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"', false, 5) . '</a><br />';

 

And replace with:

 

echo '<a rel="image_group" title="'.$title.'" href="' . ($m_source ? $m_source : DIR_WS_IMAGES . $product_info['products_image']) . '" alt="' . $product_info['products_name'] . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"', false, 4) . '</a><br />';

---------------------------------------------------------

 

It just changed the last parameter(thumbnail_type) in function tep_image() to the value I think it must be. I don't know why u set it to 5 there, let me know if I went wrong.

 

In additions, I think the constants [sMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT] should be changed to [PRODUCT_INFO_IMAGE_WIDTH, PRODUCT_INFO_IMAGE_HEIGHT] for independent setting (this constants was newly added by oscthumb installation, and it can be set in admin>Images).

 

Have fun!

Share this post


Link to post
Share on other sites

 

 

Oops, sorry forgot that was there, blush.gif don't need it you could just delete , false, 5

 

I think it was added as some wanted to stop the size paramter change, if its set to 4, or you leave it blank (also 4) the PRODUCT_INFO_IMAGE_WIDTH, PRODUCT_INFO_IMAGE_HEIGHT params are used, so no point adding them there. wink.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

I had installed the fancybox/Simple Image and am having an issue with info box heading bar sizing only in Product_Info.php.

 

All other areas of the cart are working properly. Here is the field I changed in CSS

TD.infoBoxHeading {

font-family: Verdana, Arial, sans-serif;

font-size: 12px;

font-weight: bold;

background: #5A4F36;

color: #F2EDE1;

 

height:25;

background-image: url('/images/Image1.gif');

background-repeat: repeat-x;

background-position: left;

 

The height code is working great at customizing the size of the bars to my liking but does not change in Product_Info with this script installed. Any ideas?

 

Thanks,

 

Charles

Share this post


Link to post
Share on other sites

product page appearence varies to rest of site.

 

 

Please read the notes & fix in the FAQ on this issue. wink.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

product page appearence varies to rest of site.

 

 

Please read the notes & fix in the FAQ on this issue. wink.gif

 

 

Wow Spooks your good! In following your comments I switched the Doc listed in the manual from:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

 

To:

 

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

 

Now all the cart appears to be the same. What is the actual function of doctype?

Share this post


Link to post
Share on other sites

What is the actual function of doctype?

 

 

 

 

from w3c:

 

The doctype declaration is an instruction to the web browser about what version of the markup language the page is written in.

The doctype declaration refers to a Document Type Definition (DTD). The DTD specifies the rules for the markup language, so that the browsers can render the content correctly.

 

 

more:

 

 


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Simple Multi Image Add-on (Un-Limited) with FancyBox Popups

 

There are many multi image contributions, but I found many have become much too bloated or just didn't fit, so I created this, allowing as many extra product pictures as you want with admin control and fancy lightbox like popups.

 

Features:

 

1.Its a simple strait forward design, only two files to edit.

2.An un-limited number of additional images can be added to any product without modification.

3.Any product can have as many (or few) images as wanted.

4.Additional images can be deleted if needed.

5.Fancybox is used for the image popups, so all product images can be browsed within a single popup. (Fancybox is like lightbox but better lighter code).

6.Additional image layout can be modified in admin, selecting a horizontal or vertical layout and the number or images to show per row

7.Additional image size is also set in admin.

8.I recommend this is used with OscThumb for auto thumbnailing & faster load times.

9.As a bonus addition, a function is added in the product edit page to give a instant update option.

 

Fancybox is released under the MIT License, details and examples can be found here .

 

 

To work Fancybox is particular about the doc-type used, check at their site & in the installation.

 

 

Tested on PHP 4 & 5, SQL 4 & 5, osC 2.2 ms2, rc1 & rc2a and is register_globals off compatible.

 

 

 

Contribution is here

 

 

 

Tried this on fire fox 3.5.5, had few problems with the install instructions you put in there (I am using rc1 version of the OS commerce)

 

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> works best....other ones like the loose might not be the best option (I stand corrected)

Also add to cart button. Even though its common sense, I still think it will be nice to alert people to watch out for this.

 

Apart from these it is brilliant!!!

 

Just a thought...how can you increase the size of smaller images ?

I think that will be nice to get all images to show similar size regardless of how big or small the image is.

Share this post


Link to post
Share on other sites

Tried this on fire fox 3.5.5, had few problems with the install instructions you put in there (I am using rc1 version of the OS commerce)

 

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> works best....other ones like the loose might not be the best option (I stand corrected)

Also add to cart button. Even though its common sense, I still think it will be nice to alert people to watch out for this.

 

Apart from these it is brilliant!!!

 

Just a thought...how can you increase the size of smaller images ?

I think that will be nice to get all images to show similar size regardless of how big or small the image is.

 

 

All your issues are already delt with in the doc, please read it!! crying.gif

 

except

Also add to cart button
is nothing to do with this!! wink.gif

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hi,

 

I've successfully installed the simple multi image add-on but I have found that when I want to edit my product description without changing or uploading any additional images, after I click the preview button, I get stuck on the next page because there are no 'back' or 'update' buttons and the screen seems like it can be scrolled down indefinitely and I'm not able to update my description.

 

Do you know how I can resolve this?

Share this post


Link to post
Share on other sites

Hi,

 

I've successfully installed the simple multi image add-on but I have found that when I want to edit my product description without changing or uploading any additional images, after I click the preview button, I get stuck on the next page because there are no 'back' or 'update' buttons and the screen seems like it can be scrolled down indefinitely and I'm not able to update my description.

 

Do you know how I can resolve this?

 

 

Check you edits again very carefully, you have made errors in the install, try using a file compare tool if you have trouble with the manual method. This add-on has been tested on a variety of server configs, with MS2 to RC2a versions, there are no known flaws, so if you get one then its 99% certain you have made errors. Try using the supplied files in place of yours, you don't have to keep it that way, but it will show you that it works.

 

 


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hey all, I am having a devil of a time getting this contribution, V1.2, working with IE8. I swear it was working with the default STS template, but now that am working on my own, I can't get the thing to work in IE8. It works fine in Foxfire. All I get is a new IE8 window to open up with the photo. I tried playing around changing the !doctypes, but best I was able to do was to see a the loading image show up, but no photo. I am currently using <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

 

My site in progress is http://www.natureguystudio.com/catalog/lake-superior-shores-p-28.html, or My catalog

 

I read the posts about IE issues, but they all seemed fixed by the V1.2 I am using. Any ideas? Thanks!

Share this post


Link to post
Share on other sites

Hey all, I am having a devil of a time getting this contribution, V1.2, working with IE8. I swear it was working with the default STS template, but now that am working on my own, I can't get the thing to work in IE8. It works fine in Foxfire. All I get is a new IE8 window to open up with the photo. I tried playing around changing the !doctypes, but best I was able to do was to see a the loading image show up, but no photo. I am currently using <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

 

My site in progress is http://www.natureguy...hores-p-28.html, or My catalog

 

I read the posts about IE issues, but they all seemed fixed by the V1.2 I am using. Any ideas? Thanks!

 

 

Pleaese install the latest, then you wont have issues that are already fixed crying.gif , also make sure you complete the install in full. ohmy.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hi Sam,

 

Firstly- Thanks for this contribution. It looks like exactly what I'm looking for.

 

Things were going so great throughout the installation, but then I got to this part in admin/categories.php where I have to find this:

 

        <td align="center" class="smallText"><?php echo sprintf(TEXT_PRODUCT_DATE_ADDED, tep_date_long($pInfo->products_date_added)); ?></td>
     </tr>
<?php
     }
?>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>
     </tr>
</table>
<?php
   }
?>

 

And add after:

 

<!-- Simple multi image addon -->
<table summary=""><tr><td>Additional Images:</td><td class="main" colspan="3"><table summary=""><tr>

  <?php  $i=1; while (list($key, $value) = each($products_image_array)) { ?>


       <?php echo '<td align="center">' . tep_image(DIR_WS_CATALOG_IMAGES . $value, $value, SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, ' hspace="8" vspace="5"');
			      if($HTTP_POST_VARS['delete_image_' .$i] == 'on') echo '<br />To Be Deleted';
		        echo '</td>'; ++$i;  } ?>	

</tr>
</table></td></tr></table>
<!-- EOF Simple multi image addon -->

 

However the code does not exist in the file. If I search for parts of that code, it finds it (Dreamweaver CS4), so the code is there- it's just not grouped together as in your install instructions.

 

Wondering whether the instructions need updating, or if you can offer me a fix for the problem?

 

All the other edits seemed to have gone smoothly.. It's just this one that's stopped me.

 

Here's my entire admin/categories.php code (In a .txt file) if you wouldn't mind taking a look:

 

http://www.pulse-performance.com/sam.txt

 

2nd problem... (Maybe due to the above though)...

 

When I click on a product in the front end to view the product page.. I get this error:

 

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/XXXXX/public_html/pulse-performance.com/includes/functions/database.php on line 103

 

Applying the SQL in PHPMyAdmin seemed to go OK (No errors).. although I've not touched any settings in the admin control panel as yet. Maybe this has something to do with it?

 

Any help would be greatly appreciated. :)

Share this post


Link to post
Share on other sites

Code mismatch and reading issues|!!

 

1st point, Your the 4th Person to have this issue, what version osc do you have & where did u get it? ohmy.gif

 

See my post of 10th November for revised instruction. smile.gif

 

http://forums.oscomm...00#entry1456124

 

 

2nd point, please read the FAQ. wink.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Spooks,

 

I have both the fancybox with multi images as well as your product listing contrib, will STS work with it and easily install without a major ordeal? :rolleyes:

Share this post


Link to post
Share on other sites

I am building a new product info page layout for my cart that sorts everything in what I believe to be a good flow, do you think it might be something you may want for the contrib? B)

Share this post


Link to post
Share on other sites

Hi Spooks,

 

Very nice contribution, I dont know what we would do without you.

 

I have been running your fancybox popup with multiple images for a couple of months now and it has been working perfectly however a couple of days ago the Navigation arrows and the X to close have gone, the black background for the image name has also vannised.

 

I have tried changing the "show pop up Navigation' option in the admin console but this does fix things.

 

Here is a link to my website so you can see what I am trying to explain.

 

http://topshelf-rc.co.nz/catalog/product_info.php?cPath=27_28&products_id=1922

 

If you get some time to have a look and provide feedback that would be great.

 

Thanks in advance..........Dave

Share this post


Link to post
Share on other sites

Hello Sam,

 

When you mouseover the product image, the location of the image file displays at the bottom of my browser - how do I stop this showing?

 

Thanks

Richard

Share this post


Link to post
Share on other sites

Hi Spooks,

 

Very nice contribution, I dont know what we would do without you.

 

I have been running your fancybox popup with multiple images for a couple of months now and it has been working perfectly however a couple of days ago the Navigation arrows and the X to close have gone, the black background for the image name has also vannised.

 

I have tried changing the "show pop up Navigation' option in the admin console but this does fix things.

 

Here is a link to my website so you can see what I am trying to explain.

 

http://topshelf-rc.co.nz/catalog/product_info.php?cPath=27_28&products_id=1922

 

If you get some time to have a look and provide feedback that would be great.

 

Thanks in advance..........Dave

 

 

I am not Spooks but when I went to your site all of your images for products, etc. were not showing up. You might want to check your images directory permissions. Either that or your images path has been changed perhaps in cart/includes/images.

 

Just a start,

 

Charles

Share this post


Link to post
Share on other sites

I am not Spooks but when I went to your site all of your images for products, etc. were not showing up. You might want to check your images directory permissions. Either that or your images path has been changed perhaps in cart/includes/images.

 

Just a start,

 

Charles

Thanks Charles, I have taken a look at my website from a number of PC's and the images are showing on these PC's but the navigation stuff and the background to the file name is still missing.

 

Cheers...........Dave

Share this post


Link to post
Share on other sites

Uploaded new version V1.3.5

 

1.Issue with osCthumb encrypted filenames fixed, (not my work, but sorry I cant find the fixers post!)

2.Modified install instuction for alternative version osC categories.

3.Fixed image bug in product info.

 

Changed files: product_info.php, images/js/jquery.fancybox.js

 

 


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Thanks Charles, I have taken a look at my website from a number of PC's and the images are showing on these PC's but the navigation stuff and the background to the file name is still missing.

 

Cheers...........Dave

 

 

Usually when that happens to me I can link it back to either my url paths not being correct in perhaps the config file or that my permissions on those particular images are set wrong. I think they need to be set to 755.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×