Jump to content
spooks

Simple Multi Image Add-on (Un-Limited) with FancyBox Popups

Recommended Posts

Use the included categories.php for your data in admin, that works fine, perhaps your old was broke? The data held in the products image array is in a nessarily complex form, I would'nt even bother to try to enter it manually.

 

The css added should not effect any of your existing it is all quite different to the default, but check incase there are any confilcts with stuff u have added b4 (Use firefox tools) .

 

You should continue to edit your store css in the default stylesheet.

 

(PS if u used the included product_info.php perhaps u had altered your original from default, if so u need to follow the included manual install.)

 

Thanks very much...I'm working on it all now.

Share this post


Link to post
Share on other sites

If you care to re-install I'll take a look tomorrow (its very late here), it may help to make a small change, an issue came up with osC thumb as I have used tep_href_link, but its not needed blush.gif , see http://forums.oscommerce.com/index.php?showtopic=344580&pid=1448402&start=200&st=200#entry1448402 wink.gif

 

 

Thanks, we will reinstall and you can take a look tomorrow. I'll post again when we have it up. I'll also try the tep_href_link suggestion and see what happens.

 

Ok, we reinstalled the Add-on and we have good news: Your suggestion to remove the tep_href_link from the product_info.php file worked. Now the primary image URL is correct and the first image shows up in the Fancybox popup.

 

Thank you Sam! :thumbsup:

Share this post


Link to post
Share on other sites

Uploaded new version 1.25

 

1.Fixed occasional issue with image url.

2.Added back 'Click to enlarge' removed by the ealier mods.

3.Added temporary fix for long product titles (permanent fix in development).

 

Changed files: product_info.php

 

Upgrading: Replace those changed or edit existing files to apply changes.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

This is an exceptional contribution, thank you very much for your efforts. I've installed it, played with it, modified it slightly and almost have it exactly as I want it but keep running into one recurring issue.

 

My application is in a heavily modified store (which in itself may be the issue). What I find is that the product_info.php page will distort somewhat. It is probably easier to show than to explain so here is an example: My link

 

Once I call up any product image the store template will distort . . . I can usually sort these things out myself but I'm at a bit of a loss where to begin . . . would anyone have any ideas?

 

Thanx in advance.

Share this post


Link to post
Share on other sites

Once I call up any product image the store template will distort . . .

 

 

I`ve looked at the page with ie7 & firefox & see no issue, what browser are u using?


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hello, Thank u very much, your addon is really great i really love it.

 

But i just got antoher Error:

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /srv/www/htdocs/web122/html/store/includes/boxes/categories.php:12) in /srv/www/htdocs/web122/html/store/includes/boxes/categories.php on line 57

 

Please help!

 

Thanks a lot.

Share this post


Link to post
Share on other sites

But i just got an Error:

 

 

You have made errors in the install, go over it again, or use the supplied file.

 

Use of a file compare tool may make it easier for you.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hi, I have a question about installing the SQL files. Namely, I don't even know what a SQL file looks like :) I took a stab and tried using my hosts phpMyAdmin interface to import the "SQL V1 to V1.1.txt" and "SQL V1.1.txt" files into the osCommerce db, but it wouldn't accept it. What is the correct method for installing the included SQL? Thanks in advance!

Share this post


Link to post
Share on other sites

What is the correct method for installing the included SQL?

 

 

This thread you help you with that.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

What is the correct method for installing the included SQL?

 

 

This thread you help you with that.

Thank you, sir! This worked for the "SQL V1 to V1.1.txt" file (no errors anyway), but for the second file "SQL V1.1.txt" phpMyAdmin came back with the following:

 

ERROR:
SQL query:

ALTER TABLE `products` ADD `products_image_array` VARCHAR( 800 ) NULL DEFAULT NULL ;

MySQL said:
#1074 - Too big column length for column 'products_image_array' (max = 255). Use BLOB instead 

Did I do something wrong? I simply pasted the SQL V1.1.txt file into the query box and hit "Go". Thanks!!!

Edited by CheeseFrog

Share this post


Link to post
Share on other sites

Thats a new one on me, its your version of MySQL, use this instead

ALTER TABLE `products` ADD `products_image_array` blob; 

 

Though its odd, as v1 has the same instruction!!

 

As this is a new install, you should have just run the v1.1 SQL, but never mind, no harm.

 

 

 

 


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

hello ... thanks for the contribution . I use it and it's cool!

but please allow me to tell something that not solved yet about the contribution ...

 

when we delete the product from list , primary image is deleted, but the additional image still exist!

also, if we change the additional image, the old one is not removed , but still exist in the hosting storage. surely its a serious problem .

 

contributors , please fix these problem . thanks :thumbsup:

Edited by LoE_Seifer

Share this post


Link to post
Share on other sites

I`ve looked at the page with ie7 & firefox & see no issue, what browser are u using?

 

 

Hi spooks

 

Thanx for looking . . . I'm using IE7 and Firefox as my main cross browser tests but also look at it periodically in Google Chrome and IE6 . . . I probably wasn't specific enough; the footer navigation bar distorts, the links in the side column become bold and the very top section stretches causing the background image to repeat. These things only happen on the product info page or after I click on one of the images.

 

Someone told me I had probably not closed a division somewhere and that is what I am looking at now but I had hoped someone had experienced something like this and might point me in the right direction.

Share this post


Link to post
Share on other sites

the footer navigation bar distorts, the links in the side column become bold and the very top section stretches causing the background image to repeat. These things only happen on the product info page or after I click on one of the images.

 

 

I see now, it appeared b4 u were talking of changes when u clicked on a popup image, what your actually saying is the product_image page style varies from other pages on the site.

 

This will be due to a different doc-type on this page to the others, play with the doc-type to fix, but remember there are a limited set that can be used for this page.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

but please allow me to tell something that not solved yet about the contribution ...

contributors , please fix these problem . thanks thumbsup.gif

 

Please read the docs!! The option to remove from server was added in v1.2!! see http://forums.oscommerce.com/index.php?showtopic=344580&pid=1444664&start=100&st=100#entry1444664 huh.gif

 

By default deleting a main image or product does not remove the image from the server, perhaps u added code for that. wink.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

I see now, it appeared b4 u were talking of changes when u clicked on a popup image, what your actually saying is the product_image page style varies from other pages on the site.

 

This will be due to a different doc-type on this page to the others, play with the doc-type to fix, but remember there are a limited set that can be used for this page.

 

Hi again spooks

 

Changing the Doc-Type resolved the issue. Thank you so much.

Share this post


Link to post
Share on other sites

Hello, thank you for your contribution. I installed your contribution in my osC 2.2 MS2. When I access the admin/products occurs this error:

Fatal error: Call to undefined function tep_hide_session_id () in /home/epicstor/public_html/shop/admin/categories.php on line 870

 

Someone knows this error?

Share this post


Link to post
Share on other sites

Fatal error: Call to undefined function tep_hide_session_id ()

 

 

It seems you have used the included categories.php file, as stated its from the rc2a distrib, so has functionsa from that. tep_hide_session_id () was not included in MS2.

 

you could add that function to your functions/general.php file, or edit your old categories.php manually, as per the instructions.

 

 

Get the function, if needed, from the 2.2rc2a distribution.

Edited by spooks

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Does anyone have any idea how to fit this in if you already have something like Header Tags SEO installed. The conflict occurs on about line 420 in admin/includes. The install documentation says to do this:

 

Find(420)

 

'products_price' => '',

'products_weight' => '',

'products_date_added' => '',

'products_last_modified' => '',

'products_date_available' => '',

'products_status' => '',

'products_tax_class_id' => '',

'manufacturers_id' => '');

 

$pInfo = new objectInfo($parameters);

 

if (isset($HTTP_GET_VARS['pID']) && empty($HTTP_POST_VARS)) {

// Simple multi image addon

$product_query = tep_db_query("select pd.products_name, pd.products_description, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "'");

$product = tep_db_fetch_array($product_query);

 

Replace with:

 

// Simple multi image addon

'products_image_array' => '',

'products_price' => '',

'products_weight' => '',

'products_date_added' => '',

'products_last_modified' => '',

'products_date_available' => '',

'products_status' => '',

'products_tax_class_id' => '',

'manufacturers_id' => '');

 

$pInfo = new objectInfo($parameters); $products_image_array = array();

 

if (isset($HTTP_GET_VARS['pID']) && empty($HTTP_POST_VARS)) {

$product_query = tep_db_query("select pd.products_name, pd.products_description, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_image_array, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "'");

$product = tep_db_fetch_array($product_query);

$products_image_array = unserialize($product['products_image_array']);

if (!is_array($products_image_array)) $products_image_array = array();

// EOF Simple multi image addon

 

 

But currently, I already have this:

 

$pInfo = new objectInfo($parameters);

 

if (isset ($HTTP_GET_VARS['pID']) && (!$HTTP_POST_VARS) ) {

/*** Begin Header Tags SEO ***/

$product_query = tep_db_query("select pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "'");

/*** End Header Tags SEO ***/

$product = tep_db_fetch_array($product_query);

 

Any ideas?

Share this post


Link to post
Share on other sites

Fatal error: Call to undefined function tep_hide_session_id ()

 

 

It seems you have used the included categories.php file, as stated its from the rc2a distrib, so has functionsa from that. tep_hide_session_id () was not included in MS2.

 

you could add that function to your functions/general.php file, or edit your old categories.php manually, as per the instructions.

 

 

Get the function, if needed, from the 2.2rc2a distribution.

 

Thanks, I updated my version of oscommerce, work and contribution

perfectly.

Thank you very much.

Share this post


Link to post
Share on other sites

Is there a way to make it so the thumbnail is scaled proportionally? Like if my image was 400x600 it'll be scaled down to 100x150 and not 100x100 on the products info page?

Share this post


Link to post
Share on other sites

One solution to image popup not working : My images didint popup , and sometimes i only got this weird blank box , well the cause of this problem for me was settings on OscThumb. I had this option "Encrypt Image Filenames" set to true (i believe this is on default) so i turned it to false and everything started working beautifully!

 

Thanks for the contribution and just wanted to say this coz might be helpful to someone.

Share this post


Link to post
Share on other sites

One solution to image popup not working : My images didint popup , and sometimes i only got this weird blank box , well the cause of this problem for me was settings on OscThumb. I had this option "Encrypt Image Filenames" set to true (i believe this is on default) so i turned it to false and everything started working beautifully!

 

Thanks for the contribution and just wanted to say this coz might be helpful to someone.

 

 

Thanks, that is a known bug, but one with osC Thumb (see that thread) it occurs with other contribs to, can even happen on default set up. ohmy.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

a way to make thumbnail scaled proportionally?

 

 

That's standard osC stuff, in admin set only widths & leave all heights empty (blank), then none of your images will be distorted. wink.gif

Edited by spooks

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×