Jump to content
Sign in to follow this  
moyashi

NewsDesk v 1.3 Released!

Recommended Posts

Don't sorry, with Newsdesk you do one of the greatest contribution for oscommerce (In My Humble Opinion)

And it is really useful for what I want to do with osc.

Is the small bug, with "Display Category/Manufacturer Filter (0=disable; 1=enable) =0" work better now ?

 

thx, take care ;)

Share this post


Link to post
Share on other sites

moyashi...

 

:idea: idea :idea:

products related to article?! this would be a great great great (you get the point, great) feature!!!

 

cheers

emiliano[/b]


patagonia, argentina

Share this post


Link to post
Share on other sites

@ Talme,

 

I posted to the answer to your problem, it's at the top of page 5 of this thread.

 

Basically, that's the setting for the newsdesk_listings.php page. It doesn't affect other pages.


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

new feature on the way...

someone needs an small text under the image? done!

 

just wait for 1.4, i send the mod steps to moyashi...

 

 

cheers

emiliano

 

you want the mods to? PM me!


patagonia, argentina

Share this post


Link to post
Share on other sites

I'll hopefully will get to your 2 mods tonight Emiliano. I'm working on an interesting feature that I've tried before.

 

Thanks so much!


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

Farrukh,

 

Did you fix it? It looks ok in Moziila on OSX.

Hmm, It might be that in 1.3 which was mentioned somewhere in this thread that a closing " > " was missing on a tag.

 

I fixed this for version 1.4 (hopefully :o )

 

Nice Site.

I love the desert look and your buttons fit nicely into the site too.


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

Hiya Thanks for the compliments moyashi :)

 

I havent fixed it as yet. I'll look into the newsdesk_info.php

 

eagerly waiting for the version 1.4 of NewsDesk.

 

Its excellent contribution and very useful indeed.

Share this post


Link to post
Share on other sites

v 1.4 is taking a little longer than I expected. I'm working on a mod right now that affects the whole system. The admin side of the mod is almost done, I hoping to finish that tomorrow by the latest. Then I have to work on the front end of the mod, add configuration variables and what not :( However it's something that many of you have wanted.

 

yes, I do believe that the html problem was in newsdesk_info ... If you scan this thread there were fixes posted.

 

good luck and yes I do like your site :D


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

HIya ill just go through the previous posts

 

Also, about version 1.4 ,i am willing to test it on my other domain if you get it done :)

Share this post


Link to post
Share on other sites
newsdesk_info.php

line 108 <td class="main" valign="top"> (just forget the ">" in end)

to correct column bug

 

and Add these 2 lines

 

define('BOX_HEADING_NEWSDESK_CATEGORIES', 'Newsdesk');

define('BOX_HEADING_NEWSDESK_LATEST', 'Latest News');

 

in newsdesk_info.php, newsdesk_index.php

 

Thanks to mooh , this solved the problem :)

Share this post


Link to post
Share on other sites

Hi Moyashi,

 

First, I want to Thank you for such a great contribution. I have just installed it onto my website and love every bit of it. However, I do have one problem that maybe you can clarify for me.

 

Is there a way I can disable the Image to "not" display on the article?

 

I have played around with the Setting "Display Image" in admin but cannot get the image "not" to display.

 

Thanks for your help,

David

Share this post


Link to post
Share on other sites

:D Walnut Creek, used to have friends from that area! A Vietnamese acquanitance parent's run (still do?) a pizza shop in the area.

 

That settings is for the listings page (the one with the strange light blue color).

 

I've been coding so much on v1.4 recently that I've forgotten what were the differences. However v1.4 has that setting now. Actually, v1.4 has a lot more settings and goodies :D


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

Moyoshi

 

So has you work on version 1.4 completed as yet or will it take some time.?

 

Simply cant wait :)

Share this post


Link to post
Share on other sites

Basically v1.4 is about 80%+ completed.

 

I'm gonna look into a 2 more mods. Then I'm going to try to change the location of all the files, ie;

 

includes/modules/newsdesk/

languages/eng/newsdesk/

 

With all the extra things I've added in the past week the structure has grown a lot and I don't want to have to search every where for a file.

 

I just finished a major mod that involved 20 file changes, hopefully these last 2 mods will only be like 5-10 files.

 

Sorry for taking so long. I putting in like 3+ hours a day into this and well, you know ... taking longer than I expected.


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

I am sorry but i have a problem with newsdesk 1.3

i geting error:

Warning: Failed opening 'includes/modules/FILENAME_newsdesk' for inclusion (include_path='.:/php/includes:/usr/share/php') in /home/virtual/site53/fst/var/www/html/index.php on line 318

 

I folowed installation instructions, and i checked if newsdesk.php is in a proper position. I adjusted rigths to 755. But it is still don't work. :cry:

Share this post


Link to post
Share on other sites

Hi Mikhail,

 

Look in catalog/includes/application_top.php if this code is there.

 

// BEGIN newdesk

define('FILENAME_newsdesk', 'newsdesk.php');

define('FILENAME_newsdesk_info', 'newsdesk_info.php');

define('FILENAME_newsdesk_index', 'newsdesk_index.php');

define('FILENAME_newsdesk_LISTING', 'newsdesk_listing.php');

define('FILENAME_NEWSDESK_LATEST', 'newsdesk_latest.php');



define('FILENAME_NEWSDESK_REVIEWS_ARTICLE', 'newsdesk_reviews_article.php');

define('FILENAME_NEWSDESK_REVIEWS_INFO', 'newsdesk_reviews_info.php');

define('FILENAME_NEWSDESK_REVIEWS_WRITE', 'newsdesk_reviews_write.php');

define('FILENAME_NEWSDESK_REVIEWS', 'newsdesk_reviews.php');

define('FILENAME_NEWSDESK_ARTICLE_REQUIRE', 'newsdesk_article_require.php');

// END newsdesk

 

 

Also check your admin/includes/application_top.php if the defines are correct there too.

 

I'm not sure which area you are referring too since I'm not sure if you renamed you default.php to index.php (I renamed it :D )


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

What I did to fix the column bug -

 

Original Code below - latest download of newsdesk_info.php v1.3

 

<td class="main" valign="top"





<?php

// Added an extra AND statement since osC is spewing Array as a "none" image for a no entry in the image field

if (($product_info_values['newsdesk_image'] != '') && ($product_info_values['newsdesk_image'] != 'Array')) {

?>



<table border="0" cellspacing="0" cellpadding="0" align="right">

<tr>

 <td>

 

to fix code ADD a > tag not remove the tag

 

Code will look like this line 108

 

<td class="main" valign="top">





<?php

// Added an extra AND statement since osC is spewing Array as a "none" image for a no entry in the image field

if (($product_info_values['newsdesk_image'] != '') && ($product_info_values['newsdesk_image'] != 'Array')) {

?>



<table border="0" cellspacing="0" cellpadding="0" align="right">

<tr>

 <td>

 

Also add the 2 lines:

 

require('includes/application_top.php');

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_newsdesk_info);

 

This what worked for me! Now I just have to figure out how to fix the horizontal line through the news image. Any suggestions??

 

http://www.tinysnutrition.com/shop/catalog...p?newsdesk_id=1

 

Team Tiny's

www.tinysnutrition.com

Share this post


Link to post
Share on other sites

Fixed another little issue with this release.

 

Add:

define('BOX_HEADING_NEWSDESK_CATEGORIES', 'News Catagories');

define('BOX_HEADING_NEWSDESK_LATEST', 'Latest News');

 

to newsdesk_index.php

 

fixes box heading title issue.

 

BTW Great contribution, thanks Moyashi for all your hard work.

 

Team Tiny's

www.tinysnutrition.com

Share this post


Link to post
Share on other sites

OOPS made a mistake in the add these 2 lines:

 

Add these two lines to newsdesk_info.php

 

define('BOX_HEADING_NEWSDESK_CATEGORIES', 'Newsdesk'); 

define('BOX_HEADING_NEWSDESK_LATEST', 'Latest News');

 

not

 

require('includes/application_top.php');

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_newsdesk_info);

 

Sorry..

 

Tiny's Team

www.tinysnutrition.com[/code]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×