Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

spooks

How do I install a contribution or add on?

28 posts in this topic

How do I install a contribution or add on?

 

This gets asked quite a lot and having checked I couldn't find any complete answer in one place, so this, I hope, will resolve that.

 

  1. Finding the right one:
    When looking for a contribution look for ones that are supported (ie have a support thread) and are current for your version of osC. The better ones will say what version of osC they have been tested on, if they require register globals on or off (off preferably) and maybe what versions of PHP/SQL they have been tested on.
    -
  2. Searching:
    Search for contribs with google, put site:http://addons.oscommerce.com then query.
    Search the forum with google by putting site:http://forums.oscommerce.com then query.
    -
  3. Which Version of a Contribution should I download
    Ideally you should pick the latest full version by the original author, unfortunately not everyone states when they have provided a Full Version, so you have to download 1st before you find if you have the right one, sometimes you will find on the support thread which is best to download (ie Ultimate seo urls 2.1d original updated is a good case in point).
     
    Take care if the contrib. has lots of fixes, it can be a real pain if you have to install the main package, then go through a load of 'fixes', an addition important note is some find an issue, fix it for their install the rush to post their 'fix' without regard to that 'fix' being peculiar to them.
    -
  4. Editing your files
    Do not use inbuilt editor in filemanager, its a security risk & damages files, best removed. Edit your files with a proper text editor, such as html-kit or notepad++ after downloading all your files to your PC with ftp such as filezilla.
    -
  5. Installation

    Before you do anything, BACKUP BACKUP BACKUP


    There is no set method, the procedure depends on each contrib.


    Within the download there is normally an installation file that describes the procedure. This may be to replace existing files or make modifications to them, if replacing files check your using the same version of osC the contrib. was written with and that your files have not already been modified. Often the easiest way is to use a file compare tool, like WinMerge or Beyond Compare.
     
    If the installation just has instructions on modifying your existing files, follow these with great care, making sure you don't miss any. Remember osC has files within the catalog directories and admin directories with the same names, make sure you are editing the correct ones, and you upload your modified files in the correct places.
     
    It is likely that the contribution has new files to add, make sure you place them in the correct places.
     
    Some contribs have auto-installs, Pektsekye seems to have taken it upon himself to add these to quite a few contribs, this makes thing a lot easier for you but take care your system is compatible first & don't forget to backup first.
    -


  6. The contribution has a SQL file, what do I do with that?
    The SQL files are there to modify you database so it will work with the contrib., so first backup your database, I suggest you look at AutoBackup Database in Admin AND Database Backup Manager to make this easier. You can also backup your dBase from within your cPanel.
     
    To apply any SQL:
    Log into your site cPanel, click on phpMyAdmin, if your database doesn't come up automatically, select it, click on any item in the dBase, say address_book then click on SQL, paste the query provided into the box, removing what's there by default, click on GO, you should get confirmation that everything was processed OK.
    -
  7. I'm not sure what version osC I'm using.
    This thread in Tips details the method to find your osC version, don't forget in Admin, under tools you have Server Info, that will provide a lot of info about your store & server.
    -
  8. I've completed the install but now my site has errors.
    First don't assume there is a problem with that contribution, the most likely cause is you have made errors during the install, so don't rush to post your problem, double & triple check your install, you probably missed something, or put something in the wrong place. If you still have errors, do a search of the forum (tips above) with the error message you get.
     
    If you still can't resolve things post in the contributions support thread, don't create a new thread unless you are sure there is no support thread, as that is likely to annoy those supporting & will probably be ignored.
    -
  9. I have a template & can't match the code given with mine.
    Unfortunately templates often contain non-standard usually out-dated code that is generally somewhat modified from the core version, so are rarely compatible with contributions, you need to talk to your template supplier if you really need the add on.
     
    For the most part you need to be good at coding to fix/modify templates, but if you were you probably wouldn't have bothered with one in the first place!!

----------------

Have fun installing, you will likely find it a learning experience.


Contributions are found

here and their support threads are usually here.


Share this post


Link to post
Share on other sites

Additional notes if you have errors after installing.

 

Assuming you have gone through the steps in item 8 on the previous post, when you create a new post make sure you include your full error message, the php and sql versions in use on your server as well as what version of osC your site is using. If your applying to a template its important you mention that too.

 

If your having to create a new thread as you are unable to find an existing support thread, ensure you make it clear what contribution you have installed and include a link to the contribution. Too often people just post I've installed, now I have this error, there are no mind readers on the forum, we need to know what your on about!!

 

The more information you can give in your original post the better, and the more likely you are to get a quick and appropriate response. Don't go mad though with loads of unnecessary prattle.

Share this post


Link to post
Share on other sites
Editing your files

Do not use inbuilt editor in filemanager, its a security risk & damages files, best removed. Edit your files with a proper text editor, such as html-kit or notepad++ after downloading all your files to your PC with ftp such as filezilla.

 

Thank you this was exactly what my installation did, I tried to find out what exactly the problem was but could not find the error, so now I found this thread.... thank you very much for sharing.

Share this post


Link to post
Share on other sites

How do I install a contribution or add on?

 

[*]Finding the right one:

When looking for a contribution look for ones that are supported (ie have a support thread) and are current for your version of osC. The better ones will say what version of osC they have been tested on, if they require register globals on or off (off preferably) and maybe what versions of PHP/SQL they have been tested on.

-

[*]Searching:

Search for contribs with google, put site:http://addons.oscommerce.com then query.

Search the forum with google by putting site:http://forums.oscommerce.com then query.

-

[*]Which Version of a Contribution should I download

Ideally you should pick the latest full version by the original author, unfortunately not everyone states when they have provided a Full Version, so you have to download 1st before you find if you have the right one, sometimes you will find on the support thread which is best to download (ie Ultimate seo urls 2.1d original updated is a good case in point).

 

Take care if the contrib. has lots of fixes, it can be a real pain if you have to install the main package, then go through a load of 'fixes', an addition important note is some find an issue, fix it for their install the rush to post their 'fix' without regard to that 'fix' being peculiar to them.

-

Thanks, Sam.

 

Re which contribution to download:

Our shop's version is v2.2 RC2a.

What is the meaning of v2.2 under the Add-On listings on the http://addons.oscommerce.com/ page? Does v2.2 mean that that particular contribution works with any v2.2 shop INCLUDING the v2.2 RC2a ones?

Share this post


Link to post
Share on other sites
What is the meaning of v2.2 under the Add-On listings on the http://addons.oscommerce.com/ page? Does v2.2 mean that that particular contribution works with any v2.2 shop INCLUDING the v2.2 RC2a ones?

 

In theory yes, but there are significant differences between MS2 & the RC releases the biggest of which is regeister globals (must be on for MS2 & off for RC), so don't install a contrib that needs RG on to an RC store, as that would be retrograde & a security risk. Note the ' This add-on is register_globals compatible ' banner on the cotribs, it means it will work with RG off.

 

The better contribs will say what varients of the 2.2 releases it has been tested on. ;)

Share this post


Link to post
Share on other sites
In theory yes, but there are significant differences between MS2 & the RC releases the biggest of which is regeister globals (must be on for MS2 & off for RC), so don't install a contrib that needs RG on to an RC store, as that would be retrograde & a security risk. Note the ' This add-on is register_globals compatible ' banner on the cotribs, it means it will work with RG off.

 

The better contribs will say what varients of the 2.2 releases it has been tested on. ;)

If I understand correctly, there are significant differences even between variants of the same release. In this case, maybe people uploading contributions should be forced to clearly specify exactly which variant(s) the add-on works with, not only in the readme files, but also on the contribution page. This way, no-one will have to download the add-on first, go through the readme, install etc. files and eventually find out that the contribution hasn't been specifically tested to work with their shop variant. Has anyone else come across this problem before I wonder? Food for thought for the contribution section maintainers and forum admins.

Share this post


Link to post
Share on other sites

If you use versions that have been uploaded in the latter part of '08 on they should be OK for rc2a, but no guarantee!!

Share this post


Link to post
Share on other sites

DOWNLOADING A CONTRIBUTION, HOW TO:

 

Some seem to have trouble working out how to download contributions.

 

Having opened the individual contribution page you will see a list of versions with the latest expanded, on the left of that expansion window is the title of that version, to the right is the name of the contributor then the 'download' link, then a 'report' link.

 

Click on the download link image to download that version. ;)

Share this post


Link to post
Share on other sites

Hey guys,

 

I am having its error in my admin section and I am not able to see any boxex or do anything in the admin section

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/bombayrc/public_html/admin/includes/boxes/reports.php on line 26

 

Please help me

Share this post


Link to post
Share on other sites

Hey guys,

 

I am having its error in my admin section and I am not able to see any boxex or do anything in the admin section

 

 

 

Please help me

 

 

If you've installed smthg, go over the install again more carefully, no-one has a majic wand to fix such errors! blink.gif

 

When you create errors in your code its no good just giving the error message as no-one can do much with that. You must also post the code around the area where your error occurs. wink.gif

 

 

Remember, php does not forgive errors, a single character out of place will cause it to fail. smile.gif

Share this post


Link to post
Share on other sites

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/bombayrc/public_html/admin/includes/boxes/reports.php on line 26

 

 

Sir this is the error I am getting in my admin section

Share this post


Link to post
Share on other sites

<?php

/*

$Id: reports.php 1739 2007-12-20 00:52:16Z hpdl $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

?>

<!-- reports //-->

<tr>

<td>

<?php

$heading = array();

$contents = array();

 

$heading[] = array('text' => BOX_HEADING_REPORTS,

'link' => tep_href_link(FILENAME_STATS_PRODUCTS_VIEWED, 'selected_box=reports'));

 

if ($selected_box == 'reports') {

$contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_VIEWED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_VIEWED . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_STATS_WISHLISTS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_WISHLISTS . '</a><br>'

'<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_PURCHASED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_PURCHASED . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_STATS_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_ORDERS_TOTAL . '</a>');

}

 

$box = new box;

echo $box->menuBox($heading, $contents);

?>

</td>

</tr>

<!-- reports_eof //-->

 

 

This is the completer report file from where the error is generated

 

Also i would like to inform you that I have installed WISHLIST on my forum before doing the installation for your contribution.

 

Waiting for your reply

Share this post


Link to post
Share on other sites

Please use the 'reply' button instead of the 'add reply' it makes conversations easier to follow. wink.gif

 

 

Did the contribution not have a support thread? thats the best place for such queries. huh.gif

 

You have an extra quote in the line:

 

'<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_PURCHASED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_PURCHASED . '</a><br>' .

it should be:

 

'<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_PURCHASED, '', 'NONSSL') . ' class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_PURCHASED . '</a><br>' .

 

 

If that code came with the contrib, you should report the error to the author. smile.gif

 

 

Share this post


Link to post
Share on other sites

Please use the 'reply' button instead of the 'add reply' it makes conversations easier to follow. wink.gif

 

 

Did the contribution not have a support thread? thats the best place for such queries. huh.gif

 

You have an extra quote in the line:

 

'<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_PURCHASED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_PURCHASED . '</a><br>' .

it should be:

 

'<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_PURCHASED, '', 'NONSSL') . ' class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_PURCHASED . '</a><br>' .

 

 

If that code came with the contrib, you should report the error to the author. smile.gif

 

 

sir,

 

no change... i still have the same error yet

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/bombayrc/public_html/admin/includes/boxes/reports.php on line 26

Share this post


Link to post
Share on other sites

sir,

 

no change... i still have the same error yet

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/bombayrc/public_html/admin/includes/boxes/reports.php on line 26

 

then you also have an error in the related language file, you must have used reserved chars in the defines without escaping them (i suspect in languages/english.php or in includes/filenames.php

)

Share this post


Link to post
Share on other sites

Sir,

 

I have installed this contribution of simple images. and everything is working fine but now the issue is the I cannot see the images in the product listing.

 

Can you please guide me with where I must have done a mistake.

 

 

kindly help

Share this post


Link to post
Share on other sites

[...]I have installed this contribution of simple images. and everything is working fine but now the issue is the I cannot see the images in the product listing.[...]

 

Does this contribution not have a support forum? It's impossible for anyone to help you since nobody knows what you installed exactly, and even this would be clear, then still the contribution support forum is the right place to report your problem

 

Please, try to keep this topic here as clean as possible, because it is not the right place to discuss your images problems

 

How to find the contribution support forum? Go back to the page where you downloaded the contribution, it should be written there. Also maybe in the installation instructions. If it is not there, then check the different uploads, maybe somebody was so nice to mention it in his upload. If you still can not find it, then search the forum using the contribution name.

 

And if there is still nothing, then finally, install an other contribution that has a proper support

spooks likes this

Share this post


Link to post
Share on other sites

Does this contribution not have a support forum? It's impossible for anyone to help you since nobody knows what you installed exactly, and even this would be clear, then still the contribution support forum is the right place to report your problem

 

Please, try to keep this topic here as clean as possible, because it is not the right place to discuss your images problems

 

How to find the contribution support forum? Go back to the page where you downloaded the contribution, it should be written there. Also maybe in the installation instructions. If it is not there, then check the different uploads, maybe somebody was so nice to mention it in his upload. If you still can not find it, then search the forum using the contribution name.

 

And if there is still nothing, then finally, install an other contribution that has a proper support

 

Sorry pal but i didn't mean to offend but as i though the contributions is written my spooks... he would help me in this thread.

 

But i will surely try and look for the exact support thread for this contrution

 

Thanks

Share this post


Link to post
Share on other sites

A point to note following the recent changes in the add-ons section (which some seem to miss) is that the primary download link always links to the latest upload, that may not be the full version but could be simply an update or possibly even empty if the last update is just a note!!

 

So always click on the HISTORY tab to check the details of the latest. wink.gif

 

 

 

 

I must say that update is a bad idea as the default info provided is that originally given when the add-on was created, which is very likely outdated info and by linking that to the latest upload can easily be linking to something of little relavence!! cool.gif

 

I would suggest displaying the latest upload info by default, adjacent to the download link, would be a better idea. smile.gif

Share this post


Link to post
Share on other sites

Please can you explain me this step:

To apply any SQL:

Log into your site cPanel, click on phpMyAdmin, if your database doesn't come up automatically, select it, click on any item in the dBase, say address_book then click on SQL, paste the query provided into the box, removing what's there by default, click on GO, you should get confirmation that everything was processed OK.

what meaning "say address_book"? I need to select this item?

or I apply the query to all db?

I need to select the item address_book?

sorry for the stupid questions, but I'm not english and I don't understand this step

thanks a lot!

Share this post


Link to post
Share on other sites

Please can you explain me this step:

To apply any SQL:

 

 

Ok I`ll try re-wording the instructions, hopefully it will become clear.

 

To apply any SQL with phpMyAdmin:

 

Log into your site cPanel then click on phpMyAdmin.

 

 

Once your logged into phpMyAdmin, you may see more than one database (listed on the left of the display), if so you will need to select your database from the dropdown list, the osC one is usually the larger one shown.

 

The left side will now show a list of all the tables within your database and the main part of the screen will show the table structure.

 

On a default osC setup the tables listed will be:

 

 

  • address_book
  • address_format
  • administrators
  • banners
  • banners_history
  • categories
  • categories_description
  • configuration
  • configuration_group
  • counter
  • counter_history
  • countries
  • currencies
  • customers
  • customers_basket
  • customers_basket_attributes
  • customers_info
  • geo_zones
  • languages
  • links
  • links_categories
  • link_description
  • manufacturers
  • manufacturers_info
  • menu
  • menu_colors
  • newsletters
  • orders
  • orders_products
  • orders_products_attributes
  • orders_products_download
  • orders_status
  • orders_status_history
  • orders_total
  • page_description
  • products
  • products_attributes
  • products_attributes_download
  • products_description
  • products_notifications
  • products_options
  • products_options_values
  • products_options_values_to_products_options
  • products_to_categories
  • reviews
  • reviews_description
  • sessions
  • specials
  • tax_class
  • tax_rates
  • whos_online
  • zones
  • zones_to_geo_zones

If your display shows a very different list, select another database & re-check.

 

Across the top of the database display area you will see a nav bar that looks like:

 

Structure | SQL | Search | Export | Import | Operations

 

Select the SQL tab.

 

You should then get a box with a title like:

 

Run SQL query/queries on database xxxxx.

 

If there is anything in that box, empty it.

 

Enter your SQL query into that box.

 

At the bottom that box is a button that says "Go", click on that and phpMyAdmin will run the query.

 

If all is well your database will be updated with your querey and you will see a success message. biggrin.gif

 

 

 

 

 

Share this post


Link to post
Share on other sites

Thanks Sam, for your tip here on installing contribution. My question is, and I hope you do not think this being a dumb question. The instruction for vast majority of the contributions will instruct to add such code just before the last ?> in filename or the language file. Example below:

define('FILENAME_XXXXXXXXX', 'Xxxxxxxxx.php'); // New Conytribution

Now when I do it, I will insert in a alphabetically manner along with a comment with each of the new additions so that I will know what's it refer to. I guess one would say, good housekeeping.

 

So this should not make any difference with the addons, correct?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi there Spooks,

 

Just looking for a nudge in the right direction on this and if you would be so kind to assist, I have installed your add-on and all seemed to be working (i.e i could access my site pages etc) however when I go to login into the admin section and go to the Catalog field it's blank. This leads me to believe there is something amiss with the categories php code as in your earlier post there is no room for error with PHP. MY SQL upload came back with no errors when i uploaded it so I don't believe this may be causing it or could it cause this?

 

Any help will be greatly appreciated.

Thanks Beats

Share this post


Link to post
Share on other sites

Hi all, I have now managed to get the catlog section to show, and if when adding new product images it gives me the option to add 3 additional images for the Simple Image Add-on, So all appeared to be well until I uploaded additional images and then clicked preview within the catalog section. I was then presented with this bit of code showing up at the botton and also an error code,

 

 

Additional Images:

if (isset($HTTP_GET_VARS['read']) && ($HTTP_GET_VARS['read'] == 'only')) { if (isset($HTTP_GET_VARS['origin'])) { $pos_params = strpos($HTTP_GET_VARS['origin'], '?', 0); if ($pos_params != false) { $back_url = substr($HTTP_GET_VARS['origin'], 0, $pos_params); $back_url_params = substr($HTTP_GET_VARS['origin'], $pos_params + 1); } else { $back_url = $HTTP_GET_VARS['origin']; $back_url_params = ''; } } else { $back_url = FILENAME_CATEGORIES; $back_url_params = 'cPath=' . $cPath . '&pID=' . $pInfo->products_id; } ?>

 

Then

 

This error

 

Error!

 

Unable to determine the page link!

 

Function used:

 

tep_href_link('', '', 'NONSSL')

 

 

I have been scouring the forums and the net for the past few days and the above error code seem fairly common however I have been unable to resolve my issue.

 

Can anybody help?

 

Thanks

Share this post


Link to post
Share on other sites