Jump to content
Sign in to follow this  
ecartz

Linkpoint Connect 2.0

Recommended Posts

I am getting ready to upload a new version of the Linkpoint Connect payment module for osCommerce. I have made no changes in the previous module. What I have done is to add a new module (with english language file) that does not collect any credit card information. Instead, it posts the order information to Linkpoint, which then collects the card information and processes the payment. This module should be suitable for shops that do not want to meet the PCI/DSS requirements for collecting credit card information. The uploaded zip has both modules in it.

 

Posting the topic before the module so that I can include a link to this thread in the module description. Previous versions have not included a support thread, which has led to some fragmentation of the topics. This is especially burdensome since there are four separate contributions for Linkpoint. Hopefully posting a support thread will collect any new information in one place.

 

Known issue with the new module: when you post to Linkpoint, it shows the credit card holder's name, street address, state, and zip code but not the city. It gets the city, but it does not allow the city to be changed even though it will allow the zip and state to be changed. This is a weird behavior, but as best I can tell, it is a Linkpoint issue rather than an issue with the module. If someone finds out differently, they should post here.

 

URL for the contribution: http://addons.oscommerce.com/info/2423


Always back up before making changes.

Share this post


Link to post
Share on other sites

Thanks for posting the module Matt!

 

I wanted to add some info for anyone who does not have the linkpoint connect menu on their account pages at linkpoint. I called the number included in the contribution and had to go through my whole story with 4 different people. Finally I was told I need to call my Relationship Manager (the guy who signed me up with linkpoint). He can turn on the connect feature if you do not already have it available. It may take 24 to 48 hours for the option to show up. There was no extra charge for me to have this turned on.

 

Once I have the option available, I am going to implement this on a new site I built. If I run into any more pertinent info, I will post here.

 

Tim

Share this post


Link to post
Share on other sites

I am having difficulty installing this payment module, Linkpoint Connect 2.0. I want paypal to work also and customers to be able to pay with a check or money order. Is Linkpoint just not worth the bother? When I call them they tell me if it doesnt work then maybe I should consider changing shopping cart software and they tell me they cant help me.

 

I have installed both Linkpoint Connect and the OffSite modules and neither work. The instructions tell me to:

 

Make this change to checkout_payment.php:

 

<!-- body_text //-->

<td width="100%" valign="top"><?php echo tep_draw_form('checkout_payment', tep_href_link(FILENAME_CHECKOUT_CONFIRMATION, '', 'SSL', false), 'post', 'onsubmit="return check_form();"'); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">

echo tep_hide_session_id();

 

<!--Added false to tep_href_link(checkout_payment) link so Linkpoint wont see sid-->

 

All this change did was give me an error message at the top of the page:

 

echo tep_hide_session_id();

 

I also made all the changes at Linkpoint but all that happens when I click "Continue" is it sends me back to my stores login page!

 

Can anyone explain the proper installation procedure for the Linkpoint module? I want Linkpoint to gather the credit card info and send my customer back to a thank you page on my site! I've been struggling with this for 4 days and need to resolve it quickly.

 

Thanks,

 

Michael

Share this post


Link to post
Share on other sites
I am having difficulty installing this payment module, Linkpoint Connect 2.0. I want paypal to work also and customers to be able to pay with a check or money order. Is Linkpoint just not worth the bother? When I call them they tell me if it doesnt work then maybe I should consider changing shopping cart software and they tell me they cant help me. They (Linkpoint Support suggest I follow the instruction in the Linkpoint Connect PDF Manual on page #28 and insert the html into my php pages to make Linkpoint work correctly.

 

I have installed both Linkpoint Connect and the OffSite modules and neither work. The instructions tell me to:

 

Make this change to checkout_payment.php:

 

<!-- body_text //-->

<td width="100%" valign="top"><?php echo tep_draw_form('checkout_payment', tep_href_link(FILENAME_CHECKOUT_CONFIRMATION, '', 'SSL', false), 'post', 'onsubmit="return check_form();"'); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">

echo tep_hide_session_id();

 

<!--Added false to tep_href_link(checkout_payment) link so Linkpoint wont see sid-->

 

All this change did was give me an error message at the top of the page:

 

echo tep_hide_session_id();

 

I also made all the changes at Linkpoint but all that happens when I click "Continue" is it sends me back to my stores login page!

 

Can anyone explain the proper installation procedure for the Linkpoint module? I want Linkpoint to gather the credit card info and send my customer back to a thank you page on my site! I've been struggling with this for 4 days and need to resolve it quickly.

 

Thanks,

 

Michael

Share this post


Link to post
Share on other sites
Make this change to checkout_payment.php:

 

<!-- body_text //-->

<td width="100%" valign="top"><?php echo tep_draw_form('checkout_payment', tep_href_link(FILENAME_CHECKOUT_CONFIRMATION, '', 'SSL', false), 'post', 'onsubmit="return check_form();"'); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">

echo tep_hide_session_id();

 

<!--Added false to tep_href_link(checkout_payment) link so Linkpoint wont see sid-->

Sorry, I wasn't involved with the install when this was being tested, so I never tried to follow these instructions. It's not clear to me if this is necessary or not. If it is necessary, I think that the code should be (instead of what's shown):
<!-- body_text //-->
<td width="100%" valign="top"><?php echo tep_draw_form('checkout_payment', tep_href_link(FILENAME_CHECKOUT_CONFIRMATION, '', 'SSL', false), 'post', 'onsubmit="return check_form();"');  echo tep_hide_session_id(); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">

Note that the echo statement moved.


Always back up before making changes.

Share this post


Link to post
Share on other sites

I have successfully installed and tested this module.

 

I did not edit my checkout_payment page to remove the oscid. Everything seems to work fine without the edit, so I did not do it.

 

I did fill out all three URL boxes.

Submission form yoursitepath/checkout_confirmation.php

Confirmation page yoursitepath/checkout_success.php

failure page yoursitepath/checkout_success.php

 

I also checked all 4 boxes for:

Url is a CGI Script

and

Automatically display Confirmation Page after the Connect receipt page

 

 

If you check the box for copies of all receipts, you will get 2 of everything. Linkpoint already sends one to the e-mail address on file. The problem is, if you uncheck the box, then you and the customer do not get the e-mail with the card approval information. I believe I will contact linkpoint today to see about this.

 

Also, I failed to see any difference in test mode versus live mode. If I remember correctly there used to be a setting in the linkpoint admin and that was removed a few years ago.

 

Tim

Share this post


Link to post
Share on other sites

I was able to get Linkpoint to process cards but osCommerse doesn't save the order in admin nor do I receive an email of what was ordered. I do get an email from Linkpoint with the purchasers details but not what they ordered!

 

I have had 4 orders this way and I dont know what to ship to them.

 

I need to fix this FAST...

 

Please Help!

Share this post


Link to post
Share on other sites

Make sure that your confirmation URL in Linkpoint is checkout_process.php

 

If you didn't before, add the revised text to checkout_payment.php:

<!-- body_text //-->
<td width="100%" valign="top"><?php echo tep_draw_form('checkout_payment', tep_href_link(FILENAME_CHECKOUT_CONFIRMATION, '', 'SSL', false), 'post', 'onsubmit="return check_form();"');  echo tep_hide_session_id(); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">

It is possible that this matters.

 

Make sure that you checked all 4 boxes for:

Url is a CGI Script

and

Automatically display Confirmation Page after the Connect receipt page


Always back up before making changes.

Share this post


Link to post
Share on other sites

Thanks for your help but I have all these changes made to my site and linkpoint and It still doesnt work. Something in the chronology of the checkout is forgetting to store the order in osCommerse and then send the email to me. All my previous orders have a generated invoice and are stored but since installing linkpoint it doesnt work.

 

Any other suggestions? I appreciate the help...

Share this post


Link to post
Share on other sites

What actually happens when you place an order? When you get back from Linkpoint, where do you go next?

 

Also, your COOKIE settings seem flawed. Even when I allow cookies, I still get an osCsid in the URL. You may want to post the relevant lines from your configure.php file (the ones with HTTP in them).


Always back up before making changes.

Share this post


Link to post
Share on other sites

I have successfully installed linkpoint connect and both versions of the module seem to work properly. The problem I am having is that the Order Number on the linkpoint receipt populates with an IP address followed by 3 groups of numbers. It does not seem to pick up the order number from the store ie. 28. Is this normal? If not where should I look for the problem?

Thanks in advance.

Share this post


Link to post
Share on other sites

Guys, I have a doubt with linkpoint connect.

Any one can change the 'chargetotal' hidden value in the form and go to linkpoint with a small amount to complete the transaction.

is it not a security concern?

Share this post


Link to post
Share on other sites

I have successfully installed linkpoint connect and both versions of the module seem to work properly. The problem I am having is that the Order Number on the linkpoint receipt populates with an IP address followed by 3 groups of numbers. It does not seem to pick up the order number from the store ie. 28. Is this normal? If not where should I look for the problem?

Thanks in advance.

 

Did you ever find an answer to this question. I have the same problem. Linkpoint generates a huge random number if and order number is not told to their system. How do you get the api to tell linkpoint what the order number is so the invoice matches the order number?

Share this post


Link to post
Share on other sites

I had the original API for link point installed, II kept geting the following message: Fatal error: Cannot use string offset as an array in/home/content/59/7142359/html/includes/modules/payment/linkpoint_api.php on line 472

 

I was told this was due to my hosting provide not allowing port 1129 to be open.

 

 

I found out abount the link point conect api, installed it per the directions and now get the below message:

 

Form Processing Error

The following errors occurred while processing your request:

  • It is not possible to order from the store at this time.

  • Contact the merchant for further information (error 1002).

 

My client is growing very impatient, can anyone please help me get this up and running.

 

Thanks Tony

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×