Jump to content
Latest News: (loading..)
Sign in to follow this  
jwilkins

[Contribution] Complete Review System

Recommended Posts

I followed the instructions exactly, this line is added into includes/languagres/english.php

 

// return a dbase formatted date for ddmmyyyy format adjust if you use the mmddyyyy format
function tep_store_date ($date) {

  return substr($date, 6, 4) . '-' . substr($date, 3, 2) . '-' . substr($date, 0, 2) . ' ' . date('H:i:s');

 }

 

Then either you failed to upload that file, or your site is using another language, if you define a function you cannot get a Call to undefined function error for it!!


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Then either you failed to upload that file, or your site is using another language, if you define a function you cannot get a Call to undefined function error for it!!

 

My site ONLY uses english, all others have been removed. The file reviews.php is in the admin/ directory.

 

I completely followed the instructions as I mentioned before. This only happens when I click the little image for preview after installing your update for the admin side review section.

 

Otherwise the contribution works perfect except using this "shortcut" button to preview a review.

Edited by Stealth1

Share this post


Link to post
Share on other sites

My site ONLY uses english, all others have been removed. The file reviews.php is in the admin/ directory.

 

I completely followed the instructions as I mentioned before. This only happens when I click the little image for preview after installing your update for the admin side review section.

 

Otherwise the contribution works perfect except using this "shortcut" button to preview a review.

 

 

perhaps u upload the file to the wrong place (not admin?) I say again if you define a function you cannot get a Call to undefined function error for it!! english.php is always called, so any functions in it are always defined so if your error says not defined, you did'nt put it there or you made errors in edit, no other option..

 

How many times do I have to repeat it, YOU MESSED UP, do others have your error no, why not!!!


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

perhaps u upload the file to the wrong place (not admin?) I say again if you define a function you cannot get a Call to undefined function error for it!! english.php is always called, so any functions in it are always defined so if your error says not defined, you did'nt put it there or you made errors in edit, no other option..

 

How many times do I have to repeat it, YOU MESSED UP, do others have your error no, why not!!!

 

I figured out YOUR error which is in the instructions in states "In includes/languages/english.php (or other language)" where it should say admin/includes/languages/english.php

 

Maybe you should take a look at your work before you blame others!

Share this post


Link to post
Share on other sites

Is there a recent full package?

 

Or do I need to do version 1 and the other 1.5, 1.5.1, 1.5.2, 1.5.3 step by step?

Edited by MichAngler

Share this post


Link to post
Share on other sites

I just did this full install with the "fixes" from spooks "Complete Reviews System (Admin) 1.5.3" (I looked at the previous versions that were listed 1.5.1, 1.5.2, etc and they all looked the same so I just did 1.5.3).

 

And it seems like the contribution itself is working fine, although on the bottom of my index page, below the center section text I have the following:

 

 

Warning: include(includes/modules/FILENAME_FEATURED) [function.include]: failed to open stream: No such file or directory in /my/sites/root/html/index.php on line 321

 

 

Warning: include() [function.include]: Failed opening 'includes/modules/FILENAME_FEATURED' for inclusion (include_path='.:/usr/local/php5/lib/php') in /my/sites/root/html/index.php on line 321

 

Any ideas what could be wrong?

 

Should I do each "Complete Reviews System (Admin) 1.5.x" fix individually? Or does 1.5.3 include the previous fixes also it looked to me like it did, but I may have missed something)?

 

Or is this related to something else?

 

For right now I went to index.php and changed this:

 

<td><?php include(DIR_WS_MODULES . FILENAME_FEATURED); ?></td>

 

to this:

 

<td><?php //include(DIR_WS_MODULES . FILENAME_FEATURED); ?></td>

 

I basically just commented out that command. I don't currently use featured products so it shouldn't affect anything else with the site right now, right?

 

What would be a better way to fix this issue instead of the band-aid that I did by commenting it out?

 

Edit:

Well that seems to have fixed it for the index.php page but it shows on other pages. So it looks like my band-aid didn't work as good as I hoped it would.

 

Hopefully some has a way to fix this.

Edited by ggrant3

Share this post


Link to post
Share on other sites

I just did this full install with the "fixes" from spooks "Complete Reviews System (Admin) 1.5.3" (I looked at the previous versions that were listed 1.5.1, 1.5.2, etc and they all looked the same so I just did 1.5.3).

 

And it seems like the contribution itself is working fine, although on the bottom of my index page, below the center section text I have the following:

 

 

Warning: include(includes/modules/FILENAME_FEATURED) [function.include]: failed to open stream: No such file or directory in /my/sites/root/html/index.php on line 321

 

 

Warning: include() [function.include]: Failed opening 'includes/modules/FILENAME_FEATURED' for inclusion (include_path='.:/usr/local/php5/lib/php') in /my/sites/root/html/index.php on line 321

 

Any ideas what could be wrong?

 

Should I do each "Complete Reviews System (Admin) 1.5.x" fix individually? Or does 1.5.3 include the previous fixes also it looked to me like it did, but I may have missed something)?

 

Or is this related to something else?

 

For right now I went to index.php and changed this:

 

<td><?php include(DIR_WS_MODULES . FILENAME_FEATURED); ?></td>

 

to this:

 

<td><?php //include(DIR_WS_MODULES . FILENAME_FEATURED); ?></td>

 

I basically just commented out that command. I don't currently use featured products so it shouldn't affect anything else with the site right now, right?

 

What would be a better way to fix this issue instead of the band-aid that I did by commenting it out?

 

Edit:

Well that seems to have fixed it for the index.php page but it shows on other pages. So it looks like my band-aid didn't work as good as I hoped it would.

 

Hopefully some has a way to fix this.

 

Bump

 

Any ideas?

Share this post


Link to post
Share on other sites

Add to /includes/filenames.php:

 

  define('FILENAME_FEATURED', 'featured.php');


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×