Jump to content
Latest News: (loading..)
Sign in to follow this  
jalung

Smoothe Populate

Recommended Posts

This contribution is loosely based on EASY POPULATE v2.76h.

 

New Features:

 

* Compressed file Import/Export

* Product Variants Import/Export

* Image Resizing

* Enhanced Multi-Language Support

* More Error Checking

Share this post


Link to post
Share on other sites

I installed it to the letter but nothing will come up for me in admin when I go to click on the Smooth Populate link under Tools. I will look into this further and see what i come up with.

 

EDIT: Nevermind, I left out an e while making the smoothpopulate directory. It works fine now. :)

Edited by wilsonao

Share this post


Link to post
Share on other sites

this is error message we are getting can anybody tell me what we are doing wrong

Warning: mysql_get_server_info(): Access denied for user 'wwwrun'@'localhost' (using password: NO) in /path_to_admin_folder/includes/functions/general.php on line 80 Warning: mysql_get_server_info(): A link to the server could not be established in /path_to_admin_folder/includes/functions/general.php on line 80

 

 

and when i try building and downloading the file EP2009Jul05-1212[1].csv.zip

and openiing it The archive is either in unknown format or damaged

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites
this is error message we are getting can anybody tell me what we are doing wrong

Warning: mysql_get_server_info(): Access denied for user 'wwwrun'@'localhost' (using password: NO) in /path_to_admin_folder/includes/functions/general.php on line 80 Warning: mysql_get_server_info(): A link to

You are not doing anything wrong (apart from giving too much information about your server :) ) but wwwrun is not added as a user in MySQL. You can get around it by using this amended versioin of the function osc_get_system_information:

  function osc_get_system_information() {
global $osC_Database;

$Qdb_date = $osC_Database->query('select now() as datetime');
$Qdb_uptime = $osC_Database->query('show status like "Uptime"');
$Qdb_db_version = $osC_Database->query('select version() as mysql_version');
$Qdb_db_version->execute();
$db_version = $Qdb_db_version->value('mysql_version');

@list($system, $host, $kernel) = preg_split('/[\s,]+/', @exec('uname -a'), 5);

$db_uptime = intval($Qdb_uptime->valueInt('Value') / 3600) . ':' . str_pad(intval(($Qdb_uptime->valueInt('Value') / 60) % 60), 2, '0', STR_PAD_LEFT);

return array('date' => osC_DateTime::getShort(null, true),
			 'system' => $system,
			 'kernel' => $kernel,
			 'host' => $host,
			 'ip' => gethostbyname($host),
			 'uptime' => @exec('uptime'),
			 'http_server' => $_SERVER['SERVER_SOFTWARE'],
			 'php' => PHP_VERSION,
			 'zend' => (function_exists('zend_version') ? zend_version() : ''),
			 'db_server' => DB_SERVER,
			 'db_ip' => gethostbyname(DB_SERVER),
//				 'db_version' => 'MySQL ' . (function_exists('mysql_get_server_info') ? mysql_get_server_info() : ''),
			 'db_version' => 'MySQL ' . $db_version,

			 'db_date' => osC_DateTime::getShort($Qdb_date->value('datetime'), true),
			 'db_uptime' => $db_uptime);
 }

Share this post


Link to post
Share on other sites
You are not doing anything wrong (apart from giving too much information about your server :) ) but wwwrun is not added as a user in MySQL. You can get around it by using this amended versioin of the function osc_get_system_information:

  function osc_get_system_information() {
global $osC_Database;

$Qdb_date = $osC_Database->query('select now() as datetime');
$Qdb_uptime = $osC_Database->query('show status like "Uptime"');
$Qdb_db_version = $osC_Database->query('select version() as mysql_version');
$Qdb_db_version->execute();
$db_version = $Qdb_db_version->value('mysql_version');

@list($system, $host, $kernel) = preg_split('/[\s,]+/', @exec('uname -a'), 5);

$db_uptime = intval($Qdb_uptime->valueInt('Value') / 3600) . ':' . str_pad(intval(($Qdb_uptime->valueInt('Value') / 60) % 60), 2, '0', STR_PAD_LEFT);

return array('date' => osC_DateTime::getShort(null, true),
			 'system' => $system,
			 'kernel' => $kernel,
			 'host' => $host,
			 'ip' => gethostbyname($host),
			 'uptime' => @exec('uptime'),
			 'http_server' => $_SERVER['SERVER_SOFTWARE'],
			 'php' => PHP_VERSION,
			 'zend' => (function_exists('zend_version') ? zend_version() : ''),
			 'db_server' => DB_SERVER,
			 'db_ip' => gethostbyname(DB_SERVER),
//				 'db_version' => 'MySQL ' . (function_exists('mysql_get_server_info') ? mysql_get_server_info() : ''),
			 'db_version' => 'MySQL ' . $db_version,

			 'db_date' => osC_DateTime::getShort($Qdb_date->value('datetime'), true),
			 'db_uptime' => $db_uptime);
 }

 

Thanks for the Quick heads ;) up we have been struggling with this for days

Share this post


Link to post
Share on other sites
and when i try building and downloading the file EP2009Jul05-1212[1].csv.zip

and openiing it The archive is either in unknown format or damaged

 

 

Try clearing your Internet Explorer cache and restart browser. I've not noticed this with Firefox.

Share this post


Link to post
Share on other sites
this was the default

Download Complete .csv file to edit

that gave me the error

but if i built file and used none instead of zip it worked

 

Is your PHP compiled with configuration option --enable-zip?

 

Check under:

tools/server information/PHP version (more info)/configure command

Share this post


Link to post
Share on other sites
Is your PHP compiled with configuration option --enable-zip?

 

Check under:

tools/server information/PHP version (more info)/configure command

 

Hi Everybody!

 

So, this is my problem is also.

On the server the all of zip type are enabled.

If I run this: Download Products with Variants .csv file to edit or other the csv.zip file is defect and this size is 0byte.

Other error:

If I run this: Create Products with Variants .csv file in temp dir or other the catalog/temp/ directory 777 is empty.

 

Can you anybody help me?

Edited by Marsy

---

Thanks and regards

Marsy from Hungary

Share this post


Link to post
Share on other sites
Hi Everybody!

 

So, this is my problem is also.

On the server the all of zip type are enabled.

If I run this: Download Products with Variants .csv file to edit or other the csv.zip file is defect and this size is 0byte.

Other error:

If I run this: Create Products with Variants .csv file in temp dir or other the catalog/temp/ directory 777 is empty.

 

Can you anybody help me?

 

Please upgrade to the newest version, 1.1

Share this post


Link to post
Share on other sites
Please upgrade to the newest version, 1.1

Hi Paul!

 

I downloaded. It's very good! :)

Thank you for your help.


---

Thanks and regards

Marsy from Hungary

Share this post


Link to post
Share on other sites

is there any version compatible with the ms2.2 version of oscommerce ?

does it handles the categories in multilanguage , a problem easy populate had was not to have this feature


MS2

Share this post


Link to post
Share on other sites
is there any version compatible with the ms2.2 version of oscommerce ?

does it handles the categories in multilanguage , a problem easy populate had was not to have this feature

Hi,

 

It is not compatible with ms 2.2 it's only OSC v3.0 compatible.

Please download this Easy Populate 2.76i-MS2 (with attributes)


---

Thanks and regards

Marsy from Hungary

Share this post


Link to post
Share on other sites

A question about the requirements for Smoothe Populate:

 

Is Apache 2.2.9 actually required for SP to operate properly?

 

My ISP unfortunately is still back on Apache 1.3.41, which is still being maintained and supported and is secure, but is getting a bit old. The last update was in January 2008 and fixed a few security issues.

 

I'm about to start testing SP and just wanted to know what kinds of problems I'm likely to encounter given the old Apache version I'm stuck with. Am I going to be able to work around the problems or are they huge, deal-breakers?

 

Thanks in advance for any info.

Edited by jrivett

Share this post


Link to post
Share on other sites

I'm looking at the configdef.php and configvar.php files, as requested by the SP installation documentation. I immediately ran into this:

------------------------------------------------------------------------------------------------

THE DIR_FS_DOCUMENT_ROOT SETTING

DIR_FS_DOCUMENT_ROOT is set in your /catalog/admin/includes/configure.php

You should look at the setting DIR_FS_DOCUMENT_ROOT setting.

------------------------------------------------------------------------------------------------

 

Here's the problem: there's no such file in my OSC 3.0 alpha 5 installation. I don't think that file exists any more in OSC 3.

 

Since SP was designed to work with OSC 3 I'm having trouble understanding what I should do about this.

 

Any suggestions?

Share this post


Link to post
Share on other sites
A question about the requirements for Smoothe Populate:

 

Is Apache 2.2.9 actually required for SP to operate properly?

 

My ISP unfortunately is still back on Apache 1.3.41, which is still being maintained and supported and is secure, but is getting a bit old. The last update was in January 2008 and fixed a few security issues.

 

I'm about to start testing SP and just wanted to know what kinds of problems I'm likely to encounter given the old Apache version I'm stuck with. Am I going to be able to work around the problems or are they huge, deal-breakers?

 

Thanks in advance for any info.

 

Basically if all features of osCommerce work, then you're ok because it uses a lot of the osc engine. The oldest it was tested on is Apache 1.3.37 and it worked fine. Smoothe Populate was built under 2.2.9.

Share this post


Link to post
Share on other sites
I'm looking at the configdef.php and configvar.php files, as requested by the SP installation documentation. I immediately ran into this:

------------------------------------------------------------------------------------------------

THE DIR_FS_DOCUMENT_ROOT SETTING

DIR_FS_DOCUMENT_ROOT is set in your /catalog/admin/includes/configure.php

You should look at the setting DIR_FS_DOCUMENT_ROOT setting.

------------------------------------------------------------------------------------------------

 

Here's the problem: there's no such file in my OSC 3.0 alpha 5 installation. I don't think that file exists any more in OSC 3.

 

Since SP was designed to work with OSC 3 I'm having trouble understanding what I should do about this.

 

Any suggestions?

Hi,

Please download this Smoothe Populate 1.1 osC-3.0-alpha-5 contrib.

It's will run under OSC V3 Alpha 5. ;)


---

Thanks and regards

Marsy from Hungary

Share this post


Link to post
Share on other sites
Hi,

Please download this Smoothe Populate 1.1 osC-3.0-alpha-5 contrib.

It's will run under OSC V3 Alpha 5. ;)

That's the version I'm using. Still, I downloaded SP again - from the link you posted - and looked at configdef.php. As expected, it's exactly the same as the file I'm using, and it also refers to admin/includes/configure.php.

 

So, thanks for trying to help, but the issue remains.

Share this post


Link to post
Share on other sites
I'm looking at the configdef.php and configvar.php files, as requested by the SP installation documentation. I immediately ran into this:

------------------------------------------------------------------------------------------------

THE DIR_FS_DOCUMENT_ROOT SETTING

DIR_FS_DOCUMENT_ROOT is set in your /catalog/admin/includes/configure.php

You should look at the setting DIR_FS_DOCUMENT_ROOT setting.

------------------------------------------------------------------------------------------------

 

Here's the problem: there's no such file in my OSC 3.0 alpha 5 installation. I don't think that file exists any more in OSC 3.

 

Since SP was designed to work with OSC 3 I'm having trouble understanding what I should do about this.

 

Any suggestions?

That section about the temp directory in configdef.php was a left over from the older package and will be revised in future update.

 

DIR_FS_CATALOG is supposed to be set to the root of your store in configure.php for anything to work. The osc installation does this for you.

 

eg; define ('DIR_FS_CATALOG' , '/home/youraccount/public_html/catalog/');

or

eg; define ('DIR_FS_CATALOG' , '/home/youraccount/public_html/');

 

 

create your "temp" directory wherever the root is and chmod to 777.

 

If osc is working fine, then the default setting in configdef.php for EP_TEMP_DIRECTORY should work.

define ('EP_TEMP_DIRECTORY', DIR_FS_CATALOG . 'temp/');

Share this post


Link to post
Share on other sites
That section about the temp directory in configdef.php was a left over from the older package and will be revised in future update.

Okay, thanks for clearing that up.

Edited by jrivett

Share this post


Link to post
Share on other sites
Basically if all features of osCommerce work, then you're ok because it uses a lot of the osc engine. The oldest it was tested on is Apache 1.3.37 and it worked fine. Smoothe Populate was built under 2.2.9.

 

do you mean there is a version fro SP working under apache 1 ?


MS2

Share this post


Link to post
Share on other sites
Basically if all features of osCommerce work, then you're ok because it uses a lot of the osc engine. The oldest it was tested on is Apache 1.3.37 and it worked fine. Smoothe Populate was built under 2.2.9.

Well, that sounds encouraging. OSC does seem to work fine on our server. The OSC documentation states that "osCommerce runs on all PHP enabled web servers" and it doesn't specify any particular version for Apache. Are you saying that OSC was tested under 1.3.37 and it worked fine, or were you referring to SP? I'm assuming the former (OSC). In that case, the "requirement" for Apache 2.2.9 listed for OSC is presumably based only on the fact that it hasn't been officially tested on Apache 1.x. In which case I think I'll be okay.

 

Thanks for the info!

Share this post


Link to post
Share on other sites

I've got a quick question about adding new products,

 

whenever I try to add one, i get an error message that says: * Error: There was a problem performing the action.

 

the new products are not added, but the old ones are updated. Any ideas on this?

Share this post


Link to post
Share on other sites
I've got a quick question about adding new products,

 

whenever I try to add one, i get an error message that says: * Error: There was a problem performing the action.

 

the new products are not added, but the old ones are updated. Any ideas on this?

More information is needed for anyone to help. Are you using Smoothe Populate and osC 3.0a5? If so, you should export a complete layout, make the changes and and re-import.

 

If you have new products with variants, these should be created manually in admin. If you exported products with variants they will be reimported too with the rest of them, but you must know what you are doing if you manually modify these kinds of records (variants) in the csv.

Share this post


Link to post
Share on other sites

I'm importing products into OSC with SP. Everything is basically working okay, with one exception: the existing category and manufacturer images are being blanked out during the import.

 

For example, I've already set up the category "CatA" and the manufacturer "MfgA" in OSC, both with images. I then import a few products, one of which is in category CatA and from manufacturer MfgA. Once the import is finished, I look at the details for CatA and MfgA and neither has an image associated with it.

 

I tried removing all the related image fields from the import but that made no difference. I understand from the documentation that if a manufacturer or a category processed during import is already in the OSC database, the image will be updated. But that only makes sense if I want to update the image. What if I'm importing new products with existing categories and manufacturers and I have no interest in changing their images?

 

Weird.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×