Jump to content

Recommended Posts

This contribution provides a way to add and track sales people that are attached to your shop in some way. Some of the options are:

 

- Sales people are assigned to groups for better control.

- A sales commission is assigned each group.

- Various reports can be generated for each sales person or group.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Hi Jack,

 

I had a quick look at the files but have not added them to a store yet until I am sure as to what the contribution does. I think I understand how part of the contribution works. You add people in admin but how does the front end customer and the sales rep link together? Does the customer select a rep from a list of reps in checkout or does the rep give a code to enter at checkout?

 

Also if any sales are generated via a rep then does the module allow for the rep to have access to that information?

 

Finally in your opinion does this contribution compliment, hinder or not affect the oscAffiliates contribution and do you think it can be used as a substitute for oscAffiliates?

 

Many Thanks

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

There is a dropdiwon on the checkout shipping page where the customer seltects their sales rep.

 

No, the sales rep doesn't have access although that would be a relatively simple page to create.

 

It won't have any affect on the affiliates contribution. I don't think it could substitute for it since it only tracks sales reps where affiliates tracks everyone.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack, I wanted to ask you if there is any way to activate and deactivate this?

 

Thanks


Daniel Dares

Share this post


Link to post
Share on other sites

No, there's not. You would have to remove the changes from the checkout pages.

 

Jack

Share this post


Link to post
Share on other sites

Great Contribution but some bugs or installation steps missed.

 

All works well except on report, order entry are multiple, sometimes 1, sometimes twice or more.

 

Any idea?

Share this post


Link to post
Share on other sites
Please be more specific so I can test it here.

 

Jack

 

Hi Jack, on the report section on admin, normally 1 order 1 commission entry. But the same order got multiple entry, somehow it recorded more than one time.

 

Any idea?

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites
Is the order ID in the report the same in the duplicates?

 

Jack

 

Yes all field data is same and same ID. Meaning it seems to "insert" a few times.

Share this post


Link to post
Share on other sites

Hmm, I don't know what could be causing that. It works fine for me here and in the shops I've installed it into. What versions of php and mysql is your server using? Maybe that is causing an issue.

 

Jack

Share this post


Link to post
Share on other sites
Hmm, I don't know what could be causing that. It works fine for me here and in the shops I've installed it into. What versions of php and mysql is your server using? Maybe that is causing an issue.

 

Jack

 

i have check the "order" db and the sales person recorded is fine. It seems the /admin/includes/modules/sales_reports.php line 145 sql query statement issue?

Share this post


Link to post
Share on other sites

I don't see anything wrong with that statement and it should be mysql 5 compatible. But if your database has multiple (duplicate) entries in the sales tables, then that code will just show them all. So the problem may be on the other side where the data gets entered.

 

Jack

Share this post


Link to post
Share on other sites
I don't see anything wrong with that statement and it should be mysql 5 compatible. But if your database has multiple (duplicate) entries in the sales tables, then that code will just show them all. So the problem may be on the other side where the data gets entered.

 

Jack

 

Hmm strange. Can i know where is the part of the code it "insert" the salesforce? Is it on the customer order table where it links to the salesforce sales person ID on the orderID? if so, there is only 1 order entry as I checked. No duplicate orderID.

 

OH I am using mysql v4.

Edited by chee

Share this post


Link to post
Share on other sites

The orders tables are updated by an order as they always were with this contribution except the sales reps information is also stored. So unless you made a mistake in those edites, I don't think those tables wouldn't be the cause. The sales force tables are also updated. I suppose there could be a mistake there, although I'm not seeing it. But as with most options in oscommerce, the code in the sales reports page in admin is just loading what has been saved. So you need to determine if the problem is on the shop side or the admin side. I'm sorry I can't be more help but it works fine here. Maybe installing it into a clean shop to see if it works at all for you would be a good way to go.

 

Jack

Share this post


Link to post
Share on other sites
The orders tables are updated by an order as they always were with this contribution except the sales reps information is also stored. So unless you made a mistake in those edites, I don't think those tables wouldn't be the cause. The sales force tables are also updated. I suppose there could be a mistake there, although I'm not seeing it. But as with most options in oscommerce, the code in the sales reports page in admin is just loading what has been saved. So you need to determine if the problem is on the shop side or the admin side. I'm sorry I can't be more help but it works fine here. Maybe installing it into a clean shop to see if it works at all for you would be a good way to go.

 

Jack

 

yes i think should not be the order database. The strange part is that the report output sometimes 2 entries, sometimes 3 upto 6 entries and not consistent. Meaning somewhere on the query looping issue i suppose. Still trying to find out.

Share this post


Link to post
Share on other sites
This contribution provides a way to add and track sales people that are attached to your shop in some way. Some of the options are:

 

- Sales people are assigned to groups for better control.

- A sales commission is assigned each group.

- Various reports can be generated for each sales person or group.

 

Jack

 

Re: Commission field

 

Thanks for a great contrib. When I set up a Sales Group via the Admin the commission field states "* Required (a number between 0 and 1)". I can't seem to enter 15% as 0.15, it just keeps resetting to 1.00. How can I enter 0.15 in the commission field.?

Share this post


Link to post
Share on other sites
Re: Commission field

 

Thanks for a great contrib. When I set up a Sales Group via the Admin the commission field states "* Required (a number between 0 and 1)". I can't seem to enter 15% as 0.15, it just keeps resetting to 1.00. How can I enter 0.15 in the commission field.?

If you are referring to editing a commission, there is a coding problem in the sales_group.php file. To fix it, find

default:

and change to

			   default:	  
			 echo tep_draw_hidden_field('group_id', $group_id);

If you are referring to entering a number on a new group, use .15, not 0.15.

 

Jack

Share this post


Link to post
Share on other sites
If you are referring to editing a commission, there is a coding problem in the sales_group.php file. To fix it, find
default:

and change to

			   default:	  
			 echo tep_draw_hidden_field('group_id', $group_id);

If you are referring to entering a number on a new group, use .15, not 0.15.

 

Jack

Thanks for both recommendations - worked like a charm!

Edited by reidwalley

Share this post


Link to post
Share on other sites

I dont want to the catalog side, i want only use admin side, in order to receive order by phone....

is that possible?

 

thanks

Share this post


Link to post
Share on other sites

This contribution works with the order code. It will not allow you to take orders in any way.

 

Jack

Share this post


Link to post
Share on other sites

The orders tables are updated by an order as they always were with this contribution except the sales reps information is also stored. So unless you made a mistake in those edites, I don't think those tables wouldn't be the cause. The sales force tables are also updated. I suppose there could be a mistake there, although I'm not seeing it. But as with most options in oscommerce, the code in the sales reports page in admin is just loading what has been saved. So you need to determine if the problem is on the shop side or the admin side. I'm sorry I can't be more help but it works fine here. Maybe installing it into a clean shop to see if it works at all for you would be a good way to go.

 

Jack

 

still having same issues, comments out your line 57, it is showing this. Any idea!?

 

new line at 0 - 1 - Jeff

new line at 1 - 2 - Outlet1

new line at 2 - 3 - 2726

new line at 3 - 4 - 10/01/2009

new line at 4 - 5 -

new line at 5 - 6 - Online Store

new line at 6 - 7 -

new line at 7 - 8 -

new line at 8 - 9 -

new line at 9 - 10 -

new line at 10 - 11 - 8.80

new line at 0 - 12 - Outlet1

new line at 1 - 13 - 2726

new line at 2 - 14 - 10/01/2009

new line at 3 - 15 -

new line at 4 - 16 - Online Store

new line at 5 - 17 -

new line at 6 - 18 -

new line at 7 - 19 -

new line at 8 - 20 -

new line at 9 - 21 - 8.80

new line at 10 - 22 - Jeff

new line at 0 - 23 - 2726

new line at 1 - 24 - 10/01/2009

new line at 2 - 25 -

new line at 3 - 26 - Online Store

new line at 4 - 27 -

new line at 5 - 28 -

new line at 6 - 29 -

new line at 7 - 30 -

Share this post


Link to post
Share on other sites

I installed the SalesForce contribution and as i was testing out my site I was unable to complete a transaction at checkout unless I chose a sales person. I don't want this to be a problem for people visiting my site from search engines,advertisements, etc... that do not have a sale rep. How do I correct this? Some of my customers will not have sales reps at all.

 

Thank you

Share this post


Link to post
Share on other sites

I installed the SalesForce contribution and as i was testing out my site I was unable to complete a transaction at checkout unless I chose a sales person. I don't want this to be a problem for people visiting my site from search engines,advertisements, etc... that do not have a sale rep. How do I correct this? Some of my customers will not have sales reps at all.

 

Thank you

Search engines shouldn't be able to get to the checkout shipping page so that isn't a concern. For the rest, you can create a sales rep named "No Sales Rep," or something like that so the person doesn't have to have a sales rep assigned. Otherwise, the code would have to be altered to remove the checking of the sales rep. But if you do that, you will probably get a lot of wrong selections since people will not select it and which ever rep is showing will be the one selected and that would defeat a large part of the reason of the addon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×