Jump to content
Latest News: (loading..)
Zappo

[Contribution] Option Types v2

Recommended Posts

@@Tsimi,

 

May I trouble you one more time, please?

 

I have used the 'required aria-required="true" tweak you posted on the previous page for the Text areas, but am using Radio buttons for my Product Options. Is there an easy way of making the customer make a choice?

 

All of the options are unchecked when the page loads & they can just add an item without making any choices at all. 

 

My items don't all have text fields.

 

I have seen questions going back many years in the forums, but not seen an answer.

 

Many thanks & Regards once again,

 

Simon

Share this post


Link to post
Share on other sites

No trouble at all that is why we have a support topic here.

Before we didn't had Bootstrap and therefore it was not that easy to do. Could have been done with some javascript code I guess. But with BS you just add 'required aria-required="true"' and you should be good.

 

Open your includes/modules/option_types.php file and look for this code around line 95

$tmp_html .= tep_draw_radio_field('id[' . $ProdOpt_ID . ']', $products_options_array['products_options_values_id'], $checked);
REPLACE WITH THIS
$tmp_html .= tep_draw_radio_field('id[' . $ProdOpt_ID . ']', $products_options_array['products_options_values_id'], $checked, 'required aria-required="true"');
Try this and tell me if that works for you. Edited by Tsimi

Share this post


Link to post
Share on other sites

@Tsimi

 

Sorry to bother you again!

 

The option type works, but........

Several customers manage to place an order WITHOUT filling in the option type?!!

I guess they press the spacebar ??????

 

You allready gave me advise how to force the customer to fill in the option (required aria-required="true")

But is there a way to say for example the filled-in option must have a minumum lenght of 5 characters ???

Share this post


Link to post
Share on other sites

@@fotogaaf

 

even if you put a minimum value that wouldn't stop the customer from pushing the space bar until they reach that minimum value.

Just write a comment and tell them to insert at least your requirements before adding the product into the cart.

Share this post


Link to post
Share on other sites

@Tsimi

 

I allready wrote a comment :(

 

So thats's why I wonder if  there is  a way to say for example the filled-in option must have a minumum lenght of 5 characters ???

Share this post


Link to post
Share on other sites

@@Tsimi

 

Thank you for the new responsive version. I just finished installing it - very easy.

Is there a version of Attribute Manager that will work with 2.3.4BS?

Share this post


Link to post
Share on other sites

Hi there,

 

Just installed this contri and have a problem . If i work with chrome i can put text in the productoptions and everything goes well. but in Edge i cant write in the text area just nothing happens

Any idea someone

 

thx Danny

Share this post


Link to post
Share on other sites

@@danta67

 

Sorry Danny but I don't use Windows 10 anymore so I can't help you there.

Maybe someone that has this Addon installed and using Edge can jump in and help.

Share this post


Link to post
Share on other sites

Thx tsimi for the quick reply. but is it  not that our customers decide what browser they use and should the contri not be working in all browser, i m not trying to be an .... but just trying to understand

 

Danny

Share this post


Link to post
Share on other sites

@@danta67

 

Agree.

Yes, it should work on all browsers unfortunately I uninstalled my Windows 10 on my PC just few days ago and put back Windows 7 which doesn't contain the Edge browser therefore I cannot support you in this matter.

I cannot imagine why it shouldn't work with the edge browser though the input fields are same as any other in the shop.

Can you enter your data inside the input fields on the create_account.php page with the Edge browser?

Share this post


Link to post
Share on other sites

@@Tsimi

 

It got nothing to do with the contri i see now . Nothing works in edge so sorry for that.

there must be something wrong with the whole  osc edge version

 

Danny

Share this post


Link to post
Share on other sites

Nothing to apologize for. :)

 

You took the right steps by coming into this thread since you presumed it to be a problem with the Option Types addon. 

We/You then figured out that it is an issue that occures anywhere in your shop which might or might not be an Edge issue which should be reported in the bug report section of github.

Read more about it here

Edited by Tsimi

Share this post


Link to post
Share on other sites

Hi Valqui

 

The AJAX attribute manager should work just fine on EDGE since the admin area is the same.

I have installed the Option Types BS

 

http://addons.oscommerce.com/info/9367

 

into a GOLD and "older" version of EDGE but not sure how it would work on the latest version. It also depends how many stuff you have already installed into your shop. Large addons like this one should be usually installed as early as possible since it becomes more and more difficult at later stages. Unless of course you used a lot modules and have barely touched any core files.

 

I would recommend to install this once into a local test shop so that you can see what work needs to be done and how everything will look like once installed.

Share this post


Link to post
Share on other sites

@@webmasterpitoyo

 

Hi pit

 

You use the BS version so you'll have to use the following Option Types addon

 

http://addons.oscommerce.com/info/9367

 

...and to your question, yes it is compatible the only difference are the changes to the product_info.php file.

The Modular Product Page addon uses multiple modules to show the product info page. Now you can either change the code inside the module that shows the options, which is not recommended since it would defeat the purpose of having modules, or better and highly recommended, create a new separate module for the Option Types BS addon.

You basically copy the options module, rename the necessary code parts and make the code changes in it. Then you can install it through the admin area. This way Kymations adddon files stay untouched as it should be.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×