Jump to content
Zappo

[Contribution] Option Types v2

Recommended Posts

I have an option value for a customer input text area for customers to leave a message with the product to be personalised. The option has a maximum of 100 characters set in the option value. When a customer fills in the option, it is cut off after 32 characters and I do not receive the rest of the message.

Any help is greatly appreciated!

Share this post


Link to post
Share on other sites

I have an option value for a customer input text area for customers to leave a message with the product to be personalised. The option has a maximum of 100 characters set in the option value. When a customer fills in the option, it is cut off after 32 characters and I do not receive the rest of the message.

Any help is greatly appreciated!

 

I noticed this problem a while back. The problem is that the field in the MySQL database was only for 100 characters. If you increase the size of that field in the database, that should solve your problem.

Share this post


Link to post
Share on other sites

I noticed this problem a while back. The problem is that the field in the MySQL database was only for 100 characters. If you increase the size of that field in the database, that should solve your problem.

 

Thanks for that information.

The database field was set to 100 characters.

When making a test purchse all the data was on the order but when it comes through to the admin it is chopped off after 32 characters.

After a bit more digging around I found out what was causing the problem. In the 'orders_products_attributes' table, the 'products_options_values' field had a varchar() length of 32. I reset it to 100 and all the data comes through now.

 

If anyone else has had this error then I hope this helps.

 

Regards Andy

ASE Awards

Share this post


Link to post
Share on other sites

I've just installed this addon and i have a problem when one of my products has more than one image attribute. In the first select buttons shows its options but in the seconds select buttons shows its own options and the options of the first image attribute.

 

I mean in the product_info page.

 

Can anybody help me?

 

Thanks.

:thumbsup:

Edited by bjeli

Share this post


Link to post
Share on other sites

[...] problem when one of my products has more than one image attribute. In the first select buttons shows its options but in the seconds select buttons shows its own options and the options of the first image attribute. [...]

 

That happens because the product id is used to select the images, read how to solve this here

Share this post


Link to post
Share on other sites

That happens because the product id is used to select the images, read how to solve this here

 

 

Thanks, I solved may problem.

 

I had to change [$product_info['products_id']] with [$products_options_name['products_options_id']] and $product_info['products_id'] with $products_options_name['products_options_id'] in some cases too.

 

The only file i had to change is option_types.php

Share this post


Link to post
Share on other sites

Hey Guys.

 

I got a little problem with the addOn - luv it - but got a little issue.

 

Okay it all works perfect i can upload files - and the files are in fact being uploaded.

 

Problem is that the [products_options_value_text] is empty in the database aswell as in the param handler through out the site.

 

So it dosent link correctly in the preview link (actually just links to the upload directory) - and on the invoice there isnt any information about wich file the customer uploaded.

 

 

I just need to get a hint to where the actually upload/save in db thingy is going on.

 

Ohh and also if somebody could tell me where i can find the file that handles a order when it has been bought ? I need to build a MIS module so that could really help me along :P

 

Hope somebody is able to help me. ?

 

BTW the link is www.reproshop.dk

 

Cheers

 

Morten "Sipman"

Share this post


Link to post
Share on other sites

Hi,

 

read through the posts and seen the question asked a couple of times with no answer - is there a way to add weights to the options to allow correct shipping calculations to be made?

 

My scenario is that for example I have one product which is "Product X Spares"

 

then I use the options to list the spares available.

 

Problem is that spare A costs pennies to ship whilst spare B costs £££ to ship.

 

Any Ideas?

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hi,

 

read through the posts and seen the question asked a couple of times with no answer - is there a way to add weights to the options to allow correct shipping calculations to be made?

 

My scenario is that for example I have one product which is "Product X Spares"

 

then I use the options to list the spares available.

 

Problem is that spare A costs pennies to ship whilst spare B costs £££ to ship.

 

Any Ideas?

 

Thanks

 

 

We have different sized products on our ranges that can have vast weight differences. I installed this contribution and it allows you to put in a seperate weight relative to the base weight for each product attribute.

 

In our case;

Product 1 has four different options with 4 different shipping weights;

options 1 - 4 can have 4 different option weights entered which are passed to the shipping module.

 

You can even add a negative weight for products that have a download option as well as a physical option such as a cd. Shipping is therefore not charged on the download but is charged for the cd.

 

I have not worked out how to integrate it into the option types contribution as my script writing is not good so I just input the weights in bulk on the product attributes screen in Admin.

 

Hope this helps

Andy

ASE Awards

Share this post


Link to post
Share on other sites

Thanks Andy,

 

But that contribution seems like overkill for what Im trying to do.

 

There is another contribution called attribute weights, but that wont slip in easily to the option types V2 modified files, as the particular area of code has been modified.

 

Any experts ??

 

Im sure this would be of use to a few people...

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Hello,

 

I installed the contribution today but I don't know how to change the option values. In option_attributes I can enter an option f.e.

 

10 batteries OPTIONS_TYPE_CHECKBOX_NAME 4 32 8x AA but when adding together with the product the product_info page shows a text field. Can you help me with this problem? I just want a checkbox or radio button.

 

Thanks.

Share this post


Link to post
Share on other sites

I have suddenly experienced a problem with this faultless contribution.

When I am at the new product/edit screen in admin, the option type is showing but with no options populated, I know the options are there as they are still showing up in the attributes screen in admin. I cannot add more options to the item as the option types do not do anything.

 

I have receibly been experiencing problems with paypal ipn contribution and one page checkout contribution not being compatible but surely these should not affect the option types contribution. Not very conversant with php but I can understand a little with guidance so any help is appreciated.

 

Thanks in advance

Andy

Share this post


Link to post
Share on other sites

I have suddenly experienced a problem with this faultless contribution.

When I am at the new product/edit screen in admin, the option type is showing but with no options populated, I know the options are there as they are still showing up in the attributes screen in admin. I cannot add more options to the item as the option types do not do anything.

 

I have receibly been experiencing problems with paypal ipn contribution and one page checkout contribution not being compatible but surely these should not affect the option types contribution. Not very conversant with php but I can understand a little with guidance so any help is appreciated.

 

Thanks in advance

Andy

 

Can you say what the last thing that you did was before "experiencing that problem suddenly"?

Share this post


Link to post
Share on other sites

Can you say what the last thing that you did was before "experiencing that problem suddenly"?

 

Not sure to be honest. After thinking about what I have been doing recently it has been a little while since I edited/added any new products so this could have been a problem for a while and I haven't noticed it.

I have compaired the installation with the original download/instructions to see if I have modified any lines of code or anything but all appears to be as it should be.

Any ideas where to start multimixer would be appreciated.

 

Regards Andy

Share this post


Link to post
Share on other sites

Sorted it.

 

I had installed Osc_sec contribution here and it was blocking AJAX attribute manager!

Changed a parameter in Osc_sec and all is back in order again!

 

Thanks to puddlec in that thread for already having experienced this!

 

Regards Andy

Edited by ase2007

Share this post


Link to post
Share on other sites

Hi

 

After installation I only get CUSTOMER-INPUT

and no text area.

in productinfo page.

 

???

Share this post


Link to post
Share on other sites

Somewhere in a database table, it is wrong, where?

 

Have change products_otion and products_otion_values and customer_basket_attributes

from a data base that work from an orginal installation.

 

If I change database with the origanal installation it's not working,

then I have the same problem with the orginal installation, it have to be something with a database.

Share this post


Link to post
Share on other sites

Hi all

 

This addon is not working with version 2.3.1.

 

If you want to use it right now, you have to use osCommerce version rc2a, that you can upgrade to v2.3

 

Since Zappo is not very active recently, I will make a new version, compatible with 2.3.1 right after the holidays, looking in the same time into issues raised up here in the forum (like image preview etc), so be a little patient till then

 

Did you get around to adapting this for OScommerce v2.3?

Share this post


Link to post
Share on other sites

Ver. 2.2

 

More people have had the same problem

 

http://forums.oscommerce.com/topic/338661-contribution-option-types-v2/page__view__findpost__p__1474846

 

Regards

 

Nick

 

In what way do you get the option with CUSTOMER_INPUT on product info? as a drop down? Are you sure you did the changes in both local/configure.php files?

 

You can't use the "original" database, you must use the one that has the alternations done by the included sql file

Share this post


Link to post
Share on other sites

In what way do you get the option with CUSTOMER_INPUT on product info? as a drop down? Are you sure you did the changes in both local/configure.php files?

 

You can't use the "original" database, you must use the one that has the alternations done by the included sql file

 

Thanks for your reply, "you are the best" it was /catalog/includes/local/configure.php that was missing.

 

Thanks again.

 

Best Regards

 

Nick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×