Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Hello,

 

There is a bug with memcache when you have several site in the same server dedicate.

For example I have a site1 with : http://www.mysite1/p...ame-p-1542.html

another site 2 with : http://www.test/prod...ame-p-1542.html

 

The result is when I am on site 1, I see the url of the site 2.

 

regards.

 

Yes the cache name should be unique for each site ( perhaps an md5 hash of the domain name ). This bug does not exist in USU5 PRO.

Share this post


Link to post
Share on other sites

Hi all.

 

Although i have upload the files for huge shop provides by FWR Media via email, i often get this error in random :

Warning: gzinflate() [function.gzinflate]: data error in /web/htdocs/www.***.***/home/***/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 57

Fatal error: Unsupported operand types in /web/htdocs/www.***.***/home/***/includes/modules/ultimate_seo_urls5/classes/Usu_Registry.php on line 79

 

Please Help me to fix that error...

 

Thanks a lot from Italy...

Share this post


Link to post
Share on other sites

Hi FWR,

 

Hope all is excellent with you.

This contribution is world class,

appreciate your generosity in sharing it.

I believe someone else was having a problem

with the @ sign being removed from the email address

(in my case it happens when unsubscribing to newletters)

Tried using the upper right search (@ sign missing from email)

but was unsuccessful

Can you recommend a method to search through this thread

to find this particular topic?

 

Thanks for your support,

jk

Share this post


Link to post
Share on other sites

Hi FWR,

 

Hope all is excellent with you.

This contribution is world class,

appreciate your generosity in sharing it.

I believe someone else was having a problem

with the @ sign being removed from the email address

(in my case it happens when unsubscribing to newletters)

Tried using the upper right search (@ sign missing from email)

but was unsuccessful

Can you recommend a method to search through this thread

to find this particular topic?

 

Thanks for your support,

jk

 

I think you may be looking for the security pro contribution.

Share this post


Link to post
Share on other sites

Also include this error :

 

Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /web/htdocs/www.***.***/home/***/includes/modules/ultimate_seo_urls5/modules/Usu_Categories.php on line 161

 

Please Help me to fix that error...

 

Thanks a lot from Italy...

Edited by Predator123

Share this post


Link to post
Share on other sites

Have installed the ULTIMATE Seo Urls 5 and all look okay for a couple of small problems:

 

Installed the ULTIMATE Seo Urls 5 on 2 website and both have the same problem:

 

First site:

BOX_HEADING_CATEGORIES

BOX_HEADING_SHOPPING_CART

BOX_SHOPPING_CART_EMPTY

DATE_FORMAT_LONG

All are not show

 

second site:

Same problem as above BUT also when you click on a article it doesn't show you anything then a blanc screen.

 

What have i done wrong here?

Share this post


Link to post
Share on other sites

Have installed the ULTIMATE Seo Urls 5 and all look okay for a couple of small problems:

 

Installed the ULTIMATE Seo Urls 5 on 2 website and both have the same problem:

 

First site:

BOX_HEADING_CATEGORIES

BOX_HEADING_SHOPPING_CART

BOX_SHOPPING_CART_EMPTY

DATE_FORMAT_LONG

All are not show

 

second site:

Same problem as above BUT also when you click on a article it doesn't show you anything then a blanc screen.

 

What have i done wrong here?

 

Those defines are nothing whatsoever to do with USU5, ot also doesn't create blank pages.

Share this post


Link to post
Share on other sites

Those defines are nothing whatsoever to do with USU5, ot also doesn't create blank pages.

 

Well my #3 site without any ULTIMATE Seo Urls 5 on it does work

 

with ULTIMATE Seo Urls 5

 

So please have a little look as only with installing this ULTIMATE Seo Urls 5 it goes wrong.

Share this post


Link to post
Share on other sites

Also include this error :

 

Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /web/htdocs/www.***.***/home/***/includes/modules/ultimate_seo_urls5/modules/Usu_Categories.php on line 161

 

Please Help me to fix that error...

 

Thanks a lot from Italy...

 

Your errors are all related to a corrupt cache file, why it is corrupt I couldn't tell you as this problem is local to you.

 

I will be releasing USU5 PRO soon so try that when it is available.

Share this post


Link to post
Share on other sites

Those defines are nothing whatsoever to do with USU5, ot also doesn't create blank pages.

 

 

HAve checked and checked and found that something is changed in the language setting:

 

Original lines in application_top.php:

 

// include the language translations

require(DIR_WS_LANGUAGES . $language . '.php');

 

 

changes made by ULTIMATE Seo Urls 5

 

// ULTIMATE Seo Urls 5 by FWR Media

if ( !isset($seo_urls) || !is_object($seo_urls) ){

include_once DIR_WS_MODULES . 'ultimate_seo_urls5' . DIRECTORY_SEPARATOR . 'classes' . DIRECTORY_SEPARATOR . 'usu.php';

$seo_urls = new usu($languages_id, $request_type, $session_started, $SID);

}

$seo_urls->initiate($SID, $languages_id, $language);

 

For some reason it now doesnt look to the language maps anymore. Therefore it showing the:

 

BOX_HEADING_CATEGORIES

BOX_HEADING_SHOPPING_CART

BOX_SHOPPING_CART_EMPTY

DATE_FORMAT_LONG

 

Please tell me what i've done wrong here.

 

btw: blanc pages is solved by copying the working website product_info file.

 

dont like to leave this add-on as it give the great URLS i was looking for so long.

So hope you will support me and help solve the little problems.

 

Thanks

Share this post


Link to post
Share on other sites

// include the language translations

require(DIR_WS_LANGUAGES . $language . '.php');

 

Its official, I'M THE NOOB OF THE DAY!!!!

 

Sorry mate it wasnt your fault, but 100% mine.

 

1- Find ...

// include the language translations

require(DIR_WS_LANGUAGES . $language . '.php');

 

<b>Add immediately below ...<b>

 

// ULTIMATE Seo Urls 5 by FWR Media .........etc.

 

I've replaced it instead of past it below.

 

Sorry for all the trouble.

Share this post


Link to post
Share on other sites

 

  • product name only ( p ) default
  • category - product ( cp )
  • product - category ( pc )
  • model - product ( mp )
  • product - model ( pm )
  • category - model - product ( cmp )
  • category - product - model ( cpm )
  • model - category - product ( mcp )
  • model - product - category ( mpc )
  • product - category - model ( pcm )
  • product - model - category ( pmc )

 

 

The above was quoted from a previous release, and I am having trouble locating instructions on how to perform similar adjustments for the newest release. I apologize if I have missed something in this thread, I have searched several different ways but have yet to find a solution or direction.

 

I recently installed "ULTIMATE_Seo_Urls_5_r141_stable", and am currently using the Standard rewrite type.

 

I would like to have the product model included in the URL for my product_info pages. Is this now done via the modules/Usu_Products.php? And do you have recommendations on how to best accomplish this? I didn't see anywhere to just change the 'tags' like listed above, and appears I would have to modify the Usu_Products.php to accomplish this.

 

Thanks for any guidance.

Share this post


Link to post
Share on other sites

The above was quoted from a previous release, and I am having trouble locating instructions on how to perform similar adjustments for the newest release. I apologize if I have missed something in this thread, I have searched several different ways but have yet to find a solution or direction.

 

I recently installed "ULTIMATE_Seo_Urls_5_r141_stable", and am currently using the Standard rewrite type.

 

I would like to have the product model included in the URL for my product_info pages. Is this now done via the modules/Usu_Products.php? And do you have recommendations on how to best accomplish this? I didn't see anywhere to just change the 'tags' like listed above, and appears I would have to modify the Usu_Products.php to accomplish this.

 

Thanks for any guidance.

 

You require the new PRO multilanguage version which is not yet released but is imminent. You must have read the development topic.

Share this post


Link to post
Share on other sites

You require the new PRO multilanguage version which is not yet released but is imminent. You must have read the development topic.

OK thank you for the prompt reply. I was looking through several threads, and there may have been some confusion on my end. Thanks again.

 

Great contrib btw, look forward to the new release, and very much appreciate your efforts.

Share this post


Link to post
Share on other sites

Hi,

 

I see on this topic you even have my error but no anwser.

 

Today, my website is down.

When I watch my log I have this:

PHP Fatal error: Call to undefined method stdClass::merge() in /www/mydomain.com/home/www/includes/modules/ultimate_seo_urls5/modules/Usu_Categories.php on line 38

 

I can go to the admin. But on the site, I have a blank page.

I hahe used backup but that doesn't work.

 

Ultimate Seo Urls 5 r141

PHP5

Apache

PHP Memory_limit: 2048M

 

My server is OK. I have nearly 30 other website which are find.

 

Have you got an idea?

It's xmas month and I lost orders

 

(sorry for my bad english).

 

Best Regards

Share this post


Link to post
Share on other sites

Hi,

 

I see on this topic you even have my error but no anwser.

 

Today, my website is down.

When I watch my log I have this:

 

 

I can go to the admin. But on the site, I have a blank page.

I hahe used backup but that doesn't work.

 

Ultimate Seo Urls 5 r141

PHP5

Apache

PHP Memory_limit: 2048M

 

My server is OK. I have nearly 30 other website which are find.

 

Have you got an idea?

It's xmas month and I lost orders

 

(sorry for my bad english).

 

Best Regards

 

For whatever reason your cache is corrupted. Reset the cache.

 

I would suggest you upgrade to USU5 PRO, I'll release it soon.

Share this post


Link to post
Share on other sites

For whatever reason your cache is corrupted. Reset the cache.

 

I would suggest you upgrade to USU5 PRO, I'll release it soon.

 

Unfortunately I have already reset the cache. And it doesn't work.

Share this post


Link to post
Share on other sites

Unfortunately I have already reset the cache. And it doesn't work (by the admin panel)

Finaly I have deleted manualy all the files in /includes/modules/ultimate_seo_urls5/cache and it's work!

 

Thanks

 

I will you USU5 Pro when you will have done the release.

 

Regards

Share this post


Link to post
Share on other sites

Hello FWR Media, Can you suggest which is your preferred option for Google XML Sitemap generation in combination with Ultimate SEO URLS 5 and Kiss MT? Is it the contribution you have added a few addendum pages (due to incompatible hard coding in the original contribution) for in SEO URLs 5 or is there another option you believe works better with these contributions? Thanks in advance Glen

Share this post


Link to post
Share on other sites

Hello FWR Media, Can you suggest which is your preferred option for Google XML Sitemap generation in combination with Ultimate SEO URLS 5 and Kiss MT? Is it the contribution you have added a few addendum pages (due to incompatible hard coding in the original contribution) for in SEO URLs 5 or is there another option you believe works better with these contributions? Thanks in advance Glen

 

USU5 PRO has sitemaps Glen so when available change to that.

Share this post


Link to post
Share on other sites

Hi Robert

 

I have used this contribution on loads of sites however on one particular site it is causing me a problem and i dont know why.

 

If you look that this link

 

http://www.jp-tackle.co.uk/product_info.php/mitchell-premium-runner-v2-50-fr-p-11537

 

you can see the product_info.php appears in the url however on everyother site i have used this contribution this dont happem. Because of this it means that I cant get a lightbox contribtuion to work either (test it on this page and you will see what i mean)

 

Any suggestions?


I dont help with templates (thats what the seller is for)

 

th search function will often help, when it dont try this in google.

 

site:http://forums.oscommerce.com then your search word

Share this post


Link to post
Share on other sites

Hi Robert

 

I have used this contribution on loads of sites however on one particular site it is causing me a problem and i dont know why.

 

If you look that this link

 

http://www.jp-tackle...2-50-fr-p-11537

 

you can see the product_info.php appears in the url however on everyother site i have used this contribution this dont happem. Because of this it means that I cant get a lightbox contribtuion to work either (test it on this page and you will see what i mean)

 

Any suggestions?

 

You have to set the correct settings in admin .. the product_info.php version is the non rewrite uri.

Share this post


Link to post
Share on other sites

I dont have a option in admin to change this:

 

true Info

Add cPath to product URLs? false Info

Add category parent to begining of URLs? true Info

Filter Short Words 1 Info

Output W3C valid URLs (parameter string)? true Info

Enable SEO cache to save queries? false Info

Enable product cache? false Info

Enable categories cache? true Info

Enable manufacturers cache? true Info

Enable articles cache? true Info

Enable topics cache? true Info

Enable information cache? true Info

Enable link directory cache? true Info

Enable automatic redirects? true Info

Choose URL Rewrite Type Rewrite

Enter special character conversions Info

Remove all non-alphanumeric characters? true Info

Reset SEO URLs Cache Info

 

If i click on edit on choose url rewrite i dont have any other options?


I dont help with templates (thats what the seller is for)

 

th search function will often help, when it dont try this in google.

 

site:http://forums.oscommerce.com then your search word

Share this post


Link to post
Share on other sites

USU5 PRO has sitemaps Glen so when available change to that.

 

Robert thank you very much, will await the PRO version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×