Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

@Michael and all others with huge shops ( numbers of products ).

 

The issue here is simple .. although we are not caching the products any more ( if you have the modified files ) I overlooked the fact that we are still caching the data for the popup image in product_info.php.

 

This means that you end up with a huge pID cache file, as an seo url for the popup product image is irrelevant to SEO ( I only included it for backwards compatibility ) just remove the module for popup images.

 

catalog/includes/modules/ultimate_seo_urls/modules/Usu_PopUpImage.php

 

Then reset your cache.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello Rob,

 

@Michael and all others with huge shops ( numbers of products ).

 

The issue here is simple .. although we are not caching the products any more ( if you have the modified files ) I overlooked the fact that we are still caching the data for the popup image in product_info.php.

 

This means that you end up with a huge pID cache file, as an seo url for the popup product image is irrelevant to SEO ( I only included it for backwards compatibility ) just remove the module for popup images.

 

catalog/includes/modules/ultimate_seo_urls/modules/Usu_PopUpImage.php

 

Then reset your cache.

 

thank you for this fast reply and solution - you are the best :) ! I will try this as soon as possible.

 

Thank you and best regards

 

Michael

Share this post


Link to post
Share on other sites

Hi and thanks for this contribution!

 

i dont know if i´m stupid but do this on my testshop

(www . my_real_shop .com/my_testshop)

 

And after installing this contrib and made the changes to the .htaccess file i come to my_real_shop when clicking on a category in my test_shop customer area.

 

Is there anything to do with the .htaccess file?

 

# Change RewriteBase using the instructions above

RewriteBase /

I left it like it is since i have my test shop in the root of my_test_shop directory.

 

This AllowOveride set to all, i dont know how to do this either. :blush:

Share this post


Link to post
Share on other sites

Hi and thanks for this contribution!

 

i dont know if i´m stupid but do this on my testshop

(www . my_real_shop .com/my_testshop)

 

And after installing this contrib and made the changes to the .htaccess file i come to my_real_shop when clicking on a category in my test_shop customer area.

 

Is there anything to do with the .htaccess file?

 

# Change RewriteBase using the instructions above

RewriteBase /

I left it like it is since i have my test shop in the root of my_test_shop directory.

 

This AllowOveride set to all, i dont know how to do this either. :blush:

 

 

Hi .. the instructions say ..

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

Share this post


Link to post
Share on other sites

:rolleyes:

 

Sorry my brain was in tilt >_<

 

thanks for such a fast respond.

 

*handing you a nice flower* :)

Share this post


Link to post
Share on other sites

Hi, its me again, since i havent installed any "Google XML sitemap SEO" earlier in my test shop i now did.

 

My stupid question now is about the cron jobs (that i yet havent added) i suppose i dont have to pay attention about this lines in the extras folder?

 

Cron jobs:

 

Because the cron files now include files the cron will have to be changed to access the file using apache.

 

Like ..

 

* * * * * * wget -q http://www.somesite.com/folder/file.php >/dev/null 2>&1

 

sorry for taking your time with my questions :blush:

Share this post


Link to post
Share on other sites

Hi, its me again, since i havent installed any "Google XML sitemap SEO" earlier in my test shop i now did.

 

My stupid question now is about the cron jobs (that i yet havent added) i suppose i dont have to pay attention about this lines in the extras folder?

 

Cron jobs:

 

Because the cron files now include files the cron will have to be changed to access the file using apache.

 

Like ..

 

* * * * * * wget -q http://www.somesite.com/folder/file.php >/dev/null 2>&1

 

sorry for taking your time with my questions :blush:

 

If you are using Chemos Google XML Sitemap SEO you have to replace the files with the ones in the extras folder and use the wget in the cron job.

Share this post


Link to post
Share on other sites

Thanks again but since i just installed the Sitemap i havent made any cron settings yet. :rolleyes:

Share this post


Link to post
Share on other sites

Considering that you have products cache turned off the file size of 320kb is huge ( perhaps you could email me this ) .. how many categories does it have?

 

To turn caching off open up the class file dealing with your chosen cache method and change ..

 

private $use_cache = 'false';

 

Hi there, I am having similar problems with the contribution. I have a 60.000 products store and I get the same type of Errors as people before. I've tried both the filesystem and the database caching system but in less than 24h I get errors (the same as people above). Clearing cache solves the problem, but that is not really a solution.

 

Anyway, I am trying to figure out how to disable the caching system by setting $use_cache = 'false', but I can't find the $use_cache anywhere.

 

I've updated from the Series2 version if that helps.

 

Any help would be appreciated because I intend to keep your contribution as it seems to be of great help, of course, except for the errors :)

Share this post


Link to post
Share on other sites

Hi there, I am having similar problems with the contribution. I have a 60.000 products store and I get the same type of Errors as people before. I've tried both the filesystem and the database caching system but in less than 24h I get errors (the same as people above). Clearing cache solves the problem, but that is not really a solution.

 

Anyway, I am trying to figure out how to disable the caching system by setting $use_cache = 'false', but I can't find the $use_cache anywhere.

 

I've updated from the Series2 version if that helps.

 

Any help would be appreciated because I intend to keep your contribution as it seems to be of great help, of course, except for the errors :)

 

Firstly look at post 2152 then send me a PM with your email and I'll send you some revised files.

Share this post


Link to post
Share on other sites

First of all thank you for this contrib. Everything works, except one discrepancy I came across. Secondly, pardon my stupidity and ignorance as I can't seem to find anything pertaining to my problem. There are a lot of pages in this thread and I want to rather just ask for help and hope for the best.

 

Product links in my shopping cart with attributes doesn't seem to be affected by ULTIMATE Seo Urls 5, I have links displaying like this: /product_info.php?products_id=1{8}24{4}4

 

Are these covered at all, or am I missing something. I installed the [sTABLE] r141 [FULL PACKAGE] from 10 Dec 2009. Other than that it works really well.

 

Thanks

Edited by Witblitz

Share this post


Link to post
Share on other sites

hi Robert

 

i sent you a pm with my email address.I was wondering if you can please send me the revised files.

 

i keep gettint this PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 10747885 bytes) in /home/xXxxxxxx/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_Database.php on line 37

 

many thanks for your contrib

 

regards

 

nafri

 

just had a look at post 2152 ..i removed the file and did a reset.Do i still need the revided file..

Edited by nafri

Share this post


Link to post
Share on other sites

hi Robert

 

i sent you a pm with my email address.I was wondering if you can please send me the revised files.

 

i keep gettint this PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 10747885 bytes) in /home/xXxxxxxx/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_Database.php on line 37

 

many thanks for your contrib

 

regards

 

nafri

 

just had a look at post 2152 ..i removed the file and did a reset.Do i still need the revided file..

 

I missed this, sorry.

 

Have sent the files.

Share this post


Link to post
Share on other sites

You can't currently and it is not something that I have seen requested enough to make it a worthwhile addition at this stage I'm afraid.

 

quick question, has this now been added?? having the manufacturers name in the URL is 100% key if you ask me, when people search for products, especially in my industry, they will always use the manufacturer and the model number, thus google will serve up pages that match that search criteria.

 

This modification was available in version 2, but now I've upgraded it's been lost. If this has been done can you point me in the direction of the modification (I tried searching the forum but found nothing), if not can the mod be made?

 

thanks

Share this post


Link to post
Share on other sites

hi robert

 

i installed the patch and now i got this errir on the info pages

 

1062 - Duplicate entry '1_usucache_seo_pages' for key 1

 

INSERT INTO `usu_cache` (cache_name, cache_data, cache_date) VALUES ('1_usucache_seo_pages', 'S7QytaoutrK0UsrMS0mt0CvIKFCyzrQytC62MjQFCablF+UmlmTm56FImVkpFRTlp5Qml8SDlKDIWSLkilLLMlPLi5GljUwwpNGMqAUA', '2010-07-05 10:30:38')

 

any ideas ?

 

kind regards

 

Sales

Share this post


Link to post
Share on other sites

Hi nafri,

 

the first try is always to reset the SEO cache. That works most of the time ;-).

 

Best regards

 

Michael

 

hi robert

 

i installed the patch and now i got this errir on the info pages

 

1062 - Duplicate entry '1_usucache_seo_pages' for key 1

 

INSERT INTO `usu_cache` (cache_name, cache_data, cache_date) VALUES ('1_usucache_seo_pages', 'S7QytaoutrK0UsrMS0mt0CvIKFCyzrQytC62MjQFCablF+UmlmTm56FImVkpFRTlp5Qml8SDlKDIWSLkilLLMlPLi5GljUwwpNGMqAUA', '2010-07-05 10:30:38')

 

any ideas ?

 

kind regards

 

Sales

Share this post


Link to post
Share on other sites

Hi nafri,

 

the first try is always to reset the SEO cache. That works most of the time ;-).

 

Best regards

 

Michael

 

 

hi

 

i did do a reset of the seo cache.It had no affect.I had to switch the caching from databse to file system and it seems to be ok now.

 

Thanks for replying though.

 

kind regards

 

nafri

Share this post


Link to post
Share on other sites

HI and thanks for a great contrubution, and great support on top of that.

 

The install went fine and I'm using "Traditional Rewrite Seo Urls" and it's producing neat urls. However ever since the install my site has been slow, images seems to be loading in bursts. Sometimes it loads very fast and sometimes it just hangs or skips an image or two. But it's never the same image. I'm using the thmbnail contrubution "Oscthumb" which stores thumbnails of all my product images (in different sizes) with long names like "phpThumb_cache_mysite.com_src4c449882bd9b8209da13d80d6eb5162b_par03caae645d16f232df730fc8e89ebccc_dat1272365083.jpeg" can this somehow conflict with USU?

 

Thanks for your time

Share this post


Link to post
Share on other sites

HI and thanks for a great contrubution, and great support on top of that.

 

The install went fine and I'm using "Traditional Rewrite Seo Urls" and it's producing neat urls. However ever since the install my site has been slow, images seems to be loading in bursts. Sometimes it loads very fast and sometimes it just hangs or skips an image or two. But it's never the same image. I'm using the thmbnail contrubution "Oscthumb" which stores thumbnails of all my product images (in different sizes) with long names like "phpThumb_cache_mysite.com_src4c449882bd9b8209da13d80d6eb5162b_par03caae645d16f232df730fc8e89ebccc_dat1272365083.jpeg" can this somehow conflict with USU?

 

Thanks for your time

 

USU5 produces links so shouldn't have an effect on an image contribution .. having said this some image contributions use the tep_href_link() function and if they are using it incorrectly ( to produce a link to an image ) then there could be a problem. Look through the code and see if tep_href_link() is used.

Share this post


Link to post
Share on other sites

USU5 produces links so shouldn't have an effect on an image contribution .. having said this some image contributions use the tep_href_link() function and if they are using it incorrectly ( to produce a link to an image ) then there could be a problem. Look through the code and see if tep_href_link() is used.

 

Thanks for your reply!

 

No oscthumb isn't using tep_href_link(). I do however use "more_pics_6_v1.4.3" for additional product images and apparently that contrib has loads of tep_href_link()in it. I'm not sure what to do about it though.

 

I'm a bit at loss here. I've installed your "KISS_Error_Handling_Debugging_v1.0_r20" to see if I could find something dodgy but apart from:

E_WARNING Error Count: 1
Error: Invalid argument supplied for foreach()
File: includes/kiss_error_handler.php
Line: 316

I have no warnings. (A shitload of E-notices though but i think they all came after my service provider updated to php 5.3 and havent given me any grief before). I have 84 querries on my index page and the total querrie time is around 0.2 seconds. Yet the images sometimes take forever to load (and sometimes lightning fast).

 

Edit. And sometimes I get timed out when clicking a manufacturer och category link.

 

I've spoken to my service provider several times and according to them everything is running fine on their end.

 

Thanks again for taking your time

 

/Kire

Edited by kurios

Share this post


Link to post
Share on other sites

A shitload of E-notices though but i think they all came after my service provider updated to php 5.3 and havent given me any grief before

 

/Kire

 

Notices are errors .. if you have these you should concentrate on removing them. Shabby code = slow sites and hacking opportunities.

 

Otherwise I can't help .. if the script is npt using tep_href_link() then USU 5 can have no effect.

Share this post


Link to post
Share on other sites

Notices are errors .. if you have these you should concentrate on removing them. Shabby code = slow sites and hacking opportunities.

 

Otherwise I can't help .. if the script is npt using tep_href_link() then USU 5 can have no effect.

 

You're right of course, i'm working my way through them.

 

One last thing though, I ran Yslow on my site and it seems that it randomly takes a very long time to connect to the server 5 calls are quick and then bang it takes 5 seconds just to connect. Can the redirects create some kind of overload?

 

(since i barely know what i'm talking about dont bother answering if i'm to far off)

Share this post


Link to post
Share on other sites

You're right of course, i'm working my way through them.

 

One last thing though, I ran Yslow on my site and it seems that it randomly takes a very long time to connect to the server 5 calls are quick and then bang it takes 5 seconds just to connect. Can the redirects create some kind of overload?

 

(since i barely know what i'm talking about dont bother answering if i'm to far off)

 

I presume you are talking of the rewrite rules when you say ( Can the redirects create some kind of overload? ) the answer is no .. a possibility is that your server ( multiple hosting environment? ) is close to maxed and occasionally runs out of resources.

Share this post


Link to post
Share on other sites

Ok I solved my problem by installing the oscThumb 1.1a fix, where apparently all image links are validated. I don't know why that was causing so much trouble but now everything is working great.

 

So in short, if you have problems with slowdowns running oscthumb and Seo Urls 5 then install the oscThumb 1.1a fix.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×