Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Hi Robert

 

I have problems with some things, for example

 

.....index.php?manufacturers_id=13&page=1/

..../index.php?currency=USD&cPath=111_108_57&language=es/

...../-p-500.html?language=de/

 

As I have read these problems are solved with PRO version

 

When you're ready to download Ultimate Seo Urls 5 Pro (version 1.1)

 

Thanks for all of your help!

 

Fer

Share this post


Link to post
Share on other sites

Hi Robert

 

I have problems with some things, for example

 

.....index.php?manufacturers_id=13&page=1/

..../index.php?currency=USD&cPath=111_108_57&language=es/

...../-p-500.html?language=de/

 

As I have read these problems are solved with PRO version

 

When you're ready to download Ultimate Seo Urls 5 Pro (version 1.1)

 

Thanks for all of your help!

 

Fer

 

I have no idea what you mean .. there are no known issues with USU5 so currently there are no problems to solve.

 

Excepting the caching of massive shops ( 20,000 products plus ).

Share this post


Link to post
Share on other sites

Ryan USU5 is a url contribution it has nothing whatsoever to do with titles, duplicate or otherwise.

 

Robert,

 

I apologize if I have wasted your time. I may have justed posted in the wrong forum. I am using KissMT and USU5. You create the most reliable contributions for osCommerce so it only made sense to install KissMT as well.

 

The reasoning that led me to believe that the problem was with USU5 originated with the duplicate URLS rather then meta tags because the meta tags (from KissMT) are functioning properly. As I have previously mentioned my version of USU5 is the latest version. However, it has one twist to it, it has a slight modification to it that allows the URL's to be written with the manufacturer's name before the product name. The modification was written by you in this thread many months ago for the first release of USU5. I reapplied it to the latest version of USU5 when I upgraded and everything appeared to 100% good.

 

In my Google Webmaster tools I am getting a large amount of penalties for duplicate descriptions and title tags. The URL of these penalties are the main reasoning I believe the problem to be with USU5. I think there may be a redirecting problem or a 301 redirect problem. When I click on one of the duplicate links it always automatically redirects to the correct URL. But after over a week these penalties still persist and have increased. For some reason that I can not explain Google is seeing two links for every product. One link with the manufacturer's name and one without.

 

picture2md.png

 

Do you think this is still not a problem with USU5?

 

Thanks for everything!

 

- Ryan


plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

I apologize if I have wasted your time. I may have justed posted in the wrong forum. I am using KissMT and USU5. You create the most reliable contributions for osCommerce so it only made sense to install KissMT as well.

 

The reasoning that led me to believe that the problem was with USU5 originated with the duplicate URLS rather then meta tags because the meta tags (from KissMT) are functioning properly. As I have previously mentioned my version of USU5 is the latest version. However, it has one twist to it, it has a slight modification to it that allows the URL's to be written with the manufacturer's name before the product name. The modification was written by you in this thread many months ago for the first release of USU5. I reapplied it to the latest version of USU5 when I upgraded and everything appeared to 100% good.

 

In my Google Webmaster tools I am getting a large amount of penalties for duplicate descriptions and title tags. The URL of these penalties are the main reasoning I believe the problem to be with USU5. I think there may be a redirecting problem or a 301 redirect problem. When I click on one of the duplicate links it always automatically redirects to the correct URL. But after over a week these penalties still persist and have increased. For some reason that I can not explain Google is seeing two links for every product. One link with the manufacturer's name and one without.

 

picture2md.png

 

Do you think this is still not a problem with USU5?

 

Thanks for everything!

 

- Ryan

 

Hi Ryan

 

Two seperate uris pointing to a page without there being a valid 301 redirect for the incorrect version should not happen with USU5 ( it does of course happen all the time with the old series 2 ).

 

What I'd suggest is that you test it.

 

1) Assuming that you use firefox .. load up the add on "Live HTTP headers".

 

Access your site with the full url that you believe should be current and see what headers are output.

 

2) Try to access your site with the legacy full url ( no manufacturer name ) and compare the headers it should be a 301 redirect.

Share this post


Link to post
Share on other sites

I downloaded the KISSMT contribution and I was about to install it for testing purpose but as I am using STS the installation should be different. So is there any additional instllation instruction fro STS users to install KISSMT.

Thanks

Step 1 Edit file includes/modules/sts_inc/sts_user_code.php

 

add

 

$sts->start_capture();

include(DIR_WS_MODULES . 'kiss_meta_tags/kiss_meta_tags.php');

$sts->stop_capture('kissmeta');

 

after first <?php and before

 

$sts->start_capture();

echo "\n<!-- Start Category Menu -->\n";

echo tep_draw_form('goto', FILENAME_DEFAULT, 'get', '');

echo tep_draw_pull_down_menu('cPath', tep_get_category_tree(), $current_category_id, 'onchange="this.form.submit();"');

echo "</form>\n"; echo "<!-- End Category Menu -->\n";

$sts->stop_capture('catmenu');

 

Step 2 Edit file includes/modules/sts_inc/general.php

 

delete

 

$sts->template['headertags']= "<title>" . TITLE ."</title>";

 

Step 3 Edit your template html

 

Now add $kissmeta to your template .html like...

<head>

<!--$headcontent-->

$kissmeta

<link rel="stylesheet" type="text/css" href="************.css">

</head>

 

I hope this works for you!


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Thanks for your reply sijo and robert

 

I seems to have sorted the problem now so not sure should I just stick on to the header tags seo? or I should install the KISSMT?

 

Is there any obvious advantage of one over the other.

 

Thanks

Share this post


Link to post
Share on other sites

Thanks for your reply sijo and robert

 

I seems to have sorted the problem now so not sure should I just stick on to the header tags seo? or I should install the KISSMT?

 

Is there any obvious advantage of one over the other.

 

Thanks

 

This is not really the place to discuss KissMT as it has its own support thread. All I will say is that I created KissMT as I would never add header tags to a web site, I find it bloated, inefficient and over complex. It should be remembered though that KissMT is dynamic it can be installed in minutes and then virtually left alone to do "its thing". If you want to laboriously write every single bit of meta data for each dynamic page manually then KissMT is not for you.

Share this post


Link to post
Share on other sites

Hi there, firstly a great contribution, I did have a few problems installing but thanks to some help from fellow community member Chooch I have been able to correct most of the problems. The main issue I have at the moment all the links on the homepage work correctly except for the categories links. They automatically revert back to the homepage. The only wy to view products at the moment is to either click images, or use drop down list from the manufacturers list and get to the products that way. Any ideas?

 

Thanks in advance

 

Timmer

 

(website is http://www.riflebitz.com)

Share this post


Link to post
Share on other sites

Hi there, firstly a great contribution, I did have a few problems installing but thanks to some help from fellow community member Chooch I have been able to correct most of the problems. The main issue I have at the moment all the links on the homepage work correctly except for the categories links. They automatically revert back to the homepage. The only wy to view products at the moment is to either click images, or use drop down list from the manufacturers list and get to the products that way. Any ideas?

 

Thanks in advance

 

Timmer

 

(website is http://www.riflebitz.com)

 

I can't imagine why you had problems installing, the instructions are quite clear.

 

The categories are not working because cPath is not being passed via _GET for some reason.

 

Can you confirm that you have EXACTLY the following line in your .htaccess code: -

 

RewriteRule ^(.*)-c-([0-9_]+).html$ index.php?cPath=$2&%{QUERY_STRING}

Share this post


Link to post
Share on other sites

Hi there,

 

I'm not sure why I had the problems when I orginally installed it, kept getting a load of errors especially in the admin area, however reinstalled it and it in the state is now. I'm sure i must of not done something correctly orginally.

 

The code I have in the htaccess file is the following:-

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

#<IfModule mod_setenvif.c>

# <IfDefine SSL>

# SetEnvIf User-Agent ".*MSIE.*" \

# nokeepalive ssl-unclean-shutdown \

# downgrade-1.0 force-response-1.0

# </IfDefine>

#</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

 

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

# php_value session.use_trans_sid 0

# php_value register_globals 1

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

 

I couldn't the line of code you mentioned, if that is the problem where abouts within the htacess file should I put it?

 

I can't imagine why you had problems installing, the instructions are quite clear.

 

The categories are not working because cPath is not being passed via _GET for some reason.

 

Can you confirm that you have EXACTLY the following line in your .htaccess code: -

 

RewriteRule ^(.*)-c-([0-9_]+).html$ index.php?cPath=$2&%{QUERY_STRING}

Share this post


Link to post
Share on other sites

You can't do this, standard mode must be a filename ( or osCommerce wouldn't know which file to load )

 

The alternative is to use rewrite mode e.g.

 

some.domain.tld/my_article_name-p-23.html

 

If rewrite mode is not working then either you have set RewriteBase incorrectly in .htaccess or your server is not setup correctly with mod_rewrite and required AllowOverride settings.

 

if ( in_array("mod_rewrite", apache_get_modules()) ) echo "mod rewrite on"; else echo "Huh, dude u don't have";

and

httpd -M shows me that mod_rewrite is fired up and running

 

RewriteBase is set to "/" according to the DocumentRoot in httpd.conf, cause the shop resides there, .htaccess too -- should be a pretty nice setting, right?

 

AllowOverride was set to None changed to All, which was the error in my case...

 

changed the setting and tried and tried and ... wtf nothing happens...

 

so @all with the same error: DON'T FORGET TO RESTART YOUR APACHE-SERVER, eg. apachectl restart

 

@FWR Media, you are a really smart person B) thx thx thx

Share this post


Link to post
Share on other sites

Hi there FWR Media,

 

Ok I have changed my htaccess file and have now icluded the line of code you mentioned as it wasn't in the original install document. my htaccess file now reads

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-([0-9_]+).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}

 

but the categories menu just automatically takes me to home page. If you click the proper address is dispalyed but doesn't physically take me there.

 

www.riflebitz.com

 

Thanks in advance

 

Timmer

 

I can't imagine why you had problems installing, the instructions are quite clear.

 

The categories are not working because cPath is not being passed via _GET for some reason.

 

Can you confirm that you have EXACTLY the following line in your .htaccess code: -

 

RewriteRule ^(.*)-c-([0-9_]+).html$ index.php?cPath=$2&%{QUERY_STRING}

Share this post


Link to post
Share on other sites

I need some help please, we are desperate because we are losing indexed pages and our traffic is to the ground.

 

In January we moved to a php5 server and i installed this wonderful contribution, the problem is that before we have Chemos contribution and our link use to be www.domain.com/categoiry/product.html and now we have www.domain.com/product.html is there anyway of adding the category to the products url so we can keep the links as they were originally.

 

We used to have 1800 pages indexed and now we dropped to 452.

 

Please Help.

Share this post


Link to post
Share on other sites

I need some help please, we are desperate because we are losing indexed pages and our traffic is to the ground.

 

In January we moved to a php5 server and i installed this wonderful contribution, the problem is that before we have Chemos contribution and our link use to be www.domain.com/categoiry/product.html and now we have www.domain.com/product.html is there anyway of adding the category to the products url so we can keep the links as they were originally.

 

We used to have 1800 pages indexed and now we dropped to 452.

 

Please Help.

 

Firstly: - Chemos old seo urls contribution never offered the type of url you have stated ..

 

www.domain.com/category/product.html

 

However if your shop used to be in a directory and has been moved to root it may have looked like ..

 

www.domain.com/[some directory]/product-p-x.html

 

USU5 301 redirects work perfectly so USU5 is not your problem, perhaps search the forums for help on moving your shop from a directory to root.

Share this post


Link to post
Share on other sites

 

but the categories menu just automatically takes me to home page. If you click the proper address is dispalyed but doesn't physically take me there.

 

Firstly you are not using the .htaccess code as given in the contribution.

 

Is this a Windows server? if so what rewrite module do you have?

Share this post


Link to post
Share on other sites

Hi there

 

Yes it is a windows server I am using. I am not sure how to find out what module I am using. I have uploaded the exact code given in the contribution just now but same problem.

 

Firstly you are not using the .htaccess code as given in the contribution.

 

Is this a Windows server? if so what rewrite module do you have?

Share this post


Link to post
Share on other sites

Hi there

 

Yes it is a windows server I am using. I am not sure how to find out what module I am using. I have uploaded the exact code given in the contribution just now but same problem.

 

Those rewrite rules are for *nix servers not for Windows, you can use the rewrite mode on a Windows server but you have to know the rewrite module and add .htaccess code that matches it.

 

I would suggest you change temporarily to standard mode and find out the answers to the above.

Share this post


Link to post
Share on other sites

Firstly: - Chemos old seo urls contribution never offered the type of url you have stated ..

 

www.domain.com/category/product.html

 

However if your shop used to be in a directory and has been moved to root it may have looked like ..

 

www.domain.com/[some directory]/product-p-x.html

 

USU5 301 redirects work perfectly so USU5 is not your problem, perhaps search the forums for help on moving your shop from a directory to root.

 

 

The page was on the root and now is on the root too. This is an example.

 

The old URL:

 http://www.cexy.co.uk/love-zone/romantic-massage-p-3330.html

New URL:

 http://www.cexy.co.uk/romantic-massage-p-3330.html

Edited by smic717394

Share this post


Link to post
Share on other sites

Just checked with the guy who hosts the site for me, they run lsapi rewrite for iis. He said that it works with 90% of linux commands and it's definately enabled. hope this helps

 

Those rewrite rules are for *nix servers not for Windows, you can use the rewrite mode on a Windows server but you have to know the rewrite module and add .htaccess code that matches it.

 

I would suggest you change temporarily to standard mode and find out the answers to the above.

Share this post


Link to post
Share on other sites

Just checked with the guy who hosts the site for me, they run lsapi rewrite for iis. He said that it works with 90% of linux commands and it's definately enabled. hope this helps

 

Isapi 2.0 or 3.0?

Share this post


Link to post
Share on other sites

hi FWR Media,

 

please ignore my last post, it's definately version 3.

 

Had a look at the info and i believe it's 2.0

Share this post


Link to post
Share on other sites

hi FWR Media,

 

please ignore my last post, it's definately version 3.

 

Isapi rewrite version 3 should only require the following in .htaccess ( presumes a root install ): -

RewriteEngine On

# RewriteBase instructions
# Change RewriteBase dependent on how your shop is accessed as below.
# http://www.mysite.com = RewriteBase /
# http://www.mysite.com/catalog/ = RewriteBase /catalog/
# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

# Change RewriteBase using the instructions above
RewriteBase /
RewriteRule ^([a-z0-9-]+)-p-([0-9]+)\.html$ product_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-c-([0-9_]+)\.html$ index.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-m-([0-9]+)\.html$ index.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-pi-([0-9]+)\.html$ popup_image.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-pr-([0-9]+)\.html$ product_reviews.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-pri-([0-9]+)\.html$ product_reviews_info.php [NC,L,QSA]
# Articles contribution
RewriteRule ^([a-z0-9-]+)-t-([0-9_]+)\.html$ articles.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-au-([0-9]+)\.html$ articles.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-a-([0-9]+)\.html$ article_info.php [NC,L,QSA]
# Information pages
RewriteRule ^([a-z0-9-]+)-i-([0-9]+)\.html$ information.php [NC,L,QSA]
# Links contribution
RewriteRule ^([a-z0-9-]+)-links-([0-9_]+)\.html$ links.php [NC,L,QSA]
# Newsdesk contribution
RewriteRule ^([a-z0-9-]+)-n-([0-9]+)\.html$ newsdesk_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-nc-([0-9]+)\.html$ newsdesk_index.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-nri-([0-9]+)\.html$ newsdesk_reviews_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-nra-([0-9]+)\.html$ newsdesk_reviews_article.php [NC,L,QSA]

Share this post


Link to post
Share on other sites

Hi there,

 

Firstly thank you for the code and your patience with me. I tried the code however, when I click the categories it says that the page couldn't be found, the same applies to the pictures. When I use the code that was supplied with the contribution, the pictures go to the correct product however the categories revert to the home page. Oscommerce is installed in the root folder, just really confused because everything works except that category menu thing. If you for example go to drop down list of manufacturers and pick 1 it'll list all products and then the category filter within that page works. The other issue is if i turn ultimate urls off then the navigation (page id etc) I believe gets timed out, so I have had to keep ultimate seo turned on.

 

Again all help is greatfully received.

 

Kind regards

 

Tim (http:www.riflebitz.com)

 

Isapi rewrite version 3 should only require the following in .htaccess ( presumes a root install ): -

RewriteEngine On

# RewriteBase instructions
# Change RewriteBase dependent on how your shop is accessed as below.
# http://www.mysite.com = RewriteBase /
# http://www.mysite.com/catalog/ = RewriteBase /catalog/
# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

# Change RewriteBase using the instructions above
RewriteBase /
RewriteRule ^([a-z0-9-]+)-p-([0-9]+)\.html$ product_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-c-([0-9_]+)\.html$ index.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-m-([0-9]+)\.html$ index.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-pi-([0-9]+)\.html$ popup_image.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-pr-([0-9]+)\.html$ product_reviews.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-pri-([0-9]+)\.html$ product_reviews_info.php [NC,L,QSA]
# Articles contribution
RewriteRule ^([a-z0-9-]+)-t-([0-9_]+)\.html$ articles.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-au-([0-9]+)\.html$ articles.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-a-([0-9]+)\.html$ article_info.php [NC,L,QSA]
# Information pages
RewriteRule ^([a-z0-9-]+)-i-([0-9]+)\.html$ information.php [NC,L,QSA]
# Links contribution
RewriteRule ^([a-z0-9-]+)-links-([0-9_]+)\.html$ links.php [NC,L,QSA]
# Newsdesk contribution
RewriteRule ^([a-z0-9-]+)-n-([0-9]+)\.html$ newsdesk_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-nc-([0-9]+)\.html$ newsdesk_index.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-nri-([0-9]+)\.html$ newsdesk_reviews_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9-]+)-nra-([0-9]+)\.html$ newsdesk_reviews_article.php [NC,L,QSA]

Share this post


Link to post
Share on other sites

just to double check as my shop is in the root folder would the exact htaccess code be written exactly as below? I am sorry to ask, I'm sure these are quite basic things I'm slowly getting the hang of it all.

 

RewriteRule ^([a-z0-9-]+)-p-([0-9]+)\.html$ product_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-c-([0-9_]+)\.html$ index.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-m-([0-9]+)\.html$ index.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-pi-([0-9]+)\.html$ popup_image.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-pr-([0-9]+)\.html$ product_reviews.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-pri-([0-9]+)\.html$ product_reviews_info.php [NC,L,QSA]

# Articles contribution

RewriteRule ^([a-z0-9-]+)-t-([0-9_]+)\.html$ articles.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-au-([0-9]+)\.html$ articles.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-a-([0-9]+)\.html$ article_info.php [NC,L,QSA]

# Information pages

RewriteRule ^([a-z0-9-]+)-i-([0-9]+)\.html$ information.php [NC,L,QSA]

# Links contribution

RewriteRule ^([a-z0-9-]+)-links-([0-9_]+)\.html$ links.php [NC,L,QSA]

# Newsdesk contribution

RewriteRule ^([a-z0-9-]+)-n-([0-9]+)\.html$ newsdesk_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-nc-([0-9]+)\.html$ newsdesk_index.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-nri-([0-9]+)\.html$ newsdesk_reviews_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9-]+)-nra-([0-9]+)\.html$ newsdesk_reviews_article.php [NC,L,QSA]

 

quote name='timmer81' date='28 April 2010 - 04:49 PM' timestamp='1272473396' post='1505215']

Hi there,

 

Firstly thank you for the code and your patience with me. I tried the code however, when I click the categories it says that the page couldn't be found, the same applies to the pictures. When I use the code that was supplied with the contribution, the pictures go to the correct product however the categories revert to the home page. Oscommerce is installed in the root folder, just really confused because everything works except that category menu thing. If you for example go to drop down list of manufacturers and pick 1 it'll list all products and then the category filter within that page works. The other issue is if i turn ultimate urls off then the navigation (page id etc) I believe gets timed out, so I have had to keep ultimate seo turned on.

 

Again all help is greatfully received.

 

Kind regards

 

Tim (http:www.riflebitz.com)

Edited by timmer81

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×