Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Er, ok ... leaving it with the '39' is better?

 

If I google "youre the voice" I can see the top result is wikipedia with a url : en.wikipedia.org/wiki/You're_the_Voice

 

Hmm.

 

Simon

I would certainly remove the 39 which is likely happening because of the '. However why not do it like this youre_The_Voice like many of the others to keep it simple and then focus on Title, Meta Desc, keywords and page content with the you're?

Share this post


Link to post
Share on other sites

Ive got this addon working fine, except for the 'details' button below the product listing on the main page under "whats new here?".

The link goes to: catalog/product_info.php and leads to a "product not found" page.

Anyone know where i can edit the listing code for the "whats new here?" section of the index.php page?

thanks

Edited by try2dream

Share this post


Link to post
Share on other sites

no, I think it would be better to not have the 39 show and unless I didn't understand this whole thing well, I was under the impression that punctation in links weren't good. Have you tried going to the SEO Urls configuration bit in admin and set "Remove all non-alphanumeric characters" to true and just have it show "youre"

 

Hi Marie - I agree punctuation isn't a good idea for seo. Yes I tried the 'remove all n-a characters' setting, apparently a ' (which is a single quote but also considered an apostrophe) isn't considered a non-alphanumeric character.

Simon

Share this post


Link to post
Share on other sites

I would certainly remove the 39 which is likely happening because of the '. However why not do it like this youre_The_Voice like many of the others to keep it simple and then focus on Title, Meta Desc, keywords and page content with the you're?

 

 

Yes I could edit the database and remove all the ' quotes ... or it seems change them to this character ’ (which I think is an acute, which USU5 does strip from the rewrite!) as in the book title: The All New Beginner’s Guide

 

Just trying to figure out how USU5 picks which characters to strip from the rewritten urls.

 

Simon

Share this post


Link to post
Share on other sites

Hi Marie - I agree punctuation isn't a good idea for seo. Yes I tried the 'remove all n-a characters' setting, apparently a ' (which is a single quote but also considered an apostrophe) isn't considered a non-alphanumeric character.

Simon

 

it worked on mine. I have quite a few product names that have the '... Like Marie's this and Jenny's that... and when the you look at my seo links they show like maries_this and jennys_that. And I don't remember having to tweak anything. I don't know if this will help but this is how mine is set:

 

Select caching system. FileSystem

Enter special character conversions. (Better to use the file bas (I didn't enter any at this time)

Choose URL Rewrite Type rewrite

Output W3C valid URLs? true

Filter Short Words: 1

Add category parent to beginning of URLs? false

Add cPath to product URLs? false

Enable SEO URLs 5? true

Turn debug reporting on true/false. false

Reset SEO URLs Cache

Set the number of days to store the cache. 7

Remove all non-alphanumeric characters? true

 

 

Share this post


Link to post
Share on other sites

in the meantime, I changed my setting to false for non-alphanumrical and reset the cache and the ' didn't show. So it might be that it's something else. Might be that in the code itself something is already there to handle the '. Did you do any editing to the original files?

 

Do you have any character conversion that you set yourself or files to the character conversion folder or have you the Google Sitemap? I was planning on doing the Google map thing but I'm waiting to resolve my issue before adding more to the mix.

Edited by mariemeh

Share this post


Link to post
Share on other sites

try uncommenting this :

 

#RewriteBase /catalog/

 

to become

 

RewriteBase /catalog/

 

... it'll make a world of difference :)

 

simon

 

changed that in htaccess changed the admin option to rewrite and i get

The requested URL /catalog/pink-lady-apples-p-26.html was not found on this server

Share this post


Link to post
Share on other sites

changed that in htaccess changed the admin option to rewrite and i get

 

 

I don't know if this will help but I've learned that I often have to reset the cache when I do modifications and I want them to take effect. My apologies for the waste in time if it's not the case.

Share this post


Link to post
Share on other sites

On my redirect issue... here is what I've tried and apparently can't make work. If any of you see something that I did wrong, please feel free to point it out:

 

Robert posted this on this thread a few posts back:

 

A reasonable way to do this is to include a script near the top of includes/application_top.php, after the configuration has loaded, that checks the $_SERVER key REQUEST_URI ( if available ) for uris matching the old uris of your previous seo url script and if there is a match redirects to the new.

 

You might use a simple array like ..

 

 

$intercept = array( 'PC/Games/Assassins-Creed-2-PC-DVD-Rom-2726/' => HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'assassins-creed-2-p-2726.html' );

 

Then check for existence maybe like ..

 

 

foreach ( $intercept as $old_uri => $new_url ) { if ( false !== stripos( $_SERVER['REQUEST_URI'], $old_uri ) ) { // Redirect to $new_url here } }

 

 

I've tried many different ways to make it work but nothing does

 

// set redirects here before USU5 takes over 
$intercept = array( 'product-name-p-619.html' => HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'product-name-p-763.html' );

 foreach ( $intercept as $old_uri => $new_url ) {    
 	if ( false !== stripos( $_SERVER['REQUEST_URI'], $old_uri ) ) {     
 // Redirect to $new_url here    
 }  }

 

then I figured maybe since we wanted this to happen before USU5 that reverting to this would help... but it didn't:

 

// set redirects here before USU5 takes over 
$intercept = array( product_info.php?products_id=619' => HTTP_SERVER . DIR_WS_HTTP_CATALOG . product_info.php?products_id=763' );

 foreach ( $intercept as $old_uri => $new_url ) {    
 	if ( false !== stripos( $_SERVER['REQUEST_URI'], $old_uri ) ) {     
 // Redirect to $new_url here    
 }  }

 

I've tried many variations on the code above but I'm guessing there is something I dont' understand about it because I can't make it work

 

 

I tried varied ways to change the .htaccess file none of them worked. After a lot more seaching, I saw a post mentioning to be careful if the Rewrite Engine was already on... which led me to trying it this way... still didn't work:

 

what I posted over the weekend:

the redirect htaccess code have been trying last was posted by MrPhil and looked something like this and placed right under RewriteBase /shop/ in the .htaccess file:

 

 

RewriteCond  %{HTTP_HOST}  ^product_info.php?products_id=622  [NC]
RewriteRule  ^(.*)$  product_info.php?products_id=619  [R=301,L]

 

 

I also found this code posted by Robert on another SEO url support thread for person who like me needed to be able to redirect one product page to another product page... again it didn't work:

http://forums.oscommerce.com/topic/154166-contribution-ultimate-seo-urls-v21-by-chemo/page__view__findpost__p__1396656

 

I did consider that I might be so bad I this that I was messing up somewhere so I tried everything I could think of. Tried different variation to make sure I wasn't overlooking something. It's as if USU5 prevents any of those redirects to work.

 

I remember being told earlier on that the redirect has to happen before USU5 took over. That if a product had been deleted, because of the cache system, the product just didnt' exists anymore in the database and couldn't be redirected. So I tried with products that were there... still not working

Share this post


Link to post
Share on other sites

I don't know if this will help but I've learned that I often have to reset the cache when I do modifications and I want them to take effect. My apologies for the waste in time if it's not the case.

 

Thanks for your input, I tried that and unfortunately it did not work. I have changed my option back to standard, so that the site works, until I can get some help from the powers. ;)

Share this post


Link to post
Share on other sites

Thanks for your input, I tried that and unfortunately it did not work. I have changed my option back to standard, so that the site works, until I can get some help from the powers. ;)

 

I noticed that when you posted your .htaccess file the text of the first few lines was different. Mine looks like this:

 

Options +FollowSymLinks
RewriteEngine On 
RewriteBase /shop/

RewriteRule ^(.*)-p-([0-9]+).html$ product_info.php?products_id=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-c-([0-9_]+).html$ index.php?cPath=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} 
# Articles contribution 
RewriteRule ^(.*)-t-([0-9_]+).html$ articles.php?tPath=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING} 
# Information pages 
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING} 
# Links contribution 
RewriteRule ^(.*)-links-([0-9_]+).html$ links.php?lPath=$2&%{QUERY_STRING} 
# Newsdesk contribution 
RewriteRule ^(.*)-n-([0-9]+).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-nc-([0-9]+).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-nri-([0-9]+).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING} 
RewriteRule ^(.*)-nra-([0-9]+).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING} 


 

did you copy the info from the instructions or did you had to have it a bit different because you had something else that required Rewrite Engine On in your file already? And my apologies if this is a dumb question but I have been distracted enough in the past to make the mistake so figured it wouldn't hurt to ask... the directory in which your store is, is it called "catalog" or something else? or is your store right in the root?

Edited by mariemeh

Share this post


Link to post
Share on other sites

Apologies if this has been covered, couldn't located it, in case it's been please direct me to the link.

 

I've just done the cron job as directed, when running on Google, I get the following message on Sitemap when following links to sitemap .xml files:

 

The XML page cannot be displayed

Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

 

 

--------------------------------------------------------------------------------

 

The stylesheet does not contain a document element. The stylesheet may be empty, or it may not be a well-formed XML documen...

 

 

Please advise

 

Regards

 

Felix

Share this post


Link to post
Share on other sites

Apologies if this has been covered, couldn't located it, in case it's been please direct me to the link.

 

I've just done the cron job as directed, when running on Google, I get the following message on Sitemap when following links to sitemap .xml files:

 

The XML page cannot be displayed

Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

 

 

--------------------------------------------------------------------------------

 

The stylesheet does not contain a document element. The stylesheet may be empty, or it may not be a well-formed XML documen...

 

 

Please advise

 

Regards

 

Felix

 

Google does not require the XML to be human readable therefore it has no style.

Share this post


Link to post
Share on other sites

Hello Robert,

 

Thank you very much for releasing the code for this contribution - your instructions were very clear and it works just fine.

I have tried to find the answer to this by searching the posts so far, but at 89 pages and a 'broad' topic, I've had no success.

 

Can you tell me how we can get a title of a product that includes punctuation (an apostrophe in this case instead of the "39"):

/amy-winehouse-you39re-the-voice-p-9172.html?

 

to show as /amy-winehouse-you're-the-voice-p-9172.html?

 

would this be a case for a character conversion file ?

 

thanks for your time

simon

 

There should be no punctuation in uris, just valid word separators like - ( hyphen ).

Share this post


Link to post
Share on other sites

changed that in htaccess changed the admin option to rewrite and i get

 

How do you browse to this shop?

 

www.mysite.com

 

or

 

www.mysite.com/catalog/

Share this post


Link to post
Share on other sites

Google does not require the XML to be human readable therefore it has no style.

 

 

 

Does this mean I should ignore this?

 

Just making sure

 

Thanks again

 

Felix

Share this post


Link to post
Share on other sites

Does this mean I should ignore this?

 

Just making sure

 

Thanks again

 

Felix

 

Yes

Share this post


Link to post
Share on other sites

www.mysite.com/catalog/

 

Ok

 

This simply means that RewriteRules are not working on your server.

 

Is mod_rewrite loaded as a module in Apache?

 

If it is .. then the AllowOverride settings in httpd.conf are not set up to allow RewiteRules.

Share this post


Link to post
Share on other sites

The only reason for a uri to have ?language=en appended would be a user clicking a language selection button and the standard method for doing this in osCommerce is via GET so it MUST append ?language=en.

 

The only way to be rid of it would be to change the language selection to POST, something I have done in the PRO version of USU5.

 

 

Hello Robert,

 

Thanks where can we find the pro version usu5 ?

 

Thx,

 

Hans

 

 

Is there someone who can help us with this ?

 

www.test.com/product.html has to be: www.test.com/en/product.html the language has to be in tghe url.

 

I have read the whole post on this forum but did not find any solution. Robert was talking about PRO version of USU5

 

Thanks for the help.

 

rgds,

 

Hans

Share this post


Link to post
Share on other sites

Ok

 

This simply means that RewriteRules are not working on your server.

 

Is mod_rewrite loaded as a module in Apache?

 

If it is .. then the AllowOverride settings in httpd.conf are not set up to allow RewiteRules.

mod_rewrite is loaded

 

My hosting company is saying that I have to create a php.ini file in the appropriate directory to correct the allow override settings. Any ideas?

Edited by dcrider1

Share this post


Link to post
Share on other sites

mod_rewrite is loaded

 

My hosting company is saying that I have to create a php.ini file in the appropriate directory to correct the allow override settings. Any ideas?

 

That's just rubbish! Perhaps you should educate them that AllowOverride settings are in httpd.conf NOT php.ini.

Share this post


Link to post
Share on other sites

Is there someone who can help us with this ?

 

www.test.com/product.html has to be: www.test.com/en/product.html the language has to be in tghe url.

 

I have read the whole post on this forum but did not find any solution. Robert was talking about PRO version of USU5

 

Thanks for the help.

 

rgds,

 

Hans

 

You can't do it with standard USU5 only the PRO version has multi language seo ability.

Share this post


Link to post
Share on other sites

That's just rubbish! Perhaps you should educate them that AllowOverride settings are in httpd.conf NOT php.ini.

 

I did and they verified it, but because its a shared server they will not change it. So i have to do it with php.ini , are you familiar?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×