Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

This is working very good FWR :thumbsup: , but i have cuestion about google webmaster tools i have about 20 dublicates there

 

Tvillingvagn - Duo Driver - Blå Svart

/tvillingvagn-driver-svart-p-243.html

/tvillingvagn-duo-driver-bla-svart-p-243.html

 

This is the correct adress : /tvillingvagn-duo-driver-bla-svart-p-243.html

And the seo urls is redirect it correct but after some weeks the dublicates are still there.

How can i get away the dublicates must do something els to ?

 

/Best Regards Marcus

Share this post


Link to post
Share on other sites

I've tried both standard and traditional and get 404s on the fresh install. But I have not verified if mod_rewrite is enabled and

AllowOveride set to All. How do I do this?

 

If you have added the code to catalog/.htaccess and you are sure that you have RewriteBase correct then all you can do is speak to your hosts. They sound ridiculously restrictive.

 

Perhaps it is a case of pay peanuts .. get monkeys?

Share this post


Link to post
Share on other sites

This is working very good FWR :thumbsup: , but i have cuestion about google webmaster tools i have about 20 dublicates there

 

Tvillingvagn - Duo Driver - Blå Svart

/tvillingvagn-driver-svart-p-243.html

/tvillingvagn-duo-driver-bla-svart-p-243.html

 

This is the correct adress : /tvillingvagn-duo-driver-bla-svart-p-243.html

And the seo urls is redirect it correct but after some weeks the dublicates are still there.

How can i get away the dublicates must do something els to ?

 

/Best Regards Marcus

 

I don't understand the first one (Tvillingvagn - Duo Driver - Blå Svart) as it is not an seo url .. the second though I would have expected to go within 3 weeks due to the 301 redirect.

 

Is it possible that you are still supplying those old urls to google via an old sitemap or something?

 

Another option is to install KissMT (see my sig) which will provide meta tags but also canonical tags.

Share this post


Link to post
Share on other sites

I don't understand the first one (Tvillingvagn - Duo Driver - Blå Svart) as it is not an seo url .. the second though I would have expected to go within 3 weeks due to the 301 redirect.

 

Is it possible that you are still supplying those old urls to google via an old sitemap or something?

 

Another option is to install KissMT (see my sig) which will provide meta tags but also canonical tags.

 

Hi

 

This i Titel -> Tvillingvagn - Duo Driver - Blå Svart

old url -> www.homepage.com/tvillingvagn-driver-svart-p-243.html

new url -> www.homepage.com/tvillingvagn-duo-driver-bla-svart-p-243.html

 

I have submited a new sitemap , i have canonical tags tags now to.

 

About this KissMT -> I have write meta tags by my self now , what will happend if i installs KissMT will the old ones disapear then ?

Share this post


Link to post
Share on other sites

Hi

 

This i Titel -> Tvillingvagn - Duo Driver - Blå Svart

old url -> www.homepage.com/tvillingvagn-driver-svart-p-243.html

new url -> www.homepage.com/tvillingvagn-duo-driver-bla-svart-p-243.html

 

I have submited a new sitemap , i have canonical tags tags now to.

 

About this KissMT -> I have write meta tags by my self now , what will happend if i installs KissMT will the old ones disapear then ?

 

Well if you are writing your own meta tags then you don't really need any contribution, just a few fields added to the database and a few file changes to admin and you're done. Most people though do not want to laboriously write tags for every single osCommerce page.

 

KissMT dynamically creates meaningful meta info which of course is great for people who don't want to do it manually. It also is extremely efficient, the file based cache system requiring zero queries after the cache is loaded and the database cache method just one.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Well if you are writing your own meta tags then you don't really need any contribution, just a few fields added to the database and a few file changes to admin and you're done.

 

KissMT dynamically creates meaningful meta info which of course is great for people who don't want to do it manually. It also is extremely efficient, the file based cache system requiring zero queries after the cache is loaded and the database cache method just one.

 

 

Okey , thanks for the information what you think about the urls , that the old one is showing in google webmaster tools.

This is the homepage : www .swekidz.se

Can you look if you see something wrong on the homepage

 

Thanks FWR

Share this post


Link to post
Share on other sites

Okey , thanks for the information what you think about the urls , that the old one is showing in google webmaster tools.

This is the homepage : www .swekidz.se

Can you look if you see something wrong on the homepage

 

Thanks FWR

 

No looks generally ok. you are using xhtml tags on an html page. The products pages have huge gaps in the source code. The keywords look quite limited but if they are well targeted then that's fine.

 

The titles also seem quite short.

Share this post


Link to post
Share on other sites

No looks generally ok. you are using xhtml tags on an html page. The products pages have huge gaps in the source code. The keywords look quite limited but if they are well targeted then that's fine.

 

The titles also seem quite short.

 

Ok , thanks what means with xhtml ? is that about the canonical tag ?

 

/Best Regards Marcus

Share this post


Link to post
Share on other sites

Hey, thanks for the awesome contribution guys. I have a minor bug to report. I have a product in my inventory that is named "New York Girl Catalog". The problem is that when I'm using this plugin and click on it I get the notfound_404.php page. I reset the cache and renamed the item to "New York Girl Cat." and the problem went away. So I'm certain the problem is that the word catalog was included in the url and it bugged out. I'm going to rename it back to its original name and just try not to reset the cache as a workaround for now. Thanks again guys!

Share this post


Link to post
Share on other sites

Hey, thanks for the awesome contribution guys. I have a minor bug to report. I have a product in my inventory that is named "New York Girl Catalog". The problem is that when I'm using this plugin and click on it I get the notfound_404.php page. I reset the cache and renamed the item to "New York Girl Cat." and the problem went away. So I'm certain the problem is that the word catalog was included in the url and it bugged out. I'm going to rename it back to its original name and just try not to reset the cache as a workaround for now. Thanks again guys!

 

I'll have a look at this.

Share this post


Link to post
Share on other sites

Ok , thanks what means with xhtml ? is that about the xhtml canonical tag ?

 

/Best Regards Marcus

 

You see xhtml on the page is that the close of xhtml canonical tag ?

 

/Regards Marcus

Share this post


Link to post
Share on other sites

Great addons!

 

but I need help.

 

I rename(Rename, Change Description, Meta and Etc) One category.

When I choose This category i moved to index.php/db_error.html "ERROR Page not found"

and i get to

Warning: file_put_contents(/home/zadarom/public_html//home/zadarom/public_html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/zadarom/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

When i change caching system to database I get index.php/db_error.html "ERROR Page not found" without Warning:....

 

Name of my categories and products in Russian.

Rewrite Type is standart.

All other categories and products work well.

 

Could I correct this ?

Share this post


Link to post
Share on other sites

Great addons!

 

but I need help.

 

I rename(Rename, Change Description, Meta and Etc) One category.

When I choose This category i moved to index.php/db_error.html "ERROR Page not found"

and i get to

Warning: file_put_contents(/home/zadarom/public_html//home/zadarom/public_html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/zadarom/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

When i change caching system to database I get index.php/db_error.html "ERROR Page not found" without Warning:....

 

Name of my categories and products in Russian.

Rewrite Type is standart.

All other categories and products work well.

 

Could I correct this ?

 

Well the first odd thing is that the cache path is incorrect ..

 

/home/zadarom/public_html//home/zadarom/public_html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache

 

This can't happen with usu5 as the script tests if the path is readable and if not triggers an error ..

 

Usu5 cannot find the full filepath, please ensure that DIR_FS_CATALOG in configure.php contains a FULL path

 

Have you modified the code?

 

Re: the second part did you reset the cache after changing the category? ( resetting the Filesystem cache does not reset the Database cache ).

Share this post


Link to post
Share on other sites

certainly ('DIR_FS_CATALOG', '/home/zadarom/public_html/')

 

I Reseted cash in all modes.

 

In mode=database cash is available(i watched by PHPmyadmin) but I get previous error with the category, and all work well with all other categories.

And when mode=database I see page db_error.html without message "Warning:..."

 

When mode=file cash directory is empty while script working.

And in Warning: file_put_contents(... You see double path: /home/zadarom/public_html//home

and double //

This is not right! I have trouble with path. But it is not principal error, by my opinion.

Share this post


Link to post
Share on other sites

certainly ('DIR_FS_CATALOG', '/home/zadarom/public_html/')

 

I Reseted cash in all modes.

 

In mode=database cash is available(i watched by PHPmyadmin) but I get previous error with the category, and all work well with all other categories.

And when mode=database I see page db_error.html without message "Warning:..."

 

When mode=file cash directory is empty while script working.

And in Warning: file_put_contents(... You see double path: /home/zadarom/public_html//home

and double //

This is not right! I have trouble with path. But it is not principal error, by my opinion.

 

I'd need to see the site Dima.

Share this post


Link to post
Share on other sites

Does this work with All Products SEO? I am getting the following errors when I click "view all products"

 

Warning: USU5 could not find a valid base filename, please inform the developer. in /home/trplscom/public_html/tougetuning/testsite/includes/application_top.php on line 69

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/trplscom/public_html/tougetuning/testsite/includes/application_top.php:69) in /home/trplscom/public_html/tougetuning/testsite/includes/functions/sessions.php on line 102

Warning: USU5 could not find a valid base filename, please inform the developer. in /home/trplscom/public_html/tougetuning/testsite/includes/application_top.php on line 69

Edited by Stealth1

Share this post


Link to post
Share on other sites

Does this work with All Products SEO? I am getting the following errors when I click "view all products"

 

Warning: USU5 could not find a valid base filename, please inform the developer. in /home/trplscom/public_html/tougetuning/testsite/includes/application_top.php on line 69

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/trplscom/public_html/tougetuning/testsite/includes/application_top.php:69) in /home/trplscom/public_html/tougetuning/testsite/includes/functions/sessions.php on line 102

Warning: USU5 could not find a valid base filename, please inform the developer. in /home/trplscom/public_html/tougetuning/testsite/includes/application_top.php on line 69

 

sure in this thread somewhere is a fix for all products. Basically the file is misnamed all-products.php osCommerce filenames use filename.php and file_name.php but never hyphen so the script is filtering it.

Share this post


Link to post
Share on other sites

I have not notice early this warning on all pages:

 

Warning: file_put_contents(/home/zadarom/public_html//home/zadarom/public_html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/zadarom/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

I see script paste together some vars with path /home/zadarom/public_html/ and others ...

Share this post


Link to post
Share on other sites

I've searched through the thread so far and have not been able to find anything relating to whether this contrition is compatible with STS Templating 4.5.8.

 

I have a Windows server, PHP 5 installed and when I enable the seo urls the sts templating for the product pages and the category pages are broken, it displays the normal OSC category pages instead of the custom STS templates.

 

Any suggestions?

 

(sorry if I missed a posting with related info on this topic!!)

 

Thanks

Share this post


Link to post
Share on other sites

I've searched through the thread so far and have not been able to find anything relating to whether this contrition is compatible with STS Templating 4.5.8.

 

I have a Windows server, PHP 5 installed and when I enable the seo urls the sts templating for the product pages and the category pages are broken, it displays the normal OSC category pages instead of the custom STS templates.

 

Any suggestions?

 

(sorry if I missed a posting with related info on this topic!!)

 

Thanks

 

STS works fine with USU5 as all it does is create links .. what I am uncertain of is whether we have any instances of people using "standard" mode seo urls with STS.

 

Almost certainly the problem will be that standard mode seo urls are path based e.g.

 

/index.php/something_here

 

Any contribution that attempts to extract a filename from such a link using basename( $_SERVER['PHP_SELF'] ) or basename( $HTTP_SERVER_VARS['PHP_SELF'] ) will fail as PHP_SELF does not return a filename for such a link.

 

your options are ..

 

1) See if you can find such instances in the contribution and change them.

 

2) Install ( unless the server already has it ) a Windows rewrite moduule like ISAPI rewrite or "the other one which I forget" there is a post in this thread somewhere and it was free.

Share this post


Link to post
Share on other sites

http://zadarom.kiev.ua

site in Russian

Help for You: Left Upper category

 

This category seems to have an additional 302 Moved Temporarily redirect to db_error.html.

 

There is no code in USU5 that does such a thing.

Share this post


Link to post
Share on other sites

I have not notice early this warning on all pages:

 

Warning: file_put_contents(/home/zadarom/public_html//home/zadarom/public_html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/zadarom/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

I see script paste together some vars with path /home/zadarom/public_html/ and others ...

 

Dima please create a new PHP file in the root of your site ( dimatest.php or something ) add the following code: -

 

<?php
 include_once 'includes/configure.php';

 function getRealPath() {
   $realpath = '';
   if( function_exists( 'realpath' ) ) {
     $realpath = str_replace( DIRECTORY_SEPARATOR, '/', realpath( '.' ) ) . '/';
     if( file_exists( $realpath . 'product_info.php' ) && !empty( $realpath ) ) {
       return $realpath;
     }
   }
   if( function_exists( 'getcwd' ) ) {
     $realpath = str_replace( DIRECTORY_SEPARATOR, '/', getcwd() ) . '/';
     if( file_exists( $realpath . 'product_info.php' ) && !empty( $realpath ) ) {
       return $realpath;
     }
   }
   if ( file_exists( DIR_FS_CATALOG . 'product_info.php' ) ) {
     return DIR_FS_CATALOG;
   }
   return 'Not Found';
 }

 $paths_array = array( 'getRealPath' => getRealPath(), 'realpath' => realpath( '.' ), 'getcwd' => getcwd(), 'osC' => DIR_FS_CATALOG );

 $it = new ArrayIterator( $paths_array );

 while ( $it->valid() ) {
   echo $it->key() . ': ' . $it->current() . '<br />' . PHP_EOL;
   $it->next();
 }    
?>

 

Browse to the file and PM me what it outputs please. Also DELETE the file after use as it is a security risk.

Share this post


Link to post
Share on other sites

Have you tried the rewrite method? that is the traditional seo url, I doubt if GoDaddy also don't provide RewriteRule functionality.

 

Hi Robert

 

Just to close this out, I opened a new hosting account and "standard" works perfectly on a fresh 2.2rc2a. I have yet to upload my normal site (heavily customised) + db to the new host. However to get "rewrite" working on the fresh one I had to delete "Options +FollowSymLinks" from .htaccess, as previously it gave internal server error. I have no idea how or why it works now as a result of this, but it does.

 

So I thought let's try deleting Options +FollowSymLinks from the GoDaddy hosted site, and sure enough.....it still didn't work. But a different error message this time - Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

 

Sorry about the above which is probably completely pointless information but someone might find it useful!

 

Now, on to KissMT!

 

cheers!

Share this post


Link to post
Share on other sites

Hi Robert

 

Just to close this out, I opened a new hosting account and "standard" works perfectly on a fresh 2.2rc2a. I have yet to upload my normal site (heavily customised) + db to the new host. However to get "rewrite" working on the fresh one I had to delete "Options +FollowSymLinks" from .htaccess, as previously it gave internal server error. I have no idea how or why it works now as a result of this, but it does.

 

So I thought let's try deleting Options +FollowSymLinks from the GoDaddy hosted site, and sure enough.....it still didn't work. But a different error message this time - Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

 

Sorry about the above which is probably completely pointless information but someone might find it useful!

 

Now, on to KissMT!

 

cheers!

 

Thanks for feeding back Graham .. all feedback is helpful.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×