Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

A blank site tells me nothing except that you obviously made an error in the install somewhere.

 

To attempt to see errors try turning Gzip off in admin and temporarily do the following in catalog/includes/application_top.php

 

Find ..

 

  error_reporting(E_ALL & ~E_NOTICE);

 

Change (TEMPORARILY) to ..

 

  //error_reporting(E_ALL & ~E_NOTICE);
 // REMOVE ME
 error_reporting( E_ALL | E_STRICT );
 // REMOVE ME

 

Your site should then output errors.

 

 

Hi thx for help,

 

but I take an older vision, it works yet.

Share this post


Link to post
Share on other sites

no i have such an error

Warning: session_start() [function.session-start]: open(C:\xampp\tmp/sess_63856960d496d8c4ec7382637c502a7f, O_RDWR) failed: No such file or directory (2) in /installer.php on line 27

 

some of the files were modified on my local installation. I use for it Appache firends Xamp.

 

can you help me with that

 

PHP has an incorrect sessions save path. Try setting session.save_path in php.ini to a location that actually exists.

Share this post


Link to post
Share on other sites

Hi thx for help,

 

but I take an older vision, it works yet.

 

You do that :rolleyes: you'll still have to install it properly though.

Share this post


Link to post
Share on other sites

no i have such an error

Warning: session_start() [function.session-start]: open(C:\xampp\tmp/sess_63856960d496d8c4ec7382637c502a7f, O_RDWR) failed: No such file or directory (2) in /installer.php on line 27

 

some of the files were modified on my local installation. I use for it Appache firends Xamp.

 

can you help me with that

 

Ok i found it. this was a problem with my php.ini file.

 

I've made conversion table but it doesn.t work.

Link to product is product_info.php/mariquita-honey-funny-bluzeczka-bawe£niana-rÓ¯yczka-p-211

and should be product_info.php/mariquita-honey-funny-bluzeczka-bawełniana-różyczka-p-211

Share this post


Link to post
Share on other sites

Ok i found it. this was a problem with my php.ini file.

 

I've made conversion table but it doesn.t work.

Link to product is product_info.php/mariquita-honey-funny-bluzeczka-bawe£niana-rÓ¯yczka-p-211

and should be product_info.php/mariquita-honey-funny-bluzeczka-bawełniana-różyczka-p-211

 

OK one of three things are wrong: -

 

1) The character conversion file was saved as the wrong charset ( or not matching the charset of the site)

 

2) the character conversion filename doesn't match your osCommerce language name e.g.

 

Is the language filename catalog/includes/languages/<mylanguage>.php the same name as the character conversion file?

 

3) The character conversion files are fine you just haven't reset the cache so you are seeing old links.

Edited by FWR Media

Share this post


Link to post
Share on other sites

After i use SEO URL i can not add product to cart

 

Probably yet another bad set up of your PHP installation.

 

arg_separator.input and arg_separator.output should be & not &

 

xamp sets up php badly.

Share this post


Link to post
Share on other sites

Probably yet another bad set up of your PHP installation.

 

arg_separator.input and arg_separator.output should be & not &

 

xamp sets up php badly.

 

instalation was on hosting server. i just tests new contributions on xamp.

This happens on php installed on hosting

Share this post


Link to post
Share on other sites

instalation was on hosting server. i just tests new contributions on xamp.

This happens on php installed on hosting

 

In which case I'd need to see the site as this contribution does not have such an issue.

Share this post


Link to post
Share on other sites

In which case I'd need to see the site as this contribution does not have such an issue.

 

just link to site?

www.dzieciecydwor.pl

i needed to disable it. Do you want me to enable the seo URL?

Share this post


Link to post
Share on other sites

just link to site?

www.dzieciecydwor.pl

i needed to disable it. Do you want me to enable the seo URL?

 

Anyone please advise

Share this post


Link to post
Share on other sites

Anyone please advise

 

I'm about now if you want to enable it.

Share this post


Link to post
Share on other sites

After i use SEO URL i can not add product to cart

 

Exactly the same as your test server . .

 

[http://www.]dzieciecydwor.pl/akcesoria-c-23.html?products_id=162&action=buy_now&sort=2a

 

Check your server for exactly what you checked on your dev server.

 

arg_separator.input should be &

 

arg_separator.output should be &

 

Looks to me AGAIN like they are set as &

Edited by FWR Media

Share this post


Link to post
Share on other sites

Exactly the same as your test server . .

 

[http://www.]dzieciecydwor.pl/akcesoria-c-23.html?products_id=162&action=buy_now&sort=2a

 

Check your server for exactly what you checked on your dev server.

 

arg_separator.input should be &

 

arg_separator.output should be &

 

Looks to me AGAIN like they are set as &

 

I new at this and i dont realy know what you are talking about. sorry.

What i did so far. problem with adding to cart was solved. MySQL db collation was utf8 shop was in iso 8859-2 i changed connection collation. ive converted all files to uft without bom and everything is ok now. i can add to cart. But still polish character is missing in URL.

So if you will be so nice and tell me as simple as you can what i should do, please.

Share this post


Link to post
Share on other sites

I new at this and i dont realy know what you are talking about. sorry.

What i did so far. problem with adding to cart was solved. MySQL db collation was utf8 shop was in iso 8859-2 i changed connection collation. ive converted all files to uft without bom and everything is ok now. i can add to cart. But still polish character is missing in URL.

So if you will be so nice and tell me as simple as you can what i should do, please.

 

Language special characters should never be in the uri. All characters must be latin to achieve this you need to build a special character conversion file ( see instructions ).

Edited by FWR Media

Share this post


Link to post
Share on other sites

Language special characters should never be in the uri. All characters must be latin to achieve this you need to build a special character conversion file ( see instructions ).

 

so url http://www.dzieciecydwor.pl/mariquita-honey-funny-bluzeczka-baweÅniana-biel-p-210.html

i try to change to bawelniana

Å=>l

 

 

<?php

/**

*

* ULTIMATE Seo Urls 5

*

*

* @package Ultimate Seo Urls 5

* @license http://www.opensource.org/licenses/gpl-2.0.php GNU Public License

* @link http://www.fwrmedia.co.uk

* @copyright Copyright 2008-2009 FWR Media

* @copyright Portions Copyright 2005 Bobby Easland

* @author Robert Fisher, FWR Media, http://www.fwrmedia.co.uk

* @lastdev $Author:: Rob $: Author of last commit

* @lastmod $Date:: 2009-06-29 16:49:50 +0100 (Mon, 29 Jun 20#$: Date of last commit

* @version $Rev:: 88 $: Revision of last commit

* @Id $Id:: czech.php 88 2009-06-29 15:49:50Z Rob $: Full Details

*/

 

 

$char_convert = array('ê'=>'ę','Ã'=>'ó','Å'=>'l','Å»'=>'ż','¦'=>'ś','¡'=>'ą');

?>

 

it didn't helped i have reset the cache too

Share this post


Link to post
Share on other sites

so url http://www.dzieciecydwor.pl/mariquita-honey-funny-bluzeczka-baweÅniana-biel-p-210.html

i try to change to bawelniana

Å=>l

 

 

<?php

/**

*

* ULTIMATE Seo Urls 5

*

*

* @package Ultimate Seo Urls 5

* @license http://www.opensource.org/licenses/gpl-2.0.php GNU Public License

* @link http://www.fwrmedia.co.uk

* @copyright Copyright 2008-2009 FWR Media

* @copyright Portions Copyright 2005 Bobby Easland

* @author Robert Fisher, FWR Media, http://www.fwrmedia.co.uk

* @lastdev $Author:: Rob $: Author of last commit

* @lastmod $Date:: 2009-06-29 16:49:50 +0100 (Mon, 29 Jun 20#$: Date of last commit

* @version $Rev:: 88 $: Revision of last commit

* @Id $Id:: czech.php 88 2009-06-29 15:49:50Z Rob $: Full Details

*/

 

 

$char_convert = array('ê'=>'ę','Ã'=>'ó','Å'=>'l','Å»'=>'ż','¦'=>'ś','¡'=>'ą');

?>

 

it didn't helped i have reset the cache too

 

Don't copy the rubbish characters from the url, write them yourself like ..

 

<my language special character> => <latin character>

 

look at the other conversion files in the extras directory.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Correct me if I am wrong. ULTIMATE Seo Urls 5 is not memcached enabled yet.

 

What makes you say that .. of course it is.

 

http://forums.oscommerce.com/topic/336702-ultimate-seo-urls-5-by-fwr-media/page__view__findpost__p__1476174

Edited by FWR Media

Share this post


Link to post
Share on other sites

Seo URL5 integrates nicely with URL Validation :rolleyes:

 

What do you mean? USU5 has URL validation built in.

Share this post


Link to post
Share on other sites

Yes it should. BUT .. as we established .. your host does not accept path based uris.

 

I didn't trust my own installation of your wonderful contribution on my heavily customised store, so I installed a fresh OSC 2.2rc2a in a subdomain with a new db as I couldn't believe that godaddy as large an organisation as they are would not accept path based urls. And it confirmed that you were right Robert, or at least it still doesn't work, due presumably to the host as you say.

 

So two quick questions,

- Is there a php setting or other setting I can ask them to set so that my server does accept path based urls?

- If not, are there any UK based hosting companies that DO accept path based urls so I can make your contribs work?

Share this post


Link to post
Share on other sites

What makes you say that .. of course it is.

 

Okay, great.

 

I found it now in "Configuration - Seo Urls 5" I knew I had seen or read about Memcached but I couldn't remember where.

Edited by Dennisra

Share this post


Link to post
Share on other sites

I didn't trust my own installation of your wonderful contribution on my heavily customised store, so I installed a fresh OSC 2.2rc2a in a subdomain with a new db as I couldn't believe that godaddy as large an organisation as they are would not accept path based urls. And it confirmed that you were right Robert, or at least it still doesn't work, due presumably to the host as you say.

 

So two quick questions,

- Is there a php setting or other setting I can ask them to set so that my server does accept path based urls?

- If not, are there any UK based hosting companies that DO accept path based urls so I can make your contribs work?

 

Have you tried the rewrite method? that is the traditional seo url, I doubt if GoDaddy also don't provide RewriteRule functionality.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Have you tried the rewrite method? that is the traditional seo url, I doubt if GoDaddy also don't provide RewriteRule functionality.

 

I've tried both standard and traditional and get 404s on the fresh install. But I have not verified if mod_rewrite is enabled and

AllowOveride set to All. How do I do this?

Edited by Project2016

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×