Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

I changed the product_info name to my mynewnamename .... and the answer is "We found your path to mynewname.php just fine!"

 

? I don't remember the question!

Share this post


Link to post
Share on other sites

Get 404 to work

 

Hi

 

Thx for fast answer , I've been thinking about making a 404 redirect in part to the home page ?

Is that possible ?

 

When i try something the 404 thats in seo urls 5 dont works , do you now if i have done something wrong becouse the 404 dont works ?

 

/Best Regard Marcus

Share this post


Link to post
Share on other sites

Get 404 to work

 

Hi

 

Thx for fast answer , I've been thinking about making a 404 redirect in part to the home page ?

Is that possible ?

 

When i try something the 404 thats in seo urls 5 dont works , do you now if i have done something wrong becouse the 404 dont works ?

 

/Best Regard Marcus

 

Hi Marcus

 

I'm not understanding the problem. I know that the standard 404 works in USU5 what are you trying to get it to do?

Share this post


Link to post
Share on other sites

? I don't remember the question!

 

 

Hello. I get this notice in error log

 

 

PHP Notice: Usu5 cannot find the full filepath, please ensure that DIR_FS_CATALOG in configure.php contains a FULL path in /var/www/sites/*************/html/*************/includes/modules/ultimate_seo_urls5/classes/usu.php on line 97, referer: http://www.*********...*****/index.php

 

 

 

WOW I never thought a hosting service could ever be that wrong that they get past my checks!! which version of USU5 are you on?

 

USU5 checks realpath() - getcwd() - and ONLY if they all fail (which they shouldn't) it falls back on your own settings in includes/configure.php for DIR_FS_CATALOG

Share this post


Link to post
Share on other sites

Hello. I get this notice in error log

 

 

PHP Notice: Usu5 cannot find the full filepath, please ensure that DIR_FS_CATALOG in configure.php contains a FULL path in /var/www/sites/*************/html/*************/includes/modules/ultimate_seo_urls5/classes/usu.php on line 97, referer: http://www.*********...*****/index.php

 

 

 

WOW I never thought a hosting service could ever be that wrong that they get past my checks!! which version of USU5 are you on?

 

USU5 checks realpath() - getcwd() - and ONLY if they all fail (which they shouldn't) it falls back on your own settings in includes/configure.php for DIR_FS_CATALOG

 

Probably an incorrectly named file with a hyphen like all-products.php etc.

Share this post


Link to post
Share on other sites

I want the 404 page that included in seo urls 5 thats a link to get back to the homepage

Now its some other 404 page Parallels® H-Sphere

is it good to redirect directly to start of homepage when it get to a 404page ?

Like when 404 comes up it redirect to www.homepage.com/

 

/Best Regards Marcus

Share this post


Link to post
Share on other sites

Hi Robert, it's me again.

 

I have a question about the Google Sitemap SEO in combination with SEO URL 5 by FWR Media.

 

My Url in the shop looks like:

 

www.xx.de/alpha-vogt-filterelement-fuer-av-16-av-88v-av-88top-34114-p-634.html

 

 

BUT in the sitemapproducts.xml like(with "standard" option):

 

www.xx.de/product_info.php?products_id=634

 

Any solution to settle this problem? I try to set the "alternate" option but then I get an error.

 

Thanks.

 

Thomas

Share this post


Link to post
Share on other sites

Hi Robert, it's me again.

 

I have a question about the Google Sitemap SEO in combination with SEO URL 5 by FWR Media.

 

My Url in the shop looks like:

 

www.xx.de/alpha-vogt-filterelement-fuer-av-16-av-88v-av-88top-34114-p-634.html

 

 

BUT in the sitemapproducts.xml like(with "standard" option):

 

www.xx.de/product_info.php?products_id=634

 

Any solution to settle this problem? I try to set the "alternate" option but then I get an error.

 

Thanks.

 

Thomas

 

Google Sitemap SEO doesn't work because it is hardcoded to use only the old series 2 seo urls (this is already covered in this support thread) There are two replacement files in the extras folder which correct the contribution to use the correct tep_href_link() function.

 

Any solution to settle this problem? I try to set the "alternate" option but then I get an error.

 

Which "alternate" option produces errors?

Share this post


Link to post
Share on other sites

I want the 404 page that included in seo urls 5 thats a link to get back to the homepage

Now its some other 404 page Parallels® H-Sphere

is it good to redirect directly to start of homepage when it get to a 404page ?

Like when 404 comes up it redirect to www.homepage.com/

 

/Best Regards Marcus

 

A 404 page should be a static page with 404 headers and not a redirection to index.php.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi again :)

 

Thanks for fast responding

 

I have a question about this url , if i have a product url thats this : fastcar-p-17.html and i change the url show it is like this : fast-car-p-17.html

Is the script redirect to the new url sow the old one is gona disappear

 

/Best Regards Marcus

Share this post


Link to post
Share on other sites

Hi again :)

 

Thanks for fast responding

 

I have a question about this url , if i have a product url thats this : fastcar-p-17.html and i change the url show it is like this : fast-car-p-17.html

Is the script redirect to the new url sow the old one is gona disappear

 

/Best Regards Marcus

 

USU5 will correctly 301 redirect the old link to the new preserving the indexing.

 

Why don't you try it.

 

Take a note of an existing seo url.

 

Change the category or product title in admin. Reset the seo cache so that the new link is produced then try to access it as the old url.

Share this post


Link to post
Share on other sites

Hi

 

You are the GOD , good work this fix all my problems. What do you think im indexed by google on 1500 pages of my page

The problem is that it dident be the same urls with the new seo urls 5. Is the old link gona dissapear after a wile ?

Or must a do something to remove the old ones.

I have seen some products of my on google and now when a click on them a comes to 404 page.

 

/Best Regards Marcus

Edited by swekidz

Share this post


Link to post
Share on other sites

Google Sitemap SEO doesn't work because it is hardcoded to use only the old series 2 seo urls (this is already covered in this support thread) There are two replacement files in the extras folder which correct the contribution to use the correct tep_href_link() function.

 

 

 

Which "alternate" option produces errors?

 

Ok. It's working now. Thanks.

I meant the alternate option in the Configuration -- Google XML Sitemap menu, but now I don't need it anymore because it works with the standard.

 

A small problem is still that now all xml files are filled although in menu option are the options false marked...

 

Write sitemapproducts.xml

Generated Google Product Sitemap Successfully

 

Write sitemapcategories.xml -- set to false on configuration

Generated Google Category Sitemap Successfully

 

Write sitemapmanufacturers.xml -- set to false on configuration

Generated Google Manufacturers Sitemap Successfully

 

Write sitemapspecials.xml -- set to false on configuration

Generated Google Specials Sitemap Successfully

 

Write sitemapindex.xml

Generated Google Sitemap Index Successfully

Share this post


Link to post
Share on other sites

Hi

 

You are the GOD , good work this fix all my problems. What do you think im indexed by google on 1500 pages of my page

The problem is that it dident be the same urls with the new seo urls 5. Is the old link gona dissapear after a wile ?

Or must a do something to remove the old ones.

I have seen some products of my on google and now when a click on them a comes to 404 page.

 

/Best Regards Marcus

 

Are the product ids always the same because if they are I can write a little script that may save at least the products for you.

Share this post


Link to post
Share on other sites

Hi, Robert

 

i have another problem with seourls 5. after a few days the Frontend index.php is blanc (i think the cache crashes)

 

After i reset the Reset SEO URLs Cache, it will work normal for a few ours or days, any idea?--> because i can´t find a mistake.....

 

Domain: www.schwimmbeckenonline.de

 

regards

 

Peter


-run the day or the day runs you-

our new Projekt: www.pooltechnik.org

Share this post


Link to post
Share on other sites

Hi, Robert

 

i have another problem with seourls 5. after a few days the Frontend index.php is blanc (i think the cache crashes)

 

After i reset the Reset SEO URLs Cache, it will work normal for a few ours or days, any idea?--> because i can´t find a mistake.....

 

Domain: www.schwimmbeckenonline.de

 

regards

 

Peter

 

Have you looked in the server error log to see what is reported?

 

How many products do you have? It may be that the cache file is getting too big for the server to handle. Is it shared hosting?

 

what cache method are you using? FileSystem?

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi

 

That looks great if you can do that script , it's the same id

 

Old url : www. homepage.com/tillbehoer/sadelstol-112/

 

New url : www. homepage.com/sadelstol-p-112.html

 

/Best Regards Marcus

Edited by swekidz

Share this post


Link to post
Share on other sites

Hi

 

That looks great if you can do that script , it's the same id

 

Old url : www. homepage.com/tillbehoer/sadelstol-112/

 

New url : www. homepage.com/sadelstol-p-112.html

 

/Best Regards Marcus

 

In the directory where the shop used to be "tillbehoer" create a file named index.php .. put in the file the following code: -

 

<?php
 $domain_url = 'http://www.mysite.com/';
 $testing = true;
 $products_id = false;

 if ( preg_match( '@[a-z0-9-]+-[0-9]+/@i', $_SERVER['REQUEST_URI'], $matches ) ) {
   $possible_products_id = str_replace( array( '-', '/' ), '', strrchr( $matches[0], '-' ) );
   $products_string = str_replace( '-' . $possible_products_id . '/', '', $matches[0] );
   if ( is_numeric( $possible_products_id ) ) {
     $products_id = (int)$possible_products_id;
   }
 }

 if ( false !== $testing ) {
   if ( ( false !== $products_id ) && isset( $products_string ) ) {
     echo '<b>FWR Comment:</b> 301 Redirect would be to ...<br />' . $domain_url . $products_string . '-p-' . $products_id . '.html';
   } else {
     echo 'FWR Comment: 301 Redirect would be to ...<br />' . $domain_url;
   }
 } else {
   if ( ( false !== $products_id ) && isset( $products_string ) ) {
     $link = $domain_url . $products_string . '-p-' . $products_id . '.html';
   } else {
     $link = $domain_url;
   }
   header( "HTTP/1.0 301 Moved Permanently" );
   header( 'Location: ' . $link );
 }
?>

 

Change the following to your real domain (including the final /)

 

$domain_url = 'http://www.mysite.com/';

 

Leave $testing = true; for now and access your site using the old url . . see what's printed out.

 

If all looks good set $testing = false; and try again it should redirect.

 

** WARNING ** This creates a double 301 redirect which is far from ideal but at least the existing links will be re indexed.

 

This will work only for products all other urls will be redirected to http://www.mysite.com/

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi :)

 

Thanks you are really great , i will comeback and tell when i have tested it. I Have oscommerce is the same for all products were in the shop should i

print this code ? in index in root or in the /includes/languages/english/ ?

 

/Best Regards Marcus

 

 

 

 

 

 

 

 

 

In the directory where the shop used to be "tillbehoer" create a file named index.php .. put in the file the following code: -

 

<?php
 $domain_url = 'http://www.mysite.com/';
 $testing = true;
 $products_id = false;

 if ( preg_match( '@[a-z0-9-]+-[0-9]+/@i', $_SERVER['REQUEST_URI'], $matches ) ) {
   $possible_products_id = str_replace( array( '-', '/' ), '', strrchr( $matches[0], '-' ) );
   $products_string = str_replace( '-' . $possible_products_id . '/', '', $matches[0] );
   if ( is_numeric( $possible_products_id ) ) {
     $products_id = (int)$possible_products_id;
   }
 }

 if ( false !== $testing ) {
   if ( ( false !== $products_id ) && isset( $products_string ) ) {
     echo '<b>FWR Comment:</b> 301 Redirect would be to ...<br />' . $domain_url . $products_string . '-p-' . $products_id . '.html';
   } else {
     echo 'FWR Comment: 301 Redirect would be to ...<br />' . $domain_url;
   }
 } else {
   if ( ( false !== $products_id ) && isset( $products_string ) ) {
     $link = $domain_url . $products_string . '-p-' . $products_id . '.html';
   } else {
     $link = $domain_url;
   }
   header( "HTTP/1.0 301 Moved Permanently" );
   header( 'Location: ' . $link );
 }
?>

 

Change the following to your real domain (including the final /)

 

$domain_url = 'http://www.mysite.com/';

 

Leave $testing = true; for now and access your site using the old url . . see what's printed out.

 

If all looks good set $testing = false; and try again it should redirect.

 

** WARNING ** This creates a double 301 redirect which is far from ideal but at least the existing links will be re indexed.

 

This will work only for products all other urls will be redirected to http://www.mysite.com/

Share this post


Link to post
Share on other sites

Hi :)

 

Thanks you are really great , i will comeback and tell when i have tested it. I Have oscommerce is the same for all products were in the shop should i

print this code ? in index in root or in the /includes/languages/english/ ?

 

/Best Regards Marcus

 

I already told you ..

 

In the directory where the shop used to be "tillbehoer" create a file named index.php

 

So www.mysite.com/tillbehoer/index.php

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi

 

I fixed this problem with mod_rewrite

 

/Best Regards Marcus

 

 

 

 

 

 

 

 

 

 

 

 

 

In the directory where the shop used to be "tillbehoer" create a file named index.php .. put in the file the following code: -

 

<?php
 $domain_url = 'http://www.mysite.com/';
 $testing = true;
 $products_id = false;

 if ( preg_match( '@[a-z0-9-]+-[0-9]+/@i', $_SERVER['REQUEST_URI'], $matches ) ) {
   $possible_products_id = str_replace( array( '-', '/' ), '', strrchr( $matches[0], '-' ) );
   $products_string = str_replace( '-' . $possible_products_id . '/', '', $matches[0] );
   if ( is_numeric( $possible_products_id ) ) {
     $products_id = (int)$possible_products_id;
   }
 }

 if ( false !== $testing ) {
   if ( ( false !== $products_id ) && isset( $products_string ) ) {
     echo '<b>FWR Comment:</b> 301 Redirect would be to ...<br />' . $domain_url . $products_string . '-p-' . $products_id . '.html';
   } else {
     echo 'FWR Comment: 301 Redirect would be to ...<br />' . $domain_url;
   }
 } else {
   if ( ( false !== $products_id ) && isset( $products_string ) ) {
     $link = $domain_url . $products_string . '-p-' . $products_id . '.html';
   } else {
     $link = $domain_url;
   }
   header( "HTTP/1.0 301 Moved Permanently" );
   header( 'Location: ' . $link );
 }
?>

 

Change the following to your real domain (including the final /)

 

$domain_url = 'http://www.mysite.com/';

 

Leave $testing = true; for now and access your site using the old url . . see what's printed out.

 

If all looks good set $testing = false; and try again it should redirect.

 

** WARNING ** This creates a double 301 redirect which is far from ideal but at least the existing links will be re indexed.

 

This will work only for products all other urls will be redirected to http://www.mysite.com/

Share this post


Link to post
Share on other sites

Hi Rob,

 

I just tried to generte the Google XML Sitemap, using the tool included (extras/Google XML Sitemap SEO). I had to increas the memory_limit in php.ini as I had a small error (I have more than 50000 products), but it worked OK, all the files have been corectely generated.

The problem is that just after that the shop started to be exremely slow. Everytime I clicked on a link the Server CPU reached 100% for a couple of seconds and the respons was of course extremely slow. Then I noticed the USU cache file had grown to about 1.7M.

After reseting the USU cache everything came to normal. What could be the problem? Is that because I have so many products in the shop, so the cache becomes too big and USU and my server need time to read it? How the cache works actually, the links are added when they are accesed for the first time (or when I run the Google script)? Would I maybe need to run without the cache enabled, knowing that after a certain time the cache file becomes to big and instead of increasing the performance it produces the oposite result?

 

Thanks.

Andybird

Share this post


Link to post
Share on other sites

Hi Rob,

 

I just tried to generte the Google XML Sitemap, using the tool included (extras/Google XML Sitemap SEO). I had to increas the memory_limit in php.ini as I had a small error (I have more than 50000 products), but it worked OK, all the files have been corectely generated.

The problem is that just after that the shop started to be exremely slow. Everytime I clicked on a link the Server CPU reached 100% for a couple of seconds and the respons was of course extremely slow. Then I noticed the USU cache file had grown to about 1.7M.

After reseting the USU cache everything came to normal. What could be the problem? Is that because I have so many products in the shop, so the cache becomes too big and USU and my server need time to read it? How the cache works actually, the links are added when they are accesed for the first time (or when I run the Google script)? Would I maybe need to run without the cache enabled, knowing that after a certain time the cache file becomes to big and instead of increasing the performance it produces the oposite result?

 

Thanks.

Andybird

 

Wow that is huge I'm not surprised you are getting slow downs, yes you may want to run with the cache off. I am doing some work at the moment re: caching for larger shops if you fancy emailing me the tables for ..

 

categories

categories_description

products

products_attributes

products_description

products_to_categories

 

It would be a great help in me organising a better solution for larger shops.

 

Have you tried memcached btw?

Edited by FWR Media

Share this post


Link to post
Share on other sites

Fatal error: Class 'Memcache' not found in xxxx\includes\modules\ultimate_seo_urls5\classes\Usu_Cache_Memcached.php on line 19

Remember I run IIS... I don't know if there's a memcache available for it. I'll have a look around.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×