Jump to content
Latest News: (loading..)
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

I have installed this on v2.2 Rc2, however when I click the buy it now buttons I get his error message: The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

 

If you think this is a server error, please contact the webmaster.

Error 404

Apache/2.2.8 (Mandriva Linux/PREFORK-6.2mdv2008.1)

192.168.1.68.

 

This doesn't happen if I go to the product and click the add to cart.

 

I did change the catalog/includes/modules/product_listing.php as it said at stage 6, but figure I must have made an error somewhere can you please help me fix the problem.

 

6- Find ...
		$lc_text = '<a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $listing['products_id']) . '">' . tep_image_button('button_buy_now.gif', IMAGE_BUTTON_BUY_NOW) . '</a> ';

Replace with ...
		$lc_text = '<a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action', 'products_id')) . 'action=buy_now&products_id=' . $listing['products_id']) . '">' . tep_image_button('button_buy_now.gif', IMAGE_BUTTON_BUY_NOW) . '</a> ';

Edited by a12c4magic

Share this post


Link to post
Share on other sites
I have installed this on v2.2 Rc2, however when I click the buy it now buttons I get his error message:

 

This doesn't happen if I go to the product and click the add to cart.

 

I did change the catalog/includes/modules/product_listing.php as it said at stage 6, but figure I must have made an error somewhere can you please help me fix the problem.

 

Not enough info given to debug this.

 

Post the link you see when you hover over the buy now buttons

Share this post


Link to post
Share on other sites
Ok you posted this once in the dev forum and then here so I'll just put the same answer..

 

Marcel

 

USU5 has two seo options .. one requires .htaccess rewrites .. the other does not (it is in the instructions)

 

When first installed USU5 automatically produces standard seo urls like ..

 

my-great-product-p-37

 

To change settings to the "traditional" seo urls there is a setting in admin the rewrite urls will look the same as the old seo urls e.g.

 

my-great-product-p-37.html

 

Hi,

 

This isn't solving the problem url is wrong it shows product_info.php/my-great-product-p-37

Share this post


Link to post
Share on other sites
Not enough info given to debug this.

 

Post the link you see when you hover over the buy now buttons

 

Hi,

 

thanks for the reply below is the link we see when hovering over the buy it now button for a particular product, only thing that changes between the buy it now buttons is the product id number

 

http://192.168.1.68/catalog/clothing-months-c-27_31?cPath=27_31&sort=2a&action=buy_now&products_id=85

 

This is on our local testing shop as we have not gone live yet.

 

Sue

Share this post


Link to post
Share on other sites
Hi,

 

This isn't solving the problem url is wrong it shows product_info.php/my-great-product-p-37

 

admin>Configuration>Seo Urls 5

 

Find .. Choose URL Rewrite Type

 

set this to rewrite

Share this post


Link to post
Share on other sites

Hmmm I can not seem to find Choose URL Rewrite Type

 

http://s61.photobucket.com/albums/h65/mypins/?action=view&current=configuration.jpg

 

However I do have:Use Search-Engine Safe URLs (still in development) set to false

Edited by a12c4magic

Share this post


Link to post
Share on other sites
Hi,

 

thanks for the reply below is the link we see when hovering over the buy it now button for a particular product, only thing that changes between the buy it now buttons is the product id number

 

http://192.168.1.68/catalog/clothing-months-c-27_31?cPath=27_31&sort=2a&action=buy_now&products_id=85

 

This is on our local testing shop as we have not gone live yet.

 

Sue

 

Well that is very odd the uri should be ..

http://192.168.1.68/catalog/index.php/clothing-months-c-27_31?cPath=27_31&sort=2a&action=buy_now&products_id=85

 

Could you turn on the debugger and post here the seo urls producted please.

Share this post


Link to post
Share on other sites
Hmmm I can not seem to find Choose URL Rewrite Type

 

http://s61.photobucket.com/albums/h65/mypins/?action=view&current=configuration.jpg

 

However I do have:Use Search-Engine Safe URLs (still in development) set to false

 

You haven't run the database installer .. please read the instructions.

Share this post


Link to post
Share on other sites

My apoligies have now run the database installer and have set AllowOveride set to all, however it breaks the whole shop and gives an error, so have disabled it for now and will take another look later on.

Share this post


Link to post
Share on other sites
My apoligies have now run the database installer and have set AllowOveride set to all, however it breaks the whole shop and gives an error, so have disabled it for now and will take another look later on.

 

Well thank you for the valuable debug information (however it breaks the whole shop and gives an error) that level of error reporting will help everyone I'm sure :rolleyes:

 

Given that you haven't followed the instructions I'll assume this is user error until reported otherwise.

 

From what you stated before I would assume that it works fine with standard seo urls but not with rewrite .. this means .. quite simply .. the server settings are incorrect.

 

Occasionally on some server set ups you have to comment out a line in .htaccess

#Options +FollowSymLinks

Edited by FWR Media

Share this post


Link to post
Share on other sites

I'm, sorry I can not even use the excuse I'm blond because I'm not.

 

 

Using rewrite I get an error as soon as I click on any of the categories

 

with rewrite:

seo urls:

http://192.168.1.68/catalog/accessories-c-25.html

 

 

 

Using standard I can click on any of the categories and only get the error when I click on a buy it now button.

 

with standard:

seo urls:

http://192.168.1.68/catalog/accessories-c-25?cPath=25&sort=2a&action=buy_now&products_id=60

 

Error code on both: Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

 

I will try commenting out

Options +FollowSymLinks

and let you know what happens

 

*fingers crossed I have given enough information this time and not tried your patience too much*

 

Sue

Edited by a12c4magic

Share this post


Link to post
Share on other sites
*fingers crossed I have given enough information this time and not tried your patience too much*

 

Sue

 

Sue I'm only too happy to help but I need the debug information.

 

Rewrite urls:

 

If you are on a *nix server and the rewrite urls are not working .. either ..

 

1) The server is not set up for rewrites (mod_rewrite/AllowOverride)

 

2) or you have the RewriteBase incorrect (in your case RewriteBase /catalog/)

 

Non rewrite:

 

http://192.168.1.68/catalog/accessories-c-25 is just wrong it should be ..

http://192.168.1.68/catalog/index.php/accessories-c-25

 

I haven't a clue why it is doing this .. I asked if you could turn on debugging in admin and post here the seo url results (at the bottom of the page)

Share this post


Link to post
Share on other sites
I haven't a clue why it is doing this .. I asked if you could turn on debugging in admin and post here the seo url results (at the bottom of the page)

 

 

If in my previous post I was reporting the errors wrong then you might have to give me up as a lost cause, because I have tried to understand and follow what you have asked of me.

I did turn the debugging on and the only url was the one in the address bar. At the bottom of the page it just said done and gave the error message as previously stated.

 

However if you are asking what the url is when I hover over a categorie then

with rewrite it is:

http://192.168.1.68/catalog/accessories-c-25.html

with standard:

http://192.168.1.68/catalog/accessories-c-25.html

 

however when I click on the categorie then I get the error message but there is no url at the bottom of the page

 

Sue

Edited by a12c4magic

Share this post


Link to post
Share on other sites

Hi i have STS installed in my shop so in catalog/includes/footer.php i have this code at the bottom:

 

<?php
 }
 // START STS 4.1
}
// END STS 4.1
?>

 

Can you please tell me how to put in this code correctly to my footer.php?

 

<?php 
 } 
 // ULTIMATE Seo Urls 5 by FWR Media 
 usu::performance(); 
?>

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Problem solved:

 

<?php
 }
 // START STS 4.1
}
// END STS 4.1

// ULTIMATE Seo Urls 5 by FWR Media 
 usu::performance(); 
?>

 

Thanks "You-kno-who-you-are"

 

I now saw that i in the bottom of my customer area have this warning text:

 

Warning: file_put_contents(/home/xxx/public_htmlincludes/modules/ultimate_seo_urls5/cache/2_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/xxx/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

is that because i havent done all of the installation yet? or is something wrong already?

Share this post


Link to post
Share on other sites
Problem solved:

 

<?php
 }
 // START STS 4.1
}
// END STS 4.1

// ULTIMATE Seo Urls 5 by FWR Media 
 usu::performance(); 
?>

 

Thanks "You-kno-who-you-are"

 

I now saw that i in the bottom of my customer area have this warning text:

 

Warning: file_put_contents(/home/xxx/public_htmlincludes/modules/ultimate_seo_urls5/cache/2_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/xxx/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

is that because i havent done all of the installation yet? or is something wrong already?

 

includes/configure.php

 

DIR_FS_CATALOG should have a trailing /

 

So ..

 

/home/xxx/public_html/

 

You seem to have ..

 

/home/xxx/public_html

Share this post


Link to post
Share on other sites
Problem solved:

 

<?php
 }
 // START STS 4.1
}
// END STS 4.1

// ULTIMATE Seo Urls 5 by FWR Media 
 usu::performance(); 
?>

 

Thanks "You-kno-who-you-are"

 

I now saw that i in the bottom of my customer area have this warning text:

 

Warning: file_put_contents(/home/xxx/public_htmlincludes/modules/ultimate_seo_urls5/cache/2_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/xxx/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

is that because i havent done all of the installation yet? or is something wrong already?

 

Thanks Solan

 

It is always nice when someone "bothers" to post a solution in order to help others, hopefully this will help all STS users.

Share this post


Link to post
Share on other sites
includes/configure.php

 

DIR_FS_CATALOG should have a trailing /

 

So ..

 

/home/xxx/public_html/

 

You seem to have ..

 

/home/xxx/public_html

 

God Morning!

 

Thanks, that helped a lot :thumbsup:

Edited by Solan

Share this post


Link to post
Share on other sites

Me again,

 

1. i had installed this contrib http://addons.oscommerce.com/info/5851 v 3.1.4 before installing your contrib.. And now it seems that all of my former work with the first contrib not shows in my titles and so on..

 

I havent yet installd the Traditional Rewrite Type URIs but i intend to do so.. i just want to go easy with my contribs, afraid of give my side major problems *lol*

 

Is there any changes i have to do to make my two contribs work together?

 

2. I also now have links that look like this: www.xxx.se/index.php/barn-c-3?osCsid=317a2723479caf6ae2e432b599024961

 

i guess the osCsid=317a2723479caf6ae2e432b599024961 shouldnt be there?

 

3. Im swedish so we have å, ä, ö in our alphabet, is it theese i should put in the "Enter special character conversions"?

If thats the case i think it should be like this:

 

å=>å,ä=>ä,ö=>ö

 

Thanks

Edited by Solan

Share this post


Link to post
Share on other sites
Me again,

 

1. i had installed this contrib http://addons.oscommerce.com/info/5851 v 3.1.4 before installing your contrib.. And now it seems that all of my former work with the first contrib not shows in my titles and so on..

 

I havent yet installd the Traditional Rewrite Type URIs but i intend to do so.. i just want to go easy with my contribs, afraid of give my side major problems *lol*

 

Is there any changes i have to do to make my two contribs work together?

 

2. I also now have links that look like this: www.xxx.se/index.php/barn-c-3?osCsid=317a2723479caf6ae2e432b599024961

 

i guess the osCsid=317a2723479caf6ae2e432b599024961 shouldnt be there?

 

3. Im swedish so we have å, ä, ö in our alphabet, is it theese i should put in the "Enter special character conversions"?

If thats the case i think it should be like this:

 

å=>å,ä=>ä,ö=>ö

 

Thanks

 

Re: character conversions there is a file in the package ..

 

character_conversion_pack/swedish.php

 

Add your conversions to the array in the file .. like 'å' => 'a'

 

catalog/includes/modules/ultimate_seo_urls5/includes/character_conversion

 

A note of warning the file name must be the same as your languages file so if your language file is swedish.php then it is fine .. if your language file is svenska you need to change the filename to svenska.php

 

The array looks like ..

  $char_convert = array('å' => '', 'ä' => '', 'ö' =>'',
					'Å' => '', 'Ä' => '', 'Ö' => '');

 

If you do this you can ignore admin settings .. you can also add similar files for other languages e.g. Norwegian, Danish etc

Edited by FWR Media

Share this post


Link to post
Share on other sites

thanks here is the code for swedish

 

$char_convert = array('å' => 'å', 'ä' => 'ä', 'ö' => 'ö',
					'Å' => 'Å', 'Ä' => 'Ä', 'Ö' => 'Ö');

 

Strange, before i did that change my link was like this:

 

http:// www.xx.se/index.php/skovård-tillbehör-c33?osCsid=317a2723479caf6ae2e432b599024961

 

And after adding that file the link is like this:

 

http:// www.xxx.se/index.php/skovaringrd-tillbehoumlr-c-33?osCsid=317a2723479caf6ae2e432b599024961

 

is that really right?

Edited by Solan

Share this post


Link to post
Share on other sites
thanks here is the code for swedish

 

$char_convert = array('å' => 'å', 'ä' => 'ä', 'ö' => 'ö',
					'Å' => 'Å', 'Ä' => 'Ä', 'Ö' => 'Ö');

 

Strange, before i did that change my link was like this:

 

http:// www.xx.se/index.php/skovård-tillbehör-c33?osCsid=317a2723479caf6ae2e432b599024961

 

And after adding that file the link is like this:

 

http:// www.xxx.se/index.php/skovaringrd-tillbehoumlr-c-33?osCsid=317a2723479caf6ae2e432b599024961

 

is that really right?

 

No

 

The character conversion should be ..

 

special character => latin character

 

Like the example I gave above.

 

'å' => 'a' or 'å' => 'aa' or whatever it may be

 

Below is a Danish conversion: -

 

  $char_convert = array('æ' => 'ae', 'ø' => 'oe', 'å' =>'aa',
					'Æ' => 'AE', 'Ø' => 'OE', 'Å' => 'AA', 'ä' => 'a',);

Edited by FWR Media

Share this post


Link to post
Share on other sites

Then this would be right for swedish (i hope) *lol*

 

$char_convert = array('å' => 'a', 'ä' => 'a', 'ö' =>'o',
					'Å' => 'A', 'Ä' => 'A', 'Ö' => 'O');

 

I´ve uploaded it to my server, but my links still look the same as before.. with the first change i made :huh: What am i doing wrong?

 

By the way i think the turkish code is like this:

 

$char_convert = array('Ğ'=>'g', 'ğ'=>'g', 'Ü'=>'u', 'ü'=>'u', 'Ş'=>'s', 'ş'=>'s', 'İ'=>'i', 'ı'=>'i', 'Ö'=>'o', 'ö'=>'o', 'Ç'=>'c', 'ç'=>'c',);

Share this post


Link to post
Share on other sites
Then this would be right for swedish (i hope) *lol*

 

$char_convert = array('å' => 'a', 'ä' => 'a', 'ö' =>'o',
					'Å' => 'A', 'Ä' => 'A', 'Ö' => 'O');

 

I´ve uploaded it to my server, but my links still look the same as before.. with the first change i made :huh: What am i doing wrong?

 

By the way i think the turkish code is like this:

 

$char_convert = array('Ğ'=>'g', 'ğ'=>'g', 'Ü'=>'u', 'ü'=>'u', 'Ş'=>'s', 'ş'=>'s', 'İ'=>'i', 'ı'=>'i', 'Ö'=>'o', 'ö'=>'o', 'Ç'=>'c', 'ç'=>'c',);

 

Try resetting the cache :)

Share this post


Link to post
Share on other sites

I´m not familiar with the reset cache function but i found 3 alternatives in my cache area:

categorie box

manufacture box

also-ordered-modul

 

i pressed the recycle buttons but nothings change so i wnt to my ftp program and manually erasied all of the files in my /tmp/ folder.

Nothing changed.. still the same link..

 

 

EDIT...

 

:blush: i now saw the reset cache function in this modul :blush:

 

Everything looks just fine now.. *handing you a flower*

Edited by Solan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×