Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Sorry, my description probably wasn't the greatest! On my homepage, the URL's show like this - index.php/cocktail-dresses-c-28 for a category, which is great. On the advanced search, they show like this - advanced_search_result.php?keywords=celebrity. I was wondering if there was a way to have this page do something similar so this would show as advanced_search_result.php/celebrity; similarly to how the index page shortens them. Thanks in advance.

 

Not really and there is little point as the search engines won't be conducting searches.

Share this post


Link to post
Share on other sites

This is the contrib that i was seeking for long time...thanks!!!

It work great in standard mode but i've some problem when i try to swith to rewrite on Seo URL format.

All product pages except the menu pages - like (home/about us/product_new.php) that are totally visible - gives me an 404 error.

I use OSC 2.2 rc2, and i've installed Header Tags SEO - Year Make Model - Google XML SEO - Seo Urls 5 like contrib.

I see in the istruction that i've to set the .htaccess...and i'm in a big trouble.

You say that .htaccess must be in root directory, and i've in "pub" category... if i moove it into the root my website seems to disappear (no access in every pages)....i use root for all, i don't have the folder catalog inside.

The .htaccess file give me this code:

 

Options +FollowSymLinks -Indexes

 

 

How i can activate mod_rewrite and AllowOveride to ALL ??

 

my website is: www(dot)sbkevolution(dot)com

 

Sorry for my bad english...but i didn't have found an italian developers that help me in this way!

 

Hi

 

The server techs need to ensure that mod_rewrite is enabled and that AllowOverride has sufficient permissions to allow for RewriteRules in .htaccess.

 

Other than that your .htaccess needs to be in the SHOP root directory ( the first shop directory containing the files conditions.php, privacy.php etc etc ) the .htaccess must contain the code as supplied by the contribution with RewriteBase adjusted correctly.

Share this post


Link to post
Share on other sites

Not really and there is little point as the search engines won't be conducting searches.

 

That makes perfect sense. Thanks for the help and thanks again for the contribution.

Share this post


Link to post
Share on other sites

I've found the .tcaccess file that you provide with the contrib and i've upload it on my website.

The .htaccess is that:

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /catalog/

 

RewriteRule ^(.*)-p-([0-9]+).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-([0-9_]+).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

# Articles contribution

RewriteRule ^(.*)-t-([0-9_]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

# Information pages

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

# Links contribution

RewriteRule ^(.*)-links-([0-9_]+).html$ links.php?lPath=$2&%{QUERY_STRING}

# Newsdesk contribution

RewriteRule ^(.*)-n-([0-9]+).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nc-([0-9]+).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nri-([0-9]+).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-nra-([0-9]+).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}

 

 

but other than the menu page (contact us, privacy,etc...) all the other pages give me a 404error.... like that:

 

Not Found

 

The requested URL /xxxx-xxxx-xxxx-yyyy.html was not found on this server.

 

It seems that no overwrite action will be done... Could you please help me??

Edited by gabriele82

Share this post


Link to post
Share on other sites

but other than the menu page (contact us, privacy,etc...) all the other pages give me a 404error.... like that:

 

Not Found

 

The requested URL /xxxx-xxxx-xxxx-yyyy.html was not found on this server.

 

It seems that no overwrite action will be done... Could you please help me??

 

Gabriele you need to read the instructions, I have clearly shown in the instructions how to set RewriteBase yet your shop is in root ..

 

www(dot)sbkevolution(dot)com

 

and your RewriteBase is /catalog/

 

With a root installation the RewriteBase should just be /

Share this post


Link to post
Share on other sites

Robert for sure i've read the istruction but something is missing!

I've change the Rewritebase /catalog in Rewritebase / but if i upload the .htaccess in the root i can't see any page... also the home page give me:

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, postmaster@sbkevolution.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

if i cancell the .htaccess from the home page and i leave it in the original position "root/pub" just the menu pages work correct, but category and products page make error 404.

 

I really don't understand what it's wrong and where i make mistake...

 

I've see that i've also to set AllowOveride to all....... but at the start of this post you say that i have to change it into the php.ini, but Aruba Server don't permit to change this setting! Maybe could be that the mistake??

Share this post


Link to post
Share on other sites

Robert for sure i've read the istruction but something is missing!

I've change the Rewritebase /catalog in Rewritebase / but if i upload the .htaccess in the root i can't see any page... also the home page give me:

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, postmaster@sbkevolution.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

if i cancell the .htaccess from the home page and i leave it in the original position "root/pub" just the menu pages work correct, but category and products page make error 404.

 

I really don't understand what it's wrong and where i make mistake...

 

I've see that i've also to set AllowOveride to all....... but at the start of this post you say that i have to change it into the php.ini, but Aruba Server don't permit to change this setting! Maybe could be that the mistake??

 

Quite simply the server has to be set up to accept .htaccess and rewriterules, I can't help with the server.

 

I'm presuming it is a *nix server and not Windows btw.

Share this post


Link to post
Share on other sites

Yes, it's a linux server. I've send an email to the Aruba Staff, waiting for the reply and I let you know.

Could I set AllowOverride All on .htaccess??

Share this post


Link to post
Share on other sites

Yes, it's a linux server. I've send an email to the Aruba Staff, waiting for the reply and I let you know.

Could I set AllowOverride All on .htaccess??

 

AllowOverride is set in apache httpd.conf it dictates whether .htaccess can be used, so you can't use .htaccess to allow itself :)

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello all,

 

I hope I do not suck all your help reserves, FWR Media:

 

I have installed ULTIMATE Seo Urls 5 - by FWR Media and it works great.

 

When I use a link checker like the one from w3c on my site I get the 404 errors like, for example www.mysite.com/-p-362.html.

 

I have read in this contrib: http://addons.oscommerce.com/info/5738 that I am not the one having this problem. Ultimate Seo Urls 2.1 has this same problem.

 

One of the things that gets you penalized in SEO ranks is having 404 errors. So, could having an addon like Ultimate Seo Urls defeat its own purpose this way?

Or are google and the rest intelligent enough so they interpret javascript and they do not get this error?

 

Are there any plans to fix this in this contrib?

 

Thanks for everything! You are great, FWR Media

Share this post


Link to post
Share on other sites

Hello all,

 

I hope I do not suck all your help reserves, FWR Media:

 

I have installed ULTIMATE Seo Urls 5 - by FWR Media and it works great.

 

When I use a link checker like the one from w3c on my site I get the 404 errors like, for example www.mysite.com/-p-362.html.

 

I have read in this contrib: http://addons.oscommerce.com/info/5738 that I am not the one having this problem. Ultimate Seo Urls 2.1 has this same problem.

 

One of the things that gets you penalized in SEO ranks is having 404 errors. So, could having an addon like Ultimate Seo Urls defeat its own purpose this way?

Or are google and the rest intelligent enough so they interpret javascript and they do not get this error?

 

Are there any plans to fix this in this contrib?

 

Thanks for everything! You are great, FWR Media

 

The link checker doesn't always work, it certainly doesn't work on all my sites. I have a feeling it kicks in mod_security measures which blocks it.

 

It has nothing to do with javascript, USU5 uses no javascript. No there is no penalty as there's no problem. W3C has the only problem.

Share this post


Link to post
Share on other sites

fixed! ;) I've just to comment the first line of the .htaccess with # !!

 

Thanks for your help Robert ;)

 

My pleasure

 

I'll have to get some bits from you when I work on my bike next ;)

Share this post


Link to post
Share on other sites

Robert,

 

I am having trouble with adding a compatible site map (Google XML Sitemap SEO -> http://addons.oscommerce.com/info/6583). Using the files provided in the extra folder in this modification I was unable to drag and drop. It keeps creating the site map within the "googlesitemap" folder instead of in the catalog where it should be. Your support would be appreciated.

 

Current Error:


Warning: file_put_contents(/home/c.n.r./public_html/googlesitemap/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/c.n.r./public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

Thanks

 

Ryan B.

(32 Degrees)

Edited by 32 Degrees

plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

I am having trouble with adding a compatible site map (Google XML Sitemap SEO -> http://addons.oscommerce.com/info/6583). Using the files provided in the extra folder in this modification I was unable to drag and drop. It keeps creating the site map within the "googlesitemap" folder instead of in the catalog where it should be. Your support would be appreciated.

 

Current Error:


Warning: file_put_contents(/home/c.n.r./public_html/googlesitemap/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/c.n.r./public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

Thanks

 

Ryan B.

(32 Degrees)

 

The save location is dictated by ..

$this->savepath = DIR_FS_CATALOG;

 

DIR_FS_CATALOG should contain the FULL path to your catalog root.

Share this post


Link to post
Share on other sites

UPDATE:

 

With a few exceptions the Site map works. The same problems from the previous post remain, however the site map is generating. I need to move the site maps to the catalog folder and I need to resolve that error. Your help is appreciated.

 

Thanks


plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

I posted the update before I refreshed the browser. Here is my code in includes/configure.php

 

 define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/');


plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

I posted the update before I refreshed the browser. Here is my code in includes/configure.php

 

 define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/');

 

As I said, that's wrong.

 

osCommerce should have a FULL path in there .. that code does not do that.

 

If you REALLY have to have a dynamic entry use ..

 

define('DIR_FS_CATALOG', realpath('.') . DIRECTORY_SEPARATOR);

Edited by FWR Media

Share this post


Link to post
Share on other sites

Robert,

 

I must admit, you have a good track record of pointing out issues in my configure.php file. I found a guide to the configure.php file and have adjusted it. Now it works! I seriously have no clue what or where my previous code came from.

 

I question I have for you... Adding brand name to USU5?

 

For Ex.

"http://www.13thgreen.com/golf-towel-black-p-520.html"'>http://www.13thgreen.com/golf-towel-black-p-520.html"

 

Changed to ->

"http://www.13thgreen.com/oakley-golf-towel-black-p-520.html"

 

I believe it would involve another query, but, having the manufacturer name might help ranking?

Edited by 32 Degrees

plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

I must admit, you have a good track record of pointing out issues in my configure.php file. I found a guide to the configure.php file and have adjusted it. Now it works! I seriously have no clue what or where my previous code came from.

 

I question I have for you... Adding brand name to USU5?

 

For Ex.

"http://www.13thgreen.com/golf-towel-black-p-520.html"'>http://www.13thgreen.com/golf-towel-black-p-520.html"

 

Changed to ->

"http://www.13thgreen.com/oakley-golf-towel-black-p-520.html"

 

I believe it would involve another query, but, having the manufacturer name might help ranking?

 

Read up a few posts about version 1.1

Share this post


Link to post
Share on other sites

Robert,

 

I must admit, you have a good track record of pointing out issues in my configure.php file. I found a guide to the configure.php file and have adjusted it. Now it works! I seriously have no clue what or where my previous code came from.

 

I question I have for you... Adding brand name to USU5?

 

For Ex.

"http://www.13thgreen.com/golf-towel-black-p-520.html"'>http://www.13thgreen.com/golf-towel-black-p-520.html"

 

Changed to ->

"http://www.13thgreen.com/oakley-golf-towel-black-p-520.html"

 

I believe it would involve another query, but, having the manufacturer name might help ranking?

 

Version 1.1 can add model, category, product name but for the very reason of a query manufacturers has not been included.

 

Yes you would need to add a query in modules/Usu_Products.php and add to the link_text.

Share this post


Link to post
Share on other sites

Robert,

 

Maybe it should be something included as an admin function (On/Off Toggle) in the next update. Because it does help with ranking, it is relevant to the modification. I looked over the code of Usu_Products and I will openly admit your code writing level is higher then my understanding level. Hence, I truly hope this feature request I am making can make it mainstream. I will be the first to volunteer to test it :)


plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

Maybe it should be something included as an admin function (On/Off Toggle) in the next update. Because it does help with ranking, it is relevant to the modification. I looked over the code of Usu_Products and I will openly admit your code writing level is higher then my understanding level. Hence, I truly hope this feature request I am making can make it mainstream. I will be the first to volunteer to test it :)

 

Try the following to add it yourself ..

 

catalog/includes/modules/ultimate_seo_urls5/modules/Usu_Products.php

 

Find ..

 

private $products_id;

 

Add immediately below ..

 

private $manufacturers_name;

 

Change the query to ..

 

    $this->base_query = "SELECT pd.products_name, p.manufacturers_id FROM " . TABLE_PRODUCTS . " p INNER JOIN " . TABLE_PRODUCTS_DESCRIPTION . " pd ON p.products_id = pd.products_id WHERE p.products_id=':pid' AND pd.language_id=':languages_id' LIMIT 1";

 

find ..

 

    $this->link_text = $this->linkText($row['products_name']);

 

Add immediately below ..

 

    $this->manufacturers_name = $this->linkText( $this->getManufacturersName( $row['manufacturers_id'] ) );

 

 

Find ..

 

protected function getProperties(){

 

Add immediately above ( leaving a gap between the two methods )

 

  private function getManufacturersName( $mid )) {
   $query = "SELECT manufacturers_name FROM " . TABLE_MANUFACTURERS . " WHERE manufacturers_id = '" . (int)$mid . "'";
   $result = usu::query( $query );
   $row = tep_db_fetch_array( $result );
   tep_db_free_result( $result );
   return $row['manufacturers_name'];
 } // end method

 

Find ..

        $url = $this->linkCreate(FILENAME_PRODUCT_INFO, $reg_item['link_text'], '-p-', $valuepair[1]);

 

Change to ..

 

         $url = $this->linkCreate(FILENAME_PRODUCT_INFO, $reg_item['manufacturers_name'] . '-' . $reg_item['link_text'], '-p-', $valuepair[1]);

 

Just threw that together so totally untested I'm afraid.

Edited by FWR Media

Share this post


Link to post
Share on other sites
Parse error: syntax error, unexpected ')', expecting ';' or '{' in /home/c.n.r./public_html/includes/modules/ultimate_seo_urls5/modules/Usu_Products.php on line 64


plasma.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×