Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Robert,

 

Quick update. With the new configuration file I am also unable to log-in to pre-existing accounts. What do you think could be causing this? I got to be careful because this is a live store!

 

Thanks


plasma.jpg

Share this post


Link to post
Share on other sites

Oh Crap! Ok so everything seemed to install fine. I still have my admin side and I can see the SEO URLs

 

But I have lost the client side completely. I get nothing but a white screen.

 

I am double and triple checking all the code.

 

I upgraded from ver 2.1 or so after switching from php4 to 5

 

I also was unable to find where to change the last install instruction regarding the .htaccess file

 

HELP, this site WAS live.


The Site can be viewed at www.performanceautopartsonline.com

 

The site is live (despite these minor glitches) please respect that and do not sign up etc...

 

maybe a contribution one day when I get this site the way I want it.

 

I don't make spelling mistakes! I have dyslecsic fingers.

Share this post


Link to post
Share on other sites

Disregard,

 

My issue is not with this contributio it turns out. I checked the veiw source code and found that some hacker has done this to me

 

<div style="display:none"><a href='http://performanceautopartsonline.com/catalog/popup_image.php/?fzde=0'>free forex courses</a> <a href='http://performanceautopartsonline.com/catalog/popup_image.php/?fzde=1'>free forex e book</a> <a href='http://performanceautopartsonline.com/catalog/popup_image.php/?fzde=2'>forex usd gbp</a> <a 

 

THis is just a sample. But when i reloaded the included file I had backed up the site came back up. Then it happened again. The same thing happened to my forum a few weeks back. I need to solve this problem first!

 

any ideas?


The Site can be viewed at www.performanceautopartsonline.com

 

The site is live (despite these minor glitches) please respect that and do not sign up etc...

 

maybe a contribution one day when I get this site the way I want it.

 

I don't make spelling mistakes! I have dyslecsic fingers.

Share this post


Link to post
Share on other sites
The links work! But the images do not display on the product pages

 

Images are nothing to do with usu5 this produces links.

 

With the new configuration file I am also unable to log-in to pre-existing accounts

 

Not a clue what you mean, the login system has nothing to do with seo urls.

 

My understanding of all your posts so far is that usu5 didn't work because your configure.php was wrong .. once correct usu5 worked.

Share this post


Link to post
Share on other sites

Robert,

 

As it stands my normal configure.php file works 100%. While it works USU5 does not work. The fix is to alter the configure.php file to what you suggested in a previous post. This makes the USU5 work 100% however, all my images load blank. They are now missing a "/". I believe the same is true with the login. How can I set up the configure.php to allow USU5 to work as well as my images to load in my shop. I know this must be possible. I am but one step away!


plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

 define('HTTP_SERVER', 'http://www.13thgreen.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://www.13thgreen.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', 'true'); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'www.13thgreen.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.13thgreen.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

Above is the configuration changes you suggested to make the modification work. However, this configuration completely disables logging in. When I go to the login page and type my information and click submit the page just refreshes and clears the user name and password that I entered. I'm soo close I just don't understand how to stop this! Believe me this is frustration! Would any other information be helpful? Admin configure.php?


plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

As it stands my normal configure.php file works 100%. While it works USU5 does not work. The fix is to alter the configure.php file to what you suggested in a previous post. This makes the USU5 work 100% however, all my images load blank. They are now missing a "/". I believe the same is true with the login. How can I set up the configure.php to allow USU5 to work as well as my images to load in my shop. I know this must be possible. I am but one step away!

 

This is simply because you had doctored your site to work with an incorrect configure.php

 

Example define('HTTP_SERVER', 'http://www.13thgreen.com/');

 

Should never have a trailing /

 

define('DIR_WS_HTTP_CATALOG', '');

 

Should ALWAYS have at least a /

 

 

 

How can I set up the configure.php to allow USU5 to work as well as my images to load in my shop.

 

No, you are looking at this the wrong way around. USU5 is not wrong your files are .. you need to find where you doctored osCommerce to work with the incorrect settings and set them back to the way they are meant to be. By continuing to modify correct files to make up for an incorrect configuration will just lead you into more problems.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Robert,

 

Thanks for setting things straight. As I have used oscommerce longer, both my knowledge and usability have grown. However, the configure.php file was created at a point when I had no knowledge or prior experience with osCommerce. Although not related directly to the modification, what would be the best road to go down to solve this?

Edited by 32 Degrees

plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

Thanks for setting things straight. As I have used oscommerce longer, both my knowledge and usability have grown. However, the configure.php file was created at a point when I had no knowledge or prior experience with osCommerce. Although not related directly to the modification, what would be the best road to go down to solve this?

 

Could you turn on seo urls for a minute for me to take a quick look?

Share this post


Link to post
Share on other sites

Robert,

 

Yes we can do that momentarily. Can I have a way to contact you? Instant messenger or phone? Our site is live and we have customer flow all day. I can only bring it down for moments at a time.


plasma.jpg

Share this post


Link to post
Share on other sites

Robert,

 

Yes we can do that momentarily. Can I have a way to contact you? Instant messenger or phone? Our site is live and we have customer flow all day. I can only bring it down for moments at a time.

 

email me admin (at) myforumname (dot) co (dot) uk

Share this post


Link to post
Share on other sites

Good day to you all.

 

I seems that I found a small bug in this refreshing ultimate SEO contribution. On the moment, I am implementing it into a shop with a prefix before the database tables. As long as every query is using the database tables as defined in database_tables.php, it is no problem. I found an entry that is not using the defines, but using a hard code table call.

In module/ultimate_seo_urls5/modules/Usu_Categories.php, line 37 (in function __construct), change:

   $this->base_query = "SELECT cd.categories_name AS cName, cd2.categories_name AS pName FROM " . TABLE_CATEGORIES . " c LEFT JOIN " . TABLE_CATEGORIES_DESCRIPTION . " cd2 ON c.parent_id = cd2.categories_id AND c.parent_id = cd2.categories_id AND cd2.language_id = :languages_id, categories_description cd WHERE c.categories_id = cd.categories_id AND c.categories_id = :cid AND cd.language_id = :languages_id";

to

   $this->base_query = "SELECT cd.categories_name AS cName, cd2.categories_name AS pName FROM " . TABLE_CATEGORIES . " c LEFT JOIN " . TABLE_CATEGORIES_DESCRIPTION . " cd2 ON c.parent_id = cd2.categories_id AND c.parent_id = cd2.categories_id AND cd2.language_id = :languages_id, " . TABLE_CATEGORIES_DESCRIPTION . " cd WHERE c.categories_id = cd.categories_id AND c.categories_id = :cid AND cd.language_id = :languages_id"; 

Share this post


Link to post
Share on other sites

Good day to you all.

 

I seems that I found a small bug in this refreshing ultimate SEO contribution. On the moment, I am implementing it into a shop with a prefix before the database tables. As long as every query is using the database tables as defined in database_tables.php, it is no problem. I found an entry that is not using the defines, but using a hard code table call.

In module/ultimate_seo_urls5/modules/Usu_Categories.php, line 37 (in function __construct), change:

   $this->base_query = "SELECT cd.categories_name AS cName, cd2.categories_name AS pName FROM " . TABLE_CATEGORIES . " c LEFT JOIN " . TABLE_CATEGORIES_DESCRIPTION . " cd2 ON c.parent_id = cd2.categories_id AND c.parent_id = cd2.categories_id AND cd2.language_id = :languages_id, categories_description cd WHERE c.categories_id = cd.categories_id AND c.categories_id = :cid AND cd.language_id = :languages_id";

to

   $this->base_query = "SELECT cd.categories_name AS cName, cd2.categories_name AS pName FROM " . TABLE_CATEGORIES . " c LEFT JOIN " . TABLE_CATEGORIES_DESCRIPTION . " cd2 ON c.parent_id = cd2.categories_id AND c.parent_id = cd2.categories_id AND cd2.language_id = :languages_id, " . TABLE_CATEGORIES_DESCRIPTION . " cd WHERE c.categories_id = cd.categories_id AND c.categories_id = :cid AND cd.language_id = :languages_id"; 

 

Good catch .. naughty me!!!! <slaps wrist>

Share this post


Link to post
Share on other sites

Robert,

 

Thanks for you help with your modification. It works beautifully! Couldn't have done it without your help.

 

- Ryan


plasma.jpg

Share this post


Link to post
Share on other sites

A note about existing and ongoing development:

 

Ultimate Seo Urls 5 in its current state as a release candidate (rc) is performing extremely well and there are currently no known issues ( bar a hardcoded table name as mentioned in the post above .. thanks Peter ).

 

This version will be consistently updated so you can be sure of solid performance into the future. I have had fantastic feedback about performance in comparison with the old 2005 version, ease of installation and the ease of upgrading due to easy to follow instructions, thanks all for your feedback.

 

Now in development .. version 1.1:

 

4 uri types:

  • Standard: www.mysite.com/index.php/my-great-product-p-32
  • Rewrite: www.mysite.com/my-great-product-p-32.html
  • Path Standard: www.mysite.com/index.php/my-great-product/-p-/32
  • Path Rewrite: www.mysite.com/my-great-product/-p-/32.html

 

Continued full support for Windows servers not just *nix

 

Languages Support

Many international users are frustrated that there is no multi language support in any of the seo url contributions.

 

If you don't know what I mean by this it is that if you have let's say two languages on the site French and German with German being the default, when bots see the French page it has the same uri which defeats the object from an seo point of view.

 

Now imagine if there were two seperate uris

 

www.mysite.com/my-great-product/-p-/32.html ( default German language )

www.mysite.com/fr/my-great-product/-p-/32.html ( french language )

 

You now have two distinctly different uris to promote your business in different countries.

 

Other

General tidying and ensuring that the code is flexible for the future ( already PHP5.3 compatible )

 

Thought users may like to know the current status and what is in the pipeline.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Interim patch

 

Affects: Standard seo uris not rewritten uris

 

Description and reason for the patch:

 

osCommerce and various contributions use basename( $PHP_SELF ) or basename( $_SERVER['PHP_SELF ) or basename( $HTTP_SERVER_VARS['PHP_SELF'] ) to pass what they believe to be a filename to tep_href_link(), this is incorrect as PHP_SELF is unreliable and spoofable.

 

Example:

A perfectly valid usu5 standard uri may look like ..

www.mysite.com/index.php/my-great-product-p-32

 

basename( $PHP_SELF ) (or other versions of the same) is expected to contain a filename ( like e.g. index.php ) but it doesn't!!

Instead it contains my-great-product-p-32 as you can imagine tep_href_link() was expecting a filename so not surprisingly this breaks.

 

Will add this patch later today hopefully.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Patch as mentioned above:

 

catalog/includes/modules/ultimate_seo_urls5/classes/usu.php

 

Find at the very bottom of the file ..

 

} // End class   
?>

 

Add immediately above ..

 

    private function getTagsToFiles() {
     $tags_to_files = array();
     foreach( self::$modules as $object ) {
       foreach( $object->dependency_tags as $tag => $filename ) {
         $tags_to_files[$tag] = $filename;
       } 
     }
     return $tags_to_files;
   } // End method

 

Find ..

 

public function href_link

 

A few lines down find ..

 

        $parameters = str_replace( '&', '&', $parameters );

 

Add immediately below: -

 

        // Some contributions incorrectly use $_SERVER['PHP_SELF'] or basename( $PHP_SELF ) which can have nasty consequences with standard seo urls
       if( ( false !== strpos( $page, '/' ) ) || ( substr( $page, -4, 4 ) != '.php' ) ) {
         preg_match('@\b[a-z_]+\.php\b@i', $page, $matches); // Is our filename in there somewhere??
         if ( array_key_exists( '0', $matches ) && ( substr( $matches[0], -4, 4 ) == '.php' ) ) {
           $page = $matches[0]; 
         } else {
           $tags_to_files = $this->getTagsToFiles();
           foreach( $tags_to_files as $marker => $filename ) {
             if ( false !== strpos( $page, $marker ) ) {  // is there a seo url marker in the page name?
               $page = $filename; // Grab the correct page name
             }
           }
         }
       }
       if ( substr( $page, -4, 4 ) != '.php' ) {
         trigger_error( 'Incorrect page entered into function ' . __FUNCTION__ . ' as <b>' . $page . '</b>,<br />
         this is caused by contributions incorrectly using $_SERVER[\'PHP_SELF\'] or basename( $PHP_SELF )
         <br />A correct page would be like index.php or product_info.php.<br />', E_USER_WARNING );
       }
       // End some contributions incorrectly use $_SERVER['PHP_SELF'] or basename( $PHP_SELF )

Share this post


Link to post
Share on other sites

hello, i m newbie.

i use ULTIMATE Seo Urls 5 fr-84

thank, that make google index my image url but not for my urls product.

when i look at google:

 

......................

Warung On-line

Hak Cipta © 2009 Warung On-line warung exalumni on line ini dibuat dengan menggunakan osCommerce thank to website-hebat.com.

warung.exalumni.com/specials.php - Tembolok - Mirip

Lain-Lain

Hak Cipta © 2009 Warung On-line warung exalumni on line ini dibuat dengan menggunakan osCommerce thank to website-hebat.com.

warung.exalumni.com/index.../penyimpanan-lainlain-c-29_30 - Tembolok - Mirip

............................

 

its found 199 url after 2 month index, and consist the same description.

so, my refferal came from image urls.

 

my question, is this seo url can handle product decription?

ex:

.....

banana (product name)

this fruits..... (description)

warung.exalumni.com/index.../banana (url)

....

 

thanks for your help, and if this out topic, i will delete my post.

Share this post


Link to post
Share on other sites

hello, i m newbie.

i use ULTIMATE Seo Urls 5 fr-84

thank, that make google index my image url but not for my urls product.

when i look at google:

 

......................

Warung On-line

Hak Cipta © 2009 Warung On-line warung exalumni on line ini dibuat dengan menggunakan osCommerce thank to website-hebat.com.

warung.exalumni.com/specials.php - Tembolok - Mirip

Lain-Lain

Hak Cipta © 2009 Warung On-line warung exalumni on line ini dibuat dengan menggunakan osCommerce thank to website-hebat.com.

warung.exalumni.com/index.../penyimpanan-lainlain-c-29_30 - Tembolok - Mirip

............................

 

its found 199 url after 2 month index, and consist the same description.

so, my refferal came from image urls.

 

my question, is this seo url can handle product decription?

ex:

.....

banana (product name)

this fruits..... (description)

warung.exalumni.com/index.../banana (url)

....

 

thanks for your help, and if this out topic, i will delete my post.

 

Hi I'm sorry but I don't understand most of your post.

 

Is your website warung.exalumni.com?

 

If so, usu5 seems to be working perfectly.

Share this post


Link to post
Share on other sites

Even more updates that will be in version 1.1 of usu5 ( expect this to be released on or around Christmas )

 

11 Different ways to create your products links text!

 

List of possible settings:

 

  • product name only ( p ) default
  • category - product ( cp )
  • product - category ( pc )
  • model - product ( mp )
  • product - model ( pm )
  • category - model - product ( cmp )
  • category - product - model ( cpm )
  • model - category - product ( mcp )
  • model - product - category ( mpc )
  • product - category - model ( pcm )
  • product - model - category ( pmc )

 

So if a product was called "great product"

and the category was called "Wiggets"

and the product model was "wgp2057"

and the product id is 27

and from the above list you chose ( mcp )

and you chose to use the rewrite method it would look like ..

www.mysite.com/wgp2057-wiggets-great-product-p-27.html

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello all, just wondering if anyone wants to have a try at some new functionality for the upcoming new version of Ultimate Seo Urls 5.

 

If you comment back then great, If you manage to break it then also great!! :)

 

What is it?

There is a real problem with osCommerce itself and add on uri contributions when it comes to multi languages.

 

e.g. www.mysite.com/index.php is the same page for english/German/Spanish etc and this is the same for all of the uris, basically an seo nightmare if you want multi language pages indexed.

 

Ultimate Seo Urls 5 v1.1 is going to handle this and the first "draft" is online at http://usu5.fwrdev.co.uk

 

How to test:

1) The usual osc language buttons (yuck)

2) Accessing the different categories/products like a search engine would but with the language appended .. e.g.

 

http://usu5.fwrdev.co.uk/hardware-c-1.html (English)

http://usu5.fwrdev.co.uk/de/hardware-c-1.html (German)

http://usu5.fwrdev.co.uk/es/hardware-c-1.html (Spanish)

 

Same for standard files like index.php or conditions.php like ..

http://usu5.fwrdev.co.uk/shipping.php

http://usu5.fwrdev.co.uk/shipping.php/de

http://usu5.fwrdev.co.uk/shipping.php/es

 

I have only me as a tester and it's not good enough to aid solid development so any and all comments/gripes/bugs greatefully received.

 

Rob

Share this post


Link to post
Share on other sites

Robert,

first off, awesome contribution. I installed and its working on my site. I just was looking at the advanced search result page and noticed that it doesn't hack off the keywords part of that URL. Is there something I can modify to have the function work on that page, or should it be already? It works perfectly on the index page for categories.

 

thanks so much.

Share this post


Link to post
Share on other sites

it doesn't hack off the keywords part of that URL

 

Sorry Collin I'm not understanding this . .could you give me an example please?

Edited by FWR Media

Share this post


Link to post
Share on other sites

This is the contrib that i was seeking for long time...thanks!!!

It work great in standard mode but i've some problem when i try to swith to rewrite on Seo URL format.

All product pages except the menu pages - like (home/about us/product_new.php) that are totally visible - gives me an 404 error.

I use OSC 2.2 rc2, and i've installed Header Tags SEO - Year Make Model - Google XML SEO - Seo Urls 5 like contrib.

I see in the istruction that i've to set the .htaccess...and i'm in a big trouble.

You say that .htaccess must be in root directory, and i've in "pub" category... if i moove it into the root my website seems to disappear (no access in every pages)....i use root for all, i don't have the folder catalog inside.

The .htaccess file give me this code:

 

Options +FollowSymLinks -Indexes

 

 

How i can activate mod_rewrite and AllowOveride to ALL ??

 

my website is: www(dot)sbkevolution(dot)com

 

Sorry for my bad english...but i didn't have found an italian developers that help me in this way!

Share this post


Link to post
Share on other sites

Sorry Collin I'm not understanding this . .could you give me an example please?

 

Sorry, my description probably wasn't the greatest! On my homepage, the URL's show like this - index.php/cocktail-dresses-c-28 for a category, which is great. On the advanced search, they show like this - advanced_search_result.php?keywords=celebrity. I was wondering if there was a way to have this page do something similar so this would show as advanced_search_result.php/celebrity; similarly to how the index page shortens them. Thanks in advance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×