Jump to content
Latest News: (loading..)
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

On 7/21/2018 at 4:24 PM, piernas said:

For now the only issue I still find is with mysql cache: Looks like the table is being truncated on every page load. Any help with locating the problem will be welcome.

@phi148 as mentioned in my previous post there's an issue with mysql code I still couldn't fix.

Share this post


Link to post
Share on other sites

Don't think MySQL cache works at this time, but u did not say much about the version of your OSC and environment. Anyway, just use file cache, I was gonna rewrite the DB cache part but had decided to wait after hearing the 2.4 release announcement at that time...

16 hours ago, phi148 said:

| Id   | User             | Host      | db               | Command | Time | State                           | Info                                                                                                 |
+------+------------------+-----------+------------------+---------+------+---------------------------------+------------------------------------------------------------------------------------------------------+
| 1330 | xxx | localhost | xxx | Query   | 1    | Waiting for table metadata lock | TRUNCATE `usu_cache`                                                                                 |
| 1331 | xxx | localhost | xxx | Query   | 1    | checking permissions            | TRUNCATE `usu_cache`                                                                                 |
| 1332 | xxx | localhost | xx | Query   | 1    | Waiting for table metadata lock | TRUNCATE `usu_cache`                                                             

Hey all I'm running into alot of metadata locks with my SQL database (you can see above what I'm talking about).

I went and looked and the "usu_cache" table is empty.  Is this even used?   

 

Share this post


Link to post
Share on other sites
13 hours ago, piernas said:

@phi148 I think I fixed the issue. Can you please test it?

 

Ultimate_Seo_Urls_5_PRO_BS_209_beta_2.zip

Hi, Could you please point to the exact changes you made, As mine are modified files I incorporated the beta_1 already, hence I could add the fixes of beta_2..

Warm Regds./

 radhavallabh

Share this post


Link to post
Share on other sites
On 8/16/2018 at 5:26 AM, radhavallabh said:

Hi, Could you please point to the exact changes you made, As mine are modified files I incorporated the beta_1 already, hence I could add the fixes of beta_2..

Warm Regds./

 radhavallabh

No need to modify the files again. Just upload the drop_on_top files over the existing ones.

Share this post


Link to post
Share on other sites

Now that URLs are no longer considered a ranking factor (one of many sources), is there still any benefit in rewriting them, especially with breadcrumb schema baked into the core? Has anyone done A/B testing? We have used this add-on for ages and are debating its retirement once migration to the new version of our shop is complete. Any insight would be greatly appreciated.

Share this post


Link to post
Share on other sites
28 minutes ago, rulegacy said:

Now that URLs are no longer considered a ranking factor (one of many sources), is there still any benefit in rewriting them, especially with breadcrumb schema baked into the core? Has anyone done A/B testing? We have used this add-on for ages and are debating its retirement once migration to the new version of our shop is complete. Any insight would be greatly appreciated.

Nowhere does it say in your article that URLs are no longer a ranking factor. Besides being a ranking factor or not, there are technical reasons to install this addon, besides the common sense reason of wanting human readable URLs.

This addon won't bring you traffic, just like "breadcrumb schema baked into the core" won't bring you traffic. We all know what brings traffic.

Share this post


Link to post
Share on other sites

I have a problem with Ultimate_Seo_Urls_5_PRO_r205 vr 205 that I have installed which is:  Installed Version 21 Mar 2011

I am running oscommerce 2.3.4 here: www.ministryhelps.com

I am getting this error:

mod_fcgid: stderr: PHP Warning: Invalid argument supplied for foreach() in /var/www/vhosts/ministryhelps.com/httpdocs/includes/modules/ultimate_seo_urls5/page_modules/index.php on line 111

Line 111 is:    foreach ( $text_array as $key => $text ) {

The file is attached.

Does anyone know the fix for this?

thanks

Leon

index.php

Edited by bibleman

I'm having a great Day - hope you are too!

 

Leon

Share this post


Link to post
Share on other sites

Basically, that error happens when you give foreach data that is not an array.  foreach expects an array.  If this is outputing to your screen then you need to turn error to screen off.  You cand do that by adding this to the top of your application_top.php

 ini_set('display_errors', false);

 


I'm not really a dog.

Share this post


Link to post
Share on other sites

To turn off the erros or the warnings is a very bad solution. Shame on this idea.

Change this:

      foreach ( $text_array as $key => $text ) {
        if ( tep_not_null( trim( $text ) ) ) {
          $final_text_array[$key] = $text;
        }
      }

to this:

if (is_array($text_array)) {
  foreach ( $text_array as $key => $text ) {
    if ( tep_not_null( trim( $text ) ) ) {
      $final_text_array[$key] = $text;
    }
  }
}

Clean code is important and a code with turn off erros or warnings tells a lot about the codestyle.


  • The clever one learn from everything and from everybody
  • The normal one learn from his experience
  • The silly one knows everything better

[socrates, 412 before Christ]

Computers help us with the problems we wouldn't have without them!
99.9% of the bugs sit in front of the computer!
My programmed add-ons: WDW EasyTabs 1.0.3, WDW Facebook Like 1.0.0

if(isset($this) || !isset($this)){ // that's the question...

 

Share this post


Link to post
Share on other sites

Hmm...true, clean code is important...

I don't know if this banaid is better than the previous one,  but they both offer a similar solution.

I would really do a var_dump($text_array) or print_r($text_array) just before the foreach statement to get a stack trace of the argument. You really need to know why PHP was complaining. In fact, the foreach statement wasn't just looking for an array, and it was expecting an associative array.

FWR is a smart dude, I would definitely understood why before deciding on a fix. That would be my approach...some upstream setting may just fix the warning.

Share this post


Link to post
Share on other sites
7 hours ago, mcmannehan said:

To turn off the erros or the warnings is a very bad solution. Shame on this idea.

I'm not saying turn off errors, just don't output them to the world.  This is recommended by PHP for production servers.  Basically, output this to a file, so only you can see it.  I was in a hurry when I posted that the other day and should have taken more time. 

Edited by John W

I'm not really a dog.

Share this post


Link to post
Share on other sites
1 hour ago, rulegacy said:

Is it possible to make this add-on pull data from the Header Tags SEO Reloaded that is part of core CE?

I don't know this SEO Urls addon inside out.  What is it that you are trying to do (with regard to pulling data)?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

@burt We would just like for this add-on to use the SEO titles instead of the stock ones. Stripping endings such as -p-4226.html and -c-32_285_297.html would be even better. Is this possible?

Share this post


Link to post
Share on other sites

I don't know this addon well enough to answer this, maybe someone else does and can help better.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

You can create new page modules (examples placed in the "extras"directory) but not remove the p-XXX thing.

Note those modules has not been updated by me and could be outdated. You can modify the "products" module included to fit your needs.

Share this post


Link to post
Share on other sites

@piernas Thanks. Hopefully, someone has already made those changes to the product_info module and is kind enough to share them here.

To all: based on experience, which of the 4 caching options is the fastest and most efficient at using server resources?

Share this post


Link to post
Share on other sites

You can't do it. It needs the product id unique key. Now, you can put a unique index on the column that you want to use as your permalink, and then you should be able to convert the "permalink" desc to product id "upstream" of any "product_id" requirements and use it that way...that would be the easiest hack.

But if you get a lot of errors as you are creating that unique index...you would have some cleanup work to do...by then you should know what I mean "it needs an unique key..."

 

On 9/30/2018 at 3:48 AM, rulegacy said:

Is it possible to make this add-on pull data from the Header Tags SEO Reloaded that is part of core CE?

 

 

 

Share this post


Link to post
Share on other sites

@clustersolutions Thank you for chiming in. This is probably in response to stripping the URL endings. I wish we could take your advice and implement it but lack of MySQL knowledge prevents us from even trying.

On a separate note, does anyone run this add-on together with the KissIT Image Thumbnailer. Strangely enough, the thumbnail for the main product image stopped being fetched after we installed the SEO URLs. Could this be due to the rewrites or a conflict of functions?

Share this post


Link to post
Share on other sites

We have both running that's KISSIT image and  SEO URL 5

 

but afraid I am just a store owner and could not give you any more information of why it was not working

 

Regards

 

David


David

Share this post


Link to post
Share on other sites

Hi,

There is a problem when I am using the usu5_sitemaps, it reports

SELECT p.products_id, p.products_date_added, p.products_last_modified FROM products_description pd INNER JOIN products p ON p.products_id = pd.products_id WHERE p.products_status = '1' AND pd.language_id = ORDER BY p.products_last_modified DESC, p.products_date_added DESC

[TEP STOP]

It seems the $languages_id is empty, could anyone advise me to solve this problem?

 

Thanks in advanced.

 

Chuntse

 

Share this post


Link to post
Share on other sites

New issue discovered: when using a module that is not located in root (e.g. /ext/modules/content/product_info/) and changing the shop language, SEO URLs rewrites the URL as if it were in root thereby leading to a 404. Could SEO URLs be forced to use the original tep_href_link in such cases?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×