Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

@@piernas this happen with all the products.

If you you press the quick add to cart in the general display of products (like show all products categories or manufacturers it works) but if press the action botton in product_info page it does not work and I go to the empty cart page.

Also all other link in the page change to the link of the default language.

If I remove the multi language support so the URL does not have the /it/ all is working

Share this post


Link to post
Share on other sites

@@teol79 I'd review the changes on install to see if something's wrong. My setup works fine under 2.2 and 2.3.4 responsive; I've never tested on other versions.

 

Installing the version I provided should not hurt; Maybe you can try it (obviousliy backup firts).

 

You can also try disablong cache for USU 5 to see if it makes any difference.

Share this post


Link to post
Share on other sites

Hi @@piernas

 

I have installed USU5 on my 2.3.4 Edge Shop and its great again  (w00t)  Thank you for porting it !

 

Unfortunately I have detected, that it eats the "%"-Percent-Signs in the URL, which are used by 

the Products Filter BS Addon (9374). Is there an easy way to leave them inside the URL ?

 

SEE YA !
Denzel.

 

Share this post


Link to post
Share on other sites

Ok, I allready have found it in usu_general_functions.php:

  function usu_cleanse( $value ) {
    return preg_replace( '@[^a-z0-9_]@i', '', $value );
  }

can be changed to:

  function usu_cleanse( $value ) {
    return preg_replace( '@[^a-z0-9_\%]@i', '', $value );
  }

Now the Percent Character (%) stays in the URL for $_GET usage.

 

But thats not my success, the question allready was asked on 1st February of 2012 by @@zipicip in #3581 of this thread.

 

SEE YA

Denzel.

Share this post


Link to post
Share on other sites

@@piernas

 

I just installed this and get the following error:

 

Warning: Failed: Unable to open database: unable to open database file in /home/tikitx10/public_html/catalog/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 103

Fatal error: Call to a member function query() on null in /home/tikitx10/public_html/catalog/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 196

Share this post


Link to post
Share on other sites

What is your PHP version?

 

 

@@piernas

 

I just installed this and get the following error:

 

Warning: Failed: Unable to open database: unable to open database file in /home/tikitx10/public_html/catalog/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 103

Fatal error: Call to a member function query() on null in /home/tikitx10/public_html/catalog/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 196

Share this post


Link to post
Share on other sites

Hello, Nice work.

 

 

Is there an option to disable the '.php' or '.html' extensions?

 

 

RewriteCond %{REQUEST_FILENAME} ! - f

RewriteRule ^([^\.]+)$ $1.html [NC,L]

 

RewriteCond %{REQUEST_FILENAME} ! - f

RewriteRule ^([^\.]+)$ $1.php [NC,L]

 

have no effect.

 

Thanks.

Share this post


Link to post
Share on other sites

Also in some products the osCID came up.

 

Admin:

Configuration:

Sessions: Force Cookie Use: True

 

Fixed that.

 

You might want to add it to the documentation.

Share this post


Link to post
Share on other sites

I had an interesting problem with some products.

 

A 'Rubiks cube 3x3' generated a webpage something  like   Rubiks3ÃÂ__3.html  Not found.

 

Editing the product name to 'Rubiks cube 3 by 3' fixed it. Then changing it back exactly like the original 'Rubiks cube 3x3'  also then worked!!

A few other random products also have displayed this.

 

I found this link: http://stackoverflow.com/questions/1344692/i-need-help-fixing-broken-utf8-encoding

 

If its a real problem maybe that might help.

 

Ta Muchly.

Share this post


Link to post
Share on other sites

@@piernas

 

I just installed this and get the following error:

 

Warning: Failed: Unable to open database: unable to open database file in /home/tikitx10/public_html/catalog/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 103

 

Fatal error: Call to a member function query() on null in /home/tikitx10/public_html/catalog/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 196

 

 

Have you checked if sqlite3 extensions is isntalled on your server? If it's not you can choose another method for cache under configuration.

Share this post


Link to post
Share on other sites

@@piernas

 

Hi,

 

I have just tried to install and experienced the same error as the other users have recently posted:

 

Warning: Failed: Unable to open database: unable to open database file in /home/anc10699/public_html/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 103

Fatal error: Call to a member function query() on null in /home/anc10699/public_html/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 196

 

I have bootstrap edge and PHP 5.6.14. I do not believe the server my site is hosted on has sqlite. I don't know what sqlite is but ran a test I found on the internet to test if it is installed and it confirmed it wasn't.

 

I note your suggestion to the prevoius poster that they could change the method for cache in configuration.

Problem is, accessing the the SEO5 menu area in admin results in the same error displaying and no options can be selected. 

Is there any other way to change the method for cache? e.g. modfiy the setting in the database directly?

 

Peter


PROUDLY PASSIONATE PHOENIX SUPPORTER

Full-time I am a C-suite executive of a large retail company in Australia. In my spare time, I enjoying learning about web-design.

Download the latest version of CE Phoenix from gitHub here

Join the Phoenix Club. Become a Phoenix Supporter.  Gain access to special codes and modules and help the project thrive. Read here

 

Share this post


Link to post
Share on other sites

Quick update,

 

 

@@piernas

 

Hi,

 

I have just tried to install and experienced the same error as the other users have recently posted:

 

Warning: Failed: Unable to open database: unable to open database file in /home/anc10699/public_html/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 103

Fatal error: Call to a member function query() on null in /home/anc10699/public_html/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 196

 

I have bootstrap edge and PHP 5.6.14. I do not believe the server my site is hosted on has sqlite. I don't know what sqlite is but ran a test I found on the internet to test if it is installed and it confirmed it wasn't.

 

I note your suggestion to the prevoius poster that they could change the method for cache in configuration.

Problem is, accessing the the SEO5 menu area in admin results in the same error displaying and no options can be selected. 

Is there any other way to change the method for cache? e.g. modfiy the setting in the database directly?

 

Peter

 

 

Quick update,

 

Reinstalling my stores database allowed me to get back in to the SE05 area and quickly change the cache method.

Only 'file' works as a cache option.

 

1. Selecting mysql results in error messages at bottom of my page displaying:

 

Warning: mysqli_error() expects parameter 1 to be mysqli, null given in /home/.../public_html/includes/functions/database.php on line 50

INSERT INTO `usu_cache` (cache_name, cache_data, cache_date) VALUES ('', '', '2017-01-29 18:20:28')

[TEP STOP]

 

2. Alternatively, selecting the memcache option returns an error saying the function was not found:

 

Fatal error: Class 'Memcache' not found in /home/.../public_html/includes/modules/ultimate_seo_urls5/cache_system/memcache.php on line 2

 

 

Aside from that, it appears to be working, will report back if there are any other issues.

 

Is there any material disadvantage to using file cache as opposed to the other options?

 

Thanks,

 

Peter

Edited by peterpil19

PROUDLY PASSIONATE PHOENIX SUPPORTER

Full-time I am a C-suite executive of a large retail company in Australia. In my spare time, I enjoying learning about web-design.

Download the latest version of CE Phoenix from gitHub here

Join the Phoenix Club. Become a Phoenix Supporter.  Gain access to special codes and modules and help the project thrive. Read here

 

Share this post


Link to post
Share on other sites

@@peterpil19 I have no idea on why USU is not passing the values to mysql; and seems your host doesn't support memcache.

anyway I have it running with file option enabled and it's working fine here.

Share this post


Link to post
Share on other sites

Just uploaded a new revision:

 

R2.07 (january 2017):
--------------------------
- Removed support for versions lower than 2.3.4 responsive
- Removed long arrays support - only superglobals used.
- Changed remaining replaces for filenames and database tables variables to strings on page modules.
- Included character conversion packs to uploads directory - no need of copying the files manually. You can remove unused languages safely fif you wish.
  These packs have been converted to UTF-8.
- Added several small fixes from support forum users.
- Modified install instructions.
- Added new box and navbar modules for multilanguage support.

TODO: Improve multilanguage support (no 301 redirects.).

Share this post


Link to post
Share on other sites

And after spending most of this weekend inspecting the code and trying code, there's still a thing I cannot find how to do: A real multilanguage support for switching language modules or sitemaps.

 

I mean, the navbar or box modules shows the language flags. For example, if you are in index and your primary language is spanish and a second language say english, you'll have a link to index.php (spanish index) and index.php/en (english index), This is great, but if you have a  product called 'Deliciosas galletas' (spanish) and 'Delicious cookies' (eglish) the links will be:

Spanish (default) link:

/deliciosas-galletas-p-1151.html

English link:

/en/deliciosas-galletas-p-1151.html

Once you switch to english the links changes:

Spanish (default) link:

/delicious-cookies-p-1151.html

English link:

/en/delicious-cookies-p-1151.html

Note the module takes the products title in the current language to construct the link instead of using the link's target language.

I've tried to use Usu_Main::i()->setVar( 'languages_id', $result_language ); to set the language for USU before the tep_href_link function, but it doesn't take the changes inmediately -  I mean the first link produced is done with the original value. If you don't change it again then the value is changed and the rest of the links on the page are produced in $result_language... weird!

 

It's not a big problem because those links are 301 redirected to the correct ones, but it's a really strange behavior. If somebody could help with this issue it would be great.

 

Share this post


Link to post
Share on other sites

@@piernas

 

@@peterpil19 I have no idea on why USU is not passing the values to mysql; and seems your host doesn't support memcache.

anyway I have it running with file option enabled and it's working fine here.

 

No worries,

 

I have it on file cache option and it is working perfectly.

 

Thank you for an exceptional add on.

 

 

Peter


PROUDLY PASSIONATE PHOENIX SUPPORTER

Full-time I am a C-suite executive of a large retail company in Australia. In my spare time, I enjoying learning about web-design.

Download the latest version of CE Phoenix from gitHub here

Join the Phoenix Club. Become a Phoenix Supporter.  Gain access to special codes and modules and help the project thrive. Read here

 

Share this post


Link to post
Share on other sites

Only 'file' works as a cache option.

 

1. Selecting mysql results in error messages at bottom of my page displaying:

 

Warning: mysqli_error() expects parameter 1 to be mysqli, null given in /home/.../public_html/includes/functions/database.php on line 50

INSERT INTO `usu_cache` (cache_name, cache_data, cache_date) VALUES ('', '', '2017-01-29 18:20:28')

[TEP STOP]

 

 

I believe to get the mysql option working you need to add a line in includes/modules/ultimate_seo_urls5/cache_system/mysql.php

 

Change this

    public function store( array $registry_vars = array() ) {
      if ( false !== self::$cache_on  ) {
        if ( false !== $this->insert ) {
          $data = serialize( $registry_vars ); // Serialize the registry of data
          $rawdata = base64_encode( gzdeflate( $data ) ); // encode and deflate
          $targets = array( ':cache_name', ':cache_data', ':cache_date' );
          $replacements = array( tep_db_input( self::$cache_name ), tep_db_input( $rawdata ), date( "Y-m-d H:i:s" ) );
          $query = str_replace( $targets, $replacements, $this->insert_query );
          Usu_Main::i()->query( $query );
        }
      }
    } // end method

to this

    public function store( array $registry_vars = array() ) {
		tep_db_connect();
      if ( false !== self::$cache_on  ) {
        if ( false !== $this->insert ) {
          $data = serialize( $registry_vars ); // Serialize the registry of data
          $rawdata = base64_encode( gzdeflate( $data ) ); // encode and deflate
          $targets = array( ':cache_name', ':cache_data', ':cache_date' );
          $replacements = array( tep_db_input( self::$cache_name ), tep_db_input( $rawdata ), date( "Y-m-d H:i:s" ) );
          $query = str_replace( $targets, $replacements, $this->insert_query );
          Usu_Main::i()->query( $query );
        }
      }
    } // end method

(added tep_db_connect(); )

 

I'm 99% sure that's all I had to do.


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×