Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

hi there, anyone can help me to fix this problem in my website? i get error on my website like this:

 

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/gifts2u/public_html/includes/functions/database.php on line 19

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/gifts2u/public_html/includes/functions/database.php:19) in /home/gifts2u/public_html/includes/functions/sessions.php on line 102

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/gifts2u/public_html/includes/functions/database.php:19) in /home/gifts2u/public_html/includes/functions/sessions.php on line 102

Warning: Cannot modify header information - headers already sent by (output started at /home/gifts2u/public_html/includes/functions/database.php:19) in /home/gifts2u/public_html/includes/modules/ultimate_seo_urls5/main/validator.phpon line 178

Warning: Cannot modify header information - headers already sent by (output started at /home/gifts2u/public_html/includes/functions/database.php:19) in /home/gifts2u/public_html/includes/modules/ultimate_seo_urls5/main/validator.phpon line 179

 

Please help, thank you very much

Share this post


Link to post
Share on other sites

Hi Everyone

 

I have gotten this wonderful addon working on a 2.3.4 bootstrap edge.

 

Just wanted to know if this was normal? The URL's being created look like this when you go into product info:

 

http://localhost/graphics-cards/matrox-g200-mms-p-1.html

 

Is this normal? Why I ask is the main category is missing from the link which is Hardware. I would have thought the link would look like this:

 

http://localhost/hardware/graphics-cards/matrox-g200-mms-p-1.html

 

How can I get the main category added to URL please?

Share this post


Link to post
Share on other sites

@@Johnatan, yeah, you only get the "next of kin" category with the existing USU5. By the comments in the codes what you wanted may have been on the todo list...I got what you wanted plus getting rid of that cPath thing working on a live system but I ran out of time to make it more robust...I wonder what happened to FWR?

 

Hi cluster

 

Any chance you can share that code please to show parent category in URL?

Share this post


Link to post
Share on other sites

Hi,

 

I installed oscommerce 2.3.4 with English and Chinese languages.

It worked fine with multi language.

After i installed Ultimate Seo Urls 5, the Chinese page can't get correct url.

i attached the picture of the incorrect url.

post-339363-0-15008800-1464221973_thumb.png

 

Please help, thank you!

 

jerry

Edited by ustcm

Share this post


Link to post
Share on other sites

I changed My oscommerce store to the last version 2.3.4. I use the extra usu5 XML Site Maps to generate my sitemaps. But now I have a problem with the sitemapIndex.xml. It shows the osCsid=, which is bad for google.

 

I don't know how to solve this problem. Is there a solution?

 

Thank you.

Share this post


Link to post
Share on other sites

I have this plugin installed, and it's working great in almost every case.

 

There are some products in my store that have characters in their name that aren't too common, such as ê. When this character exists in the product name, it gets stuck in the URL by the plugin, and the product page will not load when I attempt to navigate to it. The product does show up in the list of products just fine, and when you mouse over the URL has the funny character in it, but looks otherwise legit.

 

When I try to navigate to the product page I get an error page saying that the page cannot be displayed, after it thinks about it for a few minutes. All the other product pages work, but the items that have such characters in their names do not. Can you add some kind translation to convert this character list to their nearest vowel/letter equivalent in the URL? Or perhaps come up with some other solution? Here's the complete list of offenders:

ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖÙÚÛÜÝßàáâãäåæçèéêëìíîïðñòóôõöùúûüýÿ

 

I found some related info here:

http://cubiq.org/the-perfect-php-clean-url-generator

 

Before I implement my own change, I thought I'd see if you would incorporate a fix for everyone in the package.

 

Thanks for any feedback / help.

Share this post


Link to post
Share on other sites

It already exists. Look for 'character_conversion_pack' directory under extras in the package you downloaded.

Share this post


Link to post
Share on other sites

Hi at all!

 

I'm struggling with my new osc 2.3.4 and this SEO add on. As soon as i turn it on, the rewrite seems to work, but no product and other pages are displayed (not found). Details are listed below, if anyone would have any idea what i'am doing wrong....you'll save my Weekend! I replaced the Domain Name with mydomain just for the Forum.

Thanks for any ideas!
 

Disabled SEO
http://www.mydomain.ch/product_info.php/spice-world-bbq-rub-p-137

 

Enabled SEO (Option rewrite)
http://www.mydomain.ch/spice-world-bbq-rub-p-137.html
 

.htaccess

RewriteEngne ON

Options +FollowSymLinks

RewriteBase /

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}



 

Share this post


Link to post
Share on other sites

I have Oscommerce setup with 2.3 customized, SEO Urls 5 already installed but in clean url it shows model number of different product, can you please help a bit where to make change for this to fix the issue.

Share this post


Link to post
Share on other sites

Good day,
I have installed this contribution and I have a question. My category structure is something like:
Top › Catalog › APRILIA › AF1 FUTURA 125 › 1990-1992 › All years ›Body

the category url is like:
website/all-years/body-c-25_51_52_53_54.html
it contains only the parent for the body category.

I would like the url to contain more parents so the url to look like:
website/aprilia/af1-futura-125/1990-1992/all-years/body-c-25_51_52_53_54.html

Is that possible?

Also, the product page, now it is:
website/fuel-tank-white/body-p-575.html
I would like to have a url like:
website/fuel-tank-white/aprilia/af1-futura-125/1990-1992/all-years/body-p-575.html

 

If anyone could point me to the right direction to make the modifications I would be greatful!

Thank you, Constantin

 

Share this post


Link to post
Share on other sites

@@mendoh this addon was not updated to work as a drop on top install with 2.3.4.

 

It must be installed manually (editing the php files in your store) by following the instructions - which also have NOT been updated for 2.3.4. It does work, when installed correctly, in both 2.3.4 and the community bootstrap versions - and very well. Obviously this makes things difficult, however the original developer of this addon no longer comes around....

 

There are other URL rewritters that work just as well, are more supported, and have updated installs and instructions for 2.3.4. Search the addon area for SEO URLS.

is this the correct one for BS/Edge?

 

https://github.com/clustersolutions/Ultimate_Seo_Urls_5_PRO_BS

 

also, can anyone chime in on the pros/cons compared with the other seo url plugins

Share this post


Link to post
Share on other sites
I have this addon installed to have the better url.My oscommerce is 2.3.4 960 grid system
We also decide to use the multi language support so now all the urls are like this:
 
www.mydomain.it/productname-p-id.html for english
www.mydomain.it/it/nomeprodotto-p-id.html for italian
 
Once we have install this we have a problem with the shopping cart in Italian side. 
In the product page if we press the action botton "add to cart" we go in the shopping card page but it did non save product id and option, give the message "your shopping card is empty"
If you are in a category page and we use the botton add to cart that is display in the product anteprima is working
 
All English is working fine.
 
If i remove Multi language support the cart is working well
 
Can you help me with this?

My oscommerce is 2.3.4 960 grid system

Share this post


Link to post
Share on other sites

Hi all,

 

sorry if this has been addressed before, but I couldn't find any reference to it.

 

For the purpose of migration to another platform, I need to export the URL's associated to each product and category page. I understand these are generated, encrypted/hashed and cached in the database under "usu_cache". Is there an easy way to export that information to a xls / csv file ? (no obvious way to decrypt).

 

The single suggested workaround I could find was to modifiy the Google Base module to output only the link and product id.

 

OSC v2.2 RC2 & SEO Urls 5

 

Thank you,

Razvan.

Share this post


Link to post
Share on other sites

Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

@@frankl, thanks for the suggestion ! Unfortunately, it's too late for that decision as we're already close to launching the new platform.

 

Still waiting for input on how to export the permalinks.

 

Thank you,

Razvan.

Share this post


Link to post
Share on other sites

@@piernas well done... and over due.

 

Of course it comes just days after I updated my install... removing all the constants for EDGE.

 

Sorry to hear I'm late - I'm also doing that stuff and I was thinking it could be ouseful.

Share this post


Link to post
Share on other sites

Dear @@piernas

 

I do not know if you can help me but could you have a look in my post down here?

Seems that with my template the the multi language support do not work properly as is not saving the data for the shopping cart

Do you think this should be solved with your version? As I have the 2.3.4 960 grid system

 

 

I have this addon installed to have the better url.My oscommerce is 2.3.4 960 grid system
We also decide to use the multi language support so now all the urls are like this:
 
www.mydomain.it/productname-p-id.html for english
www.mydomain.it/it/nomeprodotto-p-id.html for italian
 
Once we have install this we have a problem with the shopping cart in Italian side. 
In the product page if we press the action botton "add to cart" we go in the shopping card page but it did non save product id and option, give the message "your shopping card is empty"
If you are in a category page and we use the botton add to cart that is display in the product anteprima is working
 
All English is working fine.
 
If i remove Multi language support the cart is working well
 
Can you help me with this?

My oscommerce is 2.3.4 960 grid system

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×