Latest News: (loading..)
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

4,317 posts in this topic

@@Dj-Viper

 

Question, i have in Application_top.php this

 

// include the language translations
$_system_locale_numeric = setlocale(LC_NUMERIC, 0);
require(DIR_WS_LANGUAGES . $language . '.php');
 // Ultimate SEO URLs v2.2d
 if ((!defined(SEO_ENABLED)) || (SEO_ENABLED == 'true')) {
   include_once(DIR_WS_CLASSES . 'seo.class.php');
   if ( !is_object($seo_urls) ){
     $seo_urls = new SEO_URL($languages_id);
   }
 }
setlocale(LC_NUMERIC, $_system_locale_numeric);
 
 
Is it good placed or need it to be under setlocale. btw. using 2.3.4. bootstrap.

I'm not sure what you are asking here....

Share this post


Link to post
Share on other sites

@@greasemonkey

 

The following at the moment :

 

// include the language translations
$_system_locale_numeric = setlocale(LC_NUMERIC, 0);
require(DIR_WS_LANGUAGES . $language . '.php');
 // Ultimate SEO URLs v2.2d
 if ((!defined(SEO_ENABLED)) || (SEO_ENABLED == 'true')) {
   include_once(DIR_WS_CLASSES . 'seo.class.php');
   if ( !is_object($seo_urls) ){
     $seo_urls = new SEO_URL($languages_id);
   }
 }
setlocale(LC_NUMERIC, $_system_locale_numeric);
 
or better to place the seo urls under like this.
 
// include the language translations
$_system_locale_numeric = setlocale(LC_NUMERIC, 0);
require(DIR_WS_LANGUAGES . $language . '.php');
setlocale(LC_NUMERIC, $_system_locale_numeric);
 // Ultimate SEO URLs v2.2d
 if ((!defined(SEO_ENABLED)) || (SEO_ENABLED == 'true')) {
   include_once(DIR_WS_CLASSES . 'seo.class.php');
   if ( !is_object($seo_urls) ){
     $seo_urls = new SEO_URL($languages_id);
   }
 }
 
In the setup of Ultmate SEO Urls stands find // include the language translations
  require(DIR_WS_LANGUAGES . $language . '.php');
 
and place after the seo urls stuff. but i have two instances of LC Numeric stuff
 
Greetings, Anne

Share this post


Link to post
Share on other sites

upon installing the addon what it does is, index.php/dvd-man-dvd-man98-c-2_26_120

 

output should be, something... domain*com/aviator-piloten-sonnenbrille-transparent-p-725.html

 

any ideas?

Share this post


Link to post
Share on other sites

Hello

 

I have a simple question

 

Is is possible to change the letter -p- diplayed in the link  into books  and the -c- into books-category?

 

Even better if I could change that letter depending on the language.

 

Thank you in advance.

 

Luke

 

 

Share this post


Link to post
Share on other sites

@---luke---

 

It is possible to change, but not easy at all. -p- and -c- are used in many places as identifier. You would need to search for them in all files included in the SEO URLs folder plus rewrite rules in the main .htaccess and change them.

You may get in trouble if you are using "books" or "books-category" in any product or category name.

Depending on language is definitive not possible.

I wouldn't touch this, it's not important for SEO purpose.

Edited by raiwa

Share this post


Link to post
Share on other sites

Hi guys, very thanks for your amazing job I used it with old Osc version without any problem, now I'm trying to install in OSC 2.3.4 but I think the installation document  is not valid for this version, probably in 2.3.4 this lines (I don't know if there are some other) are changed and I've problem to modify the code for correct installation. Does it exist a documentation for 2.3.4 or this add is imcompatible with it?

Really thanks 

 function tep_redirect($url) { 
    if ( (strstr($url, "\n") != false) || (strstr($url, "\r") != false) ) {  
      tep_redirect(tep_href_link(FILENAME_DEFAULT, '', 'NONSSL', false)); 
    } 

    if ( (ENABLE_SSL == true) && (getenv('HTTPS') == 'on') ) { // We are loading an SSL page 
      if (substr($url, 0, strlen(HTTP_SERVER)) == HTTP_SERVER) { // NONSSL url 
        $url = HTTPS_SERVER . substr($url, strlen(HTTP_SERVER)); // Change it to SSL 
      } 
    } 

    header('Location: ' . $url); 

    tep_exit(); 
  }
  $PHP_SELF = (((strlen(ini_get('cgi.fix_pathinfo')) > 0) && ((bool)ini_get('cgi.fix_pathinfo') == false)) || !isset($HTTP_SERVER_VARS['SCRIPT_NAME'])) ? basename($HTTP_SERVER_VARS['PHP_SELF']) : basename($HTTP_SERVER_VARS['SCRIPT_NAME']);

// set php_self in the local scope
  $PHP_SELF = (((strlen(ini_get('cgi.fix_pathinfo')) > 0) && ((bool)ini_get('cgi.fix_pathinfo') == false)) || !isset($HTTP_SERVER_VARS['SCRIPT_NAME'])) ? basename($HTTP_SERVER_VARS['PHP_SELF']) : basename($HTTP_SERVER_VARS['SCRIPT_NAME']);

Share this post


Link to post
Share on other sites

Hi, I am upgrading my site to Osc 2.3.4BS PHP5.6 and on test version i am trying to force test.mysite/index.php to test.mysite.

In admin I set  Force www.mysite.com/ when www.mysite.com/index.php to TRUE, but it doesn't seem to have any effect.

am i missing something?

Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

@@gummipingvin, when you say it works like it should I assume you are saying with file cache and not sqlite. Ok, switch to file cache, all is ok? Then remove the sqlite db cache file. Now, switch back to sqlite cache. What's the error message? So it shouldn't work with sqlite cache if it can't create the cache file. I think under normal circumstance it would recreate the sqlite cache file...if it is not it should complain and you would need to fix whatever's necessary to stop it from complaining...

 

Hope this helps!

For reference and if others experience problems, I fixed this SQLite problem by updating the USU5 and following the fixes in this thread:

http://forums.oscommerce.com/topic/407692-fwrs-usu5-for-bs/

 

So thank you for the solution @@clustersolutions, it did the trick!

 

Edited by gummipingvin

Share this post


Link to post
Share on other sites

Side question, anyone knows if I can somehow easy "redirect" the product review links we have with -pr- into our -p- pages (Product-info.php) ? 

We don't use the reviews, so it makes no sense, but apperaently we have alot of links to these and now I get alot of errors in Google Webmaster tools for these not working, I tried just to send it to product_info.php in the .htaccess file, but that did not work, it just sents me to the frontpage? :)

Anyone with insight in the module that can help me? :)

Share this post


Link to post
Share on other sites

Hi, I am upgrading my site to Osc 2.3.4BS PHP5.6 and on test version i am trying to force test.mysite/index.php to test.mysite.

In admin I set  Force www.mysite.com/ when www.mysite.com/index.php to TRUE, but it doesn't seem to have any effect.

am i missing something?

Any help would be greatly appreciated.

Is everything else working fine? Could it be your .htaccess file?

Share this post


Link to post
Share on other sites

Hi FWR Media,

 

I saw your post about the Chinese charterer on url around page 138, do you have solution for that problem on the seo urls 5 pro version? 

 

thank you

 

ken

Share this post


Link to post
Share on other sites

@---luke---, you can change them and I had changed them before and, typically, there are two places that you need to make the modifications. For example, for the -c- marker, you would need to make changes inside the .htaccess and includes/modules/ultimate_seo_urls5/page_modules/index.php. I am gonna extract the modifications I had made in my files...

 

In .htaccess:

  RewriteRule ^([a-z0-9/-]+)/category-([0-9_]+).html$ index.php [NC,L,QSA]

& in includes/modules/ultimate_seo_urls5/page_modules/index.php:

    protected $dependencies = array( 'cPath'            => array( 'marker'     => '/category-',
                                                                  'query'      => ...

One caveat, you marker as it implies will become a marker, so in your case -book- will become problematic since a book title "A Good Book" will not become a-good-book-book-23.html. <---look now you don't have a unique marker for returning the products_id...

 

The rest you should be able to figure it out...

 

 

 

Hello

 

I have a simple question

 

Is is possible to change the letter -p- diplayed in the link  into books  and the -c- into books-category?

 

Even better if I could change that letter depending on the language.

 

Thank you in advance.

 

Luke

Share this post


Link to post
Share on other sites

@@gummipingvin, If that's the case the best way would be to just have those links removed from Google using the webmaster tool. May be also makes sure that those links don't get indexed?

 

 

Side question, anyone knows if I can somehow easy "redirect" the product review links we have with -pr- into our -p- pages (Product-info.php) ? 

We don't use the reviews, so it makes no sense, but apperaently we have alot of links to these and now I get alot of errors in Google Webmaster tools for these not working, I tried just to send it to product_info.php in the .htaccess file, but that did not work, it just sents me to the frontpage? :)

Anyone with insight in the module that can help me? :)

Share this post


Link to post
Share on other sites

@@denny8x, your answer may be in this link...I had it working in 234 b4 I went BS.

 

https://github.com/clustersolutions/Ultimate_Seo_Urls_5_PRO_BS

 

 

Hi guys, very thanks for your amazing job I used it with old Osc version without any problem, now I'm trying to install in OSC 2.3.4 but I think the installation document  is not valid for this version, probably in 2.3.4 this lines (I don't know if there are some other) are changed and I've problem to modify the code for correct installation. Does it exist a documentation for 2.3.4 or this add is imcompatible with it?

Really thanks 

 function tep_redirect($url) { 
    if ( (strstr($url, "\n") != false) || (strstr($url, "\r") != false) ) {  
      tep_redirect(tep_href_link(FILENAME_DEFAULT, '', 'NONSSL', false)); 
    } 

    if ( (ENABLE_SSL == true) && (getenv('HTTPS') == 'on') ) { // We are loading an SSL page 
      if (substr($url, 0, strlen(HTTP_SERVER)) == HTTP_SERVER) { // NONSSL url 
        $url = HTTPS_SERVER . substr($url, strlen(HTTP_SERVER)); // Change it to SSL 
      } 
    } 

    header('Location: ' . $url); 

    tep_exit(); 
  }
  $PHP_SELF = (((strlen(ini_get('cgi.fix_pathinfo')) > 0) && ((bool)ini_get('cgi.fix_pathinfo') == false)) || !isset($HTTP_SERVER_VARS['SCRIPT_NAME'])) ? basename($HTTP_SERVER_VARS['PHP_SELF']) : basename($HTTP_SERVER_VARS['SCRIPT_NAME']);

// set php_self in the local scope
  $PHP_SELF = (((strlen(ini_get('cgi.fix_pathinfo')) > 0) && ((bool)ini_get('cgi.fix_pathinfo') == false)) || !isset($HTTP_SERVER_VARS['SCRIPT_NAME'])) ? basename($HTTP_SERVER_VARS['PHP_SELF']) : basename($HTTP_SERVER_VARS['SCRIPT_NAME']);

Share this post


Link to post
Share on other sites

@@gummipingvin Thank you very much for the reply.

 

I am very confused now. I am under assumption that if i use standard URI format, then there will be no changes in my .httaccess file.

In my old setup i used URI rewrite and had changes in .httaccess file, and it was great, but i switched to new host and it works kind of funny - i cant really explain it, but it definitely doesn't work the same way it did before. Also I get my URLs rejected by Yahoo-Shopping, because they do not accept redirects. 

I was hoping to get away from changing .httacces in my new setup.

I guess i just don't understand what Force www.mysite.com/ does if i need to change it in .httaccess

 

Please help. my site

 

Is everything else working fine? Could it be your .htaccess file?

Share this post


Link to post
Share on other sites

Hi

 

Each time I update products thru admin  then check on web site I get the following

 

Warning: mysqli_free_result() expects parameter 1 to be mysqli_result, boolean given in /home/-/public_html/includes/classes/seo.class.php on line 152

 

If I simply refresh the site, the message goes away and the site loads correctly.

 

Can anyone tell me what this means, and what, if anything, I need to do.

 

Many thanks

 

Grandpa

 

(This is a duplicate post as I inadvertently posted in PHP / SQL / Web Design)

Edited by burt

Share this post


Link to post
Share on other sites

@@grandpaj

Can you double check which seo addon you're using?  This version be FWR doesn't use that file.  On that note, I would not switch to this version on a new site.  FWR hasn't been around for a while and this isn't really being maintained.

 

However, to answer your question.  It's probably returning false (boolean) and there should be a conditional statement to make sure there is a result to free.

Edited by John W

Share this post


Link to post
Share on other sites

@@John W

 

Hi John

 

Thanks for your reply, however I havent a clue what " It's probably returning false (boolean) and there should be a conditional statement to make sure there is a result to free" means, or even what I need to do to sort it. Any help on what to do would be appreciated.

Coul there be a file somewhere that I need to remove, I did try  Search Friendly URLS but couldn't get it to work correctly, so removed it

 

I am using.

Ultimate_SEO_URLSv22d_14a

 

Hope that helps

 

Many thanks

John

 

I think I should have posted here, so have erposted.

http://forums.oscommerce.com/topic/154166-contribution-ultimate-seo-urls-v21-by-chemo/page-360

Edited by grandpaj

Share this post


Link to post
Share on other sites

No, there's nothing you need to remove and you probably don't have to sweat this much.  Basically, the function mysqli_free_result expects to have data to free but if there is no data to free it returns that error becaue it's not getting what it expects.  I wouldn't really sweat this error but if this is outputing to your screen you need to turn erro reporting off to the screen and only output to a file.  You really don't want to output errors to a screen on a live domain. 

Share this post


Link to post
Share on other sites
Some days ago I downloaded certificate TLS. Somehow I managed to make site work but I have a problem. If I have on Enable SEO URLs 5 while turning pages on product listing all web site crashes down. When I jump on next page I get url line "https://www.mydomain.comdir_wss_http_catalogcategoryname-c-341.html/?page=2&sort=2a"andbrowser comment ERR_NAME_NOT_RESOLVED​.When I turn module off SEO URL works fine. I deleted all cache. Whats wrong? 

 

my configure.php:

 

.....

efine('HTTP_SERVER', 'https://www.mydomain.com');

 

define('HTTPS_SERVER', 'https://www.mydomain.com');

 

define('ENABLE_SSL', true);

 

define('HTTP_COOKIE_DOMAIN', 'www.mydomain.com');

 

define('HTTPS_COOKIE_DOMAIN', 'www.mydomain.com');

 

define('HTTP_COOKIE_PATH', '/');

 

define('HTTPS_COOKIE_PATH', '/');

 

define('DIR_WS_HTTP_CATALOG', '/');

 

define('DIR_WS_HTTPS_CATALOG', '/');

........etc

 

 

and  .htaccess:

 

RewriteEngine On

 

RewriteCond %{HTTPS} off

 

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

 

 

 

 

# If you are getting errors you may need to comment this out like ..

 

# Options +FollowSymLinks

 

Options +SymLinksIfOwnerMatch

 

<IfModule mod_rewrite.c>

 

RewriteEngine On

 

 

# RewriteBase instructions

 

# Change RewriteBase dependent on how your shop is accessed as below.

 

# http://www.mysite.com = RewriteBase / 

 

# http://www.mysite.com/catalog/ = RewriteBase /catalog/ 

 

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ 

 

 

# Change RewriteBase using the instructions above 

 

RewriteBase / 

 

RewriteRule ^([a-z0-9/-]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-c-([0-9_]+).html$ index.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA]

 

 

# Articles contribution

 

RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]

 

# Information pages

 

RewriteRule ^([a-z0-9/-]+)-i-([0-9]+).html$ information.php [NC,L,QSA]

 

# Links contribution

 

RewriteRule ^([a-z0-9/-]+)-links-([0-9_]+).html$ links.php [NC,L,QSA]

 

# Newsdesk contribution

 

RewriteRule ^([a-z0-9/-]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA]

 

RewriteRule ^([a-z0-9/-]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA]

 

 

</IfModule>

Share this post


Link to post
Share on other sites

I'm using the usu5_sitemaps to generate my xml sitemaps in my oscommerce 2.3.4 store. And now I have some problems with the sitemapProducts.

 

I've suddenly started getting a few errors show up in Webmaster Tools regarding the sitemapProducts.xml.  When I look at the XML file, the the entries with problems are:

 

<url>
    <loc></loc>
    <lastmod>2013-01-14</lastmod>
    <changefreq>weekly</changefreq>
    <priority>0.5</priority>
  </url

 

<url>
    <loc></loc>
    <lastmod>2012-09-06</lastmod>
    <changefreq>weekly</changefreq>
    <priority>0.5</priority>
  </url>

 

The errors are always almost in the same position.

 

If someone could help me to find where the problem is I'll be grateful.

 

Regards

Share this post


Link to post
Share on other sites

Hi everybody.

I tried to install this contribution but apparently there is no way for me to get it to work.

I performed a full "drop-on-top" installation (very first contribution on a fresh 2.3.4 install!), however, each and every time I turned the contribution on, it cripples my whole webshop.

 

Here is what happens after turning on the contribution:
1) clicking on any product link redirects me to a "not found" page
2) enabling multi-language support does not work at all, it only gives a fully blank page
3) I am unable to use the standard .htaccess file, I only must use the htaccess.txt file (which I found inside the "extras" folder and copied to webshop directory), otherwise I am getting a 505 internal server error 
 
Is there anybody having any idea of what might be causing the above issues to happen?
I am seriously thinking of uninstalling the contribution completely...
 
Thank you

Share this post


Link to post
Share on other sites

@@mendoh this addon was not updated to work as a drop on top install with 2.3.4.

 

It must be installed manually (editing the php files in your store) by following the instructions - which also have NOT been updated for 2.3.4. It does work, when installed correctly, in both 2.3.4 and the community bootstrap versions - and very well. Obviously this makes things difficult, however the original developer of this addon no longer comes around....

 

There are other URL rewritters that work just as well, are more supported, and have updated installs and instructions for 2.3.4. Search the addon area for SEO URLS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now