Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

I'm at a loss here. I installed this contribution and everything installed without a hitch. When I went to my shop to check it everything was fine until I clicked on one of my products, I then got a completely blank page with "No input file specified' in the top left corner. I went through your file changes at the top of this forum page but with no luck. I know it has to be something simple I'm overlooking and I'm going to slap myself when I realize what an idiot I am for overlooking it but since I've been staring at code for going on 12 hours now, it all kind of runs together. I would greatly appreciate an suggestions you might have to unstick my stupid!!!!

Share this post


Link to post
Share on other sites

I don't know what this means if anything at all but per the installation instructions I typed the address www.mysite.com/index,php/test. The page that came up was the same page I get when using the contribution. A completely blank page with "no input file specified". I have been through this thread up, down, forwards and backwards. There are a couple of instances where someone is having the same problem I am but I can't find the solution anywhere in their conversations. Again, maybe I'm just stuck on stupid but I am unable to determine what is causing my problem. Since I can't figure out what's causing it, I can't figure out how to fix it. ANYBODY's help will be greatly appreciated. THANKS.

Share this post


Link to post
Share on other sites

@@bcleather

 

 

Try this:

 

1. Use Search-Engine Safe URLs (still in development)' to false.

 

2. 'Use Cache' to false

 

PS: To see the seo urls working its better to clear the cache and then check.


Like post..hit LIKE button.

 

osCommerce | Joomla | WordPress | Magento | SEO | CakePHP | CI

 

Guaranteed Website Speed Optimization!!

Share this post


Link to post
Share on other sites

I typed the address www.mysite.com/index,php/test.

 

 

Your server is set up not to accept path info as a part of the uri.

 

In .htaccess put: -

 

AcceptPathInfo On

Share this post


Link to post
Share on other sites

@Praful,

Both cache and SEO URL's are off. I should also mention that I am using version 2.3.2.

 

@@FWR Media,

I add the line to my htaccess.txt file and that shutdown the site. At this point maybe I should mention (or ask) I am supposed to change the htaccess.txt file to .htaccess on the server side, right? That's the only way it seems to have any effect at all. When I do i get a server configuration error.

Share this post


Link to post
Share on other sites

@Praful and FWR Media,

Below is my htaccess file, maybe this will help.

 

# If you are getting errors you may need to comment this out like ..

# Options +FollowSymLinks

Options +SymLinksIfOwnerMatch

<IfModule mod_rewrite.c>

RewriteEngine On

 

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

# Change RewriteBase using the instructions above

http://www.bearcreekleather.com = RewriteBase /

RewriteRule ^([a-z0-9/-]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-c-([0-9_]+).html$ index.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA]

# Articles contribution

RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]

# Information pages

RewriteRule ^([a-z0-9/-]+)-i-([0-9]+).html$ information.php [NC,L,QSA]

# Links contribution

RewriteRule ^([a-z0-9/-]+)-links-([0-9_]+).html$ links.php [NC,L,QSA]

# Newsdesk contribution

RewriteRule ^([a-z0-9/-]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA]

</IfModule>

Share this post


Link to post
Share on other sites

@@bcleather

 

Please read the instructions: -

 

documentation/install_files/install_complete.htm

 

If your server won't accept path based uris nore allow it to be set in .htaccess then you need to speak to your host .. or simply don't use path based uris .. use rewrite.

Share this post


Link to post
Share on other sites

http://www.bearcreekleather.com = RewriteBase /

 

Should be just: -

 

RewriteBase /

Share this post


Link to post
Share on other sites

@@FWR Media.

Thanks for the information. Some of the instructions were a little vague but it's working as of now. I changed the htaccess file and also changed the config. The only issue I'm having now is for some reason, the sitemapCategories.xml file had a date of 1969-12-31 at the end of it and google Webmaster Tools reports it as an error. Is this something that you know has been reported before or is this isolated to my site.

Share this post


Link to post
Share on other sites

After installing on 2.2 i get the following error

 

Catchable fatal error: Argument 1 passed to Installer_Class::setConfigConstants() must be an array, null given, called in /home/site/public_html/includes/modules/ultimate_seo_urls5/main/bootstrap.php on line 306 and defined in /home/site/public_html/includes/modules/ultimate_seo_urls5/database_install/installer_class.php on line 67

Share this post


Link to post
Share on other sites

@@bazmlb

 

Have a look at your error log .. there's something wrong with paths.

 

What version of PHP are you running?

Share this post


Link to post
Share on other sites

@@FWR Media

 

Have a look at your error log .. there's something wrong with paths.

 

What version of PHP are you running?

 

PHP Version 5.2.17

 

from the error logs

[sat Aug 18 06:47:24 2012] [error] [client 49.48.58.151] File does not exist: /home/site/public_html/404.shtml

[sat Aug 18 06:47:24 2012] [error] [client 49.48.58.151] File does not exist: /home/site/public_html/robots.txt

Edited by bazmlb

Share this post


Link to post
Share on other sites

@@bazmlb

 

Very odd . .check for the existence of the file: -

 

catalog/includes/modules/ultimate_seo_urls5/database_install/installer_constants.php

Share this post


Link to post
Share on other sites

When i click a product or category it loops back to the /intro page which is only meant to be seen once when they load the site the first time, this is the code, is there a way to fix that?

 

if (substr_count($_SERVER['PHP_SELF'],"/index.php") > 0 && !$_GET['cPath']) {

header("Location: /intro/");

exit;

}

 

require('includes/application_top.php');

Share this post


Link to post
Share on other sites

Change the method in admin to rewrite and make sure you have added the correct code to .htaccess as per the instructions.

 

That is poor code which will redirect any path based uri

Edited by FWR Media

Share this post


Link to post
Share on other sites

I have removed that code for now, turned on rewrite in the console and added htaccess, but get 404's when opening cats and products

Share this post


Link to post
Share on other sites

@@bazmlb Please read the instructions fully

 

Add the code from htaccess.txt to .htaccess making sure that RewriteBase is set correctly.

Share this post


Link to post
Share on other sites

ok, great thanks, that works, but if i set the product link url to "cp" it does not put a / between the category name and the product, it ends up like /bedsfourpost.html where beds is the cat name and product is fourpost

Share this post


Link to post
Share on other sites

/bedsfourpost.html where beds is the cat name and product is fourpost

 

USU5 cannot produce a uri like that.

Share this post


Link to post
Share on other sites

Thank you for the wonderful module. It worked perfectly on my multi-languages website. I have tested using the standard url format locally but it somwhow failed to work on the MyDaddy's server. I have then changed to url re-write method and it worked well for my english language but I got a "404 (Page Not Found) Error" on other languages. Am I missing anything? Any help is appreciated.

Share this post


Link to post
Share on other sites

@@cfemoca

 

Is your server very restricted? you need to be able to override settings via .htaccess.

 

Try adding the following to .htaccess: -

 

AcceptPathInfo On

 

Aslo PM me a personal link to the site in question so I can test.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello,

 

I have successfully installed seo urls 5 pro with multi language. French translation is doing fine including the character conversion of urls. When i added another language espanol character conversion of url is not working.

 

Any help is highly appreciated.

 

 

fgwapo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×