Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Sry - posted this in the wrong forum - this is for the Ultimate SEO Urls 5

 

I followed the the letter the installation, had no issues it seems, but my URL's aren't producing my products.

 

http://funkyrat.com/product_info.php/core-...de-supply-p-103

 

The categories aren't working either: http://funkyrat.com/index.php/joint-bone-care-c-18

 

Has anyone seen this issue, and what can I do to fix this issue?

 

Also receiving this error in my footer on the hompage:

 

 

Warning: file_put_contents(/home/content/f/u/n/funkyrat/html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/content/f/u/n/funkyrat/html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

Don't understand, everything seemed to work perfectly.

 

I don't suppose you are hosted with godaddy are you?

Share this post


Link to post
Share on other sites
Regular expressions and RewriteRules make my head explode under normal circumstances I have no wish to learn the whole new science of isapi rewrites lol, all I can think of is this ..

 

Looking at the isapi rewrite tutorials the flags need to have a space before them to separate from the expressions.

 

You seem to currently have ..

 

RewriteRule [^?]*-p-([0-9]+)\.html(?:\?(.*))? /product_info.php\?products_id=$1?2&$2[i,L]

 

Which I believe needs to be ..

 

RewriteRule [^?]*-p-([0-9]+)\.html(?:\?(.*))? /product_info.php\?products_id=$1?2&$2 [i,L]

 

Just a space after the $2 and before the [i,L]

 

It must be a rewrite issue .. hope this is it as I'm out of ideas.

 

That was the solution. The flags are working correct now and also the add to cart buttons, both with Cpath set to true or false. It didn't solve the problem with the standard option and header Tags. But that's no problem, because the rewrite option is working.

Thanks for helping.

Share this post


Link to post
Share on other sites

Hi

 

I just wonder if it is possible to use cyrillic letters in the URL names

 

Take a look at that address:

 

http://magazin-online.net/bg/израбо?...газин.html

 

the last part is in cyrillic and it works fine.

 

At he moment I use char conversion to convert whole bulgarian alphabet to latin. Like http://www.kupuvalnik.com/dynki-diesel-p-1001.html

While it works fine, I'd rather prefer to have it in cyrillic script in the URL, if possible.

Any ideas on how this might reflect on google searches if the URL has cyrillica chars?

Thanks


OSC beginner

Share this post


Link to post
Share on other sites
Hi

 

I just wonder if it is possible to use cyrillic letters in the URL names

 

Take a look at that address:

 

http://magazin-online.net/bg/израбо?...газин.html

 

the last part is in cyrillic and it works fine.

 

At he moment I use char conversion to convert whole bulgarian alphabet to latin. Like http://www.kupuvalnik.com/dynki-diesel-p-1001.html

While it works fine, I'd rather prefer to have it in cyrillic script in the URL, if possible.

Any ideas on how this might reflect on google searches if the URL has cyrillica chars?

Thanks

 

You have to have latin characters only in urls.

Share this post


Link to post
Share on other sites
It didn't solve the problem with the standard option and header Tags. But that's no problem, because the rewrite option is working.

Thanks for helping.

 

The header tags solution is described a few posts up. The problem is that header tags uses the unreliable $_SERVER['PHP_SELF'] instead of the correct $_SERVER['SCRIPT_NAME'] therefore where header tags may expect to receive e.g. index.php it instead receives /my-great-product-c-34 etc.

Share this post


Link to post
Share on other sites

Robert

 

Firstly, many thanks for all the work you have put into this excellent contribution. Installation was painless and I'm looking forward to moving higher up the search rankings when our site has been revisited by the bots.

 

One issue though (which may be unique to my site because I cannot find anyone with similar symptoms):

 

When I hover over a category link I see the following link, as expected, on my status bar:

http://www.omahonys.ie/catalog/schoolbooks-c-1230.html

 

When I click on the link, the following link is displayed in my address bar:

http://www.omahonys.ie/catalog/schoolbooks-c-0_1230.html

 

Somehow a zero has been added to the cPath and this is having significant consequences on other parts of my site.

 

This doesn't happen for all of my category links (the schoolbooks category is unique in that it has four levels) but I did see it temporarily on the Stationery category. I thought I had fixed the problem by temporarily disabling SEO URLs, clearing its cache, clearing the oscommerce categories cache and then re-enabling it. It seemed to work for a while but has reoccured again within a few hours.

 

I'm using osc 2.2ms2. This problem does not occur using our internal test version!

 

Any ideas or pointers? :huh:

 

Thanks again for your work on this.

Edited by leafyglade

Share this post


Link to post
Share on other sites
Robert

 

Firstly, many thanks for all the work you have put into this excellent contribution. Installation was painless and I'm looking forward to moving higher up the search rankings when our site has been revisited by the bots.

 

One issue though (which may be unique to my site because I cannot find anyone with similar symptoms):

 

When I hover over a category link I see the following link, as expected, on my status bar:

http://www.omahonys.ie/catalog/schoolbooks-c-1230.html

 

When I click on the link, the following link is displayed in my address bar:

http://www.omahonys.ie/catalog/schoolbooks-c-0_1230.html

 

Somehow a zero has been added to the cPath and this is having significant consequences on other parts of my site.

 

This doesn't happen for all of my category links (the schoolbooks category is unique in that it has four levels) but I did see it temporarily on the Stationery category. I thought I had fixed the problem by temporarily disabling SEO URLs, clearing its cache, clearing the oscommerce categories cache and then re-enabling it. It seemed to work for a while but has reoccured again within a few hours.

 

I'm using osc 2.2ms2. This problem does not occur using our internal test version!

 

Any ideas or pointers? :huh:

 

Thanks again for your work on this.

 

Well that's strange .. is this a live site or one that I could get access to?

Share this post


Link to post
Share on other sites
Well that's strange .. is this a live site or one that I could get access to?

 

Thanks for the fast response!

 

You should be able to access the site directly by clicking the links in my post or else go directly to www.omahonys.ie

 

The issue is now apparent under the College Books category. Sigh!

 

I have written a short program to call tep_href_link for the categories and it shows the following for College Books:

(page, parameters, connection, add_session_id) VALUES ARE index.php, cPath=1030, NONSSL,

http://www.omahonys.ie/catalog/college-books-c-0_1030.html

 

This indicates to me that the correct parameters are sent to your replacement tep_href_link but it is returning the url with the leading zero.

Share this post


Link to post
Share on other sites

More information:

 

An extract of a series of calls to your tep_href_link gives the following:

 

BEFORE: index.php cPath=1010

AFTER: http://www.omahonys.ie/catalog/children-c-1010.html

 

BEFORE: index.php cPath=1030

AFTER: http://www.omahonys.ie/catalog/college-books-c-800_1030.html

 

BEFORE: index.php cPath=1050

AFTER: http://www.omahonys.ie/catalog/dvds-cds-c-1050.html

 

Note that the College Books link now has an 800 prefix yet this is a top level category. There is no category with an ID or Parent ID of 800 so I have no clue as to where that value could come from. :rolleyes:

 

Finally, and most importantly, when the Seo Urls 5 cache is reset, the extra value disappears! For a while and then the problem reappears. Cache is FileSystem.

Edited by leafyglade

Share this post


Link to post
Share on other sites

Hi,

 

I use Yahoo hosting. The server and php have the following version. I notice that this contribution requre 5.1.3+. Is there anyway I can use this contribution?

 

Thanks,

 

 

 

HTTP Server: Apache/1.3.37 (Unix) mod_ssl/2.8.28 OpenSSL/0.9.6b FrontPage/5.0.2.2510

PHP Version: 4.3.11 (Zend: 1.3.0)

Share this post


Link to post
Share on other sites
Hi,

great contrib.

2 questions:

I am using googlexml_sitemap_seo_v_1.1 contrib and it still output the URLs in the old format with ?s in them. Is there a way to make it work with SEO URLs?

 

If I want to include the category name also in the URL, so it it like www.mysite.com/dress/very-nice-dress.html, can it be done somehow?

 

Thanks

 

P.S. I have produced a bulgarian language conversion file. I am ready to send it for sharing.

 

Hi

the files you put in the extras work fine if I start them manually.If I use i cronjob though it fails. The error is

 

Status: 302 Moved Temporarily

X-Powered-By: PHP/5.2.9

Location: http://www.kupuvalnik.com/blocked.php

Content-type: text/html

 

 

and the explanation from my sys admin is:

 

There are some errors.

 

/usr/local/bin/php /home/kupuvaln/public_html/googlesitemap/index.php

 

Warning: include_once(includes/application_top.php): failed to open stream: No such file or directory in /home/kupuvaln/public_html/googlesitemap/index.php on line 44

 

Warning: include_once(): Failed opening 'includes/application_top.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/kupuvaln/public_html/googlesitemap/index.php on line 44

 

Warning: require_once(googlesitemap/sitemap.class.php): failed to open stream: No such file or directory in /home/kupuvaln/public_html/googlesitemap/index.php on line 46

 

Fatal error: require_once(): Failed opening required 'googlesitemap/sitemap.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/kupuvaln/public_html/googlesitemap/index.php on line 46

 

Please resolve the error. This is coding issue.

 

I am not sure how to fix that.With the original Sitemap files it works OK with CRON.


OSC beginner

Share this post


Link to post
Share on other sites
Sry - posted this in the wrong forum - this is for the Ultimate SEO Urls 5

 

I followed the the letter the installation, had no issues it seems, but my URL's aren't producing my products.

 

http://funkyrat.com/product_info.php/core-...de-supply-p-103

 

The categories aren't working either: http://funkyrat.com/index.php/joint-bone-care-c-18

 

Has anyone seen this issue, and what can I do to fix this issue?

 

Also receiving this error in my footer on the hompage:

 

 

Warning: file_put_contents(/home/content/f/u/n/funkyrat/html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/content/f/u/n/funkyrat/html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

Don't understand, everything seemed to work perfectly.

 

I am having the same problem.

 

When I look in the includes/modules/ultimate_seo_urls5/cache/ folder, there are no files. I have double checked that the folder has write permissions.

 

I host with TMDhosting.

 

Is it possible that the path is not being recognised due to configure.php settings? - Everything else on the site seems to be working correctly.

 

Any ideas are welcome.

Share this post


Link to post
Share on other sites
I am not sure how to fix that.With the original Sitemap files it works OK with CRON.

 

php files called via cron cannot have includes .. the files I put up include other files and therefore will not work with cron.

Share this post


Link to post
Share on other sites
I am having the same problem.

 

When I look in the includes/modules/ultimate_seo_urls5/cache/ folder, there are no files. I have double checked that the folder has write permissions.

 

I host with TMDhosting.

 

Is it possible that the path is not being recognised due to configure.php settings? - Everything else on the site seems to be working correctly.

 

Any ideas are welcome.

 

Yes it would be your configure settings .. it works as follows (and I hope they are not your real server paths as it is a security issue): -

 

The cache path is made up of the following ..

 

self::$usuPath = DIR_WS_MODULES . 'ultimate_seo_urls5' . DIRECTORY_SEPARATOR;

 

$this->cache_path = DIR_FS_CATALOG . self::$usuPath . 'cache' . DIRECTORY_SEPARATOR;

 

So self::$usuPath should = includes/modules/ultimate_seo_urls5/

 

$this->cache_path should = /home/content/f/u/n/funkyrat/html/ + self::$usuPath + cache/

 

So therefore ...

 

/home/content/f/u/n/funkyrat/html/includes/modules/ultimate_seo_urls5/cache/

Share this post


Link to post
Share on other sites
Hi,

 

I use Yahoo hosting. The server and php have the following version. I notice that this contribution requre 5.1.3+. Is there anyway I can use this contribution?

 

Thanks,

 

 

 

HTTP Server: Apache/1.3.37 (Unix) mod_ssl/2.8.28 OpenSSL/0.9.6b FrontPage/5.0.2.2510

PHP Version: 4.3.11 (Zend: 1.3.0)

 

No php4 is ancient history and to php 4.4.9 php 4.3.11 is ancient history.

 

A decent version of PHP5 is required for this I'm afraid.

Share this post


Link to post
Share on other sites
I am having the same problem.

 

When I look in the includes/modules/ultimate_seo_urls5/cache/ folder, there are no files. I have double checked that the folder has write permissions.

 

I host with TMDhosting.

 

Is it possible that the path is not being recognised due to configure.php settings? - Everything else on the site seems to be working correctly.

 

Any ideas are welcome.

 

Ok, I seem to have got it working. I had an incorrect 'DIR_FS_CATALOG' path in my configure. It now works, but I still get

 

Warning: file_put_contents(home/domain/public_html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/domain/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

in my footer.

 

Thanks for any sugesstions?

Edited by maartenvonz

Share this post


Link to post
Share on other sites
Thanks for the fast response!

 

You should be able to access the site directly by clicking the links in my post or else go directly to www.omahonys.ie

 

The issue is now apparent under the College Books category. Sigh!

 

I have written a short program to call tep_href_link for the categories and it shows the following for College Books:

(page, parameters, connection, add_session_id) VALUES ARE index.php, cPath=1030, NONSSL,

http://www.omahonys.ie/catalog/college-books-c-0_1030.html

 

This indicates to me that the correct parameters are sent to your replacement tep_href_link but it is returning the url with the leading zero.

 

Hi I was just looking at your site and it seems like the only time it creates links with the 0_ is when you access the site that way, otherwise it shows the links correctly.

 

I stopped looking as you just turned seo urls off.

Share this post


Link to post
Share on other sites
Ok, I seem to have got it working. I had an incorrect 'DIR_FS_CATALOG' path in my configure. It now works, but I still get

 

Warning: file_put_contents(home/domain/public_html/includes/modules/ultimate_seo_urls5/cache/1_usucache.cache) [function.file-put-contents]: failed to open stream: No such file or directory in /home/domain/public_html/includes/modules/ultimate_seo_urls5/classes/Usu_Cache_FileSystem.php on line 35

 

in my footer.

 

Thanks for any sugesstions?

 

Your host seems to have strong limits on file creation .. perhaps change the cacheing to database.

Share this post


Link to post
Share on other sites
php files called via cron cannot have includes .. the files I put up include other files and therefore will not work with cron.

so can it be re-written, say with copying all application_top.php and application_bottom.php as variable your index.php so it can run in CRON?

Thanks


OSC beginner

Share this post


Link to post
Share on other sites
Hi I was just looking at your site and it seems like the only time it creates links with the 0_ is when you access the site that way, otherwise it shows the links correctly.

 

I stopped looking as you just turned seo urls off.

 

Thanks for looking at the site Robert. I had to switch it off because the extra 'ghost' category is causing problems but I can switch it on again temporarily if this helps.

 

I'm fairly sure that the problem is related to the cache - possible corruption or confusion in it. This contribution works well for a while but I think the problem starts when the cache grows. We have around 4,500 products and >170 categories. Is there any limit on products/categories/cache size?

 

I'm going on holidays for 2 weeks tomorrow and would love to have this working before I go so that Google et al can do their work while I'm away :)

Share this post


Link to post
Share on other sites
Thanks for looking at the site Robert. I had to switch it off because the extra 'ghost' category is causing problems but I can switch it on again temporarily if this helps.

 

I'm fairly sure that the problem is related to the cache - possible corruption or confusion in it. This contribution works well for a while but I think the problem starts when the cache grows. We have around 4,500 products and >170 categories. Is there any limit on products/categories/cache size?

 

I'm going on holidays for 2 weeks tomorrow and would love to have this working before I go so that Google et al can do their work while I'm away :)

 

Well without seeing it on and with the categories cache off there's not a lot I can do.

Share this post


Link to post
Share on other sites
Well without seeing it on and with the categories cache off there's not a lot I can do.

 

OSC Cache is off now and SEO 5 is on. Let me know by PM if possible when I can turn it off - Thanks again for your help.

 

Use http://www.omahonys.ie/catalog/pom_gmap.php to see my test program which lists the first 18 categories and first 5 products with parameters and results.

Edited by leafyglade

Share this post


Link to post
Share on other sites

Hi Robert,

 

I enabled Rewrite for url rewrite type and now the links don't work. I also reset the cache, ftp'ed the htaccess file from the sample folder, and also tested to see if mod_rewrite is enabled and working using a custom htaccess file that redirects one file to another file. Still the rewrite method is not working. Do you have any other troubleshooting ideas? TIA

 

- Raheem

Share this post


Link to post
Share on other sites
and now the links don't work

 

Absolutely useless for me to even consider attempting to work out what your problem is.

Share this post


Link to post
Share on other sites
Absolutely useless for me to even consider attempting to work out what your problem is.

 

My bad - here is more info about the problem. The url rewrite works fine when I select the "standard" method. But the links stop working when I use "rewrite" method. So for example, the following link works - http://usgc.fewtureweb.com/index.php/apple...tridge-c-3.html

 

But this one is NOT working - http://usgc.fewtureweb.com/apple-toner-cartridge-c-3.html

I added the .htaccess file from the extra folder of the USU install folder, but that did not work either. So I have removed it. The only difference between having the .htaccess and deleting it, is that when its deleted, the error page shown is the one from FWR media. If the htaccess file is available in the catalog folder, then the default Apache error page shows up.

 

- Raheem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×