Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Is it my eyes ( no pun intended ) or is that a capital I at the front of Index.php

 

None taken Robert,

 

It seems like a capital, but this store is on a windows IIS, so could that have anything to do with this issue?

Share this post


Link to post
Share on other sites

None taken Robert,

 

It seems like a capital, but this store is on a windows IIS, so could that have anything to do with this issue?

 

Weird, i does matter, calling Index.php gives results in the fatal error :blink:

 

I can't seem to find what capitalizes the I

Edited by roadkill

Share this post


Link to post
Share on other sites

Basically you need to find this problem in your own code I think.

 

Then again., maybe not. Maybe some versions of IIS produce Index.php when access at domain root with no filename.

 

Try this.

 

catalog/includes/modules/ultimate_seo_urls5/main/usu5.php ( lines 179 - 182 )

 

Find ..

 

	public function setVar( $var_name, $value ) {
	$this->vars[$var_name] = $value;
	return $this;
} // end method

 

Change to ..

 

	public function setVar( $var_name, $value ) {
 	if ( $var_name == 'filename' ) $value = strtolower( $value );
 	$this->vars[$var_name] = $value;
 	return $this;
} // end method

 

see if that makes a difference.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Then again., maybe not. Maybe some versions of IIS produce Index.php when access at domain root with no filename.

 

Try this.

 

catalog/includes/modules/ultimate_seo_urls5/main/usu5.php ( lines 179 - 182 )

 

Find ..

 

	public function setVar( $var_name, $value ) {
	$this->vars[$var_name] = $value;
	return $this;
} // end method

 

Change to ..

 

	public function setVar( $var_name, $value ) {
 	if ( $var_name == 'filename' ) $value = strtolower( $value );
 	$this->vars[$var_name] = $value;
 	return $this;
} // end method

 

see if that makes a difference.

SOLVED :D

 

Gotta love Windows >_<

 

IIS server settings, the default document was set to Index.php i.s.o. index.php the store is on a brand new server IIS fresh installed.

I made the change in Internet Information Services and it works like a charm :D

Thank you Robert for your invested time!

Share this post


Link to post
Share on other sites

SOLVED :D

 

Gotta love Windows >_<

 

IIS server settings, the default document was set to Index.php i.s.o. index.php the store is on a brand new server IIS fresh installed.

I made the change in Internet Information Services and it works like a charm :D

Thank you Robert for your invested time!

 

Glad you got it sorted but I still need my code checked please. USU5 needs to function correctly with IIS default document set at Index.php.

 

Could you set the server back and try my code please?

Share this post


Link to post
Share on other sites

Sure Robert, I have to pause for now but I will try in one or two hours

 

The strtolower did the trick!

With the 'old' server settings the url www.mysite.com perfectly resulted in displaying the index page.

 

Thank you again, Robert!

Edited by roadkill

Share this post


Link to post
Share on other sites

Sure Robert, I have to pause for now but I will try in one or two hours

 

The strtolower did the trick!

With the 'old' server settings the url www.mysite.com perfectly resulted in displaying the index page.

 

Thank you again, Robert!

 

Thanks for taking the time to do that.

 

The whole scenario now will benefit other IIS users.

Share this post


Link to post
Share on other sites

I have another 2 little problems:

 

1. When I select a manufacturer (for example Akasa) from the drop-down, it gives me the link:

www.mystore.com/akasa-m-46.html, but it shows all the products in the store from all the manufacturers, not only the products from Akasa.

2. It gives me an 404 error when I select links that have in the name of the product (and automatically in the link) characters like: ™ © ® ..etc.

 

Thank you for your time.

Share this post


Link to post
Share on other sites

i think that my installation looks ok. Could someone verify? http://www.insidertrips.com

 

If i want to have my links appear as www.insidertrips.com/honolulu-hawaii-trip or something to that effect without the path numbers..how exactly would i do that? Thanks!

Share this post


Link to post
Share on other sites

i think that my installation looks ok. Could someone verify? http://www.insidertrips.com

 

If i want to have my links appear as www.insidertrips.com/honolulu-hawaii-trip or something to that effect without the path numbers..how exactly would i do that? Thanks!

I don't know I closed out of your page when I couldn't close that overlay splash screen. I think that should be removed as I wouldn't use your site because of that... BUT to answer your question I don't think you can. It needs the "P" and "C" type tags to figure out what things (products or categories) to show.

 

Mike

Share this post


Link to post
Share on other sites

Hi,

 

I'm having issues with Forceing www.mysite.com when the url shows www.mysite.com/index.php. It is also showing www.mysite.com/product_info.php/thentheproduct too. I have tried disableing within the admin etc, but no joy. Any ideas please? Otherwise it seems to be working well :)

 

 

Thanks in advance.

 

Ken

Share this post


Link to post
Share on other sites

Hi,

 

I'm having issues with Forceing www.mysite.com when the url shows www.mysite.com/index.php. It is also showing www.mysite.com/product_info.php/thentheproduct too. I have tried disableing within the admin etc, but no joy. Any ideas please? Otherwise it seems to be working well :)

 

 

Thanks in advance.

 

Ken

 

Hi Ken

 

You mention having problems but you fail to mention what those problems are. I therefore don't understand the question.

 

Force www.mysite.com either works or it doesn't dependent on the server. On a few servers it creates a redirect loop in which case you simply don't use it and turn it off.

 

Re: product_info.php this only shows if you are using the standard urls. Rewrite urls lose it.

Share this post


Link to post
Share on other sites

Hi Robert,

 

Firstly thanks for your reply.

 

At the moment the URL shows like this www.*******.com/index.php/brother-ink-cartridges-brother-lc980-1100-c-64_55 When I switch on the option to force the removal in the admin of the index.php, the URL still remains the same with the index.php part there. The same applies to the product info too, where it shows www.*******.com/product_info.php/full-sets-brother-lc980lc1100-compatible-cartridges-p-226. Its changing the URL fine to the catergory names, but it still has the index.php & product_info part.php in the URL. Am I missing something?

 

Hope that make sense :)

 

Thanks again for the reply :)

 

Ken

Share this post


Link to post
Share on other sites

I have another 2 little problems:

 

1. When I select a manufacturer (for example Akasa) from the drop-down, it gives me the link:

www.mystore.com/akasa-m-46.html, but it shows all the products in the store from all the manufacturers, not only the products from Akasa.

2. It gives me an 404 error when I select links that have in the name of the product (and automatically in the link) characters like: ™ © ® ..etc.

 

Thank you for your time.

 

Any ideas on my problems? Thanks.

Share this post


Link to post
Share on other sites

Any ideas on my problems? Thanks.

 

For your problem #2 just add '™' => '', '©' => '', '®' => '', etc. to the $char_convert array in catalog/includes/modules/ultimate_seo_urls5/includes/character_conversion/"your_language".php

Share this post


Link to post
Share on other sites

Any ideas on my problems? Thanks.

 

You don't need to do anything except read the instructions.

 

As standard Remove all non-alphanumeric characters? is on, this strips all non alphanumeric characters.

Share this post


Link to post
Share on other sites

Hi Robert,

 

Firstly thanks for your reply.

 

At the moment the URL shows like this www.*******.com/index.php/brother-ink-cartridges-brother-lc980-1100-c-64_55 When I switch on the option to force the removal in the admin of the index.php, the URL still remains the same with the index.php part there. The same applies to the product info too, where it shows www.*******.com/product_info.php/full-sets-brother-lc980lc1100-compatible-cartridges-p-226. Its changing the URL fine to the catergory names, but it still has the index.php & product_info part.php in the URL. Am I missing something?

 

Hope that make sense :)

 

Thanks again for the reply :)

 

Ken

 

All of this is in the instructions Ken.

Share this post


Link to post
Share on other sites

Also need support for the last Article Manager contribution.

 

In the last release introduces article_blog.php

 

USU5 dont change the links, and remains as ... article_blog.php?articles_id=1028

 

I dont know if addind to .htaccess

  RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_blog.php [NC,L,QSA]

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Hello Robert

Thank you for your contrbution Ultimate SEO 5 Pro, works perfectly.

I am trying to find the correct Googlefeeder to work with Ultimate Seo 5. I remember seing one edited by you, can you please poit to the right file. Have found this in your profile My link. Is it the right thing to use?

Thank you and appologies if posted in the wrong place.

Olga

Share this post


Link to post
Share on other sites

You don't need to do anything except read the instructions.

 

As standard Remove all non-alphanumeric characters? is on, this strips all non alphanumeric characters.

 

This didn't work for me. I thought it was because I use the utf-8 character set. So I included '™' => '', '©' => '', '®' => '' to my character conversion table.

 

But now I found this line in page_modules.php:

 

$pattern = ( defined( 'SEO_REMOVE_ALL_SPEC_CHARS' ) && SEO_REMOVE_ALL_SPEC_CHARS == 'true' ) ?  "@[^\sa-z0-9]@i" : "@[!#\$%&'\"()\*\+,\-\./:;<=>\?\@\[\]\^_`\{|\}~]+@";

 

after changing this line to:

 

$pattern = ( defined( 'USU5_REMOVE_ALL_SPEC_CHARS' ) && USU5_REMOVE_ALL_SPEC_CHARS == 'true' ) ?  "@[^\sa-z0-9]@i" : "@[!#\$%&'\"()\*\+,\-\./:;<=>\?\@\[\]\^_`\{|\}~]+@";

 

it worked as you described.

Share this post


Link to post
Share on other sites

 

after changing this line to:

 

$pattern = ( defined( 'USU5_REMOVE_ALL_SPEC_CHARS' ) && USU5_REMOVE_ALL_SPEC_CHARS == 'true' ) ?  "@[^\sa-z0-9]@i" : "@[!#\$%&'\"()\*\+,\-\./:;<=>\?\@\[\]\^_`\{|\}~]+@";

 

it worked as you described.

 

Well spotted!

 

I can't believe this hasn't been picked up before.

 

That is indeed a typo, a carry over from the old USU5.

 

Everyone should change this code.

 

Thanks for the report Manniman.

Share this post


Link to post
Share on other sites

This didn't work for me. I thought it was because I use the utf-8 character set. So I included '™' => '', '©' => '', '®' => '' to my character conversion table.

 

But now I found this line in page_modules.php:

 

$pattern = ( defined( 'SEO_REMOVE_ALL_SPEC_CHARS' ) && SEO_REMOVE_ALL_SPEC_CHARS == 'true' ) ?  "@[^\sa-z0-9]@i" : "@[!#\$%&'\"()\*\+,\-\./:;<=>\?\@\[\]\^_`\{|\}~]+@";

 

after changing this line to:

 

$pattern = ( defined( 'USU5_REMOVE_ALL_SPEC_CHARS' ) && USU5_REMOVE_ALL_SPEC_CHARS == 'true' ) ?  "@[^\sa-z0-9]@i" : "@[!#\$%&'\"()\*\+,\-\./:;<=>\?\@\[\]\^_`\{|\}~]+@";

 

it worked as you described.

 

Thank you. It works now, as you said.

 

I'm still having problems with the manufacturer link, I mentioned in an earlier post:

 

" 1. When I select a manufacturer (for example Akasa) from the drop-down, it gives me the link:

www.mystore.com/akasa-m-46.html, but it shows all the products in the store from all the manufacturers, not only the products from Akasa. "

 

In the previous working htaccess file, with USU 2.1, I had this line:

 

RewriteCond %{QUERY_STRING} ^options\=(.*)$

RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

 

 

and in the present htaccess file, I have:

 

RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA]

 

I read the instructions a few times, but I can't figure it out.

Share this post


Link to post
Share on other sites

Hi Robert.

 

Thank you for the work you have put into this contribution.

 

This is my first time working with any version beyond Chemo's version 2.2d and I'm running into a problem.

 

First, this is a new site. I am using osC v2.3.1, and installed the following add-ons prior to installing ULTIMATE Seo Urls 5 Pro - by FWR Media (r205):


  •  
  • AJAX-AttributeManager-V2.8.9.2
  • ot_discount_coupon_codes_3_34_osc2.3
  • GoogleFeeder_V_2.8
  • HeaderTags_SEO_V_3.2.5
  • Monthly Sales Report V 1.6
  • order_editor_for2.3_v1.1
  • priceSort
  • Supertracker v3.2b
     

I have been doing the work on an XAMPP local development server.

 

After completing the installation following your instructions for "installing to a modified osCommerce version 2.3 ( no existing Ultimate Seo Urls present )", I opened the install_complete.htm file. Following the instruction on that page, I visited the front page of the store, but no SEO URLs were displaying when hovering over links.

 

I am using Firefox v3.6.17 for site development. I've closed the browser (which in my case, clears the cache) and reopened it, then reopened the front page, but the SEO URL links are still not there.

 

I've tried changing various settings in configuration, but see no changes to the links. Following your instructions, I updated my .htaccess file and tried the rewrite options in the configuration settings.

 

At this point, I decided to see if it was something to do with a local install, so I installed this site in it's current state to my server. However, I'm having the exact same problem. (Here's the test domain-- http://www.treasuredsilkflowers.com )

 

I've accessed the site from the following os/browsers:


  •  
  • WinXP/Firefox v3.6.17
  • WinXP/Internet Explorer v8.0
  • Win7/Firefox v4.0.1
  • Win7/Google Chrome v11.0
  • Win7/Internet Explorer v8.0
     

And I've accessed the local on WinXP from these browsers:


  •  
  • Firefox v3.6.17
  • Internet Explorer v8.0

The links do not seem to work anywhere.

 

So the question is, have I managed to screw up the install, or is there something different in v2.3.1 over 2.3 that I need to change?

 

Thank you in advance for you help.

-Anita Cross

Share this post


Link to post
Share on other sites

So the question is, have I managed to screw up the install, or is there something different in v2.3.1 over 2.3 that I need to change?

Just to be thorough, I setup a clean install, and followed the directions for the "Drop on Top Quick Install". With this install, the SEO URLs are working. I'm off to see if there is anything different in the install files. If not, I'll reinstall each of the contributions on this new install until I find the conflict.

 

I'll let you know what I discover...

 

Thanks for you time,

-Anita Cross

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×