Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Robert please answer my question . Is it correct what I wrote above ?

 

I answer when I get the free time to answer and not before, please don't post to "hurry me up".

 

No you are wrong, it is clear in the instructions what bcmp represent.

Share this post


Link to post
Share on other sites

I answer when I get the free time to answer and not before, please don't post to "hurry me up".

 

No you are wrong, it is clear in the instructions what bcmp represent.

 

 

I am sorry for trying to make u answer faster but I saw the answer above and I thought you skipped my post because you thought that was a dumb question and no need to answer.

 

I really appreciate your work and time you spent here to answer all questions.

 

I am trying only to understand some things.

 

I saw now what bcmp represent but if you try to put a print_r to $details you will see that there is no product model index set in that array

 

Array
(
   [products_name] => a name
   [manufacturers_name] => a manufacturer
   [categories_name] => a category 
   [categories_id] => a category id
)

Share this post


Link to post
Share on other sites

I am sorry for trying to make u answer faster but I saw the answer above and I thought you skipped my post because you thought that was a dumb question and no need to answer.

 

I really appreciate your work and time you spent here to answer all questions.

 

I am trying only to understand some things.

 

I saw now what bcmp represent but if you try to put a print_r to $details you will see that there is no product model index set in that array

 

Array
(
   [products_name] => a name
   [manufacturers_name] => a manufacturer
   [categories_name] => a category 
   [categories_id] => a category id
)

 

Set the query back to using INNER JOIN as it was originally.

 

Basically if products_model is not returned then you have the query set to LEFT JOIN. The query would return no results ( and errors from the script ) if set back to INNER JOIN as the data is corrupt.

 

The query can be run in phpMyAdmin ( or whatever you prefer ) as below: -

 

SELECT pd.products_name, m.manufacturers_name, cd.categories_name, p.products_model, p2c.categories_id
FROM products_description pd
INNER JOIN products_to_categories p2c ON p2c.products_id = pd.products_id
INNER JOIN products p ON pd.products_id = p.products_id
LEFT JOIN manufacturers m ON m.manufacturers_id = p.manufacturers_id
INNER JOIN categories_description cd ON p2c.categories_id = cd.categories_id AND cd.language_id='XXX'
WHERE pd.products_id='XXX'
AND pd.language_id='XXX' LIMIT 1

 

Fill in the 3 XXX with languages_id and product_id

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi,

 

I added this contribution, but am running into issues when on a SSL page, like "my account", and then clicking to a category in the catalog. The error is"The page isn't redirecting properly, Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies."

 

I have a shared SSL certificate, and so the SSL url is not the same as my site URL. Is this an error that can be fixed, or is it just not possible to get SEO to work with a shared SSL certificate? Is there a way to turn SEO off on SSL pages?

 

Thanks,

Lindsay

Edited by lwest

Share this post


Link to post
Share on other sites

Hi,

 

I added this contribution, but am running into issues when on a SSL page, like "my account", and then clicking to a category in the catalog. The error is"The page isn't redirecting properly, Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies."

 

I have a shared SSL certificate, and so the SSL url is not the same as my site URL. Is this an error that can be fixed, or is it just not possible to get SEO to work with a shared SSL certificate? Is there a way to turn SEO off on SSL pages?

 

Thanks,

Lindsay

 

I believe this was already covered in this support thread but a new revision has not been uploaded yet.

 

Please try this.

 

If that link doesn't work it's page 71 post #2483

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi Robert,

 

I love this contribution and see the benefit on having it installed. I have an issue though and was hoping you could point me in the right direction.

 

Installation of the addon went fine, no real problems there and it is working in my shop. Urls are getting rewritten and the shop seems to work fine.

 

However the log file is showing an error. I googled the error and it pops up with alot of other stores as well.

 

I found one refrence to it in the development post of USU5 pro made by steven, but not a real fix.

 

The error the log file is generating is:

[Tue Jan 25 22:14:54 2011] [error] [client xxx.xxx.x.42] PHP Warning: aPage_Modules::stripPathToLastNumber: Incorrect path value of presented in /var/www/vhosts/website.com/http/includes/modules/ultimate_seo_urls5/abstracts/page_modules.php on line 313, referer: http://www.webshop.com/shopping_cart.php 

[Tue Jan 25 22:14:57 2011] [error] [client xxx.xxx.x.42] PHP Warning: aPage_Modules::stripPathToLastNumber: Incorrect path value of presented in /var/www/vhosts/website.com/http/includes/modules/ultimate_seo_urls5/abstracts/page_modules.php on line 313, referer: http://www.website.com/login.php 

[Tue Jan 25 22:15:31 2011] [error] [client 66.249.72.161] PHP Warning: aPage_Modules::stripPathToLastNumber: Incorrect path value of presented in /var/www/vhosts/website.com/http/includes/modules/ultimate_seo_urls5/abstracts/page_modules.php on line 313 

 

Any ideas what could be causing this and how bad is it since the shop seems to work ?

 

I would appriciate some input.

Share this post


Link to post
Share on other sites

Hi Robert,

 

I love this contribution and see the benefit on having it installed. I have an issue though and was hoping you could point me in the right direction.

 

Hi Bjorn

 

It is good that this error is being produced, the error is triggered to inform the shop owner that invalid values are being passed ( the shop has bugs ).

 

The error is purposely created in ultimate_seo_urls5/abstracts/page_modules.php line 313.

 

An instance where this would occur would be e.g. if cPath was passed in as a null value. ( ?cPath=&something_else_perhaps ).

Edited by FWR Media

Share this post


Link to post
Share on other sites

Okay, this leaves me flabbergasted :P

 

As i have no idea where to start , but thanks for the info.

 

Well your only other option is to open up all the page modules .. find ..

 

 $this->key = $this->getDependencyKey();

 

And change them to ..

 

  $this->key = $this->getDependencyKey();
 /**
 * If the shop has issues it may pass in null values, in this case return false to force the standard osCommerce link wrapper
 */
 if ( !array_key_exists( $this->key, $this->keys_index ) || !tep_not_null( $this->keys_index[$this->key] ) ) {
return false;
 }

 

This will force the use of the standard osCommerce link wrapper when a bad value is passed and avoid the error.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Well your only other option is to open up all the page modules .. find ..

 

 $this->key = $this->getDependencyKey();

 

And change it to ..

 

  $this->key = $this->getDependencyKey();
 /**
 * If the shop has issues it may pass in null values, in this case return false to force the standard osCommerce link wrapper
 */
 if ( !array_key_exists( $this->key, $this->keys_index ) || !tep_not_null( $this->keys_index[$this->key] ) ) {
return false;
 }

 

This will force the use of the standard osCommerce link wrapper when a bad value is passed and avoid the error.

 

 

Seems like a quick fix for now, so i can sort it out later. Thanks alot for that code. I am grateful you took the time and effort.

Share this post


Link to post
Share on other sites

PHP Fatal error: Call to a member function retrieveDependencies() on a non-object in /home/***/public_html/includes/modules/ultimate_seo_urls5/uri_modules/osc_experimental.php on line 51

 

 

I have this error in my error log every time a cron job is executed on some new files, not standard oscommerce, for example my_new_file.php

 

Can u help me debugging this ?

Share this post


Link to post
Share on other sites

Hello, I installed Ultimate Seo Urls 5 about a month ago and haven't had any issue. Today while checking crawl errors on goolgle I noticed a lot of 404 not founds. I came here and read through about 100 posts looking for a fix to it or if I missed something but I do not see anything in the install instructions about doing anything for the Custom 404 or redirects. I just read that it should do it.

 

There is a .htaccess file in the Extras folder but not sure if I am suppose to copy that into my existing .htaccess file or what. I really need to get this taken care of I have hundreds of bad urls now in google.

 

Any assistance is appreciate, thank you. Please let me know if you need me to post any of my files.

Share this post


Link to post
Share on other sites

Update:

 

Well I added the info from the .htaccess file into mine just to see and it looks like now I can use the Mod_Rewrite option in the admin settings that I wasnt able to do before. Still not finding anything on how to setup the 404 or any of the errors for missing pages to redirect.

 

Thanks again

 

I found this while waiting to get a reply:

 

How can I manage the 404 errors?

When it gets an error appears the logo of my host.

How can I modify ir to include a sitemap???

I modified .httpps to include:

# ErrorDocument 404 http://www. myshop .com/sittemap.php

ErrorDocument 404 /sitemap.php

 

USU5 produces a custom 404 page which you can alter.

catalog/includes/modules/ultimate_seo_urls5/includes/notfound_404.php

But when I click on one of the bad urls that google has it doesn't display this page.

Edited by ShaunB

Share this post


Link to post
Share on other sites

Thanks for the reply, I see the file but when you enter an invalid url on the site or click a bad url from google is does not redirect to the 404.

 

Do I need to put something in my .htaccess to direct to the FWR Media 404 error page?

Share this post


Link to post
Share on other sites

Thanks for the reply, I see the file but when you enter an invalid url on the site or click a bad url from google is does not redirect to the 404.

 

Do I need to put something in my .htaccess to direct to the FWR Media 404 error page?

 

The 404 of USU5/5 PRO only kicks in if it is a bad SEO URL it does not kick in for non seo urls.

Share this post


Link to post
Share on other sites

Hi ...

 

Im having strange issues with latest seo5 ...

 

i was using seo by Chemo and i didnt have this problems ... but when i upgraded it troubles started ...

 

here is the thing: http://moja-beba.com/ducan/ some of the categories/product works fine but some don't ... As you can notice i need to use characters like Č Ć Š Đ etc. and I discovered that all characters that are written to database like "& # 2 6 9 ;" instead of "č" works fine but all others don't ...

 

Edit Delete 16 6 Mlije & # 2 6 9 ; ne formule

Edit Delete 15 6 Dje & # 2 6 9 ; ja hrana

Edit Delete 19 6 Voćne kašice

Edit Delete 20 6 Deserti

Edit Delete 22 6 Čajevi

Edit Delete 24 6 Pelene

Edit Delete 29 6 Kreme, mlijeka i losioni

Edit Delete 30 6 Suha i osjetljiva koža

Edit Delete 79 6 Pribor za njegu

 

does anybody have some advices ?

 

thanx

Edited by sergio_cro

Share this post


Link to post
Share on other sites

The 404 of USU5/5 PRO only kicks in if it is a bad SEO URL it does not kick in for non seo urls.

 

I see, should I add another contrib to do another 404 page?

 

for example this url: http://www.snipercompany.com/-c-46.html

 

comes up with a normal 404 and from I understand from you is that since this is not one of the new SEO urls it doesn't fix or redirect it?

 

If I install another 404 contrib or put something in my .htaccess what would you suggest? would your 404 redirect still work on new SEO urls?

 

Thanks

Share this post


Link to post
Share on other sites

Shaun,

 

You don't have to install any other contribution. Simply add the following to your .htaccess in your main folder generally /home/xxx/public_html/

 

ErrorDocument 404 /404.php

 

Make sure that you have a 404.php file

 

thank you, as I do not should/can I put:

 

ErrorDocument 404 /includes/modules/ultimate_seo_urls5/includes/notfound_404.php

 

or should I just created a static 404.php page and use that?

Edited by ShaunB

Share this post


Link to post
Share on other sites

IMO, you are better off creating a different 404.

 

What I have done is basically created a replicate of shipping.php into 404.php so that I can possibly do something in the future, such as catch the errors and show related products etc.

Share this post


Link to post
Share on other sites

IMO, you are better off creating a different 404.

 

What I have done is basically created a replicate of shipping.php into 404.php so that I can possibly do something in the future, such as catch the errors and show related products etc.

 

I was just thinking about using this contrib:

 

http://addons.oscommerce.com/info/933

 

pretty simple to do but would look like a normal page, I guess the shipping page or any other page would do too.

Share this post


Link to post
Share on other sites

I see, should I add another contrib to do another 404 page?

 

for example this url: http://www.snipercom....com/-c-46.html

 

comes up with a normal 404 and from I understand from you is that since this is not one of the new SEO urls it doesn't fix or redirect it?

 

If I install another 404 contrib or put something in my .htaccess what would you suggest? would your 404 redirect still work on new SEO urls?

 

Thanks

 

That is "sort of" an seo url but it has no link text so does not match as an seo url.

 

E.g. [sCHEME:DOMAIN]/aardwark-c-46.html will produce the 404 page as it matches as an seo url.

 

As Spoofy mentioned you should also have a standard 404 page.

Share this post


Link to post
Share on other sites

how to avoid this kind of url http://moja-beba.com/ducan/dje9999ja-hrana-�ajevi-c-15_22.html to be created ? I'm not able to transform "�" to something usable and readable by browsers ?!?

 

i just dont have a clue what is wrong ...

 

i would appreciate if someone can help me ...

 

other examples:

 

Seo Urls:

 

 

.../djecja-hrana-voÌne-kašice-c-15_19.html

.../djecja-hrana-dobro-jutro-laku-noĂŚ-c-15_51.html

.../ducan/djecja-hrana-�ajevi-c-15_22.html

.../frutek-nektar-jabuka-grožða-borovnica-p-303.html

.../frutek-sok-krušaka-p-302.html

 

 

 

Thanks

Edited by sergio_cro

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×