Jump to content
FWR Media

ULTIMATE Seo Urls 5 - by FWR Media

Recommended Posts

Hi Robert,

online again after moving my complete home to another location and finishing christmas preparations, I saw that you finished beta phase for USU5Pro. I installed the new version on my life site and it works great.

 

Thank you very much for your wonderful contribution.

 

Manfred

Share this post


Link to post
Share on other sites

Hi Robert,

online again after moving my complete home to another location and finishing christmas preparations, I saw that you finished beta phase for USU5Pro. I installed the new version on my life site and it works great.

 

Thank you very much for your wonderful contribution.

 

Manfred

 

My pleasure, until I upload a new version please ensure to make the mod mentioned in the post below: -

 

http://forums.oscomm...ost__p__1554022

 

I am waiting a little while in case of any bug reports before creating a maintenance release.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Congratulations Robert,

finally working with this new version.

 

Questions:

 

Enable SEO URLs 5? false

if I put to false, the USU5 continues working, and the rewrites also continues working.

 

Enable the cache? true

Select your chosen cache system?

Where does SQlite and MySQL stores the data.??

For the moment I use File and all goes right.

Are the SQLite or MySQL faster?

 

Enable multi language support? true

This doesnt work for me.

There is no www. myshop. com/en/ or www. myshop . com/en/product...

I only have 1 language. But I need the multilanguage to work. Is that right?

 

How can I manage the 404 errors?

When it gets an error appears the logo of my host.

How can I modify ir to include a sitemap???

I modified .httpps to include:

# ErrorDocument 404 http://www. myshop .com/sittemap.php

ErrorDocument 404 /sitemap.php

 

Choose the uri format path_rewrite

Add category parent to beginning of category uris? true

../clothes/levis-c-928_288.html

 

It seems to work, but in some categories it gets an 404 error.

 

I must change the uri format to rewrite

../clothes-levis-c-928_288.html

 

and working.

 

 

In .httpps ¿how to include rewrites for other contribs?

faqdesk_info.php

pollbooth.php

links.php

 

For sitemaps /usu5_sitemaps/index.php

Also didnt worked for me. It gets a white-blank page. I have more than 50000products. Shared host. Could be this??

 

 

In the last update I see that there is not an old folder.(removed?)

catalog/includes/modules/ultimate_seo_urls5/classes/

 

I copied it inside from the old version. This is right?

 

You said:

"To fix this simply modify it to use the standard osc link coding and it will work with usu5." related to sitemap an HeaderTags.

where is the link to such information?

All my sitemaps are generated with Dinamic Sitemap contribution, but the urls are type:

http://www. myshop .com/product_info.php?products_id=34509

 

Then in webmaster tools:

"URLs not followed When we tested a sample of URLs from your Sitemap, we found that some URLs redirect to other locations. We recommend that your Sitemap contain URLs that point to the final destination (the redirect target) instead of redirecting to another URL."

 

Force www.mysite.com/ when www.mysite.com/index.php false

Why this??

If I turned on I gets that the "Page is not indexable" because it has a Canonical Link to "www. mysite .com/index.php"

How to avoid or correct this??

Edited by bhbilbao

Share this post


Link to post
Share on other sites

Congratulations Robert,

finally working with this new version.

 

Questions:

 

Enable SEO URLs 5? false

if I put to false, the USU5 continues working, and the rewrites also continues working.

 

I can't replicate this on any servers.. with USU5 set to "Enable SEO URLs 5? = false" the links return to the standard osCommerce links.

 

Enable the cache? true

Select your chosen cache system?

Where does SQlite and MySQL stores the data.??

For the moment I use File and all goes right.

Are the SQLite or MySQL faster?

Read the instructions .. it depends on your particular needs.

 

Enable multi language support? true

This doesnt work for me.

There is no www. myshop. com/en/ or www. myshop . com/en/product...

I only have 1 language. But I need the multilanguage to work. Is that right?

 

Read the instructions .. particularly ..

documentation/install_files/multi_language.htm

You haven't uploaded the languages box in additional_uploads.

You can also browse to the language link manually like: ( assuming a secondary language of es )

 

www.mysite.com/my-great-product-p-32.html

 

www.mysite.com/es/my-greatspanish-product-p-32.html ( loads spanish ).

 

How can I manage the 404 errors?

When it gets an error appears the logo of my host.

How can I modify ir to include a sitemap???

I modified .httpps to include:

# ErrorDocument 404 http://www. myshop .com/sittemap.php

ErrorDocument 404 /sitemap.php

 

USU5 produces a custom 404 page which you can alter.

catalog/includes/modules/ultimate_seo_urls5/includes/notfound_404.php

Choose the uri format path_rewrite

Add category parent to beginning of category uris? true

../clothes/levis-c-928_288.html

It seems to work, but in some categories it gets an 404 error.

 

I must change the uri format to rewrite

../clothes-levis-c-928_288.html

 

and working.

Yes .. read the instructions .. some servers cannot handle path based uris.

 

 

In .httpps ¿how to include rewrites for other contribs?

faqdesk_info.php

pollbooth.php

links.php

 

Please read the release thread for USU5 PRO.

Currently supported are: -

* Articles manager

* Links manager

* Information Pages

* Newsdesk

 

I didn't see the point in faqdesk or pollbooth.

 

For sitemaps /usu5_sitemaps/index.php

Also didnt worked for me. It gets a white-blank page. I have more than 50000products. Shared host. Could be this??

The sitemaps are produced in catalog root .. check there. When run the file produces no output ( a blank page ).

 

 

In the last update I see that there is not an old folder.(removed?)

catalog/includes/modules/ultimate_seo_urls5/classes/

 

I copied it inside from the old version. This is right?

 

No .. I didn't include an "old" folder as they should be no old folder.

 

You said:

"To fix this simply modify it to use the standard osc link coding and it will work with usu5." related to sitemap an HeaderTags.

where is the link to such information?

All my sitemaps are generated with Dinamic Sitemap contribution, but the urls are type:

http://www. myshop .com/product_info.php?products_id=34509

This is very simple .. contributions should stick to osCommerce coding standards .. this means that links are produced using the tep_href_link() function .. if they don't you shouldn't use them .. if they do USU5 will work.

Then in webmaster tools:

 

Force www.mysite.com/ when www.mysite.com/index.php false

Why this??

If I turned on I gets that the "Page is not indexable" because it has a Canonical Link to "www. mysite .com/index.php"

How to avoid or correct this??

 

Please read the instructions .. this feature causes mysite.com/index.php to redirect to www.mysite.com/ if you have added a contribution that is not compatible with this feature then turn the feature off of remove the other contribution.

Conclusion:

 

This was a long post for me to answer and most of the answers are in the instructions so please read them.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello.

 

I was using last Seo Url .

 

Now I updated to the last version and url mod: rewrite doesn't work anymore (that I was using last time). Now everything goes on index.php

 

Any help on debugging this.

 

It only works with standard and path standard.

Edited by zipicip

Share this post


Link to post
Share on other sites

Hello.

 

I was using last Seo Url .

 

Now I updated to the last version and url mod: rewrite doesn't work anymore (that I was using last time). I get an The page isn't redirecting properly error.

 

Any help on debugging this.

 

It only works with standard and path standard

 

Sounds like you didn't replace the old RewriteRules in .htaccess with the new ones, also there was a thread earlier where we corrected the rules to the following ..

 

 

# If you are getting errors you may need to comment this out like ..
# Options +FollowSymLinks
Options +SymLinksIfOwnerMatch
<IfModule mod_rewrite.c>
 RewriteEngine On

 # RewriteBase instructions
 # Change RewriteBase dependent on how your shop is accessed as below.
 # http://www.mysite.com = RewriteBase /
 # http://www.mysite.com/catalog/ = RewriteBase /catalog/ 
 # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 # Change RewriteBase using the instructions above  
 RewriteBase / 
 RewriteRule ^([a-z0-9/-]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-c-([0-9_]+).html$ index.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA]
 # Articles contribution
 RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]
 # Information pages
 RewriteRule ^([a-z0-9/-]+)-i-([0-9]+).html$ information.php [NC,L,QSA]
 # Links contribution
 RewriteRule ^([a-z0-9/-]+)-links-([0-9_]+).html$ links.php [NC,L,QSA]
 # Newsdesk contribution
 RewriteRule ^([a-z0-9/-]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA]
</IfModule>

Edited by FWR Media

Share this post


Link to post
Share on other sites

I already did this. And same problem. Another thing I discovered. When I change to rewrite mod and access a product page every time he goes to one product page and every time is the same product.

Edited by zipicip

Share this post


Link to post
Share on other sites

I already did this. And same problem. Another thing I discovered. When I change to rewrite mod and access a product page every time he goes to one product page and every time is the same product.

 

If path based uris work and rewrite does not then it almost always relates to .htaccess.

 

Either the rules are not present of you have set RewriteBase incorrectly I would think.

Share this post


Link to post
Share on other sites

Ok here is my .httacess

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

 

 

 

# If you are getting errors you may need to comment this out like ..

# Options +FollowSymLinks

Options +SymLinksIfOwnerMatch

<IfModule mod_rewrite.c>

RewriteEngine On

 

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

# Change RewriteBase using the instructions above

RewriteBase /

RewriteRule ^([a-z0-9/-]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-c-([0-9_]+).html$ index.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA]

# Articles contribution

RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]

# Information pages

RewriteRule ^([a-z0-9/-]+)-i-([0-9]+).html$ information.php [NC,L,QSA]

# Links contribution

RewriteRule ^([a-z0-9/-]+)-links-([0-9_]+).html$ links.php [NC,L,QSA]

# Newsdesk contribution

RewriteRule ^([a-z0-9/-]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9/-]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA]

</IfModule>

 

#

# Skip the next two rewriterules if NOT a spider

RewriteCond %{HTTP_USER_AGENT} !(msnbot|slurp|googlebot) [NC]

RewriteRule .* - [s=2]

#

# case: leading and trailing parameters

RewriteCond %{QUERY_STRING} ^(.+)&osCsid=[0-9a-z]+&(.+)$ [NC]

RewriteRule (.*) $1?%1&%2 [R=301,L]

#

# case: leading-only, trailing-only or no additional parameters

RewriteCond %{QUERY_STRING} ^(.+)&osCsid=[0-9a-z]+$|^osCsid=[0-9a-z]+&?(.*)$ [NC]

RewriteRule (.*) $1?%1 [R=301,L]

 

 

ErrorDocument 400 /400.shtml

ErrorDocument 401 /401.shtml

ErrorDocument 404 /403.shtml

ErrorDocument 404 /404.shtml

 

 

# BEGIN Compress text files

<IfModule mod_deflate.c>

<FilesMatch "\.(css|js|x?html?|php)$">

SetOutputFilter DEFLATE

</FilesMatch>

</IfModule>

# END Compress text files

 

# Turn on Expires and set default expires to 3 days

ExpiresActive On

ExpiresDefault A259200

 

# Set up caching on media files for 1 month

<FilesMatch "\.(ico|gif|jpg|jpeg|png|flv|pdf|swf|mov|mp3|wmv|ppt)$">

ExpiresDefault A2419200

Header append Cache-Control "public"

</FilesMatch>

 

# Set up 2 Hour caching on commonly updated files

<FilesMatch "\.(xml|txt|html|js|css)$">

ExpiresDefault A7200

Header append Cache-Control "private, must-revalidate"

</FilesMatch>

 

# Force no caching for dynamic files

<FilesMatch "\.(php|cgi|pl|htm)$">

ExpiresDefault A0

Header set Cache-Control "no-store, no-cache, must-revalidate, max-age=0"

Header set Pragma "no-cache"

</FilesMatch>

 

 

 

#Options +FollowSymlinks

#RewriteEngine on

#RewriteCond %{REQUEST_URI} !/maintenance.html$

#RewriteCond %{REMOTE_HOST} !^89\.120\.10\.196

#RewriteRule $ /maintenance.html [R=302,L]

 

 

Options -Indexes +FollowSymLinks

 

# To redirect all users to access the site WITH the 'www.' prefix,

# (http://originals.ro/... will be redirected to http://www.originals.ro/...)

# adapt and uncomment the following:

RewriteCond %{HTTP_HOST} ^originals\.ro$ [NC]

RewriteRule ^(.*)$ http://www.originals.ro/$1 [L,R=301]

 

 

# REDIRECT /folder/index.php to /folder/

RewriteEngine on

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /([^/]+/)*index\.php\ HTTP/

RewriteRule ^(([^/]+/)*)index\.php$ http://www.originals.ro/$1 [R=301,L]

 

RedirectMatch 301 ^/blog/(.*)$ http://blog.originals.ro/$1

RedirectMatch 301 ^/ecko-romania/(.*)$ http://ecko-romania.originals.ro/$1

 

Options -Indexes

 

 

Redirect 301 /informatii.php http://www.originals.ro/information.php

Redirect 301 /informatii_originals.php http://www.originals.ro/information.php?info_id=7

Redirect 301 /cum_comand.php http://www.originals.ro/information.php?info_id=8

Redirect 301 /informatii_plata.php http://www.originals.ro/information.php?info_id=9

Redirect 301 /informatii_livrare.php http://www.originals.ro/information.php?info_id=10

Redirect 301 /returnare_produse.php http://www.originals.ro/information.php?info_id=11

Redirect 301 /despre_vouchere.php http://www.originals.ro/information.php?info_id=12

Redirect 301 /fidelizare.php http://www.originals.ro/information.php?info_id=13

Redirect 301 /utilizare_confidentialitate.php http://www.originals.ro/information.php?info_id=14

 

Redirect 301 /specials.php http://www.originals.ro/reduceri.php

Redirect 301 /products_new.php http://www.originals.ro/produse_noi.php

 

 

 

<Files .htaccess>

order allow,deny

deny from all

</Files>

Share this post


Link to post
Share on other sites

Ok here is my .httacess

 

Take out all of the rubbish except for the USU5 RewriteRules and try it.

 

Also your RewriteBase is set as ..

 

RewriteBase /

 

Is your osCommerce installed in the root directory?

Share this post


Link to post
Share on other sites

domain is www.originals.ro

 

I deleted everything and still no change. Everything goes to index.

 

I managed to simulate something.

 

I changed to rewrite: I entered a product page everything was fine the url was rewrited. I tried to go to another product and then I was redirected to the same product I first rewrited the rule

 

for example.

 

http://mydomain.com/product1-name-p-4714.html

http://mydomain.com/product2-name-p-4715.html = same content as http://mydomain.com/product1-name-p-4714.html but url rewrites correctly

Edited by zipicip

Share this post


Link to post
Share on other sites

domain is www.originals.ro

 

I deleted everything and still no change. Everything goes to index.

 

I managed to simulate something.

 

I changed to rewrite: I entered a product page everything was fine the url was rewrited. I tried to go to another product and then I was redirected to the same product I first rewrited the rule

 

for example.

 

http://mydomain.com/...ame-p-4714.html

http://mydomain.com/...ame-p-4715.html = same content as http://mydomain.com/...ame-p-4714.html but url rewrites correctly

 

I tried going to your domain but USU5 is not set as rewrite.

Share this post


Link to post
Share on other sites

Yes because that is the live shop and I changed back to standard so no errors will be.

 

If you think that the above scenario doesn't help tonight (I my country) I will make some print screen and set for debug option.

 

What do you need.

Edited by zipicip

Share this post


Link to post
Share on other sites

Yes because that is the live shop and I changed back to standard so no errors will be.

 

If you think that the above scenario doesn't help tonight (I my country) I will make some print screen and set for debug option.

 

What do you need.

 

Well if I can't see it I can't help.

 

All products load fine to me but some products are shown using rewrite and some path based which suggests to me you have some odd caching going on .. page cache contribution?

Share this post


Link to post
Share on other sites

Well if I can't see it I can't help.

 

All products load fine to me but some products are shown using rewrite and some path based which suggests to me you have some odd caching going on .. page cache contribution?

 

 

Yes. And advanced cache from chemo.

Share this post


Link to post
Share on other sites

Yes. And advanced cache from chemo.

 

 

Ok. So I managed to make a test server

 

 

http://www.originals.ro/server_test/

 

I let in .httacess only

 

# If you are getting errors you may need to comment this out like ..

# Options +FollowSymLinks

Options +SymLinksIfOwnerMatch

<IfModule mod_rewrite.c>

RewriteEngine On

 

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

# Change RewriteBase using the instructions above

RewriteBase /server_test/

RewriteRule ^([a-z0-9-/]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-c-([0-9_]+).html$ index.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-m-([0-9]+).html$ index.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA]

# Articles contribution

RewriteRule ^([a-z0-9-/]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]

# Information pages

RewriteRule ^([a-z0-9-/]+)-i-([0-9]+).html$ information.php [NC,L,QSA]

# Links contribution

RewriteRule ^([a-z0-9-/]+)-links-([0-9_]+).html$ links.php [NC,L,QSA]

# Newsdesk contribution

RewriteRule ^([a-z0-9-/]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA]

RewriteRule ^([a-z0-9-/]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA]

</IfModule>

 

I deleted the cache folder.

 

Problem here not even standard doesn't work I don't understand why. I added now mod rewrite and set for debugging.

Share this post


Link to post
Share on other sites

Ok. So I managed to make a test server

 

I deleted the cache folder.

 

Problem here not even standard doesn't work I don't understand why. I added now mod rewrite and set for debugging.

 

Ok this site seems to have a number of issues, a main one being suppression of the osCsid. The other being the use of Chemos page cache which is a bad idea.

 

I'll PM you my personal email where we can continue this but I don't want this topic to take over the support thread as the problem seems limited to your environment only.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Ok this site seems to have a number of issues, a main one being suppression of the osCsid. The other being the use of Chemos page cache which is a bad idea.

 

I'll PM you my personal email where we can continue this but I don't want this topic to take over the support thread as the problem seems limited to your environment only.

 

 

Ok. I understand. I sent u an email from oscommerce forum form.

Share this post


Link to post
Share on other sites

Everything is working fine now it was chemo page cache contribution that was causing that all rewriting url to have same content.

 

Thanks FWR Media (Robert) for this great contribution and for fast support.

Share this post


Link to post
Share on other sites

Hi,

 

I have just upgrade my Ultimate SEO from Chemos original Ultimate Seo Urls version 2 ( including modifications by jackmcs to v22d_10) to the latest release. I have as well apply the changes to fix the two bug discovered after the release.

 

Unfortunately even though the installation seems completed succesfully the redirections failing now.

 

Let me clarify:

 

I can access succesfully my index.php but it fails to redirect if selecting any categories or products with the following error:

 

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

 

Any ideas?

Previous version was working fine.

 

Another thing I have notice is if I switch to true redirection for index.php, if I access www.mywebsite.co.uk/index.php it does not redirect to www.mywebsite.co.uk. Is it normal?

 

Thanks in advance for your help.

Kind Regards

JK

Share this post


Link to post
Share on other sites

Hi,

 

I have just upgrade my Ultimate SEO from Chemos original Ultimate Seo Urls version 2 ( including modifications by jackmcs to v22d_10) to the latest release. I have as well apply the changes to fix the two bug discovered after the release.

 

Unfortunately even though the installation seems completed succesfully the redirections failing now.

 

Let me clarify:

 

I can access succesfully my index.php but it fails to redirect if selecting any categories or products with the following error:

 

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

 

Any ideas?

Previous version was working fine.

 

Another thing I have notice is if I switch to true redirection for index.php, if I access www.mywebsite.co.uk/index.php it does not redirect to www.mywebsite.co.uk. Is it normal?

 

Thanks in advance for your help.

Kind Regards

JK

 

Strange .. is there a site I can view please ( PM me if you don't want others to see it ).

Share this post


Link to post
Share on other sites

Hi,

 

I have just upgrade my Ultimate SEO from Chemos original Ultimate Seo Urls version 2 ( including modifications by jackmcs to v22d_10) to the latest release. I have as well apply the changes to fix the two bug discovered after the release.

 

Unfortunately even though the installation seems completed succesfully the redirections failing now.

 

I have sent you a pm I think your configure.php file is incorrect.

Share this post


Link to post
Share on other sites

Can I ask you an unrelated question?

 

What rules can I add to redirect any http://organiculture.co.uk to http://www.organiculture.co.uk ?

 

Something like ..

 

RewriteEngine On
RewriteCond %{HTTP_HOST} !^www\.organiculture\.co\.uk$
RewriteRule (.*) http://www.organiculture.co.uk/$1 [R=301,L]

 

Although if you are using USU5 PRO RewriteRules you will already have the RewriteEngine on so just find ( in .htaccess ) ..

 

</IfModule>

 

change to ..

 

  # Redirect domain without www. prefix
 RewriteCond %{HTTP_HOST} !^www\.organiculture\.co\.uk$
 RewriteRule (.*) http://www.organiculture.co.uk/$1 [R=301,L]
</IfModule>

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello. The contribution works very well but I checked my error log and this is what I found out:

 

 

 

PHP Fatal error: Call to a member function retrieveDependencies() on a non-object in /home/original/public_html/includes/modules/ultimate_seo_urls5/main/bootstrap.php on line 409

 

 

I read on oscommerce forum that error came from filename that contains "-" instead of " _" is there any way to find out what file is causing the problem ? and exclude that file.

 

Another error:

 

HP Fatal error: Call to a member function store() on a non-object in /home/original/public_html/includes/modules/ultimate_seo_urls5/main/usu5.php on line 78, referer: http

 

I also checked this on forum and there was something similar but I don't now when the error triggers because usually rewrites work fine.

Edited by zipicip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×