Jump to content
Sign in to follow this  
hodja451

After Amazon install, base url repeats

Recommended Posts

After install there was an error in English.php that made all pages inaccessible. I temporarily solved that problem by restoring the original html_output.php. Now I get an error on login.php that PEAR.php is missing. It is there, but the error discloses that it is inserting the base url multiple times, after each sub directory, as seen below.

 

How is it doing that?

 

Fatal error: require_once() [function.require]: Failed opening required 'PEAR/PEAR.php' (include_path='.:http://www.instantvideogames.com/catalog/:http://www.instantvideogames.com/catalog/checkout_by_amazon:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/PHP_Compat-1.6.0a1:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/SOAP-0.12.0:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/PEAR-1.7.2:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/PEAR-1.7.2/PEAR:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/HTTP-1.4.3:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/Mail_Mime-1.5.2:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/Mail_mimeDecode-1.5.0:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/Net_Socket-1.0.9:http://www.instantvideogames.com/catalog/checkout_by_amazon/library/Net_URL-1.0.15:http://www.instantvideogames.com/catalog/checkou in /home/content/h/o/d/hodja451/html/catalog/checkout_by_amazon/checkout_by_amazon_includes.php on line 50

 

Thanks,

Walter


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites

checkout_by_amazon_order_builder.php is missing a ?> tag?

 

Is this correct? Or is this a mistake in the install file?


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites
checkout_by_amazon_order_builder.php is missing a ?> tag?

 

Is this correct? Or is this a mistake in the install file?

 

Hi Walter,

Is your problem resolved? Please let us know if you need any help.

 

Thanks

Amazon Payments Team

Share this post


Link to post
Share on other sites

Unfortunately, I resolved my problem by not taking Amazon payments. I will be attempting to set it up again soon, like tomorrow. Please set an email notification on this thread (like I have), so that if I have a problem with it, I can get help.

Thanks,

Walter

 

PS As an existing Amazon merchant, adding website payments to my account actually locked my Amazon account in an endless registration loop, apparently a know issue that still took 2 days to fix, preventing me from mailing out purchases for 2 days.


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites
Unfortunately, I resolved my problem by not taking Amazon payments. I will be attempting to set it up again soon, like tomorrow. Please set an email notification on this thread (like I have), so that if I have a problem with it, I can get help.

Thanks,

Walter

 

PS As an existing Amazon merchant, adding website payments to my account actually locked my Amazon account in an endless registration loop, apparently a know issue that still took 2 days to fix, preventing me from mailing out purchases for 2 days.

 

Hi Walter,

Apologize for the difficulty you faced during registration. Please let us know if you face any problem while integration.

 

Regards

~Amazon Payments Team

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×