Jump to content
Sign in to follow this  
jashelea

Purchase Without Account - asks for password?

Recommended Posts

I have just installed PWA 2.1, everything working great (once I fixed up a } issue), all good, except that it even though no account is created, it asks for a password, and also the 'newsletter' option underneath. It really confuses customers, puts them off as I think they think I'm sneakily creating an ccount even though I know I am not, and no account in admin.

 

How can I change this? I want to keep the create account feature, and have PWA alongside that, otherwise I'd just hide the standard 'create account' details.

Share this post


Link to post
Share on other sites
I have just installed PWA 2.1, everything working great (once I fixed up a } issue), all good, except that it even though no account is created, it asks for a password, and also the 'newsletter' option underneath. It really confuses customers, puts them off as I think they think I'm sneakily creating an ccount even though I know I am not, and no account in admin.

 

How can I change this? I want to keep the create account feature, and have PWA alongside that, otherwise I'd just hide the standard 'create account' details.

 

Did you miss out anything in create account

this should be your code in create_account.php from fax number down

				<td class="main"><?php echo ENTRY_FAX_NUMBER; ?></td>
			<td class="main"><?php echo tep_draw_input_field('fax') . ' ' . (tep_not_null(ENTRY_FAX_NUMBER_TEXT) ? '<span class="inputRequirement">' . ENTRY_FAX_NUMBER_TEXT . '</span>': ''); ?></td>
		  </tr>
		</table></td>
	  </tr>
	</table></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
// PWA BOF
 if (!isset($HTTP_GET_VARS['guest']) && !isset($HTTP_POST_VARS['guest'])) {
// PWA EOF
?>
  <tr>
	<td class="main"><b><?php echo CATEGORY_OPTIONS; ?></b></td>
  </tr>
  <tr>
	<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
	  <tr class="infoBoxContents">
		<td><table border="0" cellspacing="2" cellpadding="2">
		  <tr>
			<td class="main"><?php echo ENTRY_NEWSLETTER; ?></td>
			<td class="main"><?php echo tep_draw_checkbox_field('newsletter', '1') . ' ' . (tep_not_null(ENTRY_NEWSLETTER_TEXT) ? '<span class="inputRequirement">' . ENTRY_NEWSLETTER_TEXT . '</span>': ''); ?></td>
		  </tr>
		</table></td>
	  </tr>
	</table></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
  <tr>
	<td class="main"><b><?php echo CATEGORY_PASSWORD; ?></b></td>
  </tr>
  <tr>
	<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
	  <tr class="infoBoxContents">
		<td><table border="0" cellspacing="2" cellpadding="2">
		  <tr>
			<td class="main"><?php echo ENTRY_PASSWORD; ?></td>
			<td class="main"><?php echo tep_draw_password_field('password') . ' ' . (tep_not_null(ENTRY_PASSWORD_TEXT) ? '<span class="inputRequirement">' . ENTRY_PASSWORD_TEXT . '</span>': ''); ?></td>
		  </tr>
		  <tr>
			<td class="main"><?php echo ENTRY_PASSWORD_CONFIRMATION; ?></td>
			<td class="main"><?php echo tep_draw_password_field('confirmation') . ' ' . (tep_not_null(ENTRY_PASSWORD_CONFIRMATION_TEXT) ? '<span class="inputRequirement">' . ENTRY_PASSWORD_CONFIRMATION_TEXT . '</span>': ''); ?></td>
		  </tr>
		</table></td>
	  </tr>
	</table></td>
  </tr>
<?php
 // PWA BOF
 }
 else
 { // Ingo PWA Ende
?>
<tr>
  <td><?php echo tep_draw_hidden_field('guest', 'guest'); ?></td>
</tr>
<?php } 
// PWA EOF
?>

 

also in catalog/includes/form_check.js.php make sure you have this code

 

<?php
// PWA BOF
 if (!isset($HTTP_GET_VARS['guest'])) {
?>

 check_password("password", "confirmation", <?php echo ENTRY_PASSWORD_MIN_LENGTH; ?>, "<?php echo ENTRY_PASSWORD_ERROR; ?>", "<?php echo ENTRY_PASSWORD_ERROR_NOT_MATCHING; ?>");
 check_password_new("password_current", "password_new", "password_confirmation", <?php echo ENTRY_PASSWORD_MIN_LENGTH; ?>, "<?php echo ENTRY_PASSWORD_ERROR; ?>", "<?php echo ENTRY_PASSWORD_NEW_ERROR; ?>", "<?php echo ENTRY_PASSWORD_NEW_ERROR_NOT_MATCHING; ?>");

<?php
 } // PWA EOF
?>

Share this post


Link to post
Share on other sites

Hello. im having the same problem.

 

I did not have the code from catalog/includes/form_check.js.php.

But i have two of these files. The one above and one at catalog/includes/javascript/form_check.js.php.

 

I don't know if this is a problem, but I got BTSv1_7 installed too. ?

 

Could that cause the problem ?

Share this post


Link to post
Share on other sites

sorry for double post, but i couldn't edit my last post.

 

I found a solution for my problem. I added some code in the create_account.php file.

 

replace this:

 

$password = tep_db_prepare_input($HTTP_POST_VARS['password']);

$confirmation = tep_db_prepare_input($HTTP_POST_VARS['confirmation']);

 

 

with this:

 

if (!isset($HTTP_GET_VARS['guest']) && !isset($HTTP_POST_VARS['guest'])) {

$password = tep_db_prepare_input($HTTP_POST_VARS['password']);

$confirmation = tep_db_prepare_input($HTTP_POST_VARS['confirmation']);

} else {

$password = 'guest';

$confirmation = 'guest';

}

 

 

Some new issues has been added, but i am working on these too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×