Jump to content
FWR Media

ULTIMATE SEO URLS 5 - who's interested?

Recommended Posts

Yes I am using Information Pages Unlimited (2.04.2)

 

I am looking through the new file: Usu_Information but it will take me a while to understand how this new ULTIMATE_Seo_Urls works.

I will have to leve for the afternoon but will try this all again this evening or tomorrow. Thank you again!!

 

You are using an older version I think if you just change

 

SELECT info_title

 

To

 

SELECT information_title

 

It should work

Share this post


Link to post
Share on other sites

I wanted to keep you up-to-date with my attempt at installing.

This looks like an incredible contribution and will surely be one of the top/best contributions once you have it refined.

 

This time I started by first removing completely Bobbys ULTIMATE SEO URLs.

I then installed this using the virgin install and not the update.

I still could not get it to work without using your suggested edit in application top;

changing this addition:

// ULTIMATE Seo Urls 5 by FWR Media

$seo_urls->initiate($SID, $languages_id, $language);

 

to instead this:

 

// ULTIMATE Seo Urls 5 by FWR Media

if ( !isset($seo_urls) || !is_object($seo_urls) ){

include_once DIR_WS_MODULES . 'ultimate_seo_urls5' . DIRECTORY_SEPARATOR . 'classes' . DIRECTORY_SEPARATOR . 'usu.php';

$seo_urls = new usu($languages_id, $request_type, $session_started, $SID);

}

$seo_urls->initiate($SID, $languages_id, $language);

 

I also had to make your additional recommendation to: includes/modules/ultimate_seo_urls5/classes/usu.php

 

perhaps I needed to make this change mearly because I had again used frontpage to install this time... I am not certain, but it did work after doing this second change.

 

I again had to go into my includes/column_left and comment out my information box. I was getting errors with this... so one thing at a time.

 

I tested all links... everything worked but...

I have article manager installed and on articles more then one level deep it threw an error "page not found".

 

In htaccess... changing this:

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

to this:

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

 

will make level two articles work. I use this above change on my site.

 

but perhaps a better way is to add this to your htaccess under your other article rules:

RewriteRule ^(.*)-t-([0-9]+_[0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

 

I still can not get my information unlimited pages to load... I listed my version earlier in the post and it is not really that outdated. Has anyone else had an issue with information pages causing an error?

Please post if so.

Thank you for posting your contribution. I look forward to using it on my live site when it works on my install.

Share this post


Link to post
Share on other sites
I tested all links... everything worked but...

I have article manager installed and on articles more then one level deep it threw an error "page not found".

 

In htaccess... changing this:

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

to this:

RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}

 

will make level two articles work. I use this above change on my site.

 

but perhaps a better way is to add this to your htaccess under your other article rules:

RewriteRule ^(.*)-t-([0-9]+_[0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

 

Yes I stated in the contribution that I had not tested any of these addons as I didn't have the time to load them all.

 

Does the tPath sometimes have an underscore then?

Share this post


Link to post
Share on other sites

If the articles paths sometimes have underscores then the RewriteRule should be similar to CPath

 

RewriteRule ^(.*)-t-([0-9_]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

 

However the acquire function in Usu_articles expects an int so that file will not work until modified like Usu_Categories.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Debs

 

catalog/includes/modules/ultimate_seo_urls5/modules/Usu_Information.php

 

Change query to:

 

	  $this->base_query = "SELECT information_title AS iName FROM " . TABLE_INFORMATION . " WHERE information_id=':info_id' AND language_id=':languages_id' LIMIT 1";

 

Find ..

$this->link_text = usu::linkText($row['iName']);

 

Replace with ..

 

$this->link_text = $this->linkText($row['iName']);

Share this post


Link to post
Share on other sites

Debs .. to correct the Usu_articles.php module to accept paths with underscrore.

 

Replace the acquire() with .. (don't forget to clear the cache or you'll see old entries))

 

  public function acquire($dependency){
if ( is_numeric(str_replace('_', '', $dependency)) ){
  $this->tPath = $dependency;
} else {
  return false;
}
if ( strpos($dependency, '_') ){
  $single_tpath = (int)ltrim(strrchr($dependency, '_'), '_');
} else {
  $single_tpath = (int)$dependency;
}  
// Bypass the query if already in the registry
if ( false !== isset(usu::$registry->{$this->dependency}[$this->tPath]) ){
  usu::$performance['queries_saved']++;
  return true;
}
$placeholders = array( ':tPath', ':languages_id' );
// $values are already type cast
$values = array( $single_tpath, usu::$languages_id );
$this->query = str_replace($placeholders, $values, $this->base_query);
$result = usu::query( $this->query );
$this->query = null;
$row = tep_db_fetch_array( $result );
tep_db_free_result( $result );
if ( false === $row ){
  return false;
}
$this->link_text = $this->linkText($row['tName']);

if ( false === isset(usu::$registry->{$this->dependency}) ){
  usu::$registry->{$this->dependency} = array();
}
usu::$registry->attach($this->dependency, $this->tPath, $this->getProperties());
 } // End method

Edited by FWR Media

Share this post


Link to post
Share on other sites

A new version has been uploaded.

 

Please use the Support Topic for support.

 

This being Contribution Development perhaps this could be used for suggestions for adding to or improving the module.

Share this post


Link to post
Share on other sites

Hi Robert,

I am using the conribution More Caregories and it adds into the URL infoBox=0 or 1 or whatever. Would it be hard to add this to ULTIMATE SEO URLS 5?

Guy

Share this post


Link to post
Share on other sites
Hi Robert,

I am using the conribution More Caregories and it adds into the URL infoBox=0 or 1 or whatever. Would it be hard to add this to ULTIMATE SEO URLS 5?

Guy

 

I really don't know never seen the contibution .. if it is pure querystring then Seo Urls 5 would not be affected by it.

 

Seo Urls 5 only comes into effect when there is a dedicated module rewriting the urls.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Just a short message with questions and ideas for features in this new module. I had a quick look at the code and the architecture has nothing to do with the old series 2. Must have been some work to refactor all of this, Well done !!

 

* The demo version seems to be in the non rewrite mode you described since we can still see the php name of the page you are on. Is this for debugging purposes. Is there a way to change it on the demo site ourselves or should I installl it on one of my own?

 

* In the version 2, there was an option to display the parent category in the path. Furthermore, i changed the code to show the main parent categorie/the current category/the product name (http://domain.com/category1/category1_3/product_name). Is it possible to have this as an option straight out? In the function I changed I also gave the option to choose the delimiter between each category, so one can use - or / to display like a directory structure (at the time it was still discussed which one was actually better, I opted for / :blush: )

 

* Will this version finally handle the language parameter correctly. Commercial products like magi SEO are doing a great job of it. This would avoid "duplicate content" on pages existing with or without the language parameter. I guess that default languages should show in the normal domain name, and other in a virtual sub directory. Something like the code below shoudl take care of the rewriting

RewriteCond %{QUERY_STRING} ^language=fr$
RewriteRule ^(.*)$ http://www.eboutik.net/fr/$1? [L,R=301]
RewriteCond %{QUERY_STRING} ^language=en$
RewriteRule ^(.*)$ http://www.eboutik.net/en/$1? [L,R=301]

or simply

RewriteRule ^([a-z]{2})/(.*)$ $2?language=$1&%{QUERY_STRING}

Not sure where this should then be handled in the abstract SEO class ( substr($_SESSION['language'], 0, 2).'/'; ??)

 

* The above logic could also apply to currencies maybe ?

RewriteRule ^(ch)/(.*)$ $2?language=fr&currency=CHF&%{QUERY_STRING}
RewriteRule ^(fr)/(.*)$ $2?language=fr&currency=EUR&%{QUERY_STRING}
RewriteRule ^(uk)/(.*)$ $2?language=en&currency=GBP&%{QUERY_STRING}
RewriteRule ^(us)/(.*)$ $2?language=en&currency=USD&%{QUERY_STRING}
RewriteRule ^(ca)/(.*)$ $2?language=en&currency=CAD&%{QUERY_STRING}
RewriteRule ^(ca-fr)/(.*)$ $2?language=fr&currency=CAD&%{QUERY_STRING}

 

* Another hack I made on my shop is for the split per page in the product listing. I however done this directly into the split_page_results.php class. I seem to remember spotting a SEO 2 soltuion on those forums

 

* Similar to the above, what about the filters on the product listing?

 

I think there is enough to discuss for now :)

Dont ger me wrong, this is not a list of features I am asking you to do .. just want to have an opinion on the feasibility in the new code structure, and if some are already planned.

Share this post


Link to post
Share on other sites
The demo version seems to be in the non rewrite mode you described since we can still see the php name of the page you are on. Is this for debugging purposes. Is there a way to change it on the demo site ourselves or should I installl it on one of my own?

 

As standard usu5 installs using the "standard" non rewrite urls.

 

Why?

 

2 reasons ..

1) They work on Windows IIS whereas the rewrite urls do not.

2) Some servers do not have mod_rewrite enabled and the standard urls allow anyone to use this module.

 

To change to rewrite urls just go to admin and set "Choose URL Rewrite Type" to rewrite.

Share this post


Link to post
Share on other sites
Will this version finally handle the language parameter correctly.

 

The language and currency params are nothing to do with seo urls .. having said that the best solution is just to change the languages and currencies boxes to use _POST instead of _GET.

 

I have already done this and may add it as a "replacements" option.

Share this post


Link to post
Share on other sites
The language and currency params are nothing to do with seo urls .. having said that the best solution is just to change the languages and currencies boxes to use _POST instead of _GET.

 

I have already done this and may add it as a "replacements" option.

 

I dont exactly agree since we can end up with 3 kinds of URL for the same page and have a bad case of duplicate content

 

www.domain.com/category_name_in_english/product_name_in_english.html

www.domain.com/category_name_in_english/product_name_in_english.html?language=uk

www.domain.com/category_name_in_english/product_name_in_english.html?language=fr (by clicking on the flag)

 

If we take a concrete example on your dev site we can have:

http://www.fwrdev.co.uk/cmonitor/index.php/drama-c-3_15

http://www.fwrdev.co.uk/cmonitor/index.php...=en&sort=2a

http://www.fwrdev.co.uk/cmonitor/index.php...=de&sort=2a

 

It seems that at product level you do a redirection to correct the product name when choosing another URL, however the url is still wrong on the actual flag link

Share this post


Link to post
Share on other sites
I dont exactly agree since we can end up with 3 kinds of URL for the same page and have a bad case of duplicate content

 

www.domain.com/category_name_in_english/product_name_in_english.html

www.domain.com/category_name_in_english/product_name_in_english.html?language=uk

www.domain.com/category_name_in_english/product_name_in_english.html?language=fr (by clicking on the flag)

 

If we take a concrete example on your dev site we can have:

http://www.fwrdev.co.uk/cmonitor/index.php/drama-c-3_15

http://www.fwrdev.co.uk/cmonitor/index.php...=en&sort=2a

http://www.fwrdev.co.uk/cmonitor/index.php...=de&sort=2a

 

It seems that at product level you do a redirection to correct the product name when choosing another URL, however the url is still wrong on the actual flag link

 

I didn't even realise cmonitor had this installed, it must be a very early version.

however the url is still wrong on the actual flag link

 

I don't see any wrong links .. but I take your point about the same url having different content when actively using multiple languages.

Share this post


Link to post
Share on other sites

Hey,

 

i've installed the new version and used "upgrade_from_2". When trying to run the database-update-file "usu2_removal.php", I receive an error warning

"Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in ..... htdocs/includes/modules/ultimate_seo_urls5/classes/usu.php on line 24"

 

I didn`t change any word in this file ... the download of the contrib was 1h ago. I checked the installation twice and more. This error warning comes even starting the "index.php".

When I searched for this error message in Gooogle, I found some more sites with the same message.

 

Maybe someone had the same problem, and fixed it?

 

Would be great!!! :rolleyes:

 

Best regards

Michael

Edited by e-peoples

Share this post


Link to post
Share on other sites
Hey,

 

i've installed the new version and used "upgrade_from_2". When trying to run the database-update-file "usu2_removal.php", I receive an error warning

"Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in ..... htdocs/includes/modules/ultimate_seo_urls5/classes/usu.php on line 24"

 

I didn`t change any word in this file ... the download of the contrib was 1h ago. I checked the installation twice and more. This error warning comes even starting the "index.php".

When I searched for this error message in Gooogle, I found some more sites with the same message.

 

Maybe someone had the same problem, and fixed it?

 

Would be great!!! :rolleyes:

 

Best regards

Michael

 

Ultimate Seo Urls 5 requires PHP5

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

i have try your seo with the upgrade instruction in Revision 67 for users of version 2.1d

everything was easy to do however when i go to my site link look like this: product_info.php/airstep-570208-boots-p-13662

 

and this isn't working. wiht version 2.1d i had no problems and everything works without any problems.

 

do you know whats wrong?

 

als i was wondering why the seo isn't looking more like www.domain.com/catogory/boots/airstep-570208.html

i this not possible?

 

thanks

Marcel

Share this post


Link to post
Share on other sites
i have try your seo with the upgrade instruction in Revision 67 for users of version 2.1d

everything was easy to do however when i go to my site link look like this: product_info.php/airstep-570208-boots-p-13662

 

and this isn't working. wiht version 2.1d i had no problems and everything works without any problems.

 

do you know whats wrong?

 

als i was wondering why the seo isn't looking more like www.domain.com/catogory/boots/airstep-570208.html

i this not possible?

 

thanks

Marcel

 

Deleted this post as you later posted in the correct support topic.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello,

I have this contribution installed. It works perfectly in standard mode. But when I try to test it in rewrite mode, I face issues. This is what I know I have done...

 

I installed rc2a and it works great

 

I'm working from my catalog folder (mysite->catalog->all my files)

 

I have

Options +FollowSymLinks
RewriteEngine On

on my .htaccess page just to make sure I have mod_rewrite enabled.

 

I have AllowOverride set to All on my <Dicrectory "c:/..../htdocs"> block within my httpd.conf file

 

So with all that said, when I land on my homepage everything works fine. But when I go away from it to any other link, I get....

 

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.
Error 404

 

Any advice? B) Thanks

 

-kenz

Edited by kenz

Share this post


Link to post
Share on other sites
Hello,

I have this contribution installed. It works perfectly in standard mode. But when I try to test it in rewrite mode, I face issues. This is what I know I have done...

 

I installed rc2a and it works great

 

I'm working from my catalog folder (mysite->catalog->all my files)

 

I have

Options +FollowSymLinks
RewriteEngine On

on my .htaccess page just to make sure I have mod_rewrite enabled.

 

I have AllowOverride set to All on my <Dicrectory "c:/..../htdocs"> block within my httpd.conf file

 

So with all that said, when I land on my homepage everything works fine. But when I go away from it to any other link, I get....

 

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.
Error 404

 

Any advice? B) Thanks

 

-kenz

 

 

 

I see that my issue is only occuring on pages that have a letter and number at the end, like...

 

-p-22.html

 

or -c-1.html

Share this post


Link to post
Share on other sites

Hi there,

 

I have a slightly odd problem. My seourls were working great (i love this contrib!) but now thay have gone a little funny... When i click a link in my store it takes me to mystore.com/products_info.php?products_id=123 and not the seourl. But, if i type into the address bar mystore.com/product-name-p-123.html it takes me to the products page. so its kind of half-working if that makes sense.

 

Any ideas?

 

thanks. Matt

Share this post


Link to post
Share on other sites

Hi,

 

I am using this module for my site running on IIS server. I want to use url rewrite but doesn't know how to use rewrite. I have contacted my web host administrator and got the info that IIS rewrite is available and I should use that.

 

Please let me know if you have a set of IIS rewrite rules or otherwise the best option for me.

 

Also please let me know how and where to put these rewrite instructions.

 

Thanks in advance.

 

Regards.

Harry

Share this post


Link to post
Share on other sites

@@hardikbaweja

 

There are different versions of rewriters for IIS which work in different ways so I have never taken the time to attempt writing for them all .. e.g.

 

URLRewriter

IIS rewrite

ISAPI_Rewrite

Ionic's Isapi Rewrite Filteretc etc.

 

Helicon Ape looks to be the best as far as i'm concerned as the syntax is designed to match apache mod_rewrite almost exactly.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi, I'm using this add-on but I have one problem, when I use the rewrite uri format, in my store are given 404 errors why is that?

I want urls like www.misite.com/myproduct.html

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×