Jump to content
Sign in to follow this  
Carbon

Anyone else experiencing problems with the Protx simulator?

Recommended Posts

Hi,

 

Yesterday at approx 18:30 the Protx simulator was returning an INVALID status in response to the initial registration post. Knowing that I hadn't changed anything I tried to log into my simulator account using my usual url of... https://ukvpstest.protx.com/VSPSimulator/loginpage.asp and found that it was unavailable with HTTP 500 Internal Server Error.

 

I was expecting the issue to be resolved over night but the issue is still present today. Interestingly, I also had this simulator login url... https://test.sagepay.com/simulator/ so out of curiosity I tried it and was able to log into my account and access transactions, vpsdirect, account etc as normal. The page looks slightly different from usual with "Sage" branding.

 

To test further I checked my debug output and discovered that the simulator was no longer recognising my IP address (which is strange as my server has a fixed IP) and that the IP address it suggested I add seemed out of range compared to the previously working one.

 

Any ideas what's going on here?

 

Many thanks

 

Carbon

Share this post


Link to post
Share on other sites

The PROTX simulator now only works with the very latest version of the PROTX API.

 

No contribution has been written as yet to support the new API therefore the only way to test is to have a test account at the moment. Test accounts still work with the older API.

Share this post


Link to post
Share on other sites
The PROTX simulator now only works with the very latest version of the PROTX API.

 

No contribution has been written as yet to support the new API therefore the only way to test is to have a test account at the moment. Test accounts still work with the older API.

 

Hi,

 

I'm not using any contributions and have written my own payment module and payment process. As stated, everything was peachy until last night with NO code changes my end. Plus of course, I have no influence over the availability of the simulator login page which simultaneously went offline.

 

Cheers

 

Carbon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×