Jump to content
Sign in to follow this  
folic10

Authorize.net NOT processing orders

Recommended Posts

I just installed Authorize.net Simple Integration Method (http://addons.oscommerce.com/info/5663) its in testing mode (Authorize.net Interface) right now. but whenver i submit the transaction. authorize.net gets it, but it does not get registered with my site.

 

it returns to the website, but it asks to login into the members area again.

 

its like the problem with PayPal.

 

i looked at the module and i can't find anywhere where it states a return address or something?

 

when i turn off "test mode" in the Authorize.net interface and the module settings are set to "LIVE" it gives me this error:

 

The following errors have occurred.

(98) This transaction cannot be accepted.

 

HELP!

What to do?

Share this post


Link to post
Share on other sites
I just installed Authorize.net Simple Integration Method (http://addons.oscommerce.com/info/5663) its in testing mode (Authorize.net Interface) right now. but whenver i submit the transaction. authorize.net gets it, but it does not get registered with my site.

 

it returns to the website, but it asks to login into the members area again.

 

its like the problem with PayPal.

 

i looked at the module and i can't find anywhere where it states a return address or something?

 

when i turn off "test mode" in the Authorize.net interface and the module settings are set to "LIVE" it gives me this error:

 

The following errors have occurred.

(98) This transaction cannot be accepted.

 

HELP!

What to do?

I'd start by reviewing the configuration at authorize.net's end. See http://www.authorize.net/support/SIM_guide.pdf

Share this post


Link to post
Share on other sites
(98) This transaction cannot be accepted.

Response Reason Code: 98

 

Response Reason Text: This transaction cannot be accepted.

 

Notes: Applicable only to the SIM API. The transaction fingerprint has already been used.

 

Integration Team Suggestions: Part of the security feature for SIM (Simple Integration Method) includes the generation of a fingerprint hash. The fingerprint hash is generated by a function in the scripting that uses five parameters to calculate the fingerprint. The parameters are: amount, sequence number, timestamp, transaction key and login ID. Any fingerprint hash can only be used once in 24 hours.

 

If a customer fills in incorrect information and the transaction is declined, they cannot click Back and re-enter the information as this will attempt to use the same fingerprint hash in resubmitting the transaction request, which will result in error 98.

 

The customer must be directed back to the page that establishes the amount of the transaction request, then re-enter information from that point on.

 

See http://developer.authorize.net/tools/responsereasoncode/

Share this post


Link to post
Share on other sites

baddog:

 

Are you saying its just that I didn't enter the correct customer information? because I just tested it. Put the exact contact information as in checkout and it worked.

 

but once i pressed "submit" it went to https://secure.authorize.net/gateway/transact.dll instead of http://www.mydomain.com/checkout_process.php

 

I'm asked to enter my login details, but that just leads to the my homepage. When I check my shopping cart; my stuff is still in it. The order DIDN'T go through.

Edited by folic10

Share this post


Link to post
Share on other sites
baddog:

 

Are you saying its just that I didn't enter the correct customer information?

 

How about the fact that the order doesn't get saved in OSC?

There is some configuring you need to do at the authorize.net end to make sure the order is accepted by them and the customer is returned to your site (where the order is captured on your end). You need to log in to your authorize.net control panel to do that.

Share this post


Link to post
Share on other sites
There is some configuring you need to do at the authorize.net end to make sure the order is accepted by them and the customer is returned to your site (where the order is captured on your end). You need to log in to your authorize.net control panel to do that.

 

where do I go to do that? i'v already changed the Response/Receipt URLs to: https://www.mydomain.com/checkout_process.php

 

what other settings do I have to change? the SIM Guide just tells how to write script for the payment page, and makes no sense.

Edited by folic10

Share this post


Link to post
Share on other sites
where do I go to do that? i'v already changed the Response/Receipt URLs to: https://www.mydomain.com/checkout_process.php

 

what other settings do I have to change? the SIM Guide just tells how to write script for the payment page, and makes no sense.

Take a look at the section entitled Integration Methods Explained in the Authorize.net knowledge base. You might consider using the AIM integration method. Personally, I use http://addons.oscommerce.com/info/4091

Edited by baddog

Share this post


Link to post
Share on other sites
Take a look at the section entitled Integration Methods Explained in the Authorize.net knowledge base. You might consider using the AIM integration method.

 

AIM seems way more complicated and when it comes to programming I'm very basic.

 

Does anyone know how to fix this?

Share this post


Link to post
Share on other sites

why do I keep getting redirected to the login page!????!!! I'm losing my hair. someone please help me. I've read the other posts, and they go in all sorts of tangents that make them useless, the guide is way too cumbersome and i'm not a php programmer so it made no sense to me.

Share this post


Link to post
Share on other sites

ok, i was able to solve PROBLEM 1: getting the order through, and having OSC confirm the order.

 

BUT....

 

THIS works fine in testing mode, once i pay with Authorize.net i get sent to http://www.mydomain.com/checkout_success.php but when i turn Authorize.net to live, i get redirected to http://www.mydomain.com/checkout_process.php

 

instead of the login page, it asks customer to choose payment>confirm>pay with credit card

 

doesn't make much sense, how do I solve this? and have it go directly to checkout_success.php as it was doing in testing mode.

 

in Authorize.net settings are:

 

Default Receipt URL: http://www.mydomain.com/checkout_success.php

Default Relay Response URL: http://www.mydomain.com/checkout_process.php

 

if I change the Relay Response URL to checkout_success.php, when I go the Authorize.net Payment form, it give me an error of:

 

(14) The referrer, relay response or receipt link URL is invalid.

 

im so close to solving this nightmare.....please help me finish this off

Edited by folic10

Share this post


Link to post
Share on other sites

I am having the same problem of Authorize.net redirecting me to the login page and not processing the order.

How did you resolve the issue? I am at a loss. I've modified the redirects to the checkout_process.php page, that didn't solve the problem

 

Please help!!

Share this post


Link to post
Share on other sites

I called Authorize.net and they told me that our website is sending and responding to them and they are receiving all the feedback they should be getting. However, I am still not receiving the info from Authorize.net that I need back from them. Auth.net says that it is probably a parsing error. I have no idea where to start trying to figure out this issue.

 

If you can help I would greatly appreciate it!! I am at a complete loss!

 

I have the redirects going to the shop/checkout_process.php but when Authorize.net sends the transaction back, shop is not seeing the info and is not recording the sale. (understand? hard for me to say it all correctly)

 

Thanks, Pam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×