Latest News: (loading..)
NimaP

One Page Checkout Support

2,293 posts in this topic

Why would someone need to reload the page? What version are you using? If you are using 1.5 they have a new button that uses AJAX to reload the shipping and payment methods without reloading the page. This makes a better user experience so that they don't have to see the shipping/payment methods reload with every change in the event they need to change information.

 

 

Maybe not reload, but if someone does it i dont want them to fill in all fields again. Im using 1.4.

 

Same if they go to the paymentprocessor and then click cancel to go back to my shop the customer details is gone.

 

There must be some way to save this information in session.

 

Im going to dig in the subject.

Share this post


Link to post
Share on other sites

Hi there,

 

Love the Contribution, but I have a problem with it.

 

The issue is with IE9, when someone enters an e-mail address IE9 freezes and will not proceed. It comes up, after a while, with "(website) is not responding due to a long-running script". I have placed <meta http-equiv="X-UA-Compatible" content="IE=8"/> into my checkout.php to force it to run as IE8, but still same problem.

 

The only other script I am running is for lightbox, and that does not impact the checkout.php. I still deleted it just in case, no effect. I also have tried putting my full address before the ext/jQuery.... in each line. No help either. Any ideas?

 

Maybe it is a IE9 problem, but as it is the one most people use due to Microsofts somewhat insistent update system I really want it to work on my website.

 

Thanks For the help

Steve C

 

Did you find a solution Steve? I am having the same issue with IE. Firefox and Chrome work fine.

torwoods likes this

Share this post


Link to post
Share on other sites

Did you find a solution Steve? I am having the same issue with IE. Firefox and Chrome work fine.

 

I had the same problem with One Page Checkout so, installed the lastest version 1.5, this seemed to have solved the problem, however I am using Protx Direct and I now get the following message

 

Warning: constant() [function.constant]: Couldn't find constant MODULE_PAYMENT_PROTX_DIRECT_USE_ in /home/redtest/public_html/includes/modules/payment/protx_direct.php on line 264

 

Warning: Cannot modify header information - headers already sent by (output started at /home/redtest/public_html/includes/modules/payment/protx_direct.php:264) in /home/redtest/public_html/includes/functions/general.php on line 29

 

any suggestions

Share this post


Link to post
Share on other sites

I have older versions of this contribution working on two different carts, but I am trying to get 1.5 working now on a third cart. Everything appears to work OK except adding addresses to the address book, and editing addresses in the address book. These two functions work, but they don't work OK. The edits take place on the server side (and the new addresses are inserted), however; despite the a 200 OK with a response of

   {
     "success": "true",

   } 

The following code block in the checkout.php file (around line 601)

onePage.queueAjaxRequest({ 
						url: onePage.pageLinks.checkout,
						beforeSendMsg: 'Updating Address',
						dataType: 'json',
						data: $(":input", this).serialize(),
						type: 'post',
						success: function (data){ 
							onePage.loadAddressBook($this, addressType);
						},
						errorMsg: 'There was an error saving your address, please inform <?php echo STORE_NAME; ?> about this error.'
					});

Is returning the errorMsg rather than completing the success function. I have gone through all the applicable code and cannot find any reason why this would happen.

If I close the alert and close the dialog then click change address I can see that the changes were in fact saved despite the error message to the contrary. Furthermore once the new address has been added or edit made I can simply click the radio button of the address I want to change to and then click confirm and it changes it without any error message. Any help would be greatly appreciated.

Edited by jsalis

Share this post


Link to post
Share on other sites

Hi all, then this contribution to implement the payment module does not work.

 

is not directed to the site of some assistance payment

Share this post


Link to post
Share on other sites

Hi there,

 

Love the Contribution, but I have a problem with it.

 

The issue is with IE9, when someone enters an e-mail address IE9 freezes and will not proceed. It comes up, after a while, with "(website) is not responding due to a long-running script". I have placed <meta http-equiv="X-UA-Compatible" content="IE=8"/> into my checkout.php to force it to run as IE8, but still same problem.

 

The only other script I am running is for lightbox, and that does not impact the checkout.php. I still deleted it just in case, no effect. I also have tried putting my full address before the ext/jQuery.... in each line. No help either. Any ideas?

 

Maybe it is a IE9 problem, but as it is the one most people use due to Microsofts somewhat insistent update system I really want it to work on my website.

 

Thanks For the help

Steve C

 

 

Did you find a solution Steve? I am having the same issue with IE. Firefox and Chrome work fine.

 

 

I had the same problem with One Page Checkout so, installed the lastest version 1.5, this seemed to have solved the problem, however ...

 

 

No not yet. I am wary about going to 1.5. I tried to install it when I first discovered this contribution but it never worked for me. I assumed it was because I am using a 2.2 MS2 version of oscommerce and not the 2.3 etc. Is that the case anyone? is the 1.5 version of OPC for all versions of oscommerce or not?

 

If I can not get this fixed I will have to try using 1.5 or removing the contrib, which sucks, as it is, in my opinion, the best single page checkout out there.

 

Steve C

Share this post


Link to post
Share on other sites

Hello the problem is that you lose the session at time of call checkout.php.

 

any solution?

Share this post


Link to post
Share on other sites

Hi all, then this contribution to implement the payment module does not work.

 

is not directed to the site of some assistance payment

 

 

Hello the problem is that you lose the session at time of call checkout.php.

 

any solution?

Share this post


Link to post
Share on other sites

Hello the problem is that you lose the session at time of call checkout.php.

 

any solution?

 

 

With the version dated 22 Mar 2011 was successful (one page checkout 1.5)

Share this post


Link to post
Share on other sites

I'm no Java pro, but this seems to do the trick:

 

In checkout.php, find:

	if (updateTotals == true){
		       onePage.updateOrderTotals();
		  }

This is around line 453.

 

Add right after:

 

javascript:location.reload(true);

 

 

 

Well done mate, this solved the password/login button issue for me too.

Share this post


Link to post
Share on other sites

I followed the installation instructions, and everything seemed fine. I checked the site right before doing the database queries and the only thing that was funky was that my paypal express button had disappeared. So I copied, pasted, and executed the database queries using phpmyadmin, and now I can't access my site or backend at all

1142 - SELECT command denied to user 'fullofju_osc1'@'localhost' for table 'configuration'

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

I've never actually run a database query before, but it seemed super easy when I did it I don't see how I could have done anything wrong? It was just paste, and press go. I used the backup I created from my Cpanel and clicked restore tables, and it still shows the same error message? Any clues?

Share this post


Link to post
Share on other sites

I have older versions of this contribution working on two different carts, but I am trying to get 1.5 working now on a third cart. Everything appears to work OK except adding addresses to the address book, and editing addresses in the address book. These two functions work, but they don't work OK. The edits take place on the server side (and the new addresses are inserted), however; despite the a 200 OK with a response of

   {
     "success": "true",

   } 

The following code block in the checkout.php file (around line 601)

onePage.queueAjaxRequest({ 
						url: onePage.pageLinks.checkout,
						beforeSendMsg: 'Updating Address',
						dataType: 'json',
						data: $(":input", this).serialize(),
						type: 'post',
						success: function (data){ 
							onePage.loadAddressBook($this, addressType);
						},
						errorMsg: 'There was an error saving your address, please inform <?php echo STORE_NAME; ?> about this error.'
					});

Is returning the errorMsg rather than completing the success function. I have gone through all the applicable code and cannot find any reason why this would happen.

If I close the alert and close the dialog then click change address I can see that the changes were in fact saved despite the error message to the contrary. Furthermore once the new address has been added or edit made I can simply click the radio button of the address I want to change to and then click confirm and it changes it without any error message. Any help would be greatly appreciated.

 

 

I am having exactly the same issue.

 

I just installed the latest version and when editing the address , I receive the error but the changes go through. "Not good" :)

 

Also if you log in and attempt to change your address directly without going through checkout, the page does not show in my case.

 

I love the speed of the newer version. Much, much faster.

 

Hope someone can solve this one. I'm trying.

Share this post


Link to post
Share on other sites

I am having exactly the same issue.

 

I just installed the latest version and when editing the address , I receive the error but the changes go through. "Not good" :)

 

Also if you log in and attempt to change your address directly without going through checkout, the page does not show in my case.

 

I love the speed of the newer version. Much, much faster.

 

Hope someone can solve this one. I'm trying.

 

Update:

 

I changed the code from:

 

errorMsg: 'There was an error saving your address, please inform <?php echo STORE_NAME; ?> about this error.'

 

To:

error: function(data, statusCode) {

alert("ERROR: "+data)

}

 

And I get the message: There was an Ajax error contact My Website to report the error.

Share this post


Link to post
Share on other sites

Update:

 

I changed the code from:

 

errorMsg: 'There was an error saving your address, please inform <?php echo STORE_NAME; ?> about this error.'

 

To:

error: function(data, statusCode) {

alert("ERROR: "+data)

}

 

And I get the message: There was an Ajax error contact My Website to report the error.

 

Actually if you remove that line completely, you get the Ajax error message.

Apparently this has been an issue that has not been addressed.

Share this post


Link to post
Share on other sites

I have older versions of this contribution working on two different carts, but I am trying to get 1.5 working now on a third cart. Everything appears to work OK except adding addresses to the address book, and editing addresses in the address book. These two functions work, but they don't work OK. The edits take place on the server side (and the new addresses are inserted), however; despite the a 200 OK with a response of

   {
     "success": "true",

   } 

The following code block in the checkout.php file (around line 601)

onePage.queueAjaxRequest({ 
						url: onePage.pageLinks.checkout,
						beforeSendMsg: 'Updating Address',
						dataType: 'json',
						data: $(":input", this).serialize(),
						type: 'post',
						success: function (data){ 
							onePage.loadAddressBook($this, addressType);
						},
						errorMsg: 'There was an error saving your address, please inform <?php echo STORE_NAME; ?> about this error.'
					});

Is returning the errorMsg rather than completing the success function. I have gone through all the applicable code and cannot find any reason why this would happen.

If I close the alert and close the dialog then click change address I can see that the changes were in fact saved despite the error message to the contrary. Furthermore once the new address has been added or edit made I can simply click the radio button of the address I want to change to and then click confirm and it changes it without any error message. Any help would be greatly appreciated.

 

 

Hey all , I found the Bug !!!

 

Within the "saveAddress" action in includes/classes/onepage_checkout

 

At around line 931, find this statement:

"success": "true",}';

 

Remove the comma. It should look like the following:

"success": "true"}';

 

Makes wanna go hmmmm..

Share this post


Link to post
Share on other sites

I have combed through this thread and others for what feels like a week now. I've tried everything and can't get this contribution to work. I would like it to work with the Credit Card CCV contribution as well.

 

I have installed a completely "fresh" installation and still can't get it to work.

 

Can anyone help me? I would be happy to compensate for their time.

 

www.rbiproswing.com/shop

Share this post


Link to post
Share on other sites

Dear All,

I thought that I had managed to get all the bugs out of this contribution and was jumping for joy to have it all setup and working as I wanted. Today I have noticed a major issue when I use Internet Explorer 8 or 9 :o .

 

After adding a product to the cart, you proceed to the checkout page. Then...

1, If you’re a new customer, you fill in your details then click checkout button. IE then hangs and then crashes.

2, If you already have an account, you sign in using the checkout.php page, all the fields are populated, but the ajax keeps refreshing (Loading…) at the bottom of the page then after 2 or 3 min it just stops but then the checkout button doesn’t work. Very occasionally it will stop after 4 or 5 min and when pressed it takes you to PayPal as normal.

 

I have tested the site using Internet Explorer 8 & 9, Google Chrome, Firefox 4 and Safari 5. All the browsers work perfectly except Internet Explorer.

The shop is at: allaccessories.co.uk

Site is OSC 2.2 RC2 and OPC 1.5

 

Please take a look and any suggestions would be greatly appreciated.

Many thanks

Share this post


Link to post
Share on other sites

Hi guys,

 

I have almost complete the implementation of OPC.

Unfortunately I am still having few issues.

 

My OPC include the add-on UK Postcode Address Finder provided by craftyclicks

 

http://www.oscommerce.com/community/contributions,6322

 

Everything seems work fine but once you search for the address using the postcode and then select the correct one, the fields Street Address and City get filled but OPC does not check them. If I finalize the checkout I get the error message saying that the Billing Addrees has not been inserted.

 

The workaround that I have found require to simply click on the form Street Address and the click on another form.

I suspect that the Javascript that get trigger once you type in, does not get trigger when select the address for UK Postcode Address FInder contribution.

 

Can anyone point me out in where I can find the code that trigger the check and verify if the address inserted is valid?

Any ideas on how to fix this?

 

Thanks in advance for your help.

Kind Regards

JK

Share this post


Link to post
Share on other sites

The issue is with IE9, when someone enters an e-mail address IE9 freezes and will not proceed. It comes up, after a while, with "(website) is not responding due to a long-running script". I have placed <meta http-equiv="X-UA-Compatible" content="IE=8"/> into my checkout.php to force it to run as IE8, but still same problem.

 

Did you find a solution Steve? I am having the same issue with IE. Firefox and Chrome work fine.

 

I just saw this issue and was hoping you guys got it figured out.

 

<meta http-equiv="X-UA-Compatible" content="IE=7"/>

 

Have you tried forcing Compatible mode IE=7 rather then 8..? Probably a long shot, but worth a try.

 

I have had a few complaints on this too. I do not have ie9 to test against.

Edited by Debs

Share this post


Link to post
Share on other sites

The issue is with IE9, when someone enters an e-mail address IE9 freezes and will not proceed. It comes up, after a while, with "(website) is not responding due to a long-running script". I have placed <meta http-equiv="X-UA-Compatible" content="IE=8"/> into my checkout.php to force it to run as IE8, but still same problem.

 

 

 

I just saw this issue and was hoping you guys got it figured out.

 

<meta http-equiv="X-UA-Compatible" content="IE=7"/>

 

Have you tried forcing Compatible mode IE=7 rather then 8..? Probably a long shot, but worth a try.

 

I have had a few complaints on this too. I do not have ie9 to test against.

 

 

Hi Debs,

 

No still not working I am afraid, switching to 7 from 8 made no difference other than my input boxes became smaller. Anyone else had any results? As it appears to be a relatively small number of us suffering from this, I can only assume it has to do with the versions we are using. Anyone using 1.5 have this issue?

 

Steve C

Share this post


Link to post
Share on other sites

Hi Debs,

 

No still not working I am afraid, switching to 7 from 8 made no difference other than my input boxes became smaller. Anyone else had any results? As it appears to be a relatively small number of us suffering from this, I can only assume it has to do with the versions we are using. Anyone using 1.5 have this issue?

 

Steve C

 

Hi Steve,

I took a quick look into it and wonder if it could be this issue:

jQuery UI does not work on IE9...

 

This page URL covers it a bit, and a possible solution: http://forum.jquery.com/topic/jquery-ui-does-not-work-on-ie9

 

I do not have IE9 to test... perhaps you could try and post your results. Our jQuery UI is combined with a few things... and they all may need to be updated.

 

Debs

Edited by Debs

Share this post


Link to post
Share on other sites

Dear All,

I thought that I had managed to get all the bugs out of this contribution and was jumping for joy to have it all setup and working as I wanted. Today I have noticed a major issue when I use Internet Explorer 8 or 9 :o .

 

After adding a product to the cart, you proceed to the checkout page. Then...

1, If you’re a new customer, you fill in your details then click checkout button. IE then hangs and then crashes.

2, If you already have an account, you sign in using the checkout.php page, all the fields are populated, but the ajax keeps refreshing (Loading…) at the bottom of the page then after 2 or 3 min it just stops but then the checkout button doesn’t work. Very occasionally it will stop after 4 or 5 min and when pressed it takes you to PayPal as normal.

 

I have tested the site using Internet Explorer 8 & 9, Google Chrome, Firefox 4 and Safari 5. All the browsers work perfectly except Internet Explorer.

The shop is at: allaccessories.co.uk

Site is OSC 2.2 RC2 and OPC 1.5

 

Please take a look and any suggestions would be greatly appreciated.

Many thanks

 

 

Can you post all of the bugs you found and how you resolved them. We need to consolidate this info into one place. What cc module are you using?

Share this post


Link to post
Share on other sites

Hi Steve,

I took a quick look into it and wonder if it could be this issue:

jQuery UI does not work on IE9...

 

This page URL covers it a bit, and a possible solution: http://forum.jquery.com/topic/jquery-ui-does-not-work-on-ie9

 

I do not have IE9 to test... perhaps you could try and post your results. Our jQuery UI is combined with a few things... and they all may need to be updated.

 

Debs

 

Interesting Debs,

 

I tried a bunch of what they were talking about, but really came away with a couple of thoughts.....

 

1..I have no idea what or how to deal with JQuerry, or infact any JavaScript

2..Maybe I should update the JQuerry.

 

So I grabbed the latest version of JQuerry called: jquery-ui-1.8.14.custom.min.js, changed the name to jQuery.ui.js and placed it into the ext folder, I also grabbed a copy of jQuery.js 1.6.2 and slammed that into my website, again into the ext folder.

 

Now I no longer get the Waiting for long running script error, I do, however, get the annoying Message from webpage "there was an error checking e-mail address, please inform......" pop up. So really no better off. In fact worse, as my Chrome no longer works, I get the same error as I do in IE9.

 

The fact that I changed the error I am getting indicates to me that I am on the right path, and need to get my JQuerry files sorted out, but to do that I need a better understanding of what they do. Anyone disagree/agree? I am sure I have created my own problems by using what I guessed at as the right script and would love someone to give me a clearer picture as to what we need for this script to work.

 

Steve C

Share this post


Link to post
Share on other sites

Please Help. and soory about my english.

 

i have a local (my town) store and i dont need Payment Method & Shipping Method.

 

 

I want to totally remove from checkout page.

 

Payment Method

...............

Shipping Method

...............

 

i try evrything but no succes.

 

 

Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now