Jump to content
Latest News: (loading..)
NimaP

One Page Checkout Support

Recommended Posts

While doing further testing I have found the following Using KGT with One Page Checkout if the coupon is processed prior to selecting a different table rate shipping method the discount will also apply to the shipping as well as the subtotal. For a fix checkout this post I wrote regarding the includes/classes/discount_coupons.php and how I fixed the issue two post later.

Duh! It might help some of you if I actually provide the link I spoke of. Here is the link to the fix for discount_coupons.php


I run a completely customized osC2.2 RC1 shop with mostly custom modifications that replicate the features of many contributions available except in a way that the data is more easily synced with Quickbooks on a continuous basis.

Share this post


Link to post
Share on other sites

Hello Bo,

 

What should the sort order be with discount coupons installed? At the moment I've got...

 

Discount Coupon 4

Low Order Fee

Shipping 2

Sub-Total 1

Tax 3

Total 5

 

Cheers,

Mark.

In the CCGV install file there is a sort order for tax calculations. You may have to play around with them to find the right combination. If the trouble is discount not going to paypal. Use the paypal fix.

Share this post


Link to post
Share on other sites

Hello Bo,

 

What should the sort order be with discount coupons installed? At the moment I've got...

 

Discount Coupon 4

Low Order Fee

Shipping 2

Sub-Total 1

Tax 3

Total 5

 

Cheers,

Mark.

Sort orders will probably depend on what you have installed. There is a sort order in the instructions for tax calculation but that will still depend on what you have installed. Here is mine that I use on several shops with one page checkout and CCGV

Discount Coupons 5

Gift Vouchers (-) 4

Low Order Fee

Shipping 2

Sub-Total 1

Tax 3

Total 6

Share this post


Link to post
Share on other sites

fernyburn, is this a Template Monster template?

 

 

Hi guys

 

No its not a template site, hundreds of mods in it though, can't find an answer to the problem anywhere

Share this post


Link to post
Share on other sites

I had time to look into the form field validation issues I was having and discovered the following:

1.) There apparently are validation scripts that do at least the minimum checks (ie. min. length)

2.) These functions are not being called and form data is going straight to the AJAX function. I put an alert in each of the three validation scripts I found (getFieldErrorCheck(), checkFieldForErrors(), fieldErrorCheck()) and none of the alerts came up.

3.) Apparently you should be able to force validation on a field by adding the class name "required" to an input, though I tried this and it did nothing. I imagine there would also have to be an entry in the getFieldErrorCheck() function which in my case there is.

4.)fieldErrorCheck() appears to be called on the various fields from the attachAddressFields() function, but in my case this call is not being made.

 

Does anybody have any pointers here?


I run a completely customized osC2.2 RC1 shop with mostly custom modifications that replicate the features of many contributions available except in a way that the data is more easily synced with Quickbooks on a continuous basis.

Share this post


Link to post
Share on other sites

On checking out, I get the following message:

Fatal error: Call to a member function loadSessionVars() on a non-object in /home/user/public_html/yebo7.com/checkout_process.php on line 60

 

Anyone with similar problem and how to solve it?

 

Felix

Share this post


Link to post
Share on other sites

Hi

 

has anybody come across this problem (no payment module selected).

 

I'm testing on a WAMP server and the site is a customised 2.2 RCa (there's not a lot of PHP changes with it - just stuff like infoboxes and so on- no STS or BTS - even so I have ran a fielcomp with a standard 2.2a and there's no extra javascript/php added that could upset the contribution) . I've installed the latest versionof the contribution and it all works apart from the fact that no payment module is 'seen' by checkout_process - the line being

 

(is_object($$payment) && ($$payment->enabled == false))

 

The checkout.php file is POSTING a value for 'payment' but that value is not getting through to checkout_process (This is the case whether a single payment module is available or more than one). - if you comment out the code above in checkout_process then the order will proceed, otherwise you get bounced back to checkout.php.

 

If you revert to the standard osC checkout it runs as normal.

 

Any clues?

 

Thanks

 

Graeme

Edited by sakwoya

Share this post


Link to post
Share on other sites

I had time to look into the form field validation issues I was having and discovered the following:

1.) There apparently are validation scripts that do at least the minimum checks (ie. min. length)

2.) These functions are not being called and form data is going straight to the AJAX function. I put an alert in each of the three validation scripts I found (getFieldErrorCheck(), checkFieldForErrors(), fieldErrorCheck()) and none of the alerts came up.

3.) Apparently you should be able to force validation on a field by adding the class name "required" to an input, though I tried this and it did nothing. I imagine there would also have to be an entry in the getFieldErrorCheck() function which in my case there is.

4.)fieldErrorCheck() appears to be called on the various fields from the attachAddressFields() function, but in my case this call is not being made.

 

Does anybody have any pointers here?

I cannot edit my post above so I've tagged this on here.

 

I also found none of the javascript validation was working in my file checkout.php

 

The JQuery files do get called correctly and they do load but do not execute. I have removed all extra code that were being called and found the problem for this lay with some code in either includes/header.php or includes/column_left.php - if I strip those out of checkout.php then validation will take place and I can also checkout. I'm currently wading through the code reapplying chunks at a time until I can find out what is causing the problem - I think it is a variable that is getting declared in the custom code in this sites' header/left column which matches a name used in the one page checkout process

 

I have tried v 1.2 and v1.4 of this contribution - both display the above behavior.

 

 

I may also add that this is the fifth or sixth time I have tried installing this contribution on different stores and I have never yet got it to work on anything other than a vanilla install - my current attempt is pretty typical. (and if a client asks for this again I may just say 'no' or inflate my fee!)

 

Graeme

Share this post


Link to post
Share on other sites

If OPC is turned on, the options are carried forward to the OPC page and if no changes are made to the shopping cart in checkout.php then all is well. BUT if the quantity in the cart on the OPC page is changed the options are lost. The values in field 'products_options_value_text' in table 'customers_basket_attributes' appear to be deleted during the cart update.

 

For others that are having this problem, I have posted a fix to this problem here:

http://forums.oscommerce.com/topic/338661-contribution-option-types-v2/page__st__580__gopid__1559766#entry1559766

Share this post


Link to post
Share on other sites

@jsalis

 

I've got the OPC working now in my templated site by stripping out each external javascript link one at a time to see what was upsetting OPC - turns out it was two things

 

a call to another version of jquery in the file includes/boxes/categories.php - took that out.

 

Call to a javascript in the in the templated files - if the calls to the javascript to OPC are placed last in <head> this one was resolved too

 

Graeme

Share this post


Link to post
Share on other sites

@jsalis

 

I've got the OPC working now in my templated site by stripping out each external javascript link one at a time to see what was upsetting OPC - turns out it was two things

 

a call to another version of jquery in the file includes/boxes/categories.php - took that out.

 

Call to a javascript in the in the templated files - if the calls to the javascript to OPC are placed last in <head> this one was resolved too

 

Graeme

Share this post


Link to post
Share on other sites

Sort orders will probably depend on what you have installed. There is a sort order in the instructions for tax calculation but that will still depend on what you have installed. Here is mine that I use on several shops with one page checkout and CCGV

Discount Coupons 5

Gift Vouchers (-) 4

Low Order Fee

Shipping 2

Sub-Total 1

Tax 3

Total 6

 

Hello Bo,

 

Thanks for your help on this. Much appreciated. I've changed the sort order to the following and it seems to be working fine now...

 

Discount Coupon 2

Low Order Fee

Shipping 3

Sub-Total 1

Tax 4

Total 5

 

Just one thing though... For those orders that came in before I still can't update the order status so they're stuck in "Completed". Is there any other way of updating the status of these orders (maybe in phpmyadmin?)

 

Thanks again,

 

Mark.

Share this post


Link to post
Share on other sites

I have combed through this thread and found similar problem but no suitable answer.

1. Everything seems to work well, but on checkout_success page, I get a blank page after installing OPC. Even when I set it to false in admin to revert back to the previous, normal checkout process, I now get the blank page. I bring back back the original catalog/checkout_process file, and I get the same blank page.

The message I get from the error log is;

Fatal error: Call to a member function loadSessionVars() on a non-object in /home/user/public_html/yebo7.com/checkout_process.php on line 60

 

Line 60 is somewhere here:

One Page Checkout - BEGIN */

if (ONEPAGE_CHECKOUT_ENABLED == 'True'){

$onePageCheckout->loadSessionVars();

$onePageCheckout->fixTaxes();

 

/*

* This error report is due to the fact that we cannot duplicate some errors.

* please forward this email always if you recieve it

*/

if ($order->customer['email_address'] == '' || $order->customer['firstname'] == '' || $order->billing['firstname'] == '' || $order->delivery['firstname'] == ''){

ob_start();

echo 'ONEPAGE::' . serialize($onepage);

echo 'SESSION::' . serialize($_SESSION);

echo 'SERVER::' . serialize($_SERVER);

echo 'ORDER::' . serialize($order);

$content = ob_get_contents();

mail(ONEPAGE_DEBUG_EMAIL_ADDRESS, 'Order Error: Please forward to I.T. Web Experts', $content);

unset($content);

ob_end_clean();

}

}

/* One Page Checkout - END */

 

 

2. Secondly, do I have to install kgt_howto even though I'm not interested in coupons? Could it be that it's because I didn't install this?

 

Please help!

 

Felix

Share this post


Link to post
Share on other sites

I have combed through this thread and found similar problem but no suitable answer.

1. Everything seems to work well, but on checkout_success page, I get a blank page after installing OPC. Even when I set it to false in admin to revert back to the previous, normal checkout process, I now get the blank page. I bring back back the original catalog/checkout_process file, and I get the same blank page.

The message I get from the error log is;

Fatal error: Call to a member function loadSessionVars() on a non-object in /home/user/public_html/yebo7.com/checkout_process.php on line 60

 

Line 60 is somewhere here:

One Page Checkout - BEGIN */

if (ONEPAGE_CHECKOUT_ENABLED == 'True'){

$onePageCheckout->loadSessionVars();

$onePageCheckout->fixTaxes();

 

/*

* This error report is due to the fact that we cannot duplicate some errors.

* please forward this email always if you recieve it

*/

if ($order->customer['email_address'] == '' || $order->customer['firstname'] == '' || $order->billing['firstname'] == '' || $order->delivery['firstname'] == ''){

ob_start();

echo 'ONEPAGE::' . serialize($onepage);

echo 'SESSION::' . serialize($_SESSION);

echo 'SERVER::' . serialize($_SERVER);

echo 'ORDER::' . serialize($order);

$content = ob_get_contents();

mail(ONEPAGE_DEBUG_EMAIL_ADDRESS, 'Order Error: Please forward to I.T. Web Experts', $content);

unset($content);

ob_end_clean();

}

}

/* One Page Checkout - END */

 

 

2. Secondly, do I have to install kgt_howto even though I'm not interested in coupons? Could it be that it's because I didn't install this?

 

Please help!

 

Felix

Hi Felix,

 

You have this added in checkout_proccess.php

/* One Page Checkout - BEGIN */

if (ONEPAGE_CHECKOUT_ENABLED == 'True'){

require('includes/classes/onepage_checkout.php');

$onePageCheckout = new osC_onePageCheckout();

}

/* One Page Checkout - END */

 

after the language

include(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CHECKOUT_PROCESS);

 

Steve

Share this post


Link to post
Share on other sites

Hi guys,

 

I wonder if you can help me with a couple of queries....

 

1. When I'm viewing the checkout page in Firefox or Safari, everything is ok, but in IE7 the boxes are all over the place.

2. When I use $ as a currency, everything is fine, but when I flick over to Euro, the very first value on the page shows with a Euro sign, but none of the rest show a sign at all.

 

Thanks

 

Andrew

Share this post


Link to post
Share on other sites

Hi guys,

 

I wonder if you can help me with a couple of queries....

 

1. When I'm viewing the checkout page in Firefox or Safari, everything is ok, but in IE7 the boxes are all over the place.

2. When I use $ as a currency, everything is fine, but when I flick over to Euro, the very first value on the page shows with a Euro sign, but none of the rest show a sign at all.

 

Thanks

 

Andrew

Hi Andrew,

 

in includes/checkout any file with address in the name you will have to add width="xxpx" to the TD tags for IE

 

use utf8 code for the euro sign

 

use this to get the utf8 code

http://www.atm.ox.ac.uk/user/iwi/charmap.html

 

Steve

Share this post


Link to post
Share on other sites

Hi Andrew,

 

in includes/checkout any file with address in the name you will have to add width="xxpx" to the TD tags for IE

 

use utf8 code for the euro sign

 

use this to get the utf8 code

http://www.atm.ox.ac.uk/user/iwi/charmap.html

 

Steve

 

Steve,

 

Thanks for the reply. The Euro code worked a treat!! I've been modding an install for a couple of weeks for a client and I've never found these errors!

 

As for the TD tags, do I whack that code in every single TD tag on the pages?

 

Thanks again

 

Andrew

Share this post


Link to post
Share on other sites

Steve,

 

Thanks for the reply. The Euro code worked a treat!! I've been modding an install for a couple of weeks for a client and I've never found these errors!

 

As for the TD tags, do I whack that code in every single TD tag on the pages?

 

Thanks again

 

Andrew

 

Steve,

 

I've managed to fix these issues - thanks again for your help!

 

I have one last issue with the checkout.js file. Basically, I need to check that if the currency is set to $, and the payment method has been selected as the iDeal Payment module, then I need to throw an error. I'm throwing out an error of Address Error followed by Password does not match confirmation password which obviously isn't correct. Any ideas?

 

Thanks

 

Andrew

Share this post


Link to post
Share on other sites

Steve,

 

I've managed to fix these issues - thanks again for your help!

 

I have one last issue with the checkout.js file. Basically, I need to check that if the currency is set to $, and the payment method has been selected as the iDeal Payment module, then I need to throw an error. I'm throwing out an error of Address Error followed by Password does not match confirmation password which obviously isn't correct. Any ideas?

 

Thanks

 

Andrew

Hi Andrew,

 

i don't i would suggest use freelancer.com and find a java/php code to look at it, i have never used that payment module, wont be a costly fix

 

Steve

Share this post


Link to post
Share on other sites

Hello,

I want to exclude the option 'country' from the checkout.php but when I remove it from the template page billing_address.php the customer details in de admin/orders.php dissapears. How can I prevent this?

 

Thx

Share this post


Link to post
Share on other sites

I'm having a problem with field validation. None of the javascripts for required fields seems to be working, as for many others in this thread.

I have set Telephone required to true in Admin but not even that field is working. Anyone that solved this problem yet?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

I'm having a problem with field validation. None of the javascripts for required fields seems to be working, as for many others in this thread.

I have set Telephone required to true in Admin but not even that field is working. Anyone that solved this problem yet?

 

Thanks in advance!

 

I can add that i'm using STS together with One Page Checkout, which seems to be the problem. Anyone solved this? I'm searching for a solution but haven't found one so far.

Share this post


Link to post
Share on other sites

I am trying to install this on a new store. I am using the latest version of OsC, osCommerce Online Merchant v2.3.1. I followed the installation instructions exactly, and when I actually activate the One Page Checkout in the admin panel, my checkout page is blank! I can see the menu at the top, but past that, everything else is blank! Not to mention, it takes the page forever to load. I have no idea what I did wrong, any ideas? If it helps, the default CSS file doesn't seem to be loading either. An image is attached.

 

blank_image.jpg

Share this post


Link to post
Share on other sites

OK, I fiddled with this addon for the remainder of the day, and I did manage to make it so it displays correctly, but I got a bunch of javascript errors, the loader wouldn't show, etc. And the layout was broken on IE. I went to the developers website, and in the demo, it does NOT display correctly in IE either. So they don't even have it right, this is using the latest version of osC V.2.3. I wish somebody would develop a checkout process for this shop that's not broken in every other way lol.

Share this post


Link to post
Share on other sites

Hello,

I want to exclude the option 'country' from the checkout.php but when I remove it from the template page billing_address.php the customer details in de admin/orders.php dissapears. How can I prevent this?

 

Thx

 

Can somebody help me with this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×