Jump to content
NimaP

One Page Checkout Support

Recommended Posts

Where would I install a <marquee> if I wanted above the shopping cart box? I've been trying, but can't work it out. :(

make a new info box copy one and rename it marquee.php

but just leave the html code in it, now place the marquee code after

<tr>
 <td>

 

 

now add an includes in catalog/includes/colomun_right.php

 

 include(DIR_WS_BOXES . 'marquee.php');

 

before

  require(DIR_WS_BOXES . 'shopping_cart.php');

 

Steve

Share this post


Link to post
Share on other sites

make a new info box copy one and rename it marquee.php

but just leave the html code in it, now place the marquee code after

<tr>
 <td>

 

 

now add an includes in catalog/includes/colomun_right.php

 

 include(DIR_WS_BOXES . 'marquee.php');

 

before

  require(DIR_WS_BOXES . 'shopping_cart.php');

 

Steve

 

Sorry Steve, I meant I want to add something like this :

 

<marquee bgcolor="#cccccc" loop="-1" scrollamount="2" width="100%">Example Marquee</marquee>

 

I had it on the front page, but just can't find a position for it on OPC.

 

I don't suppose you will get a chance to reply to my previous post could you? I really need to sort the currency out.

Share this post


Link to post
Share on other sites

I have One Page Checkout installed on 2 of my catalogs and they both work OK. We are missing the billing state and shipping state in the admin side of the order. I have done testing with my test account and the state shows up just fine on the checkout page during checking out. No state on order from the admin side for invoices or packing slips, it is also missing from the database too. I have searched for a fix to no avail.


Life Is Too Short,

Enjoy Your Coffee!

Pete

Share this post


Link to post
Share on other sites

I've done that, but it hasn't done anything. The thing that is strange is that it was working perfectly before I installed KGT. I didn't have to remove any code or anything. Now I have uninstalled KGT I have had to remove lots of code just to get it partly functional. How can that be possible?!

 

Would it be worth installing OPC again?

 

Sorted. I just uploaded all the original files again. :)

Share this post


Link to post
Share on other sites

Sorry Steve, I meant I want to add something like this :

 

<marquee bgcolor="#cccccc" loop="-1" scrollamount="2" width="100%">Example Marquee</marquee>

 

I had it on the front page, but just can't find a position for it on OPC.

 

I don't suppose you will get a chance to reply to my previous post could you? I really need to sort the currency out.

just have a look in catalog/includes/checkout/ folder and pick a file where you would like to place it

 

Regarding currency have you setup the new one as the default?

 

Steve

Share this post


Link to post
Share on other sites

I have One Page Checkout installed on 2 of my catalogs and they both work OK. We are missing the billing state and shipping state in the admin side of the order. I have done testing with my test account and the state shows up just fine on the checkout page during checking out. No state on order from the admin side for invoices or packing slips, it is also missing from the database too. I have searched for a fix to no avail.

Hi

 

I have same problem, i will look into this tomorrow

 

Steve

Share this post


Link to post
Share on other sites

just have a look in catalog/includes/checkout/ folder and pick a file where you would like to place it

 

Regarding currency have you setup the new one as the default?

 

Steve

 

I took the other currency off in the end. Should I set it to default then? I don't need it as the default though.

Share this post


Link to post
Share on other sites

Hi Longhorn1999

 

I had the same problem as you, I think I found the solution

 

if you go to the end of includes/checkout/payment_method.php

 

delete the CREDIT CLASS GIFT VOUCHER CONTRIBUTION

 

That should fix you problem

 

Well it did for me anyway :-)

 

Simon

 

Thank you, thank you, thank you

 

I can finally use this great contribution now that it works properly!

Share this post


Link to post
Share on other sites

Hi

 

I have same problem, i will look into this tomorrow

 

Steve

Thanks for looking! I am still trying to find an answer too. I may take the one page checkout off for a while and run a few tests and see if any orders show up correctly.


Life Is Too Short,

Enjoy Your Coffee!

Pete

Share this post


Link to post
Share on other sites

Hi this is a nice contribution.

 

I have only two problems. I use authorize.net aim and for some reason (with credit card orders) The State/Province info is not attached to the order. I manualy fix it on all new orders but our authorize.net conformation email also is without the state/province info. Anyone know were to start.

 

Thank you,

Mike

Share this post


Link to post
Share on other sites

Hi

 

I have managed to get this contribution almost sorted for my needs, but I have a problem with the creation of customer accounts. I have Account Creation set to required and Required Login to False. New customer enters all their details down to and including the password twice and then clicks Continue in order to checkout (we only take paypal for payments) (Paypal IPN v2.3.3 or thereabouts). After payment is finished paypal automatically redirects back to the order confirmation page - perfect.

 

BUT if the customer returns to the shop BEFORE payment is completed, all the address details are lost, AND NO ACCOUNT HAS BEEN CREATED.

 

I could set Required Login to True, but then the customer is sent to the 'normal' Login page and we lose the biggest advantage of OPC.

We want everyone to have an account set up using the password the customer chose, using the OPC interface. Is it possible?

 

Is it possible to make the account creation happen when the Continue button is pressed, rather than on successful return from Paypal?

 

Thanks very much.

Share this post


Link to post
Share on other sites

Hi

 

I have managed to get this contribution almost sorted for my needs, but I have a problem with the creation of customer accounts. I have Account Creation set to required and Required Login to False. New customer enters all their details down to and including the password twice and then clicks Continue in order to checkout (we only take paypal for payments) (Paypal IPN v2.3.3 or thereabouts). After payment is finished paypal automatically redirects back to the order confirmation page - perfect.

 

BUT if the customer returns to the shop BEFORE payment is completed, all the address details are lost, AND NO ACCOUNT HAS BEEN CREATED.

 

I could set Required Login to True, but then the customer is sent to the 'normal' Login page and we lose the biggest advantage of OPC.

We want everyone to have an account set up using the password the customer chose, using the OPC interface. Is it possible?

 

Is it possible to make the account creation happen when the Continue button is pressed, rather than on successful return from Paypal?

 

Thanks very much.

Hi

 

I would send that request to itwebexperts.com for next release

 

Steve

Share this post


Link to post
Share on other sites

Hi this is a nice contribution.

 

I have only two problems. I use authorize.net aim and for some reason (with credit card orders) The State/Province info is not attached to the order. I manualy fix it on all new orders but our authorize.net conformation email also is without the state/province info. Anyone know were to start.

 

Thank you,

Mike

this is regards to post above, it happens on all payment methods

 

Steve

Share this post


Link to post
Share on other sites

Hi

 

I would send that request to itwebexperts.com for next release

 

Steve

 

Thanks Steve, but on further investigation this works on the demo site with the PayPal payment method selected. Use the OPC page to enter account information and passwords, then proceed to paypal and then cancel. On the demo site all the details are remembered and an account has been created.

 

I have tried all 3 settings on our website with the same result - on cancelling in paypal and being returned to the website, all the fields are blank and no account has been created. Therefore there must be something set up differently between my shop and the demo shop. You can see our shop at silverstoneschoolsparking dot co dot uk. There is a test product up at the moment. Create an order but cancel in paypal and you will see what I mean. Any help appreciated.

Thanks

Share this post


Link to post
Share on other sites

Hi

 

I also have a minor problem with the £ Pound sign still.

 

I have done all the changes suggested so far and the only problem I have is that when we get to the OPC page the values in the cart section at the top are not quite right. But when you click update everything is corrected. See the 2 images below. How can I force the page to do a cart update after the page has loaded in order to make this minor issue go away?

Thanks

 

pound1.jpgpound2.jpg

Share this post


Link to post
Share on other sites
this is regards to post above, it happens on all payment methods

 

Steve

 

Thanks for the reply Steve. Not sure I get what you mean though. Is it normal to drop the state/province data?

 

Thanks again,

Mike

Share this post


Link to post
Share on other sites

Hi

 

I also have a minor problem with the £ Pound sign still.

 

I have done all the changes suggested so far and the only problem I have is that when we get to the OPC page the values in the cart section at the top are not quite right. But when you click update everything is corrected. See the 2 images below. How can I force the page to do a cart update after the page has loaded in order to make this minor issue go away?

Thanks

 

pound1.jpgpound2.jpg

replace the pound sign with the utf8 code for it, it will display properly on all of your site, simply look for the utf8 char code map, once found edit currencies in admin and enter utf8 code for the pound sign

 

Steve

Share this post


Link to post
Share on other sites

Thanks for the reply Steve. Not sure I get what you mean though. Is it normal to drop the state/province data?

 

Thanks again,

Mike

Hi Mike

 

OPC seems to be dropping the state field, when orders are being written, i have tried to see if their demo does the same thing, but they have zone disabled, so i cant test it, i have sent an email to itwebexperts.com asking them about this

 

Steve

Share this post


Link to post
Share on other sites

Thanks Steve, but on further investigation this works on the demo site with the PayPal payment method selected. Use the OPC page to enter account information and passwords, then proceed to paypal and then cancel. On the demo site all the details are remembered and an account has been created.

 

I have tried all 3 settings on our website with the same result - on cancelling in paypal and being returned to the website, all the fields are blank and no account has been created. Therefore there must be something set up differently between my shop and the demo shop. You can see our shop at silverstoneschoolsparking dot co dot uk. There is a test product up at the moment. Create an order but cancel in paypal and you will see what I mean. Any help appreciated.

Thanks

Hi

 

Did you upgrade from a previous version?

 

Steve

Share this post


Link to post
Share on other sites

Thank you very much Steve,

 

The other small bug i have involves the payment method stored after a pay pal standard order.

I get "paypal_standard" in the order data, rather than "Pay Pal Website Payments Standard" this seems like a small problem and does not prevent me from using OPC. Anyone know where to look for that broken ref.

 

On a side note, has anyone used the google's level 2 checkout contrib with OPC?

 

Thanks,

 

Mike

snosk8.com

Share this post


Link to post
Share on other sites

Hi

 

Did you upgrade from a previous version?

 

Steve

 

Hi Steve

No, I installed latest version of OPC for the first time earlier this week.

Everything else appears to work fine in terms of returning from paypal. The emails fire off correctly via ipn.php in catalog/ext/modules/payment/paypal_ipn, I have now fixed getting telephone number required and a few other minor issues (except the ajax-loader.gif which the demo does not have working either?) but this is weird.

The redirect within PayPal is only for completed purchases yes? so that shouldn't have any bearing on this. Cancel and Return to (name of shop) sends back to checkout.php correctly and even returns the correct session parameters (checkout.php?osCsid=??????????????????) as from when the Continue button was pressed.

 

I wondered if it was because I only have one payment module and one shipping module, so I installed another of each. Still it does not work. Only if the payment is completed is the account created.

 

Very peculiar!

 

When does the code create the account in theory? I have not made any changes to checkout.php which could affect this (only added header("Content-Type: text/html; charset=UTF-8\n"); after <?php at the top, and changed the comment for the Sign In Button)

 

I guess it is something to do with checkout_process.php (I made all the necessary changes) or ipn.php or paypal_ipn.php. I made the changes I think which were needed and I have tried different combinations with no success. Any ideas?

 

Thanks

Lee

Share this post


Link to post
Share on other sites

replace the pound sign with the utf8 code for it, it will display properly on all of your site, simply look for the utf8 char code map, once found edit currencies in admin and enter utf8 code for the pound sign

 

Steve

Hi Steve

 

I tried that before and it didn't work. I tried it again just now and this is what it gives. In admin it looks OK as £ having typed in £, but it doesn't work on the screen. See below. Putting header("Content-Type: text/html; charset=UTF-8\n"); at the top of checkout.php made the most positive change, I am now just left with the white on black £ image in the cart until update is pressed.

pound3.jpg

Share this post


Link to post
Share on other sites

Hi Steve

 

I tried that before and it didn't work. I tried it again just now and this is what it gives. In admin it looks OK as £ having typed in £, but it doesn't work on the screen. See below. Putting header("Content-Type: text/html; charset=UTF-8\n"); at the top of checkout.php made the most positive change, I am now just left with the white on black £ image in the cart until update is pressed.

pound3.jpg

Hi

 

I have this at top of my checkout.php

define('CHARSET', 'UTF-8');

 

and have had no issues using utf8 code for char at all

 

Steve

Share this post


Link to post
Share on other sites

Hi Steve

No, I installed latest version of OPC for the first time earlier this week.

Everything else appears to work fine in terms of returning from paypal. The emails fire off correctly via ipn.php in catalog/ext/modules/payment/paypal_ipn, I have now fixed getting telephone number required and a few other minor issues (except the ajax-loader.gif which the demo does not have working either?) but this is weird.

The redirect within PayPal is only for completed purchases yes? so that shouldn't have any bearing on this. Cancel and Return to (name of shop) sends back to checkout.php correctly and even returns the correct session parameters (checkout.php?osCsid=??????????????????) as from when the Continue button was pressed.

 

I wondered if it was because I only have one payment module and one shipping module, so I installed another of each. Still it does not work. Only if the payment is completed is the account created.

 

Very peculiar!

 

When does the code create the account in theory? I have not made any changes to checkout.php which could affect this (only added header("Content-Type: text/html; charset=UTF-8\n"); after <?php at the top, and changed the comment for the Sign In Button)

 

I guess it is something to do with checkout_process.php (I made all the necessary changes) or ipn.php or paypal_ipn.php. I made the changes I think which were needed and I have tried different combinations with no success. Any ideas?

 

Thanks

Lee

Hi Lee,

 

I have heard in previous versions, the account was created when they login after completing order, someone said they did get paypal ipn to work with opc in this forum, but i dont think they said how

 

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×