Jump to content
NimaP

One Page Checkout Support

Recommended Posts

Hmmm... when I remove that... it takes the coupon box away - so nowhere to enter in the coupon code.

Weird its pickup up KGT discount and not the CCGV discount, that is why you are having errors

 

ok to get the ccgv coupon box changed this in checkout.php

 

if (MODULE_ORDER_TOTAL_COUPON_STATUS == 'true'){
		echo '<table cellpadding="2" cellspacing="0" border="0">
		 <tr>
		  <td class="main"><b>Have A Coupon?</b></td>
		 </tr>
		 <tr>
		  <td class="main">' . tep_draw_input_field('gv_redeem_code', 'redeem code') . '</td>
		  <td class="main">' . tep_image_submit('button_redeem.gif', IMAGE_REDEEM_VOUCHER, 'id="voucherRedeem"') . '</td>
		 </tr>
		</table>';
	}

 

to

		echo '<table cellpadding="2" cellspacing="0" border="0">
		 <tr>
		  <td class="main"><b>Have A Coupon?</b></td>
		 </tr>
		 <tr>
		  <td class="main">' . tep_draw_input_field('gv_redeem_code', 'redeem code') . '</td>
		  <td class="main">' . tep_image_submit('button_redeem.gif', IMAGE_REDEEM_VOUCHER, 'id="voucherRedeem"') . '</td>
		 </tr>
		</table>';

Steve

Share this post


Link to post
Share on other sites

Hi!

 

I have problem with language encoding. My DB is set to UTF-8. If I register through the One Page Checkout, then in DB "customers" I got "B?rzi??" instead of "Bērziņš". but if I register through Create Account.php all is OK!

 

Any help?

Hi

 

There was an answer to this in this forum, but i couldnt work out how he done it, ajax uses utf8 char set, so special char wont be displayed properly unless entered in utf8 coding

 

Steve

Share this post


Link to post
Share on other sites

IS anyone having an issue where it is not using the CC validation? I am testing with cc.php and you can submit orders with no CC number and it goes through fine. I tested this on the live demo site at ITweb but theirs works fine.

Share this post


Link to post
Share on other sites

Hi all,

 

I am having a few issues with One Page checkout and CCGV coupons as follows

 

When both are installed and enabled, a existing user already logged in can use the checkout and the coupon and it seems to work fine.

When a new user (not logged in) tries to use the checkout it seems to process and then returns the user to the login screen and no order is registered.

 

The coupon section seems to be working correctly except when one page is disabled and it then doesnt show any errors in the red infobox

 

Any ideas

Thanks

Richard

Share this post


Link to post
Share on other sites

Hi all,

 

I am having a few issues with One Page checkout and CCGV coupons as follows

 

When both are installed and enabled, a existing user already logged in can use the checkout and the coupon and it seems to work fine.

When a new user (not logged in) tries to use the checkout it seems to process and then returns the user to the login screen and no order is registered.

 

The coupon section seems to be working correctly except when one page is disabled and it then doesnt show any errors in the red infobox

 

Any ideas

Thanks

Richard

 

Hi Richard,

 

Check account settings in admin>configuration>one page checkout, make sure ie password is optional if not entering one failing that you can set customer must be loged in to true

 

Steve

Share this post


Link to post
Share on other sites

Hi

 

There was an answer to this in this forum, but i couldnt work out how he done it, ajax uses utf8 char set, so special char wont be displayed properly unless entered in utf8 coding

 

Steve

Hi.

 

I use UTF-8 for my oscommerce, my DB... All is working fine! so if ajax uses UTF-8 - there should not be such troubles! or am I wrong,

Share this post


Link to post
Share on other sites

Hi.

 

I use UTF-8 for my oscommerce, my DB... All is working fine! so if ajax uses UTF-8 - there should not be such troubles! or am I wrong,

Hi

 

your special char can not be i qwerty text only utf8 special code for them, so if user enters any special char via keyboard its in qwerty text not utf8 coding, do a search for utf8 char coding and you will see what i mean

 

Steve

Share this post


Link to post
Share on other sites

Hi do a search in bottom of theis thread for STS, you will find all you need to know to get this to work

 

Steve

 

Hi Steve,

Thanks for replying, I take it this is the post you're refering to?

 

Yes this is down to sts and the way it handles java, which is why i removed sts and went with bts a lot less hassle when using mods with java

 

Steve

 

 

Just double checking so i get you... as far as getting it to "work" - it won't? there's no work around?

 

Thanks for clearing this up for me,

 

Vicky aka barneybruce

Share this post


Link to post
Share on other sites

Hi Steve,

Thanks for replying, I take it this is the post you're refering to?

 

 

 

 

Just double checking so i get you... as far as getting it to "work" - it won't? there's no work around?

 

Thanks for clearing this up for me,

 

Vicky aka barneybruce

Hi Vicky

 

No, there is a couple of posts on how to get it to work with STS

 

Steve

Share this post


Link to post
Share on other sites

Hey Steve,

 

I got so confused with trying to keep track of how to get KGT to work with this that I lost track of how to get rid of KGT out of it. I have KGT installed, but how can I make OPC work without it? I noticed there was some mention of code to be removed or something similar? With that removed do I have to turn off KGT?

Share this post


Link to post
Share on other sites

No it will not lead to any issues just using defines

 

Steve

 

Steve, I am getting confused now as I have taken out all the code referring to KGT and also put in the defines like you mentioned, but I am still getting this error:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'where customer_id = '2'' at line 1

 

select amount from where customer_id = '2'

Edited by Whiskers

Share this post


Link to post
Share on other sites

Steve, I am getting confused now as I have taken out all the code referring to KGT and also put in the defines like you mentioned, but I am still getting this error:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'where customer_id = '2'' at line 1

 

select amount from where customer_id = '2'

Hi

 

Remove that from what ever file produces that error, or comment it out repeat if necessary till error free, or email me that file

 

Steve

Share this post


Link to post
Share on other sites

Another issue with OPC and KGT discount enabled. I get a blank checkout.php . If i disable OPC and apply the discount code in checkout_payment.php and then re-enable it (without placing the order), checkout.php will show just fine with the code applied in the cart and i can use these two contributions combined. If i log out the problem reappears.

 

We all appreciate contributions but why post something that it s not working at all...

Edited by anabrolic

Share this post


Link to post
Share on other sites

Hi

 

Remove that from what ever file produces that error, or comment it out repeat if necessary till error free, or email me that file

 

Steve

 

I sorted it eventually! I just kept taking the various bits out until something happened. But now I am getting a problem with checkout_success.php. I don't think I can talk about that here can I?

Share this post


Link to post
Share on other sites

I just installed this and I have an issue, the sub-total is not showing nor is the taxes.

 

Sub-Total is always displaying $0.00 and then somehow the Total: ends up at some random number which I can't seem to find a reason for as it is not just the shipping. There is also no line for taxes it simply has sub-total, shipping, total.

 

Another issue is it doesn't display any of the payment details, I use money order as a method of payment yet it doesn't tell the customer where or who to send the Money Order to.

 

Was there a fix for this? I have just started using Euro as a currency and found that the sub-total, shipping and total are all zero and also still show in £ rather than €. Also all the symbols in the section where it says add comments about your order are in £ including the total price one.

Edited by Whiskers

Share this post


Link to post
Share on other sites

Was there a fix for this? I have just started using Euro as a currency and found that the sub-total, shipping and total are all zero and also still show in £ rather than €. Also all the symbols in the section where it says add comments about your order are in £ including the total price one.

Hi yes there is its a few pages back i think

 

Steve

Share this post


Link to post
Share on other sites

Was there a fix for this? I have just started using Euro as a currency and found that the sub-total, shipping and total are all zero and also still show in £ rather than €. Also all the symbols in the section where it says add comments about your order are in £ including the total price one.

Hi

 

Remove payment and shipping mods, then install them again, if still zero, add another currency goto store change currencies then back to default currency remove extra currency in admin

 

Steve

Share this post


Link to post
Share on other sites

Hi all,

 

I've got some fantastic news for those of you using STS (Simple Template System contribution - I'm using v4.5.8) ...

 

I was desperate to get this contribution working due to a number of bailed carts at login.php and I spent a couple of days scratching my head, but eventually gave up. Instead, I hired a PHP/Javascript developer to look at the issue. The community has given me all the contributions I've ever needed, so I thought it was time to give something back. Here's the fix:

 

  • Firstly, I created an includes/sts_templates/xxxxx/checkout.php.html template file (obviously xxxxx is your template folder). I simply used a copy of my sts_default.html file and renamed it. I then added the following within the <head> tag as recommended by tokyoguy :

<link rel="stylesheet" type="text/css" href="ext/jQuery/themes/smoothness/ui.all.css">

 

  • Then the developer stepped in and found that in the shopping cart Javscript file (includes/checkout/checkout.js) there were php tags, which were simply comments like <?php //this is a comment?> and so entirely unnecessary. IE was bombing out at this point, whereas other browsers ignored them. However, they can simply be removed.

  • For those who are using the "Pay by check (or cheque in English)/cash" payment method, the tep_validate() function was being declared twice. It was being declared in checkout_success.php and in application_top.php. To get around this, within checkout_success.php, find and modify the declaration around line 24 as follows:

require_once('includes/functions/password_funcs.php');

 

  • UK shops may also have a problem with the £ (UK pound) symbol. To correct this, change the encoding within english.php to UTF-8, then within the admin panel, change the £ (UK pound) and Euro symbols to their UTF-8 decimal equivalents (Google this if needed).

 

Enjoy guys. I've already had several successful sales go through the new checkout and nobody has bailed at this screen so far.

 

Cheers

 

I'm using STS, and tried this, but I'm still getting an error. It appears that the credit card number and info is not being validated.

 

 

Warning: str_repeat() [function.str-repeat]: Second argument has to be greater than or equal to 0 in /catalog/includes/modules/payment/cc.php on line 168

 

Processing Order, Please Wait...

 

It still processes the order, but doesn't perform any validation on the CC number, nor does it provide the type of card used in the orders admin screen

 

Has anyone else encountered this?

Share this post


Link to post
Share on other sites

did some more testing, the CC validation works fine on the stock OSC checkout just not on the single page checkout.

i'm having the same problem

are you using STS?

i can't figure out if that's the problem or not

Share this post


Link to post
Share on other sites

i'm having the same problem

are you using STS?

i can't figure out if that's the problem or not

Hi it might be down to STS

 

Steve

Share this post


Link to post
Share on other sites

Hi

 

Remove payment and shipping mods, then install them again, if still zero, add another currency goto store change currencies then back to default currency remove extra currency in admin

 

Steve

 

I've done that, but it hasn't done anything. The thing that is strange is that it was working perfectly before I installed KGT. I didn't have to remove any code or anything. Now I have uninstalled KGT I have had to remove lots of code just to get it partly functional. How can that be possible?!

 

Would it be worth installing OPC again?

Edited by Whiskers

Share this post


Link to post
Share on other sites

I've done that, but it hasn't done anything. The thing that is strange is that it was working perfectly before I installed KGT. I didn't have to remove any code or anything. Now I have uninstalled KGT I have had to remove lots of code just to get it partly functional. How can that be possible?!

 

Would it be worth installing OPC again?

 

Where would I install a <marquee> if I wanted above the shopping cart box? I've been trying, but can't work it out. :(

Share this post


Link to post
Share on other sites

I've done that, but it hasn't done anything. The thing that is strange is that it was working perfectly before I installed KGT. I didn't have to remove any code or anything. Now I have uninstalled KGT I have had to remove lots of code just to get it partly functional. How can that be possible?!

 

Would it be worth installing OPC again?

If it has caused that much trouble maybe not, your using STS yes?

 

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×