Jump to content
NimaP

One Page Checkout Support

Recommended Posts

I have installed the contribution...would be great if I can have it working...here are some issues i am experiencing...

 

make changes? problem

My problem is that when I am on the checkout page and I click on the button to make changes (Make Changes?) to the cart I get:

Fatal error: Call to a member function on a non-object in /homepages/5/d180349627/htdocs/test_store/includes/classes/onepage_checkout.php on line 741

 

login window problem:

if I want to login from the checkout page instead of filling the forms (Already have an account?) and click on the button, a login little window comes up but the button does not work even if I enter my login information...no error displayed or anything...just nothing happens

 

shipping overwriting problem

When I fillout the shipping form at checkout, it calculates the shipping charge based on the "per item" setting i opted for in the admin page...

After I hit the continue button, it takes me to PayPal payment page (using PayPal Standard Payment) and it asks for my zip code to calculate shipping again...showing different shipping charges

how can i fix this shipping overlapping issue? should I remove any shipping settings in my PayPal account? (Working with sandbox...as I am still testing)

 

Button image problem

When on the checkout form page checkout.php, instead of the text in the buttons I have displayed what I believe is the alternative text to an image...in fact on the button to make changes to the cart is says _IMAGE_UPDATE and on the button to login (in case you already have an account) it says IMAGE_LOGIN

Hi

 

I would suggest you double check install guide, it also seems you have uploaded the language file for checkout.php

 

Steve

Share this post


Link to post
Share on other sites

Everything works except when I click to continue to checkout, it loads the checkout_process.php but it never checks out. It just loops back to the checkout.php page with the same product in the shopping cart and the CC is never processed. If the user logs in, this doesn't happen.

 

We are using the CC module not for production use and have QTPro and CCGV installed.

 

Has anyone encountered this problem before? Any ideas?

Is that on trying to create an account or user already loged in, if you upgraded you will neeed to remove old sql for create account and replace with new sql from install see previous page for this

 

Steve

Share this post


Link to post
Share on other sites

Hi Steve,

 

Please help. My problem is before a customer logged in, the checkout and redeem coupon works smoothly but when a customer logged in and try to redeem coupon, a fatal error occured.

 

Fatal error: Call to a member function pre_confirmation_check() on a non-object in ..\includes\classes\onepage_checkout.php on line 716

 

Note: The error occured only if I logged in as customer and tried to redeem the coupon on checkout page.

 

Well, I'm using STS and CCGV.

Not sure whether STS is block any javascript.

 

But I did follow instuction in this page

http://forums.oscommerce.com/topic/333292-one-page-checkout-support/page__view__findpost__p__1405737

 

Wonder why still have error.

 

 

My site - Checkout page

 

Thanks in advanced.

Hi you need to remove from catalog/checkout.php the following

<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/includes/checkout/checkout.js"></script>
<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/ext/jQuery/jQuery.js"></script>
<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/ext/jQuery/jQuery.ajaxq.js"></script>
<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/ext/jQuery/jQuery.pstrength.js"></script>
<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/ext/jQuery/jQuery.ui.js"></script>

 

 

As that is being called twice in you checkout.php using sts

 

Steve

Share this post


Link to post
Share on other sites

Hi

 

I would suggest you double check install guide, it also seems you have uploaded the language file for checkout.php

 

Steve

 

Hi Steve thank you for the reply

I dont understand which language file you are referring to...can you explain better please?

I did follow the installation instructions...i believe my problem with the button images was due to the fact that I was using css button...i changed that to image buttons and i dont get the weird text anymore...login button also works now (for some reason it was not working as css button)...

All I need to fix now is the error that I get when I click the button to modify the cart content...

any idea? the error refers to the onepage_checkout.php file itself...

Share this post


Link to post
Share on other sites

Hi cherubrock74,

 

This is my pleasure. Are you using STS template now? If not, you may go to checkout.php

 

find this line

 

<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->

 

change to

 

<!-- right_navigation //-->
<?php //require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->

 

Hope it can help.

 

 

Katherinelow thank you...i will work on the code tomorrow morning and I will let you know how it goes...:)

Share this post


Link to post
Share on other sites

Hi Steve thank you for the reply

I dont understand which language file you are referring to...can you explain better please?

I did follow the installation instructions...i believe my problem with the button images was due to the fact that I was using css button...i changed that to image buttons and i dont get the weird text anymore...login button also works now (for some reason it was not working as css button)...

All I need to fix now is the error that I get when I click the button to modify the cart content...

any idea? the error refers to the onepage_checkout.php file itself...

Hi

 

i dont have any idea as im not getting that error, what version are you using?

 

Steve

Share this post


Link to post
Share on other sites

Hi you need to remove from catalog/checkout.php the following

<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/includes/checkout/checkout.js"></script>
<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/ext/jQuery/jQuery.js"></script>
<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/ext/jQuery/jQuery.ajaxq.js"></script>
<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/ext/jQuery/jQuery.pstrength.js"></script>
<script type="text/javascript" language="javascript" src="http://www.balancingact.asia/ext/jQuery/jQuery.ui.js"></script>

 

 

As that is being called twice in you checkout.php using sts

 

Steve

 

Hi Steve,

 

Thanks your reply. I did removed the following code in checkout.php but result was still the same.

 

A Fatal error: Call to a member function pre_confirmation_check() on a non-object in ..\includes\classes\onepage_checkout.php on line 716

 

I think the problem might due to STS because when I disable STS in admin site, the coupon redeem for customer logged in is working properly.

 

It is really weird. Any advise?

 

 

Thanks in advanced.

Share this post


Link to post
Share on other sites

Hi Steve,

 

Please help. My problem is before a customer logged in, the checkout and redeem coupon works smoothly but when a customer logged in and try to redeem coupon, a fatal error occured.

 

Fatal error: Call to a member function pre_confirmation_check() on a non-object in ..\includes\classes\onepage_checkout.php on line 716

 

Note: The error occured only if I logged in as customer and tried to redeem the coupon on checkout page.

 

Well, I'm using STS and CCGV.

Not sure whether STS is block any javascript.

 

But I did follow instuction in this page

http://forums.oscommerce.com/topic/333292-one-page-checkout-support/page__view__findpost__p__1405737

 

Wonder why still have error.

 

 

My site - Checkout page

 

Thanks in advanced.

 

Katherinelow it worked, but the content of the page is not "fluid" so even if I do not display the right column, it is still constricted to the original dimensions...

do you know where I can fix this?

attacked a capture for better understanding...:)

capture1.jpg

Share this post


Link to post
Share on other sites

Hi

 

i dont have any idea as im not getting that error, what version are you using?

 

Steve

 

Hi Steve

I downloaded opc1.093 which I believe is the latest version...

this is the code referring to the button, but it is not working

 

<td><?php echo tep_image_submit('button_update_cart.gif', IMAGE_UPDATE_CART, 'name="updateQuantities" id="updateCartButton"');?></td>

anything you can suggest me?

Share this post


Link to post
Share on other sites

Hi Steve,

 

Thanks your reply. I did removed the following code in checkout.php but result was still the same.

 

A Fatal error: Call to a member function pre_confirmation_check() on a non-object in ..\includes\classes\onepage_checkout.php on line 716

 

I think the problem might due to STS because when I disable STS in admin site, the coupon redeem for customer logged in is working properly.

 

It is really weird. Any advise?

 

 

Thanks in advanced.

 

Ask in STS forum see if anyone can help you i know some are using this with STS other than that contract a php/java coder

 

Steve

Share this post


Link to post
Share on other sites

Hi Steve

I downloaded opc1.093 which I believe is the latest version...

this is the code referring to the button, but it is not working

 

<td><?php echo tep_image_submit('button_update_cart.gif', IMAGE_UPDATE_CART, 'name="updateQuantities" id="updateCartButton"');?></td>

anything you can suggest me?

All i can suggest is either java is turned off in browser or a java file is missing or corrupted

 

Try uploading ext and includes/checkout/checkout.js again

 

Steve

Share this post


Link to post
Share on other sites

Katherinelow it worked, but the content of the page is not "fluid" so even if I do not display the right column, it is still constricted to the original dimensions...

do you know where I can fix this?

attacked a capture for better understanding...:)

capture1.jpg

Hi if you dont want a right column remove this from catalog/checkout.php

 

<?php
if (ONEPAGE_SHOW_OSC_COLUMNS == 'true'){
?>
<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
</table></td>
<?php
}elseif (ONEPAGE_SHOW_CUSTOM_COLUMN == 'true'){
?>
<td width="200px" valign="top"><table border="0" width="200px" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'checkout/column_right.php'); ?>
<!-- right_navigation_eof //-->
</table></td>
<?php
}
?>

 

Steve

Share this post


Link to post
Share on other sites

Hi if you dont want a right column remove this from catalog/checkout.php

 

<?php
if (ONEPAGE_SHOW_OSC_COLUMNS == 'true'){
?>
<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
</table></td>
<?php
}elseif (ONEPAGE_SHOW_CUSTOM_COLUMN == 'true'){
?>
<td width="200px" valign="top"><table border="0" width="200px" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'checkout/column_right.php'); ?>
<!-- right_navigation_eof //-->
</table></td>
<?php
}
?>

 

Steve

 

Steve that worked thank you...I have couple more questions

the store will only accept customers from the US so is there a way to force the country billing field to be just United States and have the state field as a drop down list?

I also noticed in the code that there are references to the coupon code contribution...I haven't installed the contribution yet, is it ok to install it now? Do I need to use a specific contribution package?

Share this post


Link to post
Share on other sites

All i can suggest is either java is turned off in browser or a java file is missing or corrupted

 

Try uploading ext and includes/checkout/checkout.js again

 

Steve

 

Hi Steve...it is working now...I need to do further testing but thank you for your help.

Share this post


Link to post
Share on other sites

Steve that worked thank you...I have couple more questions

the store will only accept customers from the US so is there a way to force the country billing field to be just United States and have the state field as a drop down list?

I also noticed in the code that there are references to the coupon code contribution...I haven't installed the contribution yet, is it ok to install it now? Do I need to use a specific contribution package?

Hi

 

admin>configuration>my store

set country to US it should now deafult to USA for country

For coupons it uses the CCGV contribution

 

Steve

Share this post


Link to post
Share on other sites

Nice and easy to install. I want to make the city, state, and post code on 3 separate lines. How can this be done?

 

Thanks.

Share this post


Link to post
Share on other sites

Nice and easy to install. I want to make the city, state, and post code on 3 separate lines. How can this be done?

 

Thanks.

includes/checkout/billing_address.php find

<?php
 if (ACCOUNT_STATE == 'true') {
?>
<td class="main" width="33%"><?php echo ENTRY_STATE; ?></td>
<?php
 }
?>
<td class="main" width="33%"><?php echo ENTRY_POST_CODE; ?></td>
  </tr>
  <tr>
<td class="main" width="33%"><?php echo tep_draw_input_field('billing_city', (isset($billingAddress) ? $billingAddress['city'] : ''), 'class="required" style="width:80%;float:left;"'); ?></td>
<?php
 if (ACCOUNT_STATE == 'true') {
$defaultCountry = (isset($billingAddress) && tep_not_null($billingAddress['country_id']) ? $billingAddress['country_id'] : ONEPAGE_DEFAULT_COUNTRY);
?>
<td class="main" width="33%" id="stateCol_billing"><?php echo $onePageCheckout->getAjaxStateField($defaultCountry);?><div class="required_icon ui-icon-red ui-icon-gear" style="margin-left: 3px; margin-top: 1px; float: left;" title="Required" /></td>
<?php
 }
?>
<td class="main" width="33%"><?php echo tep_draw_input_field('billing_zipcode', (isset($billingAddress) ? $billingAddress['postcode'] : ''), 'class="required" style="width:80%;float:left;"'); ?></td>

 

change to

<?php

if (ACCOUNT_STATE == 'true') {

?>

<td class="main" width="33%"><?php echo ENTRY_STATE; ?></td></tr>

<?php

}

?>

<tr><td class="main" width="33%"><?php echo ENTRY_POST_CODE; ?></td>

</tr>

<tr>

<td class="main" width="33%"><?php echo tep_draw_input_field('billing_city', (isset($billingAddress) ? $billingAddress['city'] : ''), 'class="required" style="width:80%;float:left;"'); ?></td></tr>

<?php

if (ACCOUNT_STATE == 'true') {

$defaultCountry = (isset($billingAddress) && tep_not_null($billingAddress['country_id']) ? $billingAddress['country_id'] : ONEPAGE_DEFAULT_COUNTRY);

?>

<tr><td class="main" width="33%" id="stateCol_billing"><?php echo $onePageCheckout->getAjaxStateField($defaultCountry);?><div class="required_icon ui-icon-red ui-icon-gear" style="margin-left: 3px; margin-top: 1px; float: left;" title="Required" /></td></tr>

<?php

}

?>

<tr><td class="main" width="33%"><?php echo tep_draw_input_field('billing_zipcode', (isset($billingAddress) ? $billingAddress['postcode'] : ''), 'class="required" style="width:80%;float:left;"'); ?></td>

Share this post


Link to post
Share on other sites

Hi

 

admin>configuration>my store

set country to US it should now deafult to USA for country

For coupons it uses the CCGV contribution

 

Steve

 

Thanks Steve

What I meant to ask you was if there is a way to have just United States as country available for billing and shipping address and therefore a drop down menu in the state field.

I have this setup in the registration form to create customers account, but I dont know how to implement the same thing in the checkout file...

Edited by cherubrock74

Share this post


Link to post
Share on other sites

Hi Steve cannot search the entire topic so I dont know if you already answered to this, but after I checkout using PayPal, then when the transaction is complete and I click on "Return to store", it takes me back to the checkout page, instead of taking me to the main store catalog page...do you know how I can fix this? let me know...thank you

Share this post


Link to post
Share on other sites

includes/checkout/billing_address.php find

<?php
 if (ACCOUNT_STATE == 'true') {
?>
<td class="main" width="33%"><?php echo ENTRY_STATE; ?></td>
<?php
 }
?>
<td class="main" width="33%"><?php echo ENTRY_POST_CODE; ?></td>
  </tr>
  <tr>
<td class="main" width="33%"><?php echo tep_draw_input_field('billing_city', (isset($billingAddress) ? $billingAddress['city'] : ''), 'class="required" style="width:80%;float:left;"'); ?></td>
<?php
 if (ACCOUNT_STATE == 'true') {
$defaultCountry = (isset($billingAddress) && tep_not_null($billingAddress['country_id']) ? $billingAddress['country_id'] : ONEPAGE_DEFAULT_COUNTRY);
?>
<td class="main" width="33%" id="stateCol_billing"><?php echo $onePageCheckout->getAjaxStateField($defaultCountry);?><div class="required_icon ui-icon-red ui-icon-gear" style="margin-left: 3px; margin-top: 1px; float: left;" title="Required" /></td>
<?php
 }
?>
<td class="main" width="33%"><?php echo tep_draw_input_field('billing_zipcode', (isset($billingAddress) ? $billingAddress['postcode'] : ''), 'class="required" style="width:80%;float:left;"'); ?></td>

 

change to

<?php

if (ACCOUNT_STATE == 'true') {

?>

<td class="main" width="33%"><?php echo ENTRY_STATE; ?></td></tr>

<?php

}

?>

<tr><td class="main" width="33%"><?php echo ENTRY_POST_CODE; ?></td>

</tr>

<tr>

<td class="main" width="33%"><?php echo tep_draw_input_field('billing_city', (isset($billingAddress) ? $billingAddress['city'] : ''), 'class="required" style="width:80%;float:left;"'); ?></td></tr>

<?php

if (ACCOUNT_STATE == 'true') {

$defaultCountry = (isset($billingAddress) && tep_not_null($billingAddress['country_id']) ? $billingAddress['country_id'] : ONEPAGE_DEFAULT_COUNTRY);

?>

<tr><td class="main" width="33%" id="stateCol_billing"><?php echo $onePageCheckout->getAjaxStateField($defaultCountry);?><div class="required_icon ui-icon-red ui-icon-gear" style="margin-left: 3px; margin-top: 1px; float: left;" title="Required" /></td></tr>

<?php

}

?>

<tr><td class="main" width="33%"><?php echo tep_draw_input_field('billing_zipcode', (isset($billingAddress) ? $billingAddress['postcode'] : ''), 'class="required" style="width:80%;float:left;"'); ?></td>

 

Thanks. That moved the boxes underneath, but it didn't move the names with them for some reason. Also how can I get a space between each box rather than them touching each other?

 

Thanks in advacne if you can help.

Share this post


Link to post
Share on other sites

Hi all,

 

I've got two stores, similar but with the following minor differences:

 

Store 1: RC2a ... Simple Template System v4.5.8 installed ... store is located in site root

Store 2: MS2.2 ... Columns and header hard coded ... store is located in sub folder /store/

 

Store 1 has been running One Page Checkout v1.05 for about 5 months, then later upgraded to v1.08, again with no problems.

 

I've just installed OPC v1.09 on Store 2 and its not working. I've also tried downgrading to v1.08, but the same problem exists as follows:

 

Once all billing details have been completed, pressing the 'Continue' button at the bottom of the checkout screen moves onto the "Processing order, please wait..." screen for a couple of seconds, then goes back to the checkout screen again and blanks out all of the details.

 

I can see the "Processing order" screen attempts to post the form with hidden values as below:

 

<form name="redirectForm" action="XXXXXXX/store/checkout_process.php?osCsid=0mjol444f5inivkk9r6lh3cbq4" method="POST">

<input type="image" src="includes/languages/english/images/buttons/button_continue.gif" border="0" alt="IMAGE_CONTINUE" title=" IMAGE_CONTINUE " style="display:none;"><input type="hidden" name="action" value="process"><input type="hidden" name="3084" value="1">

...(code removed)... <input type="hidden" name="formUrl"><script>

redirectForm.submit();

</script></form>

 

Can anyone see why it is failing and not giving an error? If anybody is able to advise, here is a link to test (remove the two instances of XXX for the correct URL):

 

http://www.ajXXXcanvasXXXprints.co.uk/store/test-product-p-3084.html

 

Please add the test product to the cart and go straight to checkout. Use the "cheque/postal order" payment method to complete the order. Please note that I'm using a shared SSL host, but please ignore this fact as it is identical to my first store which works fine.

 

Any help or pointers of where I need to look would be much appreciated !

 

Cheers

 

Andy

Share this post


Link to post
Share on other sites

Thanks. That moved the boxes underneath, but it didn't move the names with them for some reason. Also how can I get a space between each box rather than them touching each other?

 

Thanks in advacne if you can help.

To move them down you add <tr> before and </tr> after the code

To add a space between them look for </td><td>

then add <td>  </td> between </td><td>

 

Steve

Share this post


Link to post
Share on other sites

To move them down you add <tr> before and </tr> after the code ie <tr><td>code</td></tr>

To add a space between them look for </td><td>

then add <td>  </td> between </td><td>

 

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×