Jump to content
NimaP

One Page Checkout Support

Recommended Posts

Steve - thanks for the fast reply. I think I mispoke about a "blank page"

What I meant is the script is not loading. I have error reporting turned on. There actually is something at the very bottom of the page - my page parse time.

And I can get the header and footer to load for the site.

 

But the middle body content that hold the checkout script is blank.

 

If I edit the script and remove the line: style="display:show;"

The I get the page but nothing works.

 

Its like the JQuery is not being loaded for the id="pageContentContainer"

 

I get a javascript error that points to

 

$(document).ready(function (){

 

And that the Object is not defined.

 

Thanks again for any ideas suggestions!!!

Hi

 

try changing the location from relative to fixed in checkout.php

 

ie

<script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.js"></script>
<script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.ajaxq.js"></script>
<script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.pstrength.js"></script>
<script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.ui.js"></script>
<script type="text/javascript" language="javascript" src="http://www.yoursite.com/includes/checkout/checkout.js"></script>

Share this post


Link to post
Share on other sites

 

 

2. There are too many people that would like to use Paypal_ipn with this contribution but get the duplicate orders problem (one order from paypal_ipn module that is the correct to get de ipn status and another order from checkot.php and checkout_process.php). The ideal thing would be to get only the paypal_ipn created order

 

 

 

 

 

Problems solved with paypal_ipn qith version 1.08, all works ok!!

 

Best regards...

Share this post


Link to post
Share on other sites

I've solved this questions:

 

Open checkout.js and find:

 

this.updateFinalProductListing();
this.updateOrderTotals();

 

Change it to:

 

checkoutClass.updateShippingMethods();
this.updateFinalProductListing();
this.updateOrderTotals();

 

Open checkout/payment_method.php:

 

search for:

 

 if ($paymentMethod == ''){
$paymentMethod = ONEPAGE_DEFAULT_PAYMENT;
 }

 

and comment it to:

 

//  if ($paymentMethod == ''){
//$paymentMethod = ONEPAGE_DEFAULT_PAYMENT;
// }

 

This solves the probems.

 

Regards...

Hi

 

I tried your changes, but then it wont let you login on onepage checkout,

 

I still get the error if no payment method selected

 

Anyone else finding one page checkout wont create an account it sends you back to one page checkout

 

Steve

Share this post


Link to post
Share on other sites

Hi emmet - have you ever encountered the error that I am having posted above??

 

What error you refer to?

 

Regards...

Share this post


Link to post
Share on other sites

Problems solved with paypal_ipn qith version 1.08, all works ok!!

 

Best regards...

Would you mind telling others how you did it

 

Steve

Share this post


Link to post
Share on other sites

Hi

 

I tried your changes, but then it wont let you login on onepage checkout,

 

I still get the error if no payment method selected

 

Anyone else finding one page checkout wont create an account it sends you back to one page checkout

 

Steve

 

 

What error you get?

 

regards...

Share this post


Link to post
Share on other sites

Would you mind telling others how you did it

 

Steve

 

I'm at home at the moment, tomorrow I can tell you my paypal_ipn version.

 

I have it working fine at the moment, tested with logged and no logged in customers.

 

All works OK and no duplicate orders.

 

Regards...

Share this post


Link to post
Share on other sites

What error you get?

 

regards...

Hi

 

weird im now getting the popup, i tried 2 orders before and got the error, cached paged maybe

 

Thanks anyway

 

Steve

Share this post


Link to post
Share on other sites

Special Characthers

This contr. is made in UTF-8, thats a problem for many of us in europe.

Because our oscommerce uses ISO_8859-1.

 

Forexampel, when we add the order to the database, the name is förnamn, instead of förnamn.

so we cant handle the special characthers Å Ä Ö and £ and €.

 

I have solved most of the problems I have with UTF-8, the thing I have left, is the e-mail function and when the order is added to the database.

 

Does any one know how to change this from UTF-8 to ISO_8859-1

Share this post


Link to post
Share on other sites

Hi

 

try changing the location from relative to fixed in checkout.php

 

ie

<script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.js"></script>
<script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.ajaxq.js"></script>
<script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.pstrength.js"></script>
<script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.ui.js"></script>
<script type="text/javascript" language="javascript" src="http://www.yoursite.com/includes/checkout/checkout.js"></script>

 

 

 

YAYYYY!!!!!!!!!!!!!

 

HHAHAHHA....it works...at least more then it did!!

 

AWESOME!!!!!

 

now...why the hell did I not think of that!!!

 

Ok....moving through some of the other fixes I see posted here.

Share this post


Link to post
Share on other sites

SHIPPING AND PAYMENT METHOD

Im working on a heavily modded store,

instead of selling items, we want the costumer to make a question after a quote.

This means that we dont need to have a shipping method or payment method.

Now i have putted this selection boxes in a div layer, thats hidden, but does anyone know a better way?

Share this post


Link to post
Share on other sites

Ok....getting closer.

 

I have Free Shipping for orders over X.xx installed.

Sometimes it will show the Free Shipping selection along with the other UPS selections...sometimes it will not

If it does show Free Shipping then if any other UPS method is choosen the Proces do not update.

 

Getting JS error on the page for checkout.js file for this line:

 

this.setModuleMethod('shipping', $button.val(), function (data){

Share this post


Link to post
Share on other sites

Special Characthers

This contr. is made in UTF-8, thats a problem for many of us in europe.

Because our oscommerce uses ISO_8859-1.

 

Forexampel, when we add the order to the database, the name is förnamn, instead of förnamn.

so we cant handle the special characthers Å Ä Ö and £ and €.

 

I have solved most of the problems I have with UTF-8, the thing I have left, is the e-mail function and when the order is added to the database.

 

Does any one know how to change this from UTF-8 to ISO_8859-1

Hi

 

About 2 to 4 pages was a post about it, but i didn't understand how to do it.

 

Steve

Share this post


Link to post
Share on other sites

Ok....getting closer.

 

I have Free Shipping for orders over X.xx installed.

Sometimes it will show the Free Shipping selection along with the other UPS selections...sometimes it will not

If it does show Free Shipping then if any other UPS method is choosen the Proces do not update.

 

Getting JS error on the page for checkout.js file for this line:

 

this.setModuleMethod('shipping', $button.val(), function (data){

Hi Monk,

 

I cant help you with that, best contact a java coder

 

Steve

Share this post


Link to post
Share on other sites

Hi Monk,

 

I cant help you with that, best contact a java coder

 

Steve

 

sounds like a bug in the script......has anyone else had this error?

Share this post


Link to post
Share on other sites

I'm at home at the moment, tomorrow I can tell you my paypal_ipn version.

 

I have it working fine at the moment, tested with logged and no logged in customers.

 

All works OK and no duplicate orders.

 

Regards...

 

Anyone get this to work with Certified PayPal WPP/Express Payment?

 

I have that turned on plus Authorize.net....and only authorize.net shows as a payment method

Share this post


Link to post
Share on other sites

Hi

 

I tried your changes, but then it wont let you login on onepage checkout,

 

I still get the error if no payment method selected

 

Anyone else finding one page checkout wont create an account it sends you back to one page checkout

 

Steve

Share this post


Link to post
Share on other sites

Steve - thanks for the fast reply. I think I mispoke about a "blank page"

What I meant is the script is not loading. I have error reporting turned on. There actually is something at the very bottom of the page - my page parse time.

And I can get the header and footer to load for the site.

 

But the middle body content that hold the checkout script is blank.

 

If I edit the script and remove the line: style="display:show;"

The I get the page but nothing works.

 

Its like the JQuery is not being loaded for the id="pageContentContainer"

 

I get a javascript error that points to

 

$(document).ready(function (){

 

And that the Object is not defined.

 

Thanks again for any ideas suggestions!!!

 

I was having this issue and figured out that the required jQuery libraries were conflicting with prototype & scriptaculous which I was using for lightbox. If you're using lightbox or any other javascript libraries, don't load them on checkout.php. I just excluded lightbox.js from the header for checkout.php and the error went away...now I just have to fix some other errors :P

Share this post


Link to post
Share on other sites

Hi

 

Try following this post http://forums.oscommerce.com/topic/333292-one-page-checkout-support/page__view__findpost__p__1449036

 

i think i just did checkout/payment.php

 

and it seemed to solve it

 

Steve

 

 

Hi Steve -

I need some help again. My customers are having trouble checking out. When signing in into an account it keeps saying that there is an error in the shipping address and to "inform IT Web experts" about this. This error also comes up when you try to checkout as a guest when typing in the email address. It won't allow the email address red required light to go green and give shipping and payment options.

 

Any ideas why it would do this?

 

thanks

Liz

Share this post


Link to post
Share on other sites

Here is an interesting idea / suggestion.

 

I use the Lost Carts Contribution. I notice as soon as you finish filling in all the Billing information that the Payment Method appears.

 

Would be cool if as Soon as the Payment Method appeared that all the customer values were sent to the database (including cart contents) in case they do not complete the order - you still have a "Lost Cart"

 

Similar to the regular create account process and the person just bailing on the shipping or payment page.

 

Make sense?

Share this post


Link to post
Share on other sites

Can anyone please help me with this?

 

I wasn't having any of these problems with this add-on after I fixed the initial ones I had and haven't touched anything in it since.

 

When a customer signs into an account it is saying there is an "error in the shipping address" and to "inform IT Web experts" about this. This message also comes up when you try to checkout as a guest when typing in the email address. It doesn't acknowledge that the email address line has been filled out correctly to show any shipping and payment options.

 

Please please help!

Share this post


Link to post
Share on other sites

Here is an interesting idea / suggestion.

 

I use the Lost Carts Contribution. I notice as soon as you finish filling in all the Billing information that the Payment Method appears.

 

Would be cool if as Soon as the Payment Method appeared that all the customer values were sent to the database (including cart contents) in case they do not complete the order - you still have a "Lost Cart"

 

Similar to the regular create account process and the person just bailing on the shipping or payment page.

 

Make sense?

Hi Matt

 

Install held order

 

then in includes/classes/onepage_checkout.php

find

function processCheckout(){

 

add after it

require('held_orders_process.php');

 

Steve

Share this post


Link to post
Share on other sites

Can anyone please help me with this?

 

I wasn't having any of these problems with this add-on after I fixed the initial ones I had and haven't touched anything in it since.

 

When a customer signs into an account it is saying there is an "error in the shipping address" and to "inform IT Web experts" about this. This message also comes up when you try to checkout as a guest when typing in the email address. It doesn't acknowledge that the email address line has been filled out correctly to show any shipping and payment options.

 

Please please help!

Hi,

 

Are you using a ajax country/state selector?

 

if so change the first if country/state selector checkout_shipping_address.php to

 

 // +Country-State Selector
require(DIR_WS_FUNCTIONS . 'ajax.php');
if (isset($_POST['action']) && $_POST['action'] == 'getStates' && (isset($_POST['country'])) && (isset($_SESSION['customer_id']))) {
   ajax_get_zones_html(tep_db_prepare_input($_POST['country']), true);
   echo tep_address_label($_SESSION['customer_id'], $_SESSION['sendto'], true, ' ', '<br>');
} else {

// -Country-State Selector

 

 

 

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×