Jump to content
NimaP

One Page Checkout Support

Recommended Posts

same problem with pay pal standard

is any one using this contribution on life shop?

it seems to be a good idea but i can see so many problems reported here in the forum

There is some post a lot further back i think someone has got paypal ipn to work.

 

Also does anyone else have the problem if you dont select shipping/payment click continue you get the popup warning you click ok to select shipping but page goes to the processing part and then get an error ?

Share this post


Link to post
Share on other sites
There is some post a lot further back i think someone has got paypal ipn to work.

 

Also does anyone else have the problem if you dont select shipping/payment click continue you get the popup warning you click ok to select shipping but page goes to the processing part and then get an error ?

 

 

I havnt installed this yet, but i went to itwebexperts demo on their site - and there demo does exactly this...

 

dont put anything in any boxes on checkout - press the last continue button, up pops the box saying no 1st name etc , then goes straight

to this error

 

Fatal error: Call to a member function pre_confirmation_check() on a non-object in /home/itweb1/public_html/onepagecheckout/includes/classes/onepage_checkout.php on line 734

 

emailed them last week, but no answer !!

Share this post


Link to post
Share on other sites
I havnt installed this yet, but i went to itwebexperts demo on their site - and there demo does exactly this...

 

dont put anything in any boxes on checkout - press the last continue button, up pops the box saying no 1st name etc , then goes straight

to this error

 

Fatal error: Call to a member function pre_confirmation_check() on a non-object in /home/itweb1/public_html/onepagecheckout/includes/classes/onepage_checkout.php on line 734

 

emailed them last week, but no answer !!

oK i shall i email them to

Share this post


Link to post
Share on other sites
They get sent to the login page After they have entered all their data and should be sent to the payment page.

It doesn't matter how I set the account creation nor if I enter a password. The account doesnt seem to get created. (I don't have any customer info mods)

Hi

 

is this using login/create on one page checkout or normal login/create or it does it on both?

 

Steve

Share this post


Link to post
Share on other sites

hello,

 

I have a problem and cant seem to find help with the search tool in this forum. The tax on my products is being calculated for twice as it should. It says 20% but it calculates as if it was 40% tax... I have 1.06 version installed...should I install 1.07 to solve this problem?

 

thank you in advance

Share this post


Link to post
Share on other sites
mostly to upgrade you would just upload the files, only in 1.0.7 did i find 1 alteration that was to checkout_shipping.php, i think now

 

Hi

do the following this is for 1.0.6

(line 106 in my checkout.php) might be different line number for you all we are doing is commenting it out ie adding // before the code

change it to

 

//$onePageCheckout->fixTaxes();

 

and

in checkout_process.php line 77

change it to

 

//$onePageCheckout->fixTaxes();

 

 

now it is showing the correct amount if customer is loged in before they visit checkout page, if customer logs in on one page checkout tax rate wont update

 

So if you got it set for customers to log in first it will be fine

 

Steve

Share this post


Link to post
Share on other sites
I havnt installed this yet, but i went to itwebexperts demo on their site - and there demo does exactly this...

 

dont put anything in any boxes on checkout - press the last continue button, up pops the box saying no 1st name etc , then goes straight

to this error

 

Fatal error: Call to a member function pre_confirmation_check() on a non-object in /home/itweb1/public_html/onepagecheckout/includes/classes/onepage_checkout.php on line 734

 

emailed them last week, but no answer !!

ok fix for 1.0.7 courtesy of itwebexperts.com to fix bug if anything is missed/not selected you stay at same page

 

includes/checkout/checkout.js and at line 795 add "return " before the "checkAllErrors();"

 

so it will be

return checkAllErrors();

 

complete segemnt will now be

		$('#checkoutButton').click(function() {
		return checkAllErrors();
	});

 

Steve

Share this post


Link to post
Share on other sites
hello,

 

I have a problem and cant seem to find help with the search tool in this forum. The tax on my products is being calculated for twice as it should. It says 20% but it calculates as if it was 40% tax... I have 1.06 version installed...should I install 1.07 to solve this problem?

 

thank you in advance

 

 

No one has this same problem? it's driving me nuts! I think I tried every possible configuration within tax zones and rates... :(

Share this post


Link to post
Share on other sites

I have 2 different questions:

 

1) I have order disclaimer installed on my site - order disclaimer.

 

How do I get that to show on one page checkout?

 

2) Has anyone got this to work with this Authorize Net AIM module (GPL) add on authorize aim gpl to work with one page checkout? If anyone has, please provide details.

Share this post


Link to post
Share on other sites
No one has this same problem? it's driving me nuts! I think I tried every possible configuration within tax zones and rates... :(

i posted to your bug about 4 posts up

 

Now bug fix for 1.0.7 on missing fields or not selected has been fixed see above post you can upgrade to 1.0.7

Edited by steve_s

Share this post


Link to post
Share on other sites
I have 2 different questions:

 

1) I have order disclaimer installed on my site - order disclaimer.

 

How do I get that to show on one page checkout?

 

2) Has anyone got this to work with this Authorize Net AIM module (GPL) add on authorize aim gpl to work with one page checkout? If anyone has, please provide details.

1) can be done but you will have to change the code ie hire a coder or make them log in first and have that on login page

Share this post


Link to post
Share on other sites
ok fix for 1.0.7 courtesy of itwebexperts.com to fix bug if anything is missed/not selected you stay at same page

 

includes/checkout/checkout.js and at line 795 add "return " before the "checkAllErrors();"

 

so it will be

return checkAllErrors();

 

complete segemnt will now be

		$('#checkoutButton').click(function() {
		return checkAllErrors();
	});

 

Steve

 

can n ot find such a line in the code?

includes/checkout/checkout.js and at line 795 add "return " before the "checkAllErrors();"

Share this post


Link to post
Share on other sites
I have the same problem with paypal standard IPN ( "The link you have used to enter the PayPal system contains an incorrectly formatted item amount" ).

Is there a fix for this yet??

 

 

hello,

 

did you find a fix for this problem?

 

paypal standard IPN = "The link you have used to enter the PayPal system contains an incorrectly formatted item amount" .

 

thanks

valerif

Share this post


Link to post
Share on other sites
can n ot find such a line in the code?

includes/checkout/checkout.js and at line 795 add "return " before the "checkAllErrors();"

You do have 1.0.7 includes/checkout/checkout.js installed or is it still the previous one there?

 

here is more of the code to help you locate it

		$('#checkoutButton').click(function() {
		return checkAllErrors(); 
	});

	if (this.ccgvInstalled == true){
		$('input[name="gv_redeem_code"]').focus(function (){
			if ($(this).val() == 'redeem code'){
				$(this).val('');
			}
		});

 

Steve

Edited by steve_s

Share this post


Link to post
Share on other sites
Hi all!

 

I faced with a problem with OnePage checkout while installing it:

Some replacing of a code are done, but when I opened a "catalog/checkout_process.php" file and trying to find a text "tep_address_label($customer_id, $billto, 0, '', "\n") . "\n";" that need to be replaced with "$billToFormatted . "\n";" I can't find it. In my file I found next line:

 

line 301 - tep_address_label($customer_id, $billto, 0, '', "\n") . "\n\n";

 

But it doesn't match exactly to needed one. I tried to replace it and then end a installation process (with a succesful SQL queries). Going to a shop, adding a goods to a shopping cart, pressing a link to checkout_shipping.php and then automatically redirecting to a page checkout.php - but there's only error 500 - Internal server error.

 

Pls help solve a problem.

Thats fine simply replace this line with what it says

 tep_address_label($customer_id, $billto, 0, '', "\n") . "\n\n";

with

$billToFormatted . "\n";

 

Steve

Edited by steve_s

Share this post


Link to post
Share on other sites

Needs help REALLY QUICK\.

 

I have this installed, and its been great until yesterday :angry: when it suddenly starting throwing out a stupid "Email address could not be checked. please refer to IT web experts"... or something along those lines.

 

Basically, it won't allow a checkout because its not able to check email addresses????? I can't work this out!!!!???!!!

 

PLEASE help, why has this happened. I didn't update anything :huh: I'd love this contrib. to work perfectly, it seems like such a good idea, but seripusly its been nothign but headaches... :(

Share this post


Link to post
Share on other sites
Needs help REALLY QUICK\.

 

I have this installed, and its been great until yesterday :angry: when it suddenly starting throwing out a stupid "Email address could not be checked. please refer to IT web experts"... or something along those lines.

 

Basically, it won't allow a checkout because its not able to check email addresses????? I can't work this out!!!!???!!!

 

PLEASE help, why has this happened. I didn't update anything :huh: I'd love this contrib. to work perfectly, it seems like such a good idea, but seripusly its been nothign but headaches... :(

Hi do you still have this file includes/tld.txt if yes

try upgrading to 1.0.7 look for fix on previous page for fields not filed in/selected

Share this post


Link to post
Share on other sites

Hey steve I have a question for you - I get 1.06 to install and work but whenever I install 1.07 I get - "The link you have used to enter the PayPal system contains an incorrectly formatted item amount" .

 

Why do you think that happens? Could it be a server configuration? I have php5 and mysql5 on a linux server.

Share this post


Link to post
Share on other sites
Hey steve I have a question for you - I get 1.06 to install and work but whenever I install 1.07 I get - "The link you have used to enter the PayPal system contains an incorrectly formatted item amount" .

 

Why do you think that happens? Could it be a server configuration? I have php5 and mysql5 on a linux server.

Hi

 

I have no idea why it does that 1.0.7 is completely re-written

 

Steve

Share this post


Link to post
Share on other sites

Steve tried it on 2 dirrent computers my work computer and home computer both ie8 - it does not work - go right to the street address and try to type more then 1 character!

 

It works fine for me was you using IE?
Edited by wflynn

Share this post


Link to post
Share on other sites

Works in firefox though

 

Steve tried it on 2 dirrent computers my work computer and home computer both ie8 - it does not work - go right to the street address and try to type more then 1 character!

Share this post


Link to post
Share on other sites
Works in firefox though

 

Yes i see what you mean its losing focus and you have to keep clicking on the field, this works on all other browsers except IE, i tried in IE6, as i don't have any other version as im using Linux, which leads me to believe this is an IE issue on Microsoft, i will contact itwebexperts.com but i think MS should either make their browser complaint as all the others or permanently remove it.

 

I have had so much issues with java script on IE its beyond a joke, just because its not a MS invention and they missed the boat

 

I have the advantage of having login/create account on one page from express checkout and account creation skip if product in cart so makes it a 2 page checkout

 

Steve

Edited by steve_s

Share this post


Link to post
Share on other sites
Works in firefox though

Yes as i thought its an IE issue

 

Well so much for supporting form auto-fillers ;) the code causing that was the code required for autofillers to validate the fields.

 

So once again its down to IE report it MS and tell them to sort their stupid browser out lol

 

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×