Jump to content
Latest News: (loading..)
NimaP

One Page Checkout Support

Recommended Posts

Hi

 

Simply install a flat rate shipping module and make price 0 is what i did to get around that problem

 

Steve

 

Hi Steve, thanks for the quick response. Are you aware of where the check is carried out as to whether a shipping method is selected?

 

Thanks.

Share this post


Link to post
Share on other sites
Hi Steve, thanks for the quick response. Are you aware of where the check is carried out as to whether a shipping method is selected?

 

Thanks.

Hi Sam,

 

Im not sorry could only find where it pulled out installed shipping modules, as for where check is made i couldn't say

checkout.php code to build shipping module options

<?php
 if (tep_count_shipping_modules() > 0) {
?>
  <tr>
	<td><?php
	$header = TABLE_HEADING_SHIPPING_METHOD;

	$shippingMethod = '';
	if (isset($_SESSION['customer_id'])){
		ob_start();
		include(DIR_WS_INCLUDES . 'checkout/shipping_method.php');
		$shippingMethod = ob_get_contents();
		ob_end_clean();
	}

	$shippingMethod = '<div id="noShippingAddress" class="main noAddress" align="center" style="font-size:15px;' . (isset($_SESSION['customer_id']) ? 'display:none;' : '') . '">Please fill in <b>at least</b> your billing address to get shipping quotes.</div><div id="shippingMethods"' . (!isset($_SESSION['customer_id']) ? ' style="display:none;"' : '') . '>' . $shippingMethod . '</div>';
	buildInfobox($header, $shippingMethod);
   ?></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
 }
?>

Share this post


Link to post
Share on other sites
Hi Sam,

 

Im not sorry could only find where it pulled out installed shipping modules, as for where check is made i couldn't say

checkout.php code to build shipping module options

<?php
 if (tep_count_shipping_modules() > 0) {
?>
  <tr>
	<td><?php
	$header = TABLE_HEADING_SHIPPING_METHOD;

	$shippingMethod = '';
	if (isset($_SESSION['customer_id'])){
		ob_start();
		include(DIR_WS_INCLUDES . 'checkout/shipping_method.php');
		$shippingMethod = ob_get_contents();
		ob_end_clean();
	}

	$shippingMethod = '<div id="noShippingAddress" class="main noAddress" align="center" style="font-size:15px;' . (isset($_SESSION['customer_id']) ? 'display:none;' : '') . '">Please fill in <b>at least</b> your billing address to get shipping quotes.</div><div id="shippingMethods"' . (!isset($_SESSION['customer_id']) ? ' style="display:none;"' : '') . '>' . $shippingMethod . '</div>';
	buildInfobox($header, $shippingMethod);
   ?></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
 }
?>

 

Hi again Steve, thanks for finding that for me, I did manage to stop the error showing. Whether that will cause problems later I don't know but for the time being I've got to get the credit card system working. I mentioned it earlier about the fields disappearing and defaulting to Dec 2019 which is incorrect and won't let the user edit them. It's a fairly bizarre problem which I can't even find the javascript which does it.

 

"When Credit/Debit card radio button is selected, The fields disappear and cannot be changed. If the fields are edited before the radio button is selected, those changes are not reflected in the details once the fields disappear."

Share this post


Link to post
Share on other sites
Hi

 

Im using purchase without account and i don't get them errors, try upgrading to the latest version of purchase without account. 2F i think it is, there is an auto installer if you have php5

or you will need to add field customers_dummy_account to orders table

 

any idea what version you are using of PWA?

 

Steve

 

 

I'm using version 2.1 since the hosting account doesn't have PHP5 support as of yet, just PHP4. Can you send me the link to the version I should be using and what mods I need to make to the code?

Thanks

Liz

Share this post


Link to post
Share on other sites
I'm using version 2.1 since the hosting account doesn't have PHP5 support as of yet, just PHP4. Can you send me the link to the version I should be using and what mods I need to make to the code?

Thanks

Liz

Hi Liz,

 

Im thinking you didn't run this sql on your stores database,

 

ALTER TABLE `customers` ADD COLUMN `guest_account` TINYINT NOT NULL DEFAULT '0' AFTER `customers_newsletter`;

ALTER TABLE `customers` MODIFY COLUMN `customers_password` VARCHAR(40) CHARACTER SET utf8 COLLATE utf8_general_ci;

ALTER TABLE `orders` ADD COLUMN `customers_dummy_account` TINYINT UNSIGNED NOT NULL AFTER `customers_address_format_id`;

 

make sure you run this if you didnt.

 

INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Purchase without account', 'PURCHASE_WITHOUT_ACCOUNT', 'yes', 'Do you allow customers to purchase without an account?', '5', '10', 'tep_cfg_select_option(array(\'yes\', \'no\'), ', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Purchase without account shippingaddress', 'PURCHASE_WITHOUT_ACCOUNT_SEPARATE_SHIPPING', 'yes', 'Do you allow customers without account to create separately shipping address?', '5', '11', 'tep_cfg_select_option(array(\'yes\', \'no\'), ', now());

 

Steve

Share this post


Link to post
Share on other sites
Hi Liz,

 

Im thinking you didn't run this sql on your stores database,

 

ALTER TABLE `customers` ADD COLUMN `guest_account` TINYINT NOT NULL DEFAULT '0' AFTER `customers_newsletter`;

ALTER TABLE `customers` MODIFY COLUMN `customers_password` VARCHAR(40) CHARACTER SET utf8 COLLATE utf8_general_ci;

ALTER TABLE `orders` ADD COLUMN `customers_dummy_account` TINYINT UNSIGNED NOT NULL AFTER `customers_address_format_id`;

 

make sure you run this if you didnt.

 

INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Purchase without account', 'PURCHASE_WITHOUT_ACCOUNT', 'yes', 'Do you allow customers to purchase without an account?', '5', '10', 'tep_cfg_select_option(array(\'yes\', \'no\'), ', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Purchase without account shippingaddress', 'PURCHASE_WITHOUT_ACCOUNT_SEPARATE_SHIPPING', 'yes', 'Do you allow customers without account to create separately shipping address?', '5', '11', 'tep_cfg_select_option(array(\'yes\', \'no\'), ', now());

 

Steve

 

 

Thank you Thank you Thank you! :-*

it worked!

 

I knew I did a query in the database before that was included in the install, but it must have needed those that you gave me too.

 

Ok - one last question since I can't get any help with this on other forums in here.....

I can't login to the admin. When I go to the admin page it just come up as a blank white page with nothing on it. Any suggestions?

 

Thanks again.

 

Liz

Share this post


Link to post
Share on other sites
Ok - one last question since I can't get any help with this on other forums in here.....

I can't login to the admin. When I go to the admin page it just come up as a blank white page with nothing on it. Any suggestions?

 

Thanks again.

 

Liz

Oh, now I wouldn't say that (click me)

;)


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites
Oh, now I wouldn't say that (click me)

;)

 

thanks Jim - I guess I had spoke too soon! I saw your post just after I put that one up. I replied to you in that thread. I'll move this discussion over to there then so this thread stays on topic.

 

Thanks again Steve for the help. Hopefully soon I'll be able to see the orders in the admin again!

 

Liz

Share this post


Link to post
Share on other sites

Im back :) I had hoped if I left this contribution for a few months the bugs would be ironed out but, alas, it seems not! Anyway!

 

Im having some weird issues for new customers who are not creating an account - they can fill in all their details on checkout.php and place the order as normal. An order appears in my database and I get an email etc BUT the customer name, email, shipping and billing addresses in the table and email are empty - all I see is spaces and a few commas.

 

In addition, when the order is completed the customer is redirected to shopping_cart.php and NOT checkout_success.php.

 

HOWEVER, if a customer logs in using their account details the order data like addresses etc is entered in the database table and I see them in the email email AND the redirect goes to checkout_success.php as it should - anyone got any ideas?

 

Ta

 

Jase

Share this post


Link to post
Share on other sites
Thank you Thank you Thank you! :-*

it worked!

 

I knew I did a query in the database before that was included in the install, but it must have needed those that you gave me too.

 

Ok - one last question since I can't get any help with this on other forums in here.....

I can't login to the admin. When I go to the admin page it just come up as a blank white page with nothing on it. Any suggestions?

 

Thanks again.

 

Liz

yes you have an error, does your server have an error log that you can see what the error is if not add this code in index.php after

  require('includes/application_top.php');

 

add

ini_set('display_errors',1);
error_reporting(E_ALL|E_STRICT);

 

now visit that page and see what the errors are

 

Steve

Share this post


Link to post
Share on other sites
Im back :) I had hoped if I left this contribution for a few months the bugs would be ironed out but, alas, it seems not! Anyway!

 

Im having some weird issues for new customers who are not creating an account - they can fill in all their details on checkout.php and place the order as normal. An order appears in my database and I get an email etc BUT the customer name, email, shipping and billing addresses in the table and email are empty - all I see is spaces and a few commas.

 

In addition, when the order is completed the customer is redirected to shopping_cart.php and NOT checkout_success.php.

 

HOWEVER, if a customer logs in using their account details the order data like addresses etc is entered in the database table and I see them in the email email AND the redirect goes to checkout_success.php as it should - anyone got any ideas?

 

Ta

 

Jase

Hi Jase,

 

There should be another update so hang on for a bit longer :) also have you reported them errors to www.itwebexperts.com as they can only fix errors they are made aware off

 

Steve

Edited by steve_s

Share this post


Link to post
Share on other sites
yes you have an error, does your server have an error log that you can see what the error is if not add this code in index.php after

  require('includes/application_top.php');

 

add

ini_set('display_errors',1);
error_reporting(E_ALL|E_STRICT);

 

now visit that page and see what the errors are

 

Steve

 

 

sorry, but which index.php file should I be checking? the catalog/index.php one or the catalog/admin/index.php?

 

Liz

Share this post


Link to post
Share on other sites
sorry, but which index.php file should I be checking? the catalog/index.php one or the catalog/admin/index.php?

 

Liz

Hi Liz,

 

catalog/admin/index.php

 

Steve

Share this post


Link to post
Share on other sites
Hi again Steve, thanks for finding that for me, I did manage to stop the error showing. Whether that will cause problems later I don't know but for the time being I've got to get the credit card system working. I mentioned it earlier about the fields disappearing and defaulting to Dec 2019 which is incorrect and won't let the user edit them. It's a fairly bizarre problem which I can't even find the javascript which does it.

 

"When Credit/Debit card radio button is selected, The fields disappear and cannot be changed. If the fields are edited before the radio button is selected, those changes are not reflected in the details once the fields disappear."

Add another payment module and see what happens when you toggle between them both, see if them fields reaper

Share this post


Link to post
Share on other sites

I just installed One Page Checkout 1.06 and have a few problems.

 

Using only one payment method I get a popup error "There was an error setting payment method..." . If I add an extra payment method I do not get the error but when I press Continue I get the following error:

 

Fatal error: Call to a member function pre_confirmation_check() on a non-object in /home/gnherbs/public_html/includes/classes/onepage_checkout.php on line 644

 

Does anyone have any ideas how I can solve this?

 

Thanks,

 

Dan

Share this post


Link to post
Share on other sites
I just installed One Page Checkout 1.06 and have a few problems.

 

Using only one payment method I get a popup error "There was an error setting payment method..." . If I add an extra payment method I do not get the error but when I press Continue I get the following error:

 

Fatal error: Call to a member function pre_confirmation_check() on a non-object in /home/gnherbs/public_html/includes/classes/onepage_checkout.php on line 644

 

Does anyone have any ideas how I can solve this?

 

Thanks,

 

Dan

 

Hi Dan,

 

Most people who have had that error are using STS, or have you added any extra fields text area content to one page checkout ?

with a link i cant say what is going on, i would suggest waiting for the next release

 

Steve

Share this post


Link to post
Share on other sites

Hi

 

I've installed contrib but are getting the following errors:

 

Warning: include(includes/checkout/cart.php) [function.include]: failed to open stream: No such file or directory in /home/****/public_html/test/checkout.php on line 571

 

ob_start();

include(DIR_WS_INCLUDES . 'checkout/cart.php');

$cartContents = ob_get_contents(); ****this is line 571*****

ob_end_clean();

 

Also,

 

Warning: include(includes/checkout/billing_address.php) [function.include]: failed to open stream: No such file or directory in /home/****/public_html/test/checkout.php on line 605

 

ob_start();

include(DIR_WS_INCLUDES . 'checkout/billing_address.php');

$billingAddress = ob_get_contents();

ob_end_clean();

 

The same for lines 626, 657, 679, and 699

 

Anybody care to help?

 

tx

 

Elroy

Share this post


Link to post
Share on other sites
Hi

 

I've installed contrib but are getting the following errors:

 

Warning: include(includes/checkout/cart.php) [function.include]: failed to open stream: No such file or directory in /home/****/public_html/test/checkout.php on line 571

 

ob_start();

include(DIR_WS_INCLUDES . 'checkout/cart.php');

$cartContents = ob_get_contents(); ****this is line 571*****

ob_end_clean();

 

Also,

 

Warning: include(includes/checkout/billing_address.php) [function.include]: failed to open stream: No such file or directory in /home/****/public_html/test/checkout.php on line 605

 

ob_start();

include(DIR_WS_INCLUDES . 'checkout/billing_address.php');

$billingAddress = ob_get_contents();

ob_end_clean();

 

The same for lines 626, 657, 679, and 699

 

Anybody care to help?

 

tx

 

Elroy

Hi Elroy,

 

it looks to me you didnt upload includes/checkout folder or you have some of the files not uploaded

follow instructions of new files to upload and you will be fine

 

Steve

Share this post


Link to post
Share on other sites

Hey,

 

I am having the following issue regarding this contribution:

 

I have installed the MultiSafePay payment module but when I Click the continue button at the checkout page I am not directed towards the MultiSafePay site to complete the payment.

Does anyone know what the problem is and how to fix it?

 

I have this Multisafepay add-on: http://addons.oscommerce.com/info/6195

I installed this multisafepay on different sites and know how to set it up so I don't think the problem is in the setup.

 

Greetings Sander

Share this post


Link to post
Share on other sites
Hey,

 

I am having the following issue regarding this contribution:

 

I have installed the MultiSafePay payment module but when I Click the continue button at the checkout page I am not directed towards the MultiSafePay site to complete the payment.

Does anyone know what the problem is and how to fix it?

 

I have this Multisafepay add-on: http://addons.oscommerce.com/info/6195

I installed this multisafepay on different sites and know how to set it up so I don't think the problem is in the setup.

 

Greetings Sander

Hi Sander,

 

please report this to www.itwebexperts.com also give them the url to your site, so they can see what is happening,

 

Steve

Share this post


Link to post
Share on other sites

I would like to know if the following is possible please:

Can One Page Checkout work where you can checkout without having a previously set up account, then in the one page checkout process it sets up the account, thus allowing Paypal IPN to work?

My understanding is that at the moment it only works as a one page checkout IF you've set up an account before or are only using boring Paypal standard.

Thanks

Share this post


Link to post
Share on other sites
I would like to know if the following is possible please:

Can One Page Checkout work where you can checkout without having a previously set up account, then in the one page checkout process it sets up the account, thus allowing Paypal IPN to work?

My understanding is that at the moment it only works as a one page checkout IF you've set up an account before or are only using boring Paypal standard.

Thanks

I believe someone has got this to work, with paypal ipn, dont know if the customer had to login in first,

Share this post


Link to post
Share on other sites

One Page Checkout and MVS?

http://addons.oscommerce.com/info/4129

 

anyone had any luck getting this One Page Checkout contrib to work with MVS (Multi Vendor Shipping)?

have been using MVS for several years and would LOVE to get it to work with this new One Page Checkout contrib.

 

anyone?


Jim Bullen - President

The Cigar Hut Group of Companies

 

 

Installed add-ons: (that now need to be upgraded to BS 2.3.4.1 Frozen)

PWA, MVS, Easy Populate, Dynamic Sitemap, Featured Products, MVS Order Editor, MVS Shipping Estimator, Google XML Sitemap, About Us, Ad Tracker, Address Enhancer, Also Purchased, Backorders, Category Descriptions, Dynamic Meta Tags, Contact Us Email Subjects, Country state Selector, Extra Address Line, Order Number in Email Subject, OSC Affiliate, Product Extra Fields, Review Approval System, Reviews in Product Display, Sold Out, Sold Out (but Displayed), Ultimate SEO URL's, Updated Spiders, Welcome Email Password, Pending Order Email, Who's Online Enhancement, CCGV, Easy Discounts, Customer Comments, Request a Review, Sales Report, plus many many more!

Share this post


Link to post
Share on other sites
Hi Sander,

 

please report this to www.itwebexperts.com also give them the url to your site, so they can see what is happening,

 

Steve

 

thanks for your reply steve but I already got it fixed. It was a problem at MultiSafePay with the account, not a problem of mine. It is fixed now and working :rolleyes:

Share this post


Link to post
Share on other sites
Hi Dan,

 

Most people who have had that error are using STS, or have you added any extra fields text area content to one page checkout ?

with a link i cant say what is going on, i would suggest waiting for the next release

 

Steve

 

 

Has anybody solved this?

I am having exactly the same problem. Steve, when you say, "have you added any extra fields text area content to one page checkout", do you mean adding content to any of the checkout_whatever pages? ie, are all those main pages like checkout_shipping, and checkout_success, are they to be totally devoid of anything extra? Do you mean all these pages collectively when you refer to the 'one page checkout'? Because yes, I have extra stuff in them, but I'd rather not fiddle with them if I don't have to so I want to make sure I understand you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×