Jump to content
Sign in to follow this  
blodder24

Site Times Out While Processing Auth.net Transaction

Recommended Posts

Hello,

 

I have an Authorize.net merchant account integrated with my website. Sometimes the payment goes through and it is recognized, but sometimes it freezes on apipayment.php (The page that connects to the gateway). I don't get any error or anything. It just times out.

 

I've talked to the host and merchant account, and they both say that everything is fine. Any ideas what is causing this issue?

Share this post


Link to post
Share on other sites
Hello,

 

I have an Authorize.net merchant account integrated with my website. Sometimes the payment goes through and it is recognized, but sometimes it freezes on apipayment.php (The page that connects to the gateway). I don't get any error or anything. It just times out.

 

I've talked to the host and merchant account, and they both say that everything is fine. Any ideas what is causing this issue?

Hi Bill,

 

Not sure if I can help, I'm actually having the same issue with Auth.Net. Let me ask you a few questions...Is this a new site or have you been processing transactions for awhile. If awhile, did this just start or have you been having the problem before? Are you using the Auth.Net SIM(server Integration method) or AIM(advanced integration method)?

 

Sorry to get right to the point, this issue is costing us alot of money and we need to get it fixed pronto, so I'll be glad to share any info we find out.

 

Thanks, Frank

Share this post


Link to post
Share on other sites
Hi Bill,

 

Not sure if I can help, I'm actually having the same issue with Auth.Net. Let me ask you a few questions...Is this a new site or have you been processing transactions for awhile. If awhile, did this just start or have you been having the problem before? Are you using the Auth.Net SIM(server Integration method) or AIM(advanced integration method)?

 

Sorry to get right to the point, this issue is costing us alot of money and we need to get it fixed pronto, so I'll be glad to share any info we find out.

 

Thanks, Frank

 

Hello,

 

Our site has only been up for a couple months, so I'm not sure if we have had problems in the past, or if they just sprung up recently. We are using the APIpayment.php file provided by Authorize.net which I believe uses the AIM.

 

I contacted our host and the merchant account, and they pointed fingers at each other along with the coding. I don't think it's the coding, because it won't work sometimes & 3 minutes later it will work.

 

Please let me know if you find anything out, because this is costing our site a lot of money as well as credibility. I'll continue to research and let you know if I come up with anything.

 

Bill

Edited by blodder24

Share this post


Link to post
Share on other sites
Hello,

 

Our site has only been up for a couple months, so I'm not sure if we have had problems in the past, or if they just sprung up recently. We are using the APIpayment.php file provided by Authorize.net which I believe uses the AIM.

 

I contacted our host and the merchant account, and they pointed fingers at each other along with the coding. I don't think it's the coding, because it won't work sometimes & 3 minutes later it will work.

 

Please let me know if you find anything out, because this is costing our site a lot of money as well as credibility. I'll continue to research and let you know if I come up with anything.

 

Bill

Bill,

 

Not sure exactly which Authorize.Net package you are using, I tried looking over Auth.Net's site today to find it today but was unable to. However, I installed a Authorize.Net contrib from Harold Ponce De Leon and it worked perfectly on a test website of mine. I ran several test transactions and also a live transaction through without any gliches from my test site. Unfortunately, it didn't work on my live business site.

 

My live site I believe has some file permission errors that has been affecting, this is one possible cause for it not working. My live site is also OSC milestone 2.2, my testing site OSC RC 2.2 this could also be a factor. I'm not sure what the problem is yet, but I thought you may want to look at Harold's contrib once. It is a very easy install and may help you out, I've included the link below.

http://addons.oscommerce.com/info/5662

 

Good luck, let me know how you make out.

Frank

Share this post


Link to post
Share on other sites
Bill,

 

Not sure exactly which Authorize.Net package you are using, I tried looking over Auth.Net's site today to find it today but was unable to. However, I installed a Authorize.Net contrib from Harold Ponce De Leon and it worked perfectly on a test website of mine. I ran several test transactions and also a live transaction through without any gliches from my test site. Unfortunately, it didn't work on my live business site.

 

My live site I believe has some file permission errors that has been affecting, this is one possible cause for it not working. My live site is also OSC milestone 2.2, my testing site OSC RC 2.2 this could also be a factor. I'm not sure what the problem is yet, but I thought you may want to look at Harold's contrib once. It is a very easy install and may help you out, I've included the link below.

http://addons.oscommerce.com/info/5662

 

Good luck, let me know how you make out.

Frank

 

Hello,

 

Our entire site was coded by hand and we did not use OS Commerce. I've made several transactions on our local site & the data goes through fine. However, it starts screwing up when I test it on the live site.

 

What host are you using? We are using Godaddy. If we are using different hosts our problem probably lies in the coding, permissions, or merchant account. We paid a professional web developer to look at it, and they said everything was fine. Any ideas what I should check out next?

 

Please let me know if you find anything out, because this is definitely hindering our website. Let me know if you would prefer to talk over a messenger program so we can solve this issue faster.

 

Bill

Share this post


Link to post
Share on other sites

Bill,

 

We are hosted by Bluehost. So you mean you aren't using OSC's authorize.net module-a custom module OR did you mean it is not an OSC website. Another suggestion, not a very desirable one is that this may be an Authorize.Net problem. Good luck getting them to admit that anything could be their mistake though.

 

I'm currently looking at some of the settings on the Auth.Net website, try to determine if something could help to streamline and error-proof the transaction process. I will try to keep you upto date on any success's I find.

 

Frank

Share this post


Link to post
Share on other sites
Bill,

 

We are hosted by Bluehost. So you mean you aren't using OSC's authorize.net module-a custom module OR did you mean it is not an OSC website. Another suggestion, not a very desirable one is that this may be an Authorize.Net problem. Good luck getting them to admit that anything could be their mistake though.

 

I'm currently looking at some of the settings on the Auth.Net website, try to determine if something could help to streamline and error-proof the transaction process. I will try to keep you upto date on any success's I find.

 

Frank

 

Frank,

 

I'm not using OSC's module-a custom module or an OSC website. Our merchant acct code was downloaded through either Freeauthnet or Authorize.net.

 

I feel like it has to be something with Authorize.net, because that is the only portion of the site that freezes up. I've called them and they run a simple test on the gateway, so they're not even testing it with my settings. I'll try looking through the settings & see if I can find anything, but I doubt it since I haven't changed much since setting it up. I will keep you up to date, because this is a major problem for both of us, and a solution will be very beneficial.

 

Bill

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×